Switches de LAN : Switching e encaminhamento na camada três

Configurando o Roteamento InterVLAN com Catalyst 3750/3560/3550 Series Switches

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (23 Fevereiro 2012) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Produtos relacionados
     Convenções
     Teoria complementar
Configurar
     Diagrama de rede
     Configurações
Verificação
Solução de Problemas
     Procedimento de Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento explica como configurar o roteamento interVLAN com Cisco Catalyst 3750/3560/3550 Series Switches. Este documento também fornece um exemplo de configuração para o roteamento interVLAN com um Catalyst 3550 Series Switch que executa o software Enhanced Multilayer Image (EMI) em um cenário típico de rede. O documento utiliza um switch Catalyst 2950 Series e um switch Catalyst 2948G como switches de gabinete de Camada 2 (L2) que conectam o Catalyst 3550. A configuração do Catalyst 3550 também tem uma rota padrão para todo tráfego que vai para Internet quando o salto seguinte aponta para um roteador Cisco 7200VXR. Você pode substituir um firewall ou outros roteadores pelo roteador Cisco 7200VXR.

Pré-requisitos

Requisitos

Verifique se estes requisitos são atendidos antes de tentar esta configuração:

Componentes Usados

As informações contidas neste documento são baseadas nas seguintes versões de hardware e software:

  • Catalyst 3550-48 que executa Cisco IOS® Software Release 12.1(12c)EA1 EMI

  • Catalyst 2950G-48 que executa Cisco IOS Software Release 12.1(12c)EA1 EI

  • Catalyst 2948G que executa Catalyst OS (CatOS) versão 6.3(10)

Observação: A configuração do Cisco 7200VXR não é relevante; portanto, este documento não mostrará a configuração.

As informações apresentadas neste documento foram criadas a partir dos dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento começaram com uma configuração esclarecida (padrão). Se a sua rede estiver ativa, certifique-se de entender o impacto potencial de todos os comandos.

Produtos relacionados

Essa configuração também pode ser utilizada com estas versões de hardware e software:

  • Qualquer switch Catalyst 3750/3560/3550 que executa o software EMI ou a imagem multicamada padrão (SMI) Cisco IOS Software Release 12.1(11)EA1 e posterior

  • Qualquer modelo de switch Catalyst 2900XL/3500XL/2950/3550 ou CatOS, utilizado como switch de camada de acesso

Convenções

Consulte Convenções de Dicas Técnicas da Cisco para obter mais informações sobre as convenções de documentos.

Teoria complementar

Em uma rede comutada, as VLANs separam dispositivos em diferentes domínios de colisão e sub-redes de Camada 3 (L3). Dispositivos em uma mesma VLAN podem se comunicar entre si sem necessidade de roteamento. Dispositivos em VLANs separadas requerem um dispositivo de roteamento para se comunicarem.

Switches L2-apenas requerem um dispositivo de roteamento L3. O dispositivo é externo ao switch ou está em outro módulo do mesmo chassi. Uma nova linha de switches incorpora o recurso de roteamento ao switch. Um exemplo é o 3550. O switch recebe um pacote, determina se o pacote pertence a outra VLAN, e envia o pacote para a porta apropriada na outra VLAN.

Um desenho de rede típico segmenta a rede com base no grupo ou na função à qual o dispositivo pertence. Por exemplo, a VLAN de engenharia só possui dispositivos relacionados ao departamento de engenharia e a VLAN de finanças só possui dispositivos relacionados ao departamento financeiro. Se o roteamento for habilitado, os dispositivos em cada VLAN poderão se comunicar entre si sem que todos os dispositivos precisem estar no mesmo domínio de transmissão. Esse tipo de desenho de VLAN também apresenta uma vantagem adicional. O desenho permite que o administrador limite a comunicação entre as VLANs com o uso de listas de acesso. No exemplo fornecido neste documento, você pode utilizar listas de acesso para restringir o acesso da VLAN de engenharia a dispositivos da VLAN de finanças.

Configurar

Nesta seção, você encontra informações sobre como configurar os recursos descritos neste documento.

Observação: Use a Ferramenta de Consulta de Comando (clientes registrados somente) para encontrar informações adicionais sobre os comandos usados neste documento.

Diagrama de rede

Este documento usa esta configuração de rede:

189-a.gif

Nesse diagrama, uma pequena rede de exemplo com o Catalyst 3550 fornece roteamento interVLAN entre diversos segmentos. Por padrão, o switch Catalyst 3550 age como um dispositivo L2 com a desativação do IP Routing. Para fazer o switch funcionar como um dispositivo L3 e fornecer roteamento interVLAN, habilite o IP Routing globalmente.

Estas VLANs são as três VLANs definidas pelo usuário:

  • VLAN 2—VLAN de usuário

  • VLAN 3—VLAN de servidor

  • VLAN 10—VLAN de gerenciamento

A configuração de gateway padrão de cada servidor e dispositivo de host deve ser o endereço IP da interface de VLAN que corresponde ao 3550. Por exemplo, para servidores, o gateway padrão é 10.1.3.1. Os switches de camada de acesso, que são o Catalyst 2950 e o 2948G, são truncados no switch Catalyst 3550.

A rota padrão do Catalyst 3550 aponta para o roteador Cisco 7200VXR. O Catalyst 3550 utiliza essa rota padrão para rotear tráfego destinado à Internet. Portanto, o tráfego para o qual o 3550 não possui uma entrada na tabela de roteamento é encaminhado a 7200VXR para processamento.

Dicas Práticas

  • Certifique-se de que a VLAN nativa de um tronco 802.1Q seja a mesma em ambas as extremidades do link do tronco. Se uma VLAN nativa em uma extremidade do tronco estiver diferente da VLAN nativa na outra extremidade, o tráfego de VLANs nativas em ambos os lados não poderá ser transmitido corretamente no tronco. Essa falha em transmitir corretamente pode implicar em alguns problemas de conectividade em sua rede.

  • Separe a VLAN de gerenciamento da VLAN de usuário ou servidor, conforme mostrado no diagrama. A VLAN de gerenciamento é diferente da VLAN de usuário ou servidor. Com essa separação, nenhuma tempestade de transmissão/pacote que ocorrer na VLAN de usuário ou de servidor afetará o gerenciamento dos switches.

  • Não utilize a VLAN 1 para gerenciamento. O padrão de todas as portas nos switches Catalyst é VLAN 1, e qualquer dispositivo que se conectar a portas não configuradas estará em VLAN 1. O uso de VLAN 1 para gerenciamento pode causar problemas para o gerenciamento dos switches, como explica a segunda dica.

  • Utilize uma porta de Camada 3 (roteada) para conectar-se à porta de gateway padrão. Neste exemplo, você pode substituir facilmente um Cisco 7200VXR Router por um firewall que conecte ao roteador de gateway da Internet.

  • Não execute um protocolo de roteamento entre o Catalyst 3550 e o roteador de gateway da Internet. Em vez disso, este exemplo configura uma rota padrão estática no 3550. Essa configuração será melhor se houver somente uma rota para a Internet. Verifique se configurou as rotas estáticas, de preferência resumidas, no roteador gateway (7200VXR) para as sub-redes que podem ser acessadas pelo Catalyst 3550. Essa etapa é muito importante porque a configuração não utiliza protocolos de roteamento.

  • Se houver dois switches Catalyst 3550 na rede, você poderá estabelecer uma conexão dupla com os switches de camada de acesso em ambos os switches 3550. Execute o Protocolo do Roteador em Standby Recente (HSRP) entre os switches para fornecer redundância na rede. Para obter mais informações sobre a configuração do HSRP, consulte a seção Configurando o HSRP de Configurando Serviços IP.

  • Se precisar de largura de banda adicional para as portas de uplink, você poderá configurar o EtherChannel. O EtherChannel também fornece redundância de link no caso de uma falha do link.

Configurações

Este documento usa estas configurações:

Catalyst 3550 (Catalyst 3550-48 Switch)

Cat3550#show running-config
Building configuration...

Current configuration : 3092 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
!
ip subnet-zero

                     !--- Habilitar o IP Routing para roteamento interVLAN.
                  
ip routing
!!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
 no ip address
!

                     !--- Saída suprimida.
                  
!
interface FastEthernet0/5
 description to SERVER_1

                     !--- Configurar a porta do servidor para estar no servidor VLAN, VLAN 3.
                  
                  switchport access vlan 3
                  
                     !--- Configurar a porta para ser uma porta de acesso para evitar retardos de negociação de tronco.
                  
                  switchport mode access
 no ip address

                     !--- Configurar PortFast para retardo inicial do Spanning Tree Protocol (STP). Consulte
!--- Utilizando o Portfast e Outros Comandos para Corrigir os Atrasos de Conectividade de Inicialização da Estação de Trabalho
!--- para obter mais informações.
                  
                  portfast de árvore de abrangência
!

                     !--- Saída suprimida.
                  
!
interface FastEthernet0/48
 description To Internet_Router

                     !--- A porta que se conecta ao roteador é convertida em uma porta roteada (L3).
                  
                  no switchport
                  
                     !--- Configurar o endereço IP nessa porta. 
                  
                  ip address 200.1.1.1 255.255.255.252
!
interface GigabitEthernet0/1
 description To 2950

                     !--- Configurar o entroncamento IEEE 802.1 (dot1q), com negociação, no switch L2.
!--- Se não houver suporte para Dynamic Trunking Protocol (DTP) no respectivo switch,
!--- emita o comando switchport mode trunk para forçar a porta do switch para o modo de tronco.
!--- Observação: O modo de entroncamento padrão é auto dinâmico. Se estabelecer um link de tronco
!--- com o modo de entroncamento padrão, o tronco não aparecerá
!--- na configuração, mesmo que um tronco seja estabelecido na
!--- interface. Utilize o comando show interfaces trunk para verificar o
!--- o estabelecimento do tronco. 
                  
                  switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 description To 2948G
 switchport trunk encapsulation dot1q
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description USER_VLAN

                     !--- Esse endereço IP é o gateway padrão para usuários.
                  
                  ip address 10.1.2.1 255.255.255.0
!
interface Vlan3
 description SERVER_VLAN

                     !--- Esse endereço IP é o gateway padrão para servidores.
                  
                  ip address 10.1.3.1 255.255.255.0
!
interface Vlan10
 description MANAGEMENT_VLAN

                     !--- Esse endereço IP é o gateway padrão para outros switches L2.
                  
                  ip address 10.1.10.1 255.255.255.0
!
ip classless

                     !--- Essa instrução de rota permite que o 3550 envie tráfego da Internet para
!--- o roteador padrão que, neste caso, é o 7200VXR (Fe 0/0 interface).
                  
                  ip route 0.0.0.0 0.0.0.0 200.1.1.2
ip http server
!
!
!
line con 0
line vty 5 15
!
end

Observação: Como o 3550 possui configuração como um servidor VLAN Trunk Protocol (VTP), o switch não exibe a configuração VTP. Esse comportamento é padrão. Esse switch utiliza esses comandos para criar um servidor VTP com as três VLANs que o usuário definiu a partir do modo de configuração global:

Cat3550(config)#vtp domain cisco
Cat3550(config)#vtp mode server
Cat3550(config)#vlan 2
Cat3550(config-vlan)#name USER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 3
Cat3550(config-vlan)#name SERVER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 10
Cat3550(config-vlan)#name MANAGEMENT
         

Catalyst 2950 (Catalyst 2950G-48 Switch)

Cat2950#show running-config
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!

                     !--- Saída suprimida.
                  
interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
                  switchport mode access
 no ip address
 portfast de árvore de abrangência
!

                     !--- Saída suprimida.
                  
!
interface FastEthernet0/33
 description HOST_1

                     !--- Configurar HOST_1 para ser a VLAN, VLAN 2 do usuário.
                  
                  
 switchport access vlan 2
 switchport mode access
 no ip address
 portfast de árvore de abrangência
!

                     !--- Saída suprimida.
                  
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT

                     !--- Esse endereço IP gerencia esse switch. 
                  
                  ip address 10.1.10.2 255.255.255.0
 no ip route-cache
!

                     !--- Configurar o gateway padrão para que o switch seja acessível a partir de outras
!--- VLANs/sub-redes. O gateway aponta para a interface VLAN 10 no 3550.
                  
                  ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Observação: Como o Catalyst 2950 possui configuração como um cliente VTP, o switch não exibe a configuração VTP. Esse comportamento é padrão. O 2950 adquire as informações de VLAN do servidor VTP, que é o 3550. O switch 2950 utiliza esses comandos para fazer do switch um cliente VTP no domínio VTP cisco a partir do modo de configuração global:

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client
         

Catalyst 2948G Switch

Cat2948G> (enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name  Cat2948G
!
#frame distribution method
set port channel all distribution mac both
!
#vtp

                     !--- Configurar o domínio VTP para ser o mesmo que o 3550, o servidor VTP.
                  
                  set vtp domain cisco
                  
                     !--- Escolher o modo VTP como cliente para esse switch.
                  
                  set vtp mode client
!
#ip

                     !--- Configurar o endereço IP de gerenciamento em VLAN 10.
                  
                  set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down

                     !--- Definir a rota padrão para que o switch seja acessível.
                  
                  set ip route 0.0.0.0/0.0.0.0         10.1.10.1
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet

                     !--- Configurar as portas HOST_2 e SERVER_3 nas respectivas VLANs.
                  
                  set vlan 2    2/2
set vlan 3    2/23
set port name       2/2  To HOST_2
set port name       2/23 to SERVER_3
                  
                     !--- Configurar o tronco para 3550 com encapsulamento dot1q.
                  
                  set trunk 2/49 desirable dot1q 1-1005
end

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

A Ferramenta de Interpretação de Saída (clientes registrados somente) (OIT) é compatível com alguns comandos show . Use a OIT para visualizar uma análise da saída de comando show.

Catalyst 3550

  • show vtp status

    Cat3550#show vtp status
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs        : 8
    VTP Operating Mode              : Servidor
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49
    Configuração modificada pela última vez por 200.1.1.1 em 3-1-93 01:06:24
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
  • show interfaces trunk

    Cat3550#show interfaces trunk
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    Gi0/2     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    Gi0/2     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    
    Gi0/1     1-3,10
    Gi0/2     1-3,10
                   
  • show ip route

    Cat3550#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    O gateway do último recurso é 200.1.1.2 para a rede 0.0.0.0
    
         200.1.1.0/30 is subnetted, 1 subnets
    C       200.1.1.0 is directly connected, FastEthernet0/48
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.1.10.0 is directly connected, Vlan10
    C       10.1.3.0 is directly connected, Vlan3
    C       10.1.2.0 is directly connected, Vlan2
    S*   0.0.0.0/0 [1/0] via 200.1.1.2
                   

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs        : 8
    VTP Operating Mode              : Client
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49
    Configuração modificada pela última vez por 200.1.1.1 em 3-1-93 01:06:24
                   
  • show interfaces trunk

    Cat2950#show interfaces trunk
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    Gi0/1     1-3,10
                   

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           client      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8          1023             3               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1       disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/49     desirable    dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     2/49     1-1005
    
    Port      Vlans allowed and active in management domain
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
                   

Solução de Problemas

Use esta seção para solucionar problemas de configuração.

Procedimento de Solução de Problemas

Siga estas instruções:

  1. Se não puder emitir o comando ping em dispositivos dentro da mesma VLAN, verifique a atribuição de VLAN das portas de origem e de destino para certificar-se de que a origem e o destino estejam na mesma VLAN.

    Para verificar a atribuição de VLAN, emita o comando show port mod/port do CatOS ou o comando show interface status do Cisco IOS Software.

    Se a origem e o destino não estiverem no mesmo switch, certifique-se de ter configurado o entroncamento corretamente. Para verificar a configuração, emita o comando show trunk do CatOS ou o comando show interfaces trunk do Cisco IOS Software. Verifique também se a VLAN nativa corresponde em ambos os lados. Certifique-se de que as máscaras de sub-rede dos dispositivos de origem e de destino sejam correspondentes.

  2. Se não puder efetuar ping de dispositivos em diferentes VLANs, certifique-se de poder efetuar ping do respectivo gateway padrão.

    Observação: Consulte a Etapa 1.

    Além disso, certifique-se de que o gateway padrão do dispositivo aponte para o endereço IP da interface VLAN correta. Verifique se a máscara de sub-rede é correspondente.

  3. Se você não conseguir acessar a Internet, verifique se a rota padrão dos 3550 pontos está no endereço IP correto, e se o endereço de sub-rede corresponde ao roteador de gateway da Internet.

    Para verificar, emita o comando show ip interface interface-id e o comando show ip route. Certifique-se de que o roteador de gateway da Internet tenha rotas para a Internet e para as redes internas.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 41260