IP : Roteamento IP

Especificando um Endereço IP do Próximo Nó para Rotas Estáticas

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (30 Outubro 2006) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Teoria complementar
     Convenções
Problema
Solução
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento introduz conceitos básicos sobre rotas estáticas. Este documento usa um cenário de problema para demonstrar as circunstâncias em que é desejável especificar a interface por meio da qual o endereço IP do próximo nó poderá ser alcançado ao configurar uma rota estática.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Usados

Este documento não está restrito a versões específicas de software e de hardware.

Teoria complementar

A habilidade para configurar uma rota estática foi introduzida no Cisco IOS® Software Release 10.0. As rotas estáticas são usadas por várias razões e freqüentemente são usadas quando não há nenhuma rota dinâmica para o destino ou quando você executa um protocolo de roteamento dinâmico que não é viaável.

Por padrão, as rotas estáticas têm uma distância administrativa de rotas, que proporciona a elas uma supremacia sobre as rotas de protocolos de roteamento dinâmico. Ao aumentar a distância administrativa para um valor maior do que o de um protocolo de roetamento dinâmico, a rota estática poderá ser uma rede segura no caso daquele roteamento dinâmico falhar. Por exemplo, as rotas derivadas do Interior Gateway Routing Protocol (IGRP) têm uma distância administrativa padrão de 100. Para configurar uma rota estática que seja substituída por rota de IGRP, especifique uma distância administrativa maior do que 100 para a rota estática.

Esse tipo de rota estática é denominada estática "flutuante". É instalada na tabela de roteamento somente quando a rota preferencial desaparece. Por exemplo, ip route 172.31.10.0 255.255.255.0 10.10.10.2 101.

Observação: Uma distância administrativa de 255 é considerada inalcançável e as rotas estáticas com uma distância administrativa de 255 nunca são inseridas na tabela de roteamento.

Se você indicar um roteamento estático para uma interface de transmissão, a rota será inserida na tabela de roteamento somente quando a interface de transmissão estiver ativa. Essa configuração não é recomendada porque quando o próximo nó de uma rota estática apontar para uma interface, o roteador considerará cada um dos hosts dentro do intervalo a ser conectado diretamente por meio daquela interface. Por exemplo, ip route 0.0.0.0 0.0.0.0 Ethernet0.

Com esse tipo de configuração, um roteador executa o Address Resolution Protocol (ARP) na Ethernet para cada destino que ele encontra por meio da rota padrão porque o roteador considera todos esses destinos como conectados diretamente à Ethernet 0.

Esse tipo de rota padrão, especialmente se for usada por muitos pacotes para muitas sub-redes de destino diferentes, pode levar a uma alta demando pelo processador e um a cache de ARP muito grande (junto com falhas de alocação de memória).

A especificação de um próximo nó numérico em uma interface conectada diretamente interface impede que o roteador execute o ARP ou cada endereço de destino. Entretanto, se a interface com o próximo nó falhar e o próximo nó numérico for alcançável por meio de uma rota recursiva, você deverá especificar o endereço IP do próximo nó e a interface por meio da qual o próximo nó deverá ser encontrado. Por exemplo, ip route 0.0.0.0 0.0.0.0 Serial 3/3 192.168.20.1.

Convenções

Consulte Convenções de Dicas Técnicas da Cisco para obter mais informações sobre as convenções de documentos.

Problema

Neste diagrama de rede, há duas rotas estáticas para o mesmo destino (172.31.10.0/24). Uma rota é uma estática flutuante, é o "backup" ou o cominho redundante para a rede de destino na LAN. O problema neste caso é que a rota estática flutuante nunca é instalada na tabela de roteamento quando o link principal está desligado.

R1 tem uma rota padrão que aponta para o roteador do Provedor de Serviços de Internet (ISP) para o acesso à Internet. R1 possui dois links para R2. O T1 é o link principal e 56 K é o link de reserva. R1 possui uma rota estática para 172.31.10.0/24 que aponta para o endereço IP de R2 Serial 0 (10.10.10.2) como o próximo nó. R1 também possui uma rota estática flutuante para 172.131.10.0/24 que aponta para o endereço IP de R2 Serial 1 (192.168.20.2), a distância administrativa para a rota estática flutuante é 250. A idéia é que os pacotes fluam através de uma linha de 56 K nas duas direções apenas se o link principal falhar.

ip_static_routes_01.gif

Este exemplo mostra a configuração de R1:

R1

hostname R1

!
ip subnet-zero
no ip domain-lookup
!
controller E1 2/0
!
controller E1 2/1
!
interface Serial3/0
 description ISP Link
 ip address 192.168.10.1 255.255.255.252
 clockrate 64000
!
interface Serial3/1
 no ip address
 shutdown
!
interface Serial3/2
 description Primary Link to R2
 ip address 10.10.10.1 255.255.255.252
!
interface Serial3/3
 description Backup Link to R2
 ip address  192.168.20.1 255.255.255.252
 clockrate 64000
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial3/0

                     !---Essa é a rota padrão para o roteador do ISP.
                  
ip route 172.31.10.0 255.255.255.0 10.10.10.2

                     !---Essa é a rota preferencial para a LAN.
                  
ip route 172.31.10.0 255.255.255.0 192.168.20.2 250

                     !---Essa é a rota flutuante para a LAN.
                  
               

Este exemplo mostra a tabela de rotemento de R1:

Tabela de roteamento de R1

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2

                     !--- A rota estática preferencial para a LAN através de T1.
                  
S*   0.0.0.0/0 is directly connected, Serial3/0

                     !--- A rota estática padrão para a Internet.
                  
               

Este exemplo mostra a configuração do R2:

R2

hostname R2
!
enable password ww
!
!
!
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
interface Ethernet0
 description Local LAN
 ip address 172.31.10.2 255.255.255.0
!
interface Serial0
 description Primary Link to R1
 ip address 10.10.10.2 255.255.255.252
 clockrate 56000
!
interface Serial1
 description Backup Link to R1
 ip address 192.168.20.2 255.255.255.252
!
interface TokenRing0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1

                     !--- Essa é a rota padrão principal.
                  
ip route 0.0.0.0 0.0.0.0 192.168.20.1 250

                     !--- A rota padrão flutuante a ser usada se T1 falhar.
                  
no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

O R2 tem a rota padrão instalada através de 10.10.10.1 e quando você usar o comando traceroute de R2 para o roteador do ISP, os pacotes usarão o link T1. O R2 pode enviar pings para o host de Internet 192.168.30.1 originário de 172.31.10.2. A rota para 192.168.30.1 é feita por meio da rota padrão 0.0.0.0 0.0.0.0.

Tabela de roteamento de R2

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.10.10.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/30 is directly connected, Serial0
S*   0.0.0.0/0 [1/0] via 10.10.10.1

                     !--- Essa é a rota padrão principal.
                  
R2#traceroute 192.168.10.2

Type escape sequence to abort.
Tracing the route to 192.168.10.2

  1 10.10.10.1 16 msec 20 msec 16 msec
  2 192.168.10.2 32 msec *  32 msec

R2#ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

Se você desligar o Serial 3/2 no R1 para testar o failover, o que se espera é que R1 instale a rota estática flutuante para a LAN local 172.31.10.0 e que R2 instale a rota estática flutuante em 0.0.0.0 por meio de 192.168.20.1. Você deve esperar que o tráfego flua através do link de 56K.

R1

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s3/2
R1(config-if)#shut
R1(config-if)#end
2d21h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
2d21h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up&                   up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2

                     !--- A rota estática por meio do T1 permanece na tabela de roteamento.
!--- Não era esperado que acontecesse isso quando o Serial 3/2 foi desligado.
                  
S*   0.0.0.0/0 is directly connected, Serial3/0

                     !--- A rota estática padrão para a Internet.
                  
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.20.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
S*   0.0.0.0/0 [250/0] via 192.168.20.1

                     !--- Não será mais possível enviar ping para o host de Internet 192.168.20.1 se o ping
!--- for originário da LAN em R2 porque R1 tentará enviar as respostas
!--- através do Serial 3/2, que está desligado.
                  
R2#ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

A rota estática flutuante não foi instalada em R1 e a rota estática principal ainda está na tabela de rotemento de R1 embora o link Serial 3/2 esteja desligado. A razão disso acontecer é porque as rotas estáticas são recursivas por natureza. Você sempre mantém a rota estática na tabela de roteamento contanto que tenha um rota para o próximo nó. Nesse caso, R1 imagina que vai para 10.10.10.2 por meio de 192.168.10.2 porque 192.168.10.2 é o próximo nó de 0.0.0.0 0.0.0.0.

A rota para o próximo nó pode ser uma rota mais ou menos específica, ou uma rota padrão. Nesse cenário do problema, você poderia pensar que pelo fato do link estar desligado, não deveria haver uma rota para 10.10.10.2, mas se examinar a tabela de roteamento em R1, verá que há uma rota estática padrão apontando para o roteador do ISP. Portanto, R1 acredita que pode alcançar o próximo nó (10.10.10.2) de 172.31.10.0/24 por meio dessa rota padrão, assim a rota estática de 172.31.10.0/24 através de 10.10.10.2 permanece na tabela de roteamento e a rota estática flutuante nunca é instalada.

Há uma forma melhor para configurar rotas estáticas que permitem evitar esse problema. Se especificar a interface pela qual o próximo nó deverá ser encontrado, você instalará a rota estática flutuante apenas se o endereço IP do próximo nó for alcançável por meio da interface especificada. Antes da solução deste problema ser apresentada, você conduzirá a interface Serial 3/2 em R1 de backup novamente.

R1

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#no shut
R1(config-if)#end
R1#
2d22h: %LINK-3-UPDOWN: Interface Serial3/2, changed state to up
2d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to up
2d22h: %SYS-5-CONFIG_I: Configured from console by console


R1#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0&             192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Solução

A solução é remover as rotas estáticas antigas na LAN (172.31.10.0) e configurar novas rotas estáticas, dessa vez especificando a interface pela qual o próximo nó deverá ser alcançado. Isso permite que a rota estática flutuante em R1 seja instalada quando a interface Serial 3/2 for desligada.

R1

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#no ip route 172.31.10.0 255.255.255.0 10.10.10.2
R1(config)#no ip route 172.31.10.0 255.255.255.0 192.168.20.2 250
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/2 10.10.10.2
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/3 192.168.20.2 250
R1(config)#end
R1#
2d22h: %SYS-5-CONFIG_I: Configured from console by console

A rota estática para 172.31.10.0 através de 10.10.10.2 é instalada na tabela de roteamento de R1 se 10.10.10.2 for visto pela Serial 3/2. Se esta condição não for atendida, a rota estática através de 10.10.10.2 será removida da tabela de roteamento e a rota estática flutuante para 172.31.10.0 através da Serial 3/3 com o próximo nó 192.168.20.2 será instalada.

Para testar como isso funciona e induzir o link T1 à falha, desligue a Serial 3/2 e veja se a rota estática flutuante é instalada na tabela de roteamento.

R1

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#shut
R1(config-if)#end
R1#
3d00h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
3d00h: %SYS-5-CONFIG_I: Configured from console by console
3d00h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [250/0] via 192.168.20.2, Serial3/3
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Agora, R1 pode enviar um ping ao host de Internet 192.168.20.1 com pacotes originários da LAN.

R2

R2#ping
Protocol [ip]:
Target IP address: 192.168.20.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

A rota estática flutuante é instalada como o esperado.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 27082