Voz : Protocolos de gateway

Compreendendo o Roteamento de Chamadas de Gatekeepers H.323 do Cisco IOS

22 Maio 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (4 Janeiro 2007) | Feedback


Índice

Introdução
Antes de Iniciar
     Convenções
     Pré-requisitos
     Componentes Usados
Mensagens de ARQ e LRQ
Conceitos de Configuração Importantes: Prefixos de Tecnologia de Zona Remota
     Prefixos de Zona
     Prefixo de Tecnologia
O Processo de Decisão/Algoritmo de Roteamento de Chamada de Gatekeeper
Exemplos de Chamadas para Zona Local
     Cenário 1: Nenhum Prefixo de Tecnologia Configurado
     Cenário 2: Prefixos de Tecnologia Configurados
     Cenário 3: Prefixos de tecnologia padrão configurados
Exemplos de chamadas para zona remota
     Cenário 1: Gatekeepers de zona configurados com prefixos de tecnologia padrão
     Cenário 2: Gatekeepers de zona configurados sem prefixos de tecnologia padrão
Comandos de Verificação e Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Os gatekeepers da Cisco são usados para agrupar gateways em zonas lógicas e realizar roteamentos de chamadas entre eles. Os gateways são responsáveis pelas decisões de roteamento de extremidade entre a Public Switched Telephone Network (PSTN) e o H.323 lenta. Os gatekeepers Cisco processam os principais roteamentos de chamadas entre dispositivos na rede do H.323 e fornecem uma administração planejada de discagem centralizada. Sem um gatekeeper Cisco, os endereços IP explícitos para cada gateway de terminação deverão ser configurados no gateway de origem e ter um peer de discagem correspondente para um Voice over IP (VoIP). Com um gatekeeper Cisco, os gateways consultam o gatekeeper quando tentarem estabelecer chamadas de VoIP com gateways VoIP remotos.

Por exemplo, quando apresentado com uma chamada, o gateway determina se irá enviá-la para o trecho de telefonia ou o trecho de IP, de acordo com seu plano de discagem. No caso do trecho de IP, o gateway consulta o gatekeeper Cisco para selecionar o melhor ponto final. Em seguida, o gatekeeper Cisco determina se o ponto final chamado é um dispositivo em sua zona local ou se está em uma zona remota controlada por um gatekeeper Cisco remoto.

Antes de Iniciar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Dicas Técnicas da Cisco Convenções.

Pré-requisitos

Os leitores deste documento devem ter conhecimento do seguinte:

Componentes Usados

As informações neste documento se baseiam nas versões de software e hardware a seguir.

  • Cisco 2500, 2600, 3600, 3700, 7200 e MC3810 Series Routers.

  • Este documento não é específico para nenhuma versão do Cisco IOS. Contudo, as configurações deste documento foram testadas no Cisco IOS Software Release 12.2(19). Consulte o Software Advisor (clientes registrados somente) para confirmar se o conjunto de recursos do Cisco IOS é necessário para oferecer suporte à funcionalidade de Gatekeeper H.323.

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos neste documento foram iniciados com uma configuração vazia (padrão). Se estiver trabalhando em uma rede ativa, certifique-se de entender o impacto potencial de todos os comandos antes de usá-los.

Mensagens de ARQ e LRQ

ARQs e LRQs são duas mensagens de Registro, Admissão e Status (RAS) H.225 que dispara um gatekeeper para iniciar o processo de decisão do roteamento de chamada.

  • ARQ—mensagens de zona local enviadas pelos pontos finais H.323 (geralmente gateways) para o gatekeeper Cisco. Os gatekeepers recebem ARQs de um ponto final, se:

    • Um ponto final da zona local iniciar uma chamada. OU

    • Um ponto final da zona local solicitar permissão para aceitar uma chamada de entrada.

    Os gatekeepers respondem às mensagens de ARQ com uma mensagem de ACF (Confirmação de Admissão) ou de ARJ (Rejeição de Admissão). Se o gatekeeper Cisco estiver configurado para aceitar a chamada, ele responderá com uma mensagem ACF (que inclui informações como o endereço IP do gateway de destino). Caso contrário, ele responderá com uma mensagem ARJ.

  • LRQ—Essas mensagens são trocadas entre os gatekeepers e usadas para chamadas entre zonas (zona remota). Por exemplo, o gatekeeper A recebe um ARQ de um gateway da zona local, solicitando a aceitação de uma chamada de um dispositivo de zona remota. O gatekeeper A envia uma mensagem de LQR para o gatekeeper B e esse responde à mensagem de LRQ com uma mensagem de LCF (Confirmação de Local) ou de LRJ (Rejeição de Local), dependendo se a sua configuração está definida para aceitar ou rejeitar a solicitação de chamada entre zonas e se o recurso solicitado está registrado.

Para obter mais informações, consulte Compreendendo Gatekeepers H.323: Fluxo de Gatekeeper para Chamadas de Gateway.

Mensagens RAS Relacionadas ao H.225

ARQ

Solicitação de Admissão

LRQ

Solicitação de Local

ACF

Conformação de Admissão

LCF

Confirmação de Local

ARJ

Rejeição de Admissão

LRJ

Rejeição de Local

Conceitos de Configuração Importantes: Prefixos de Tecnologia de Zona Remota

Para compreender o processo de decisão de roteamento de chamada de gatekeeper da Cisco, é essencial entender os prefixos de tecnologia e zona. Em geral (com poucas exceções), o prefixo de zona determina o roteamento para uma zona, em que o prefixo de tecnologia determina o gateway nessa zona.

Prefixos de Zona

Um prefixo de zona é a parte do número chamado que identifica a zona para a qual uma chamada é desconectada. Os prefixos de zona são normalmente usados para associar um código de área a uma zona configurada.

O gatekeeper Cisco determina se uma chamada será roteada para uma zona remota ou processada localmente. Por exemplo, de acordo com o seguinte trecho de configuração, o gatekeeper (GK) A encaminha 214 chamadas para o GK-B. As chamadas para o código de área (512) são processadas localmente.

gatekeeper
     zone local GK-A abc.com
     zone remote GK-B abc.com 172.22.2.3 1719
	
 !--- O endereço IP de gerenciamento configurado acima deveria ser o endereço
 !--- RAS do gatekeeper remoto
 !--- e deveria estar acessível pelo gateway local.
 !--- Para descobrir o endereço do no Gatekeeper remoto,
 !--- execute o comando 
                     show gatekeeper zone status
                   no gateway remoto.
            
     zone prefix GK-B 214.......
     zone prefix GK-A 512.......

Prefixo de Tecnologia

Um prefixo de tecnologia é um recurso opcional baseado no H.323 padrão, compatíveis com os gateways e gatekeepers Cisco , que permitem mais flexibilidade no roteamento de chamadas em uma rede VoIP do H.323. O gatekeeper Cisco usa prefixos de tecnologia para agrupar pontos finais do mesmo tipo. Os prefixos de tecnologia também podem ser usados para identificar um tipo, classe ou pool de gateways.

Os gatekeepers Cisco usam prefixos de tecnologia para rotear chamadas quando não houver endereços E.164 registrados (por um gateway) que corresponda ao número chamado. Na verdade, esse é um cenário bastante comum, visto que a maioria dos gateways Cisco IOS registram apenas suas portas com o ID do H.323 (exceto se eles apresentarem portas FXS (Estação de câmbio internacional) configuradas). Sem endereços E.164 registrados, o gatekeeper Cisco conta com duas opções para tomar a decisão de roteamento da chamada:

  • Com a opção Correspondências do Prefixo de Tecnologia, o gatekeeper Cisco usa o prefixo de tecnologia anexado ao número chamado para selecionar o gateway ou a zona de destino

  • Com a opção Prefixos de Tecnologia Padrão, o gatekeeper Cisco atribui gateway(s) padrão para rotear endereços de chamadas sem solução. Essa atribuição é baseada no prefixo de tecnologia registrado do gateway.

A tabela a seguir resume as opções de configuração disponíveis.

No Gateway

VoIP Interface

Esse comando registra o gateway Cisco com o prefixo de tecnologia definido. As informações de registro do prefixo de tecnologia são enviadas ao gatekeeper Cisco na mensagem de RRQ (Solicitação de Registro) do RAS. Por exemplo:

GWY-B1(config)#interface ethernet 0/0
GWY-B1(config-if)#h323-gateway voip tech-prefix ?
     WORD: A technology prefix that the interface will register
     with the Gatekeeper.

VoIP Dial-peer

Esse comando toma o lugar de um prefixo de tecnologia anexado ao número chamado que correspondente ao peer de discagem. Ele não é usado para registro, mas para configurar a chamada com um gatekeeper Cisco. Por exemplo, o número chamado 5551010 se torna 1#5551010.

GWY-B1(config)#dial-peer voice 2 voip
GWY-B1(config-dial-peer)#tech-prefix ?
     WORD: A string.

Observação: O número chamado modificado também é enviado ao gateway de terminação na configuração da chamada. Verifique se os peers de discagem do serviço de telefonia tradicional (POTS) do gateway de terminação são atualizados para completar a chamada.

No Gatekeeper

Gatekeeper Default Technology Prefix

Esse comando define os gateways registrados com o prefixo de tecnologia especificado como padrão para rotear os endereços de chamada que estão sem solução. Por exemplo, se a maioria dos gateways em sua zona roteiam o mesmo tipo de chamadas e estão registrados com o prefixo de tecnologia 1#, você poderá configurar o gatekeeper Cisco para usar 1# como o prefixo de tecnologia padrão. Portanto, não é mais necessário que os gateways de origem substituam o número chamado com 1#. Os número chamados sem um prefixo de tecnologia válido são roteados para um dos gateways registrados com 1#.

GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# default-technology
               

Observação: Se houver mais de um gateway padrão, você poderá afetar a utilização de prioridade do gateway com o comando zone prefix <gk_id> <e.164_pattern> gw-priority <0-10> .

Gatekeeper Hop-Off Zone

As configurações de desconexão são usadas para substituir a seleção de prefixo da zona e forçar a chamada a ser desconectada de uma zona especificada, independentemente do prefixo da zona do número chamado. Por exemplo, com a seguinte configuração, todas as chamadas com o prefixo de tecnologia 2# serão encaminhadas para a zona do GK-A.

GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 2# hopoff GK-A
               

Gatekeeper Static Gateway Technology Prefix Registration

Usado para registrar estaticamente um prefixo de tecnologia de um gateway. Ele fornece os mesmo resultados no gatekeeper, à medida que a configuração de interface do gateway de VoIP atinge o gateway. Se tiver um grande número de gateways, é recomendável usar essa configuração nos gateways. Geralmente, é mais fácil configurar cada gateway com o prefixo de tecnologia do que configurar o gatekeeper com todos os prefixos de tecnologia para cada gateway.

GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# gw ipaddr ?
     A.B.C.D  RAS signaling IP address

O Processo de Decisão/Algoritmo de Roteamento de Chamada de Gatekeeper

Os seguintes diagramas exibem o processo de decisão de roteamento de chamada de gatekeeper depois de receber mensagens de ARQ e LRQ.

gk-call-routing-1.gif

gk-call-routing-2.gif

Exemplos de Chamadas para Zona Local

Nos seguintes exemplos, os dois gateways são registrados com o gatekeeper Cisco e seus respectivos IDs do H.323. Além disso, o gateway (GWY) A2 é registrado com um endereço E.164. O diagrama a seguir é usado para todos os exemplos dessa seção.

gk-call-routing-3.gif

As seções a seguir explicam o processo de decisão passo a passo usado pelo gatekeeper para rotear chamadas com base nas mensagens de ARQ.

Observação: Somente a saída relevante é mostrada nestes exemplos de capturas de configuração.

Cenário 1: Nenhum Prefixo de Tecnologia Configurado

GK-A

!
gatekeeper
zone local GK-A abc.com
no shutdown
!

GWY-A1

GWY-A2

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718 
                     
!--- O endereço IP de gerenciamento configurado acima deveria
!ser o endereço RAS do GK-A
!--- e deveria estar acessível pelo gateway.
!--- Para descobrir o endereço RAS,
!--- execute o comando 
           show gatekeeper zone status
                        
!--- no GK-A.
                  
h323-gateway voip h323-id GW-A1@abc.com
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512

!--- Nas chamadas de saída pelos peers de discagem do POTS,
!--- todas as correspondências de números explícitos 
!--- são descartados, o que é o motivo
!--- para adicionar o prefixo 512. Isso não tem nenhuma relação
!--- com os prefixos de tecnologia.
                  
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
                  
!--- Usa mensagens RAS (GK) para obter
!--- informação de configuração de chamada.
                  

!
gateway
!
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718

!--- O endereço IP de gerenciamento configurado acima deveria
!--- ser o endereço RAS do GK-A.
!--- e deveria estar acessível pelo gateway.
!--- Para descobrir o endereço RAS,
!--- execute o comando 
                 show gatekeeper zone status
                        
!--- no GK-A.
                  
h323-gateway voip h323-id GW-A2@abc.com
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!--- Esta é porta FXS.
                  
!
gateway
!

A seguinte saída capturada no GK-A exibe os registros reais. Observe que o GWY-A2 também registra o ID do E.164 da porta FXS.

GK-A#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
--------------- ----- --------------- ----- ---------         ----    --
172.22.1.1      1720  172.22.1.1      49317 GK-A              VOIP-GW
    ID do H323: GW-A1@abc.com
172.22.1.2      1720  172.22.1.2      58196 GK-A              VOIP-GW
    ID do E164: 9725551010
    ID do H323: GW-A2@abc.com
Total number of active registrations = 2

Primeira Ação de Chamada: O usuário A1 faz uma chamada para o usuário A2 pelo número 972-555-1010. Use o diagrama ARQ para seguir o processo de decisão.

GK-A recebe ARQ no GWY-A1.

  1. O prefixo de tecnologia corresponde? Não

  2. O prefixo de zona corresponde? Não

  3. Um comando rq reject-unknown-prefix está definido? Não, a zona de destino é igual à zona local.

  4. A zona de destino é local? Sim

  5. Um prefixo de tecnologia foi encontrado na etapa 1? Não

  6. O endereço de destino está registrado? Sim. Envie uma ACF.

Configuração de chamada bem-sucedida.

Observação: Observe que o GWY-A2 possui o ID do E.164 de destino registrado (porta FXS), por isso, o gatekeeper pôde aceitar a chamada.

Ação de Chamada Secundária: O usuário A2 disca 512-555-1212 para fazer uma chamada para o usuário de chamada A1.

GK-A recebe ARQ no GWY-A2.

  1. O prefixo de tecnologia corresponde? Não

  2. O prefixo de zona corresponde? Não

  3. O comando arq reject-unknown-prefix está definido? Não. A zona de destino é igual à zona local.

  4. A zona de destino é local? Sim

  5. Um prefixo de tecnologia foi encontrado na etapa 1? Não

  6. O endereço de destino está registrado? Não

  7. O prefixo de tecnologia padrão está definido? Não. Envie uma ARJ.

Falha na configuração da chamada.

Observação: O Cenário 2 explica como corrigir o problema de roteamento de chamada descrito acima, usando os prefixos de tecnologia.

Cenário 2: Prefixos de Tecnologia Configurados

Nesse cenário, as seguintes alterações de configuração foram feitas:

  • GWY-A1—Comando h323-gateway voip tech-prefix 1# adicionado. GWY-A1 faz o registro no GK-A com o prefixo de tecnologia 1#.

  • GWY-A1—Peer de discagem POTS adicionado com um destination-pattern comando que corresponde ao número chamado de entrada do GWY-A2 com prefixo de tecnologia 1#.

  • GK-A—Comando zone prefix GK-A adicionado. Define os prefixos de zona local que o GK-A gerencia.

  • GK-A—Comando arq reject-unknown-prefix adicionado. Isso estabelece que o GK-A aceite somente chamadas de ARQ para os prefixos de zona que gerencia. No cenário 1, isso não foi configurado. Sendo assim, a zona de destino foi definida como a zona local padrão.

  • GWY-A2—Comando tech-prefix Comando 1# no peer VoIP. Dessa forma, o GWY-A2 toma o lugar dos dígitos 1# nas chamadas VoIP de saída. O GK-A identifica o padrão 1# para selecionar GWY-A1 como o gateway de destino.

GK-A

gatekeeper
zone local GK-A abc.com
prefixo de zona GK-A 512.......
prefixo de zona GK-A 972.......
arq reject-unknown-prefix
no shutdown
!

GWY-A1

GWY-A2

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
tech-prefix 1# de h323-gateway voip
!
dial-peer voice 3 pots
incoming called-number 972.......
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
tech-prefix 1#
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

A saída a seguir capturada em GK-A exibe os prefixos de tecnologia registrados.

GK-A#show gatekeeper gw-type-prefix

        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#*
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Observação: Em vez de configurar GW-A1 com o comando h323-gateway voip tech-prefix 1#, isso poderia ter sido realizado da mesma maneira configurando manualmente essas informações no GK-A com o comando.

GK-A(config-gk)#gw-type-prefix 1#* gw ipaddr 172.22.1.1
         

Ação de Chamada: O usuário A2 disca 512-555-1212 para o usuário de chamada A1.

GK-A recebe ARQ no GWY-A2.

  1. O prefixo de tecnologia corresponde? Sim

    Observação: Após a correspondência do prefixo de tecnologia, o gatekeeper remove-o para analisar o prefixo de zona. Essa remoção só é executada pela análise do gatekeeper . O gateway de origem ainda o anexará na configuração da chamada para o gateway de terminação.

  2. O prefixo de zona corresponde? Sim. Defina a zona de destino como igual à zona local.

  3. A zona de destino é local? Sim

  4. Um prefixo de tecnologia foi encontrado na etapa 1? Sim

  5. Foi encontrado um gateway local com um prefixo de tecnologia? Sim. Envie uma ACF .

    Configuração de chamada bem-sucedida.

O seguinte comando de saída debug do GK-A ilustra o comportamento acima.

Observação: O comando debug abaixo é útil mas oculta depuração. Assim, o parser não mostrará a depuração.

GK-A#debug gatekeeper main 5

    *Jun 19 09:50:10.086: gk_rassrv_arq: arqp=0x631CC400, crv=0x82, answerCall=0
    *Jun 19 09:50:10.086: gk_dns_locate_gk(): No Name servers
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): tech-prefix 1# correspondente
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Prefixo de zona 512 correspondente
    *Jun 19 09:50:10.118: gk_rassrv_arq: arqp=0x631CC400, crv=0x1A, answerCall=1

Observação: Veja a seguir uma configuração alternativa que talvez seja mais intuitiva:

  • Configure o GWY-A1 para registrar com o prefixo de tecnologia 512 usando o comando h323-gateway voip tech-prefix 512.

  • Dessa forma, o GWY-A2 não precisará passar o prefixo no segmento de chamada de peer VoIP, pois o padrão de destino já inclui 512. Sendo assim, remova o comando tech-prefix 1# na configuração do GWY-A2 e o 1# do padrão da destino abaixo do peer POTS no GWY-A1.

Cenário 3: Prefixos de tecnologia padrão configurados

Nesse cenário, os registros do GWY-A1 com prefixo de tecnologia 1# e GK-A são configurados para rotear chamadas sem uma correspondência de prefixos de tecnologia com os gateways de prefixo de tecnologia padrão. Sendo assim, o GWY-A2 não precisa ser configurado para passar o prefixo de tecnologia de destino.

GK-A

!
gatekeeper
zone local GK-A abc.com
prefixo de zona GK-A 512.......
prefixo de zona GK-A 972.......
tecnologia padrão gw-type-prefix 1#*
arq reject-unknown-prefix 
no shutdown
!

GWY-A1

GWY-A2

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
tech-prefix 1# de h323-gateway voip
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
! 
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
! 

A saída a seguir capturada em GK-A exibe os prefixos de tecnologia.

GK-A#show gatekeeper gw-type-prefix

        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefixo: 1#* (Tecnologia de gateway padrão)
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Ação da Chamada: O usuário A2 disca 512-555-1212 para o usuário de chamada A1.

GK-A recebe ARQ no GWY-A2.

  1. O prefixo de tecnologia é correspondente? Não

  2. O prefixo de zona corresponde? Sim. Defina a zona de destino como igual à zona local.

  3. A zona de destino é local? Sim

  4. Um prefixo de tecnologia foi encontrado na etapa 1? Não

  5. O endereço de destino está registrado? Não

  6. O prefixo de tecnologia padrão está definido? Sim. Selecione a local. gateway com o prefixo de tecnologia (apenas um disponível).

  7. Envie uma ACF.

    Configuração de chamada bem-sucedida.

Exemplos de chamadas para zona remota

Nesses exemplo há duas zonas H.323; uma controlada por GK-A e outra por GK-B.

gk-call-routing-4.gif

As seções a seguir explicam o processo de decisão passo-a-passo usado pelos gatekeepers para rotear chamadas com base nas mensagens de ARQ e LRQ.

Observação: Somente a saída relevante é mostrada nestes exemplos de configuração .

Cenário 1: Gatekeepers de zona configurados com prefixos de tecnologia padrão

Nesse cenário, o GWY-A1 registra no GK-A com prefixo de tecnologia 1# e o GWY-B1 registra no GK-B com prefixo de tecnologia 2#. Ambos os gatekeepers são configurados com gateways de prefixos de tecnologia padrão.

GK-A

GK-B

!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
tecnologia padrão gw-type-prefix 1#*
arq reject-unknown-prefix
no shutdown
! 
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
tecnologia padrão gw-type-prefix 2#*
no shutdown
!

GWY-A1

GWY-B1

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
tech-prefix 1# de h323-gateway voip
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern ..........
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
tech-prefix 2# de h323-gateway voip
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
!
gateway
!

Ação de Chamada: O usuário A2 disca 214-555-1111 para o usuário de chamada B1.

GK-A recebe ARQ de GWY-A1.

  1. O prefixo de tecnologia corresponde? Não

  2. O prefixo de zona corresponde? Sim. Defina a zona de destino como igual à zona remota GK-B (214).

  3. A zona de destino é local? Não

  4. Envie LRQ para GK-B.

GK-B recebe LRQ de GK-A.

  1. O prefixo de tecnologia é correspondente? Não

  2. O prefixo de zona corresponde? Sim. Defina a zona de destino como igual à zona local.

  3. A zona de destino é local? Sim

  4. Um prefixo de tecnologia foi encontrado na etapa 1? Não

  5. O endereço de destino está registrado? Não

  6. O prefixo de tecnologia padrão está definido? Sim. Selecione a local. gateway com o prefixo de tecnologia (2#).

  7. Envie LCF para GK-A.

    GK-A recebe LCF de GK-B com informações do gateway de terminação.

    GK-A envia ACF para GWY-A1.

    A configuração da chamada foi bem-sucedida.

Cenário 2: Gatekeepers de zona configurados sem prefixos de tecnologia padrão

Nesse cenário, o GWY-A1 registra no GK-A com prefixo de tecnologia 1# e o GWY-B1 registra no GK-B com prefixo de tecnologia 2#. GWY-A1 adiciona prefixo de tecnologia 2# à seqüência de números chamada quando faz chamadas para (214) e o GWY-B1 adiciona prefixo de tecnologia 1# à seqüência de números chamada quando faz chamadas para (512).

GK-A

GK-B

!
gatekeeper
zona local GK-A abc.com
zona remota GK-B abc.com 172.22.2.3 1719
prefixo de zona GK-B 214*
prefixo de zona GK-A 512*
arq reject-unknown-prefix
no shutdown
!
!
gatekeeper
zona local GK-B abc.com 172.22.2.3
zona remota GK-A abc.com 172.22.1.3 1719
prefixo de zona GK-B 214*
prefixo de zona GK-A 512*
no shutdown
!

GWY-A1

GWY-B1

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
tech-prefix 1# de h323-gateway voip
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2#
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
tech-prefix 2# de h323-gateway voip
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1#
!
gateway
!

Primeira Ação de Chamada: O usuário B1 disca 512-555-1212 para o usuário de chamada A1.

GK-B recebe ARQ de GWY-B1.

  1. O prefixo de tecnologia corresponde? Não

  2. O prefixo de zona corresponde? Não

    Observação: Como o GK-B não está ciente de um prefixo de tecnologia 1#, ele pressupõe que o prefixo faz parte do número chamado e o lê como um prefixo de zona.

  3. A zona de destino é local? Sim

    Observação: O GK-B considera a zona de destino padrão igual à zona local, pois o comando arq reject-unknown-prefix não está definido.

  4. Um prefixo de tecnologia foi encontrado na etapa 1? Não

  5. O endereço de destino está registrado? Não

  6. O prefixo de tecnologia padrão está definido? Não

  7. Envie ARJ para GWY-B1.

    Falha na configuração da chamada.

A saída a seguir foi capturada em GK-B para ilustrar em mais detalhes esse comportamento.

            
               !--- De debug gatekeeper main 5.
            

GK-B#
gk_rassrv_arq: arqp=0x62F6A7E0, crv=0x22, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Falha na correspondência de prefixo técnico
rassrv_get_addrinfo(1#5125551212): prefixo de zona não resolvido, usando a zona de origem GK-B
rassrv_get_addrinfo(1#5125551212): endereço desconhecido e nenhuma tecnologia padrão definida
gk_rassrv_sep_arq(): rassrv_get_addrinfo() failed (return code = 0x103)

               
!--- De debug ras.
            

GK-B#
RecvUDP_IPSockData successfully rcvd message of length 156 from 172.22.2.1:51141
ARQ (seq# 1796) rcvdparse_arq_nonstd: ARQ Nonstd decode succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 4 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendARJ: ARJ (seq# 1796) enviado para 172.22.2.1
         

Para corrigir esse problema, configure os gatekeepers para identificar prefixos de tecnologia de zona remota.

  • Adicione o seguintes ao GK-B:

    GK-B(config-gk)#gw-type-prefix 1# hopoff GK-A
                   
  • Adicione o seguinte ao GK-A:

    GK-A(config-gk)#gw-type-prefix 2# hopoff GK-B
                   

Observe que o peer de discagem POTS nos gateways de terminação precisa ser melhorado para corresponder às seqüências de discagem de entrada com os prefixos de tecnologia.

GK-A

GK-B

!
gatekeeper
zona local GK-A abc.com
zona remota GK-B abc.com 172.22.2.3 1719
prefixo de zona GK-B 214*
prefixo de zona GK-A 512*
arq reject-unknown-prefix
gw-type-prefix 2# hopoff GK-B
no shutdown
!
!
gatekeeper
zona local GK-B abc.com 172.22.2.3
zona remota GK-A abc.com 172.22.1.3 1719
prefixo de zona GK-B 214*
prefixo de zona GK-A 512*
gw-type-prefix 1# hopoff GK-A
no shutdown
!

GK-B

GWY-B1

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
tech-prefix 1# de h323-gateway voip
!
                     
!-- Este peer de discagem é usado para
!--- chamadas de entrada do PSTN.
                  
dial-peer voice 1 pots
incoming called-number 512.......
direct-inward-dial
port 1/0:23
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2#
!

                     !-- Este peer de discagem é usado para
!--- terminar chamadas (512) provenientes
!--- da rede VoIP. Observe
!--- que o prefixo de tecnologia
!--- correspondeu ao peer de discagem selecionado
!--- mas não passe-o para
!--- o PSTN.
                  
dial-peer voice 3 pots
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 4 voip
destination-pattern 972.......
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
tech-prefix 2# de h323-gateway voip
!
dial-peer voice 1 pots
incoming called-number 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1#
!
dial-peer voice 3 pots
destination-pattern 2#214.......
port 3/0:23
prefix 214
!
gateway
!

Ação de Chamada Secundária: O usuário B1 disca 512-555-1212 para o usuário de chamada A1.

GK-B recebe ARQ de GWY-B1.

  1. O prefixo de tecnologia corresponde? Sim

  2. Há um prefixo de tecnologia de desconexão? Sim

  3. Envie LRQ para GK-A.

    Observação: O LRQ inclui o prefixo de tecnologia no número chamado para análise do GK-A.

GK-A recebe LRQ de GK-B.

  1. O prefixo de tecnologia corresponde? Sim

  2. Há um prefixo de tecnologia de desconexão? Não

    Observação: Para continuar a análise do roteamento de chamadas, o GK-A remove o prefixo de tecnologia. O prefixo de tecnologia permanece na seqüência de números chamada quando os gateways configuram os segmentos de chamada.

  3. O prefixo de zona corresponde? Sim. Defina a zona de destino como igual à zona local.

  4. A zona de destino é local? Sim

  5. Um prefixo de tecnologia foi encontrado na etapa 1? Sim

  6. Você encontrou um gateway local com um prefixo de tecnologia? Sim

  7. Envie LCF para GK-B.

    GK-B recebe LCF de GK-A com informações do gateway de terminação.

    GK-B envia ACF para GWY-B1.

    Configuração de chamada bem-sucedida.

A saída de comando a seguir foi capturada em GK-B para ilustrar em mais detalhes esse comportamento.

            
               !--- De debug gatekeeper main 5.
            

GK-B#
gk_rassrv_arq: arqp=0x62ED2D68, crv=0x24, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): tech-prefix 1# correspondente
rassrv_put_remote_zones_from_zone_list() zona GK-A
gk_rassrv_irr: irrp=0x62F0D8FC, from 172.22.2.1:51141
GK-B#
GK-B#
     
               
!--- De debug ras.
            

RecvUDP_IPSockData successfully received message of
length 156 from 172.22.2.1:51141
ARQ (seq# 1809) rcvdparse_arq_nonstd: ARQ Nonstd decode
succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 104 from
172.22.2.3:1719 to 172.22.1.3: 1719
RASLib::RASSendLRQ: LRQ (seq# 1042) enviado para 172.22.1.3
IPSOCK_RAS_sendto: msg length 7 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendRIP: RIP (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length
131 from 172.22.1.3:1719
LCF (seq# 1042) rcvdparse_lcf_nonstd: LCF Nonstd
decode succeeded, remlen= 131
IPSOCK_RAS_sendto: msg length 34 from 172.22.2.3:1719
to 172.22.2.1: 51141
RASLib::RASSendACF: ACF (seq# 1809) enviado para 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length
76 from 172.22.2.1:51141

Comandos de Verificação e Solução de Problemas

Veja a seguir uma lista de comandos show e debug usados para verificar e solucionar problemas problemas de roteamento de chamada de gateway e gatekeeper

Alguns comandos show recebem suporte da Output Interpreter Tool (clientes registrados somente) , que permite que você veja uma análise da saída do comando show.

Observação: Antes de executar comandos debug, consulte as Informações Importantes sobre Comandos Debug.

  • show gateway—Usado para verificar o registro de alias E.164 e H.323 no gateway.

  • show gatekeeper endpoints—Usado para verificar o alias E.164 e H.323 registrado no gatekeeper.

  • show gatekeeper gw-type-prefix—Usado para verificar registros de prefixo E.164 no gatekeeper.

  • show gatekeeper zone prefix | status—Usado para verificar o status da zona e os parâmetros de configuração.

  • debug ras—Aplicável para gateways e gatekeepers.

  • debug h225 asn1—Aplicável para gateways e gatekeepers.

  • show dial-peer voice—Usado para verificar prefixos de tecnologia configurados em peers de discagem.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 24462