Voz : Qualidade de voz

QoS de Voz: Marcação de Pacote ToS-CoS para Ser Utilizado com LLQ

22 Maio 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (2 Fevereiro 2006) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Configurar
     Diagrama de rede
     Configurações
Verificação
Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento descreve Quality of Service (QoS) para Voz sobre IP (VoIP) em um ambiente de rede pelo mapeamento do Tipo de Serviço (ToS) para os parâmetros da Classe de Serviço (CoS).

Até recentemente, era consenso geral que a QoS jamais seria um problema no lado da empresa devido à natureza intermitente do tráfego de rede e à capacidade de excesso de buffer. A razão da QoS no lado da rede é devido ao armazenamento em buffer, não à falta de largura de banda. Por essa razão, as ferramentas de QoS são necessárias para gerenciar esses buffers para minimizar perdas, atrasos e variações de atrasos. Os buffers de transmissão têm uma tendência a ocupar a capacidade das redes de alta velocidade devido à natureza intermitente das redes de dados combinado ao alto volume de pacotes TCP menores. Se um buffer de saída for totalmente ocupado, as interfaces de ingresso não serão capazes de colocar imediatamente um novo tráfego de fluxo no buffer de saída. Depois que o buffer de ingresso for totalmente ocupado (isso pode acontecer rapidamente), ocorrerá o descarta de pacotes. É neste momento que a qualidade de voz pode degradar devido à perda de pacotes.

O tráfego VoIP é sensível tanto ao atraso de pacotes quanto à queda no fluxo de pacotes. O atraso nunca deve ser um fator a ser considerado, independente do tamanho do buffer na fila, devido à alta velocidade de links da rede. Porém, os descartes sempre afetam negativamente a qualidade de voz em todas as redes. O uso de várias filas nas interfaces de transmissão é a única maneira possível de eliminar o potencial de descarte de tráfego causado pelos buffers que operam com 100% de capacidade. A separação de voz e vídeo (sensível a atrasos e descartes) em filas próprias pode evitar as quedas de fluxos na interface de ingresso, mesmo que os fluxos de dados ocupem totalmente o buffer de transmissão de dados.

Nas redes com altas cargas de tráfego, é crucial gerenciar a distribuição do tráfego de controle para garantir qualidade ao usuário do VoIP. Isso pode ser ilustrado com facilidade. Por exemplo, quando um telefone de IP está fora do gancho, pergunta ao Cisco CallManager o que fazer. O Cisco CallManager instrui o telefone de IP a reproduzir o tom de discagem. Se o gerenciamento do Skinny Client Protocol e o tráfego de controle for descartado ou com atrasado, o usuário será afetado negativamente. Para fornecer a QoS, marque os cabeçalhos dos pacotes em ordem de prioridade e mapeie-os corretamente para os cabeçalhos da Camada 2 para que os Catalysts possam compreender. Isso assegura uma ordem de prioridade correta aos pacotes de voz através da rede.

Pré-requisitos

Requisitos

Não existem pré-requisitos específicos para este documento.

Componentes Usados

As informações neste documento são baseadas nestas versões de hardware e software.

  • Porta de voz Cisco 3725 com Cisco IOS® Software Release 12.3(4)T.

  • Switch Catalyst 4000

  • Cisco CallManagers e telefones de IP

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento foram iniciados com uma configuração vazia (padrão). Caso esteja trabalhando em uma rede ativa, certifique-se de ter compreendido o possível impacto dos comandos antes de utilizá-los.

Convenções

Para obter mais informações sobre convenções em documentos, consulte as Convenções de Dicas Técnicas da Cisco.

Configurar

Nesta seção, você vai conhecer informações para configurar os recursos descritos neste documento.

Observação: Para obter outras informações sobre os comandos utilizados neste documento, utilize a Ferramenta de Consulta de Comandos (clientes registrados somente) .

Diagrama de rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

tos-cos-1.gif

Configurações

Este documento usa estas configurações.

Essa configuração mostra como mapear os valores de ToS/Differentiated Services Code Point (DSCP) em um valor da CoS na porção de cabeçalho 802.1p. Existe muitas maneiras de implementar isso e as poucas diferenças variam dependendo de seu desenho. Os dois exemplos de configuração aqui são equivalentes e qualquer um deles pode ser utilizado para chegar ao mesmo resultado. Certifique-se de autorizar apenas os pacotes VoIP que tenham uma precedência de IP definida para crítica (5) no bit ToS. Nenhum outro tráfego deve ter esse bit definido para crítico. Isso causa sobreposição de tráfego indesejável na fila de voz.

Observação: A configuração de LLQ é feita em outros dispositivos da rede como o Catalyst 4000, mas não é discutida neste documento.

Neste primeiro exemplo, apenas os fluxos RTP que atendam à precedência de IP 5 são marcados e não os RTCP ou qualquer pacote de sinalização ou mensagem H.225/245.

Cisco 3660 (exemplo 1)

!
ip cef
!

                     !--- O mecanismo Cisco Express Forwarding (CEF) precisa ser habilitado
!--- para que o comando set cos que é
!--- configurado posteriormente entre em vigor.
!--- Se isso não for feito, o roteador o lembrará com
!--- a mensagem de erro "O switching de CEF é necessário para operações 'set'".
                  
!
class-map match-all RTP
match ip precedence 5 
                  
                     !--- Este comando atende a todos os pacotes com a precedência de IP de 5.
                  
!
policy-map OutboundPolicy
class RTP
set CoS 5
                  
                     !--- Para que todos os pacotes que foram compatibilizados anteriormente no RTP de mapas de classe
!--- tenham precedência de 5, o bit CoS agora é definido para 5.
                  
                  class class-default
set CoS 0
                  
                     !--- Todo o outro tráfego tem uma CoS de 0 e
!--- transporta uma prioridade mais baixa de entrega.
                  
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulamento dot1Q 816
                  
                     !--- Deve haver interfaces intermediárias para que a interface FastEthernet habilite o entroncamento,
!--- assim como o encapsulamento dot1q ou isl.
                  
ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

                     !--- Aplica a QoS à interface que se conecta à rede
!--- por meio do Catalyst 4000.
                  
!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media
no vad
!

Observação: O comando ip qos dscp foi introduzido no Cisco IOS Software Release 12.2(2)T. Ele substitui o comando ip precedence (dial-peer). Todos os roteadores que são executados no Cisco IOS Software Release 12.2(2)T e anteriores podem usar ip precedence na configuração dial-peer.

O segundo exemplo tem parâmetros de compatibilidade diferentes para as classes de mapa de política. A configuração do Cisco 3660 atende aos pacotes de configuração de chamada H.225 assim como os fluxos de RTP. Os critérios de compatibilidade do fluxo de RTP também são ligeiramente diferentes. Não examine os cabeçalhos IP, apenas o intervalo de porta UDP. Se falhar entre 16384 e 32767, marque-os e os envie para o mapa de política.

Cisco 3660 (exemplo 2)

!
ip cef
!

                     !--- O mecanismo de CEF precisa ser habilitado
!--- para que o comando set cos que é
!--- configurado posteriormente entre em vigor.
!--- Se isso não for feito, o roteador o lembrará com
!--- a mensagem de erro "O switching de CEF é necessárip para operações 'set'".
                  !
class-map match-all Call-Control
match access-group 101
!
class-map match-all RTP
match ip rtp 16384 16383
                  
                     !--- Compara o intervalo de portas UDP 16384-32767 para especificar
!--- os pacotes VoIP para o mapa de política.
                  
!
access-list 101 permit tcp host 10.120.16.112 any eq 1720
                  
                     !--- Compara todos os pacotes usando a porta TCP 1720 que é
!--- dedicada para a configuração de chamada H.225. 
                  
!
policy-map OutboundPolicy
class RTP
set CoS 5
                  
                     !--- Para todos os pacotes VoIP que atendam ao intervalo de portas UDP listado acima,
!--- defina o bit CoS para 5.
                  
class Call-Control
set CoS 3
set ip precedence 3

                     !--- Para todos os pacotes de sinalização e controle que atendam à lista de acesso
!--- 101, defina o bit CoS para 3 e a precedência de IP para 3.
                  
class class-default
set CoS 0

                     !--- Todo o outro tráfego tem um CoS de 0 e transporta
!--- prioridade de entrega mais baixa. 
                  
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816
ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy
                  
                     !--- Aplica sua QoS à interface que se conecta à
!--- rede por meio do Catalyst 4000.
                  
!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media
no vad
!

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Alguns comandos show recebem suporte da Output Interpreter Tool (clientes registrados somente) , o que permite visualizar uma análise da saída do comandoshow.

  • show policy-map interface — Exibe contadores compatíveis para todas as classes de um mapa de política de serviço especificado.

Os roteadores agora estão configurados para mapear o bit ToS para o bit CoS. Utilize o comando show policy-map interface para certificar-se de que o tráfego está realmente marcado de acordo com a configuração.

Neste primeiro exemplo de saída, os 539 pacotes VoIP são compatíveis com o mapa de classe e todos os 539 pacotes têm o bit CoS marcado para um valor de crítica como resultado. Esse tipo de enfileiramento não tem de aguardar por congestionamentos para ser ativado. Logo que haja tráfego de voz que atravesse o link FastEthernet, todos os pacotes são marcados de acordo. No segundo exemplo, todos os pacotes VoIP marcados para o valor CoS de 5 e todos os pacotes de sinalização são marcados para um valor de CoS de 3 de acordo com a configuração.

Do exemplo de configuração do primeiro 3660:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816
  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      539 packets, 42042 bytes
      5 minute offered rate 2000 bps, drop rate 0 BPS
      Match: ip precedence 5
      QoS Set
        CoS 5
          539 pacotes marcados

    Class-map: class-default (match-any)
      13 packets, 1803 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any
      QoS Set
        CoS 0
          13 pacotes marcados
         

Do exemplo de configuração do segundo 3660:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816

  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      370 packets, 28860 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip rtp 16384 16383
      QoS Set
        CoS 5
          370 pacotes marcados

    Class-map: Call-Control (match-all)
      26 packets, 2697 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: access-group 101
      QoS Set
        ip precedence 3
          26 pacotes marcados
        CoS 3
          26 pacotes marcados

    Class-map: class-default (match-any)
      4363 packets, 515087 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any
      QoS Set
        CoS 0
          4363 pacotes marcados
vdtl-3660-16a#

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 23442