Segurança e VPN : Negociação IPSec/Protocolos IKE

Configurando o IPSec de Estático para Dinâmico do Roteador para PIX com o NAT

22 Maio 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (26 Setembro 2008) | Feedback


Índice

Introdução
Antes de Iniciar
     Convenções
     Pré-requisitos
     Componentes Usados
Configurar
     Diagrama de Rede
     Configurações
Verificação
Solução de Problemas
     Comandos de Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento fornece um exemplo de configuração para habilitar o PIX a aceitar conexões IPSec dinâmicas. O roteador remoto executa a Network Address Translation (NAT) se a rede privada 10.1.1.x acessa a Internet. O tráfego de 10.1.1.x para 192.168.1.x da rede privada por trás do PIX é excluído do processo da NAT. O roteador pode iniciar conexões para o PIX, mas a recíproca não é verdadeira.

Antes de Iniciar

Convenções

Para obter mais informações sobre convenções em documentos, consulte as Convenções de Dicas Técnicas da Cisco.

Pré-requisitos

Não existem pré-requisitos específicos para este documento.

Componentes Usados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Cisco IOS Software Release 12.2.(8)T, 12.2.(15)T2 e 12.3(1)

  • Cisco PIX Firewall Software Release 6.1.3 e 6.3.1

  • Cisco Secure PIX Firewall 515E

  • Router Cisco 7206

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento foram iniciados com uma configuração vazia (padrão). Caso esteja trabalhando em uma rede ativa, certifique-se de ter compreendido o possível impacto dos comandos antes de utilizá-los.

Configurar

Nesta seção, você vai conhecer informações para configurar os recursos descritos neste documento.

Observação: Para obter outras informações sobre os comandos utilizados neste documento, utilize a Ferramenta de Consulta de Comandos (clientes registrados somente) .

Diagrama de Rede

Este documento utiliza a configuração de rede apresentada no diagrama abaixo.

pix_router_dyn_01.gif

Configurações

Este documento utiliza a configuração apresentada abaixo.

Elf (PIX)

Building configuration...
: Saved
:
PIX Version 6.3(1)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security10
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname elf
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names

                     !--- Lista de controle de acesso (ACL) para evitar o NAT nos pacotes IPSec
                  
                  access-list nonat permit ip 192.168.1.0 255.255.255.0 10.1.1.0 255.255.255.0
pager lines 24
logging on
logging buffered debugging
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside 172.18.124.2 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip address intf2 127.0.0.1 255.255.255.255
ip audit info action alarm
ip audit attack action alarm
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
failover ip address intf2 0.0.0.0
pdm history enable
arp timeout 14400
global (outside) 1 interface

                     !—Vinculando a instrução nonat da ACL à instrução NAT para evitar a NAT nos pacotes IPSec
                  
                  nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
                  
                     !--- Permitindo o tráfego de Internet Control Message Protocol (ICMP) para testes.
!--- Não o habilita na rede ativa.
                  
                  conduit permit icmp any any
route outside 0.0.0.0 0.0.0.0 10.64.10.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00
h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol tacacs+
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat

                     !--- Configuração do IPSec
                  
                  crypto ipsec transform-set router-set esp-des esp-md5-hmac
crypto dynamic-map cisco 1 set transform-set router-set
crypto map dyn-map 10 ipsec-isakmp dynamic cisco
crypto map pixmap interface outside
isakmp enable outside
                  
                     !--- Internet Security Association and Key Management Protocol (ISAKMP)
!--- política de aceitação de conexões dinâmicas para PIX remoto PIX.
!--- Observação: Na saída mostrada por um processamento real, as chaves pré-compartilhadas aparecem como *******.
                  
                  isakmp key cisco123 address 0.0.0.0 netmask 0.0.0.0
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh timeout 5
terminal width 80
Cryptochecksum:eeb67d5df47045f7e6ac4aa090aab683
: end
[OK]
elf#

Mop (Router Cisco 7204)

mop#show running-configuration
Building configuration...

Current configuration : 1916 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mop
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
ip cef
ip audit notify log
ip audit po max-events 100
!

                     !--- Políticas do Internet Key Exchange (IKE)
                  
                  crypto isakmp policy 1
 hash md5
 authentication pre-share
crypto isakmp key cisco123 address 172.18.124.2
!
!

                     !--- Políticas do IPSec
                  
                  crypto ipsec transform-set pix-set esp-des esp-md5-hmac
!
crypto map pix 10 ipsec-isakmp
 set peer 172.18.124.2
 set transform-set pix-set
 match address 101
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Ethernet1/0
ip address 172.18.124.1 255.255.255.0
ip nat outside
duplex half
crypto map pix
!
interface Ethernet1/1
ip address 10.1.1.1 255.255.255.0
ip nat inside
duplex half
!

                     !--- Exclua a rede privada do processo NAT.
                  
                  ip nat inside source route-map nonat interface Ethernet1/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.124.2
no ip http server
ip pim bidir-enable
!

                     !--- Inclua o tráfego de rede privada para rede privada
!--- no processo de criptografia.
                  
                  access-list 101 permit ip 10.1.1.0 0.0.0.255 192.168.1.0 0.0.0.255
                  
                     !--- Exclua a rede privada do processo NAT.
                  
                  access-list 110 deny ip 10.1.1.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 110 permit ip 10.1.1.0 0.0.0.255 any
!
route-map nonat permit 10
 match ip address 110
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Alguns comandos show recebem suporte da Output Interpreter Tool (clientes registrados somente) , o que permite visualizar uma análise da saída do comandoshow.

Os seguintes comandos show podem ser executados no PIX e no roteador.

  • show crypto isakmp sa - Mostra todas as associações de segurança (SAs) IKE em um par.

  • show crypto ipsec sa - Mostra as configurações usadas pelas SAs [IPSec] atuais.

  • show crypto engine connections active - Mostra as conexões e informações atuais relativas aos pacotes criptografados e descriptografados. (somente roteador)

Você deve limpar as SAs nos dois pares.

  • Os comandos do PIX são executados no modo de config.

    • clear crypto isakmp sa - Limpa as SAs da Fase 1.

    • clear crypto ipsec sa - Limpa as SAs da Fase 2.

  • Os comandos do roteador são executados no modo habilitar.

    • clear crypto isakmp - Limpa as SAs da Fase 1.

    • clear crypto sa - Limpa as SAs da Fase 2.

Solução de Problemas

Esta seção fornece informações que podem ser utilizadas para solucionar problemas de configuração.

Comandos de Solução de Problemas

Observação: Antes de emitir comandos debug, consulte Informações Importantes sobre Comandos de Depuração.

  • show crypto isakmp sa - Visualize todas as associações de segurança de IKE (SAs) em um correspondente.

  • show crypto ipsec sa - Mostra as configurações usadas pelas SAs [IPSec] atuais.

  • show crypto engine connections active - Mostra as conexões e informações atuais relativas aos pacotes criptografados e descriptografados. (somente roteador)


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 23102