IP : Serviços de endereçamento IP

Configurando Dinamicamente as Opções do Servidor DHCP

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (12 Outubro 2005) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Configurar
     Diagrama de Rede
     Configurações
Verificação
Solução de Problemas
     Comandos de Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

O DHCP o habilita a atribuir automaticamente endereços de IP reutilizáveis para clientes DHCP. Este documento fornece um exemplo de como configurar as opções do DHCP como os endereços de Domain Name System (DNS) e Windows Internet Name Service (WINS), para responder às solicitações de DHCP de clientes locais por trás do customer premises equipment (CPE).

Anteriormente, os administradores de rede tinham de configurar manualmente o servidor DHCP Cisco IOS® em cada dispositivo habilitado com este recurso. Após a implantação de um roteador, torna-se muito trabalhoso, demorado e caro acessar cada local e fazer modificações.

Conseqüentemente, o servidor DHCP Cisco IOS foi aperfeiçoado para permitir que informações sobre configuração sejam atualizadas automaticamente. Os administradores de rede podem configurar um ou mais servidores DHCP centralizados para atualizar opções específicas de DHCP nos pools de DHCP. Os servidores remotos podem solicitar ou importar esses parâmetros de opção de servidores centralizados.

Pré-requisitos

Requisitos

A Cisco recomenda aos leitores deste documento que tenham conhecimento destes tópicos:

  • DHCP

  • Domain Name System (DNS)

  • Windows Internet Name Service (WINS)

Componentes Usados

Esta configuração foi desenvolvida e testada com estas versões de software e hardware.

  • Cisco IOS® Software Release 12.2(27)

  • Dois roteadores Cisco 3660 com NM-1E utilizados para a conexão de PC e cliente

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento foram iniciados com uma configuração vazia (padrão). Se a sua rede estiver ativa, certifique-se de entender o impacto potencial de todos os comandos.

Observação: o recurso Servidor DHCP do Cisco IOS é introduzido na Cisco IOS Software Release 12.0(1)T. Você precisa da Cisco IOS® Software Release 12.0(2)T ou posterior para ser utilizada com os Cisco 1700 Series Routers. Para obter mais informações sobre roteadores que dêem suporte ao recurso Servidor DHCP, consulte a seção Plataformas Suportadas do documento Servidor DHCP Cisco IOS.

Convenções

Para obter mais informações sobre convenções de documentos, consulte Convenções de Dicas Técnicas da Cisco.

Configurar

Nesta seção, você vai conhecer as informações para configurar as opções do servidor DHCP para o DNS e WINS. O roteador 'Central' é configurado para essas opções de servidor e o roteador 'Remoto' importa essas opções. O PC ou cliente remoto recebe essas opções importadas do roteador 'Remoto' durante seu estágio DHCPACK.

Observação: Para encontrar outras informações sobre os comandos utilizados neste documento, consulte o documento Comandos do DHCP ou utilize a Ferramenta de Consulta de Comandos (clientes registrados somente) .

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

dhcp_ser_01.gif

Configurações

Este documento utiliza estas configurações:

Central (3660)

Central# show running-config
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

                     !--- Este intervalo não deve ser atribuído a clientes DHCP.
                  
!
ip dhcp pool Central
   network 10.0.0.0 255.255.255.0

                     !--- Especifique o número e a máscara de rede para clientes DHCP.
                  
   domain-name Central

                     !--- Especifique o nome de domínio do cliente.
                  
   dns-server 10.0.0.2

                     !--- Especifique o servidor DNS que você deseja responder a clientes DHCP que 
                  
                  
                     !--- precisam correlacionar o nome do host ao endereço IP.
                  
   netbios-name-server 10.0.0.2

                     !--- Especifique o Network Basic Input/Output System (NetBIOS)
                  
                  
                     !--- O servidor WINS (para clientes Microsoft DHCP)
                  
!
.
.
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
.
.
!
end

Remoto (3660)

Remote# show running-config
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

                     !--- Esse endereço IP não deve ser atribuído aos clientes DHCP.
                  
!
ip dhcp pool Client
   import all

                     !--- Importe os parâmetros de opção do DHCP para o banco de dados.
                  
   network 192.168.1.0 255.255.255.248

                     !--- Especifique o número e a máscara de rede para clientes DHCP.
                  
   default-router 192.168.1.1

                     !--- Especifique o gateway padrão para os clientes DHCP.
                  
!
.
.
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração funciona corretamente.

Alguns comandos show recebem suporte da Output Interpreter Tool (clientes registrados somente) , o que permite visualizar uma análise da saída do comandoshow.

  • show ip dhcp import —Exibe os parâmetros de opção importados para o banco de dados do DHCP.

            Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
            Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
            Central#show ip dhcp binding
IP address       Client-ID/Hardware address	 	Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.
                 30

Solução de Problemas

Esta seção fornece informações que podem ser utilizadas para solucionar problemas de configuração.

Comandos de Solução de Problemas

Observação: Antes de executar comandos debug, consulte Informações Importantes sobre Comandos de Depuração.

A saída obtida de um PC ou cliente com um sistema operacional Microsoft Windows com o comando ipconfig /all fornece os valores da configuração do TCP/IP configurados pelo DHCP.

C:\>ipconfig /all

Windows 2000 IP Configuration

  Host Name . . . . . . . . . . . . : PC
  Primary DNS Suffix . . . . . . .  : cisco.com
  Node Type . . . . . . . . . . . . : Hybrid
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No
  DNS Suffix Search List. . . . . . : cisco.com

Ethernet adapter Local Area Connection :

  Connection-specific DNS Suffix . : Central
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX)
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA
  DHCP Enabled. . . . . . . . . .  : Yes
  Autoconfiguration Enabled . . .  : Yes
  Endereço IP. . . . . . . . . . .  : 192.168.1.2
  Máscara de sub-rede . . . . . . . . . .  : 255.255.255.248
  Gateway padrão . . . . . . . .  : 192.168.1.1
  Servidor DHCP . . . . . . . . . .  : 10.0.0.6
  Servidores DNS . . . . . . . . . .  : 10.0.0.2
  Servidor WINS primário . . . . . .  : 10.0.0.2
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 22920