Qualidade de Serviço (QoS) : Regulamentação QoS

Frame Relay Traffic Shaping com QoS Distribuída na Série Cisco 7500

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (10 Agosto 2005) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Informações Complementares
Etapas da Configuração
FRF.12 e DTS
Problema Conhecido
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento explica a diferença entre o aplicativo de modelagem de tráfego em interfaces de Frame Relay em Cisco 7500 Series Routers com Processadores de Interface Versátil (VIPs) e em outras plataformas. As outras plataformas incluem roteadores das séries Cisco 7200, 3600 e 2600.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Usados

Este documento não está restrito a versões específicas de software e de hardware.

Convenções

Para obter mais informações sobre convenções de documentos, consulte Convenções de dicas técnicas da Cisco.

Informações Complementares

Assim como na Cisco IOS® Software Release 12.1(5)T, as políticas de Quality of Service (QoS) precisam ser executadas de forma distribuída no VIP; a QoS baseada no Route Switch Processor (RSP) não recebe mais suporte. Portanto, você precisa usar o comando shape e outros comandos da Modular QoS Command-Line Interface (MQC) para implementar a Distributed Traffic Shaping (DTS) para as interfaces de Frame Relay em VIPs na série Cisco 7500. A DTS combines Generic Traffic Shaping (GTS) e a Frame Relay Traffic Shaping (Frame Relay TS). Consulte Configurando a Distributed Traffic Shaping para obter um exemplo de configuração.

Esta tabela explica como configurar a Frame Relay TS, que depende da plataforma:

Série 7500

Séries 7200, 3600, 2600 e outras plataformas que não seja o VIP

Mecanismos de modelagem com suporte

DTS

Frame Relay TS

Comando de configuração

O comando shape em um mapa de política

frame-relay traffic-shaping em uma interface principal; map-class comandos de configuração para especificar parâmetros de modelagem específicos

Requer dCEF1

Sim (Verifique com o comando show cef linecard.)

Não

1 dCEF = distributed Cisco Express Forwarding

Observação: Na série Cisco 7500, a habilidade de configurar a Frame Relay TS por meio do comando frame-relay traffic-shaping agora está bloqueada porque a Frame Relay TS executa apenas o RSP em um modo não distribuído. Com o dCEF e o Frame Relay TS, uma adjacência de "punt" CEF faz com o RSP acelere a comutação de todos os pacotes, o que é quase o ideal para o desempenho máximo de encaminhamento.

Etapas da Configuração

Utilize estas etapas para configurar a DTS em interfaces Frame Relay baseadas no VIP:

  1. Habilite o dCEF com este comando:

    router(config)# ip cef distributed
                   
  2. Verifique se a interface de Frame Relay está habilitada para switching distribuído.

    router(config-if)# interface serial 8/0/0
    router(config-if)# ip route-cache distributed
    
    router# show ip interface serial 8/0/0 
    Serial8/0/0 is up, line protocol is up
      Internet address is 24.0.0.2/24
      Broadcast address is 255.255.255.255
     
                         !--- Saída suprimida.
                      
      ICMP redirects are always sent
      ICMP unreachables are always sent
      ICMP mask replies are never sent
      IP fast switching is enabled
      IP fast switching on the same interface is disabled
      IP Flow switching is disabled
      IP CEF switching is enabled
      O switching distribuído de IP está habilitada 
      IP Fast switching turbo vector
      IP CEF switching with tag imposition turbo vector
      IP multicast fast switching is enabled
      IP multicast distributed fast switching is disabled
      IP route-cache flags are Fast, Distributed, CEF
      Router Discovery is disabled
      IP output packet accounting is disabled
  3. Crie uma política de serviço e aplique à classe de mapa.

    Você pode implementar uma destas políticas:

    Observação: Enquanto a Cisco IOS Software Release 12.1(2)T introduziu o suporte ao enfileiramento de baixa latência (LLQ) em plataformas diferentes da série Cisco 7500, o LLQ distribuído (dLLQ) foi introduzido na Cisco IOS Software Release 12.1(5)T no VIP. As versões distribuídas aumentam o desempenho desse recurso. Você pode configurar uma política de serviço exclusiva por identificador de conexão de vínculo de dados (DLCI). Você não precisa utilizar uma classe de mapa. Você pode aplicar o comando service-policy diretamente na interface secundária ou no DLCI. Porém, configure o dLLQ em uma classe de mapa.

  4. Verifique a operação correta de sua política de serviços com este comandos:

    • show policy-map interface

    • show interface shape

    • show vip full-qos

    Exemplo de Configuração de DTS com uma Política de Hierarquia

    ip cef distributed
    !
    class-map 1
      match <>
      
                               !--- Define critérios de compatibilidade.
                            
    class-map 2
      match <>
      
                               !--- Define critérios de compatibilidade.
                            
    !
    policy-map CBWFQ
      class 1
        bandwidth <>
        
                               !--- Define o valor em kbps ou percentagem.
                            
      class 2
        priority <>
        
                               !--- Define o valor em kbps ou percentagem.
                            
    !
    policy-map SHAPE
       class class-default
        shape average
        service-policy CBWFQ
    !
    int s0/0
      encapsulation frame-relay
      ip route-cache distributed
    
                               !--- Não configura o comando frame-relay traffic-shaping.
    
                            !
    int s0/0.1 point-to-point
      ip address a.b.c.d
      frame-relay interface-dlci xxx
       class cisco
    !
    map-class frame-relay cisco
      service-policy output SHAPE

FRF.12 e DTS

A Cisco IOS Software Release 12.1(5)T introduziu uma versão distribuída de fragmentação de Frame Relay, FRF.12. Ao aplicar a FRF.12 distribuída em uma interface Frame Relay, você precisará definir uma classe de mapa e aplicar a política de serviço na classe de mapa. Se tentar configurar uma classe de mapa com a política de serviços aplicadas diretamente à interface, se roteador reportará esta mensagem de erro com logging console habilitado:

Frame Relay fragmentation works with dTS only.
Please remove traffic-shaping from the interface serial 1/0/0

A configuração desta seção e os comandos de verificação de configuração foram testados em um roteador da série Cisco 7500 executando a Cisco IOS Software Release 12.2(5)T em um RSP 8.

Observação: Consulte VoIP sobre Frame Relay co Qualidade de Serviço (Fragmentação, Modelagem de Tráfego, Prioridade RTP de LLQ / IP) para obter mais informações sobre a seleção de valores de fragmentação.

Exemplo de Configuração de DTS e FRF.12

interface Ethernet4/1/3
 ip address 10.122.3.206 255.255.255.0
!
interface Serial5/0/0:0
 no ip address
 encapsulation frame-relay
 load-interval 30
 no fair-queue

                     !--- Não configura o comando frame-relay traffic-shaping.

                  !
interface Serial5/0/0:0.1 point-to-point
 ip address 10.1.1.2 255.255.255.0
 frame-relay interface-dlci 16
 class test
 frame-relay ip rtp header-compression
!
map-class frame-relay test
 no frame-relay adaptive-shaping
 service-policy output llq-shape
 frame-relay fragment 120

                     !--- Aplica o comando frame-relay fragment à
!--- classe de mapa de Frame Relay.
                  
 access-list 101 permit udp any range 16384 32767 any  range 16384 32767

MS-7507-8A# show ip rtp head
RTP/UDP/IP header compression statistics:
DLCI 16 Link/Destination info: point-to-point dlci
Interface Serial5/0/0:0:
Distributed fast switched:
4 seconds since line card sent last stats update
Rcvd: 105475 total, 105472 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 99451 total, 99447 compressed,
3776208 bytes saved, 2187963 bytes sent
2.72 efficiency improvement factor
Connect: 256 rx slots, 256 tx slots,
0 long searches, 3 misses 0 collisions, 0 negative cache hits
99% hit ratio, five minute miss rate 0 misses/sec, 0 max

MS-7507-8A# show policy-map
Policy Map llq-shape
 Class class-default
  shape peak 256000 1024 1024
  service-policy llq
Policy Map llq
 Class voip
  priority percent 50

MS-7507-8A# show policy-map interface s 5/0/0:0.1
Serial5/0/0:0.1: DLCI 16 -
Service-policy output: llq-shape
  queue stats for all priority classes:
  queue size 0, queue limit 32
  packets output 147008, packet drops 0
  tail/random drops 0, no buffer drops 0, other drops 0
 Class-map: class-default (match-any)
  148237 packets, 10393582 bytes
  30 second offered rate 24000 bps, drop rate 0 bps
  Match: any
   queue size 0, queue limit 64
   packets output 149563, packet drops 0
   tail/random drops 0, no buffer drops 0, other drops 0
  Shape: cir 256000, Bc 1024, Be 1024
   lower bound cir 0, adapt to fecn 0
   output bytes 6972057, shape rate 10000 bps
Service-policy : llq
  Class-map: voip (match-all)
  146701 packets, 10325334 bytes
  30 second offered rate 24000 bps, drop rate 0 bps
  Match: access-group 101
  Priority: 50% (128 kbps), burst bytes 3200, b/w
  exceed drops: 0
  Class-map: class-default (match-any)
  1536 packets, 68248 bytes
  30 second offered rate 0 bps, drop rate 0 bps
  Match: any
  queue size 0, queue limit 32
  packets output 2555, packet drops 0
  tail/random drops 0, no buffer drops 0, other drops 0

MS-7507-8A# show frame pvc 16
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE)
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1
input pkts 3036327   output pkts 199453
in bytes 198958363
out bytes 17271661   dropped pkts 0   in FECN pkts 0
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0
in DE pkts 0         out DE pkts 0
out bcast pkts 1071  out bcast bytes 371448
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 35000 bits/sec, 50 packets/sec
pvc create time 17:51:42, last time pvc status changed 17:50:53
fragment type end-to-end fragment size 120

MS-7507-8A# show interface shape
Serial5/0/0:0 nobuffer drop 0
Serial5/0/0:0.1(class 0):
cir 256000, Bc 1024, Be 1024
lower bound cir 0, adapt to fecn 0
packets output 152104, bytes output 6985505
queue limit 64, queue size 0, drops 0
last clear = 16:58:59 ago, shape rate = 10000 bps

MS-7507-8A# show ip rtp head
RTP/UDP/IP header compression statistics:
DLCI 16 Link/Destination info: point-to-point dlci
Interface Serial5/0/0:0:
Distributed fast switched:
4 seconds since line card sent last stats update
Rcvd: 105475 total, 105472 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 99451 total, 99447 compressed,
3776208 bytes saved, 2187963 bytes sent
2.72 efficiency improvement factor
Connect: 256 rx slots, 256 tx slots,
0 long searches, 3 misses 0 collisions, 0 negative cache hits
99% hit ratio, five minute miss rate 0 misses/sec, 0 max

MS-7507-8A# show policy-map
Policy Map llq-shape
 Class class-default
  shape peak 256000 1024 1024
  service-policy llq
Policy Map llq
 Class voip
  priority percent 50

MS-7507-8A# show policy-map interface s 5/0/0:0.1
Serial5/0/0:0.1: DLCI 16 -
Service-policy output: llq-shape
  queue stats for all priority classes:
  queue size 0, queue limit 32
  packets output 147008, packet drops 0
  tail/random drops 0, no buffer drops 0, other drops 0
 Class-map: class-default (match-any)
  148237 packets, 10393582 bytes
  30 second offered rate 24000 bps, drop rate 0 bps
  Match: any
   queue size 0, queue limit 64
   packets output 149563, packet drops 0
   tail/random drops 0, no buffer drops 0, other drops 0
  Shape: cir 256000, Bc 1024, Be 1024
   lower bound cir 0, adapt to fecn 0
   output bytes 6972057, shape rate 10000 bps
Service-policy : llq
  Class-map: voip (match-all)
  146701 packets, 10325334 bytes
  30 second offered rate 24000 bps, drop rate 0 bps
  Match: access-group 101
  Priority: 50% (128 kbps), burst bytes 3200, b/w
  exceed drops: 0
  Class-map: class-default (match-any)
  1536 packets, 68248 bytes
  30 second offered rate 0 bps, drop rate 0 bps
  Match: any
  queue size 0, queue limit 32
  packets output 2555, packet drops 0
  tail/random drops 0, no buffer drops 0, other drops 0

MS-7507-8A# show frame pvc 16
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE)
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1
input pkts 3036327   output pkts 199453
in bytes 198958363
out bytes 17271661   dropped pkts 0   in FECN pkts 0
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0
in DE pkts 0         out DE pkts 0
out bcast pkts 1071  out bcast bytes 371448
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 35000 bits/sec, 50 packets/sec
pvc create time 17:51:42, last time pvc status changed 17:50:53
fragment type end-to-end fragment size 120

MS-7507-8A# show interface shape
Serial5/0/0:0 nobuffer drop 0
Serial5/0/0:0.1(class 0):
cir 256000, Bc 1024, Be 1024
lower bound cir 0, adapt to fecn 0
packets output 152104, bytes output 6985505
queue limit 64, queue size 0, drops 0
last clear = 16:58:59 ago, shape rate = 10000 bps

Problema Conhecido

Se você ainda utilizar a Cisco IOS Software Release 12.1E, a interface do VIP que está configurada com encapsulamento de Frame Relay pode travar com um erro de barramento. Esse travamento ocorrerá se você aplicar uma política de serviço enquanto a interface autoriza o tráfego. A solução é interromper todo tráfego em segundo plano antes de atualizar a política de serviço. Ou pode atualizar a Cisco IOS Software Release 12.2 ou posterior.

Para obter mais informações, consulte a página Ferramentas e Recursos da Cisco.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 18660