IP : Roteamento IP

Enhanced Interior Gateway Routing Protocol

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (9 Setembro 2005) | Feedback


Interativo: Este documento oferece uma análise personalizada do seu dispositivo Cisco.


Índice

Introdução
Teoria de Operação EIGRP
     Principais Revisões do Protocolo
     Teoria Básica
     Descoberta e Manutenção de Vizinho
     Criando a Tabela de Topologia
     Métricas do EIGRP
     Distância Factível, Distância Informada e Sucessor Possível
     Decidindo se um Caminho é Sem Circuito
Horizonte Dividido e Poison Reverse
     Modo de inicialização
     Alteração da tabela de topologia
     Consultas
Rotas “stuck in active” (travadas em modo ativo)
     Solução de Problemas de rotas SIA
Redistribuição
     Redistribuição entre dois sistemas EIGRP autônomos
     Redistribuição entre EIGRP e IGRP em dois sistemas autônomos diferentes
     Redistribuição Entre EIGRP e IGRP no Mesmo Sistema Autônomo
     Redistribuição Para Outros Protocolos e De Outros Protocolos
     Redistribuição de Rotas Estáticas em Interfaces
Sumarização
     Sumarização Automática
     Sumarização Manual
     Sumarização automática de rotas externas
Processamento e Intervalo de Consulta
     Como os Pontos de Sumarização Afetam o Intervalo de Consulta
     Como os Limites do Sistema Autônomo Afetam o Intervalo de Consulta
     Como as Listas de Distribuição Afetam o Intervalo de Consulta
Pacotes de Ritmo
Roteamento Padrão
Função de Balanceamento de Carga
Usando as Métricas
Usando Tarefas Administrativas na Redistribuição
Compreendendo a Saída de Comando EIGRP
     show ip eigrp topology
     show ip eigrp topology <network>
     show ip eigrp topology [active | pending | zero-successors]
     show ip eigrp topology all-links
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

O Enhanced Interior Gateway Routing Protocol (EIGRP) é um protocolo de gateway interior adequado para várias topologias e mídias diferentes. Em uma rede bem desenhada, o EIGRP é bem dimensionado e fornece tempos de convergência extremamente rápidos, com um mínimo de tráfego de rede.

Teoria de Operação EIGRP

Algumas das muitas vantagens do EIGRP são:

  • uso muito baixo dos recursos de rede durante a operação normal; apenas pacotes de saudação são transmitidos em uma rede estável

  • quando ocorre uma alteração, apenas as alterações da tabela de roteamento são propagadas, não a tabela de roteamento inteira; isso reduz a carga que o próprio protocolo de roteamento coloca na rede

  • tempos de convergência rápida para alterações na topologia da rede (em algumas situações a convergência pode ser quase instantânea)

O EIGRP é um protocolo de vetor de distância avançado, que depende do DUAL (Diffused Update Algorithm) para calcular o caminho mais curto até um destino na rede.

Principais Revisões do Protocolo

Há duas revisões principais do EIGRP:, versões 0 e 1. Versões do Cisco IOS anteriores às versões 10.3(11), 11.0(8) e 11.1(3) executam a versão anterior do EIGRP; algumas explicações neste documento talvez não se apliquem a essa versão anterior. É altamente recomendado utilizar a versão mais recente do EIGRP, pois ela inclui muitas melhorias de estabilidade e desempenho.

Teoria Básica

Um protocolo de vetor de distância típico salva as informações a seguir quando computa o melhor caminho para um destino: a distância (métrica ou distância total, como contagem de nós) e o vetor (o salto seguinte). Por exemplo, todos os roteadores da rede na Figura 1 estão executando o Routing Information Protocol (RIP). O Roteador 2 escolhe o caminho para a Rede A examinando a contagem de nós até cada caminho disponível.

eigrp1.gif

Como o caminho até o Roteador 3 é de três saltos e o caminho até o Roteador 1 é de dois saltos, o Roteador 2 escolhe o caminho até o 1 e descarta as informações obtidas até o 3. Se o caminho entre o Roteador 1 e a Rede A ficar inativo, o Roteador 2 perderá toda a conectividade com esse destino até que se esgote o tempo da rota da respectiva tabela de roteamento (três períodos de atualização ou 90 segundos), e o Roteador 3 anunciará novamente a rota (o que ocorre a cada 30 segundos em RIP). Sem incluir qualquer tempo de espera, será necessário entre 90 a 120 segundos para o Roteador 2 comutar o caminho do Roteador um para o Roteador 3.

O EIGRP, em lugar de contar as atualizações periódicas completas para a reconvergência, cria uma tabela de topologia de cada um dos anúncios de seus vizinhos (em lugar de descartar os dados) e faz a convergência procurando uma rota provavelmente sem circuito na tabela da topologia ou, caso não conheça outra rota, consultando seus vizinhos. O Roteador 2 salva as informações recebidas dos Roteadores 1 e 3. Ele escolhe o caminho por meio de 1 como o melhor caminho (o sucessor e o caminho por meio de 3 como o caminho sem circuito (um possível sucessor). Quando o caminho pelo roteador 1 estiver indisponível, o roteador 2 examinará sua tabela de topologia e, ao localizar um sucessor adequado, começará a usar o caminho pelo 3 imediatamente.

Desta explicação rápida, fica evidente que o EIGRP deve oferecer:

  • um sistema em que ele envie apenas as atualizações necessárias em um determinado momento; isso é conseguido por meio de descoberta e manutenção de vizinho

  • um modo de determinar quais os caminhos que um roteador aprendeu são sem circuito

  • um processo para limpar rotas incorretas das tabelas de topologia de todos os roteadores da rede

  • um processo para consultar vizinhos e encontrar caminhos para destinos perdidos

Abordaremos cada um desses requisitos separadamente.

Descoberta e Manutenção de Vizinho

Para distribuir informações de roteamento em uma rede, o EIGRP utiliza atualizações de roteamento incrementais não periódicas. Ou seja, o EIGRP só envia atualizações de roteamento sobre caminhos alterados quando esses caminhos tiverem sido alterados.

O problema básico com o envio apenas de atualizações de roteamento é que você pode não saber quando um caminho até um roteador vizinho não está mais disponível. Você não pode determinar o tempo das rotas, esperando receber uma nova tabela de roteamento de seus vizinhos. O EIGRP conta com relacionamento vizinhos para propagar, de modo confiável, as alterações da tabela de roteamento por toda a rede; dois roteadores tornam-se vizinhos quando eles detectam os pacotes de saudação um do outro em uma rede comum.

O EIGRP envia pacotes de saudação a cada 5 segundos em links de largura de banda alta e a cada 60 segundos em enlaces de multiponto de largura de banda baixa.

  • Saudação de 5 segundos:

    • mídia de broadcast, como Ethernet, Token Ring e FDDI

    • links seriais ponto a ponto, como circuitos concedidos PPP ou HDLC, subinterfaces ponto a ponto de Frame Relay e subinterface ponto a ponto ATM.

    • circuitos multiponto com largura de banda elevada (superior a T1), como ISDN PRI e Frame Relay

  • Saudação de 60 segundos:

    • A largura de banda T1 de circuitos multiponto ou mais lentos, como interfaces multiponto de Frame Relay, interfaces multiponto de ATM, circuitos virtuais comutados de ATM e BRIs de ISDN

The rate at which EIGRP sends hello packets is called the hello interval, and you can adjust it per interface with the ip hello-interval eigrp command. The hold time is the amount of time that a router will consider a neighbor alive without receiving a hello packet. The hold time is typically three times the hello interval, by default, 15 seconds and 180 seconds. You can adjust the hold time with the ip hold-time eigrp command.

Observe que, se você alterar o intervalo de saudação, o tempo de espera não será ajustado automaticamente para cálculo dessa alteração - você deverá ajustar manualmente o tempo de espera para refletir o intervalo de saudação configurado.

É possível para dois roteadores tornarem-se vizinhos EIGRP, embora os cronômetros de saudação e de espera não coincidam. O tempo de espera é incluído nos pacotes de saudação, assim, cada vizinho deverá permanecer ativo, embora o intervalo de saudação e os cronômetros de espera não coincidam.

Embora não haja um modo direto de determinar o intervalo de saudação que se encontra em um roteador, é possível deduzi-lo, na saída de show ip eigrp neighbor, no roteador vizinho.

Se você tiver a saída de um comando show ip eigrp neighbor do seu dispositivo Cisco, você pode usar o Output Interpreter (clientes registrados somente) para exibir problemas potenciais e correções. Para usar o Output Interpreter, deve-se ter o JavaScript ativado.

router# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address       Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2      Et1           13 12:00:53   12   300  0  620
0   10.1.2.2      S0           174 12:00:56   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           12 12:00:55   12   300  0  620
0   10.1.2.2       S0           173 12:00:57   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           11 12:00:56   12   300  0  620
0   10.1.2.2       S0           172 12:00:58   17   200  0  645

O valor na coluna Hold da saída do comando nunca deve exceder o tempo de espera e nunca deve ser menor do que o tempo de espera menos o intervalo de saudação (a menos, é claro, que você esteja perdendo pacotes de saudação). Se a coluna de espera geralmente varia entre 10 e 15 segundos, o intervalo de saudação é de 5 segundos e o tempo de espera é de 15 segundos. Se a coluna de espera geralmente tem um intervalo mais amplo - entre 120 e 180 segundos - o intervalo de saudação é de 60 segundos e o tempo de espera é de 180 segundos. Se os números parecem não se encaixar em uma das configurações padrão do cronômetro, verifique a interface em questão, no roteador vizinho – os cronômetros de saudação e de espera podem ter sido configurados manualmente.

Observação: 

  • O EIGRP não cria relacionamentos de peer em endereços secundários. Todo o tráfego de EIGRP tem origem no endereço principal da interface.

  • Ao configurar o EIGRP por uma rede Frame Relay multiacesso (ponto a multiponto etc.), configure a palavra-chave broadcast nas instruções de frame-relay map. Sem a palavra-chave broadcast, as adjacências não seriam estabelecidas entre dois roteadores EIGRP. Para obter mais informações, consulte Configurando e Solucionando Problemas de Frame Relay.

  • Não há limitações quanto ao número de vizinhos que o EIGRP pode suportar. O número real de vizinhos suportados depende da capacidade do dispositivo, como por exemplo:

    • capacidade de memória

    • potência de processamento

    • quantidade de informações trocadas, como o número de rotas enviadas

    • complexidade da topologia

    • estabilidade de rede

Criando a Tabela de Topologia

Agora que estes roteadores estão conversando um com o outro, qual é o assunto da conversa? As tabelas de topologia, obviamente. O EIGRP, diferente do RIP e do IGRP, não confia na tabela de roteamento (ou encaminhamento) do roteador para manter todas as informações necessárias para sua operação. Em vez disso, cria uma segunda tabela, a tabela de topologias, a partir da qual instala rotas na tabela de roteamentos.

Observação: A partir das versões 12.0T e 12.1do Cisco IOS, o RIP mantém seu próprio banco de dados a partir do qual instala rotas na tabela de roteamento.

Para ver o formato básico da tabela de topologia em um roteador com o EIGRP em execução, emita o comando show ip eigrp topology. A tabela de topologia contém as informações necessárias à criação de um conjunto de distâncias e vetores para cada rede alcançável, incluindo:

  • menor largura de banda no caminho para esse destino, conforme reportado pelo vizinho upstream

  • retardo total

  • confiabilidade do caminho

  • carga do trajeto

  • unidade de transmissão máxima de caminho mínimo (MTU)

  • distância factível

  • distância informada

  • origem de rota (rotas externas são marcadas)

Distância factível e distância informada são abordadas posteriormente nesta seção.

Se você tiver a saída de um comando show ip eigrp topology do seu dispositivo Cisco, você pode usar o Output Interpreter (clientes registrados somente) para exibir problemas potenciais e correções. Para usar o Output Interpreter, deve-se ter o JavaScript ativado.

Métricas do EIGRP

O EIGRP usa a largura de banda mínima no caminho para uma rede de destino e o retardo total para computar métricas de roteamento. Embora você possa configurar outras métricas, não recomendamos essa prática, pois ela pode ocasionar circuitos de roteamento na rede. As métricas de largura de banda e de retardo são determinadas a partir de valores configurados nas interfaces de roteadores, no caminho em direção à rede de destino.

Por exemplo, na Figura 2 abaixo, o Roteador 1 está computando o melhor caminho para a Rede A.

eigrp2.gif

Ele começa com os dois anúncios para esta rede: um até o Roteador 4, com uma largura de banda mínima de 56 e um retardo total de 2200, e o outro até o Roteador 3, com uma largura de banda mínima de 128 e um retardo de 1200. O Roteador 1 escolhe o caminho com a menor métrica.

Vamos computar as métricas. O EIGRP calcula a métrica total dimensionando as métricas de largura de banda e de retardo. O EIGRP usa a seguinte fórmula para dimensionar a largura de banda:

  • Largura de banda = (10000000/largura de banda(i)) * 256

    onde bandwidth(i) é a única largura de banda de todas as interfaces de saída na rota para a rede de destino representada em quilobits.

O EIGRP usa a seguinte fórmula para dimensionar o retardo:

  • retardo = retardo(i) * 256(i)

    em que delay(i) é a soma dos retardos configurados nas interfaces, na rota para a rede de destino, em dezenas de microssegundos. O retardo como mostrado nos comandos show ip eigrp topology ou show interface estão em microssegundos, portanto, você precisa dividir por 10 antes de usá-lo nesta fórmula. Ao longo deste documento, o retardo é utilizado da forma como configurado e mostrado na interface.

O EIGRP usa estes valores dimensionados para determinar a métrica total para a rede:

  • métrica = [K1 * largura de banda + (K2 * largura de banda) / (256 - carga) + K3 * atraso] * [K5 / (confiabilidade + K4)]

Observação: Esses valores K devem ser usados depois de um planejamento cuidadoso. Valores K incompatíveis impedem que um relacionamento vizinho seja criado, o que pode fazer com que a rede falhe na convergência.

Observação: Se K5 = 0, a fórmula reduz para a Métrica = [k1 * largura de banda + (k2 * largura de banda)/(256 - carga) + k3 * atraso].

Os valores padrão para K são:

  • K1 = 1

  • K2 = 0

  • K3 = 1

  • K4 = 0

  • K5 = 0

Para o comportamento padrão, você pode simplificar a fórmula como a seguir:

metric = bandwidth + delay 

Os roteadores Cisco não realizam cálculos de ponto flutuante; por isso, em cada estágio do cálculo, é necessário arredondar para o menor número inteiro mais próximo para calcular a métrica corretamente. Neste exemplo, o custo total até o Roteador 4 é de:

Neste exemplo, o custo total até o Roteador 4 é de:

minimum bandwidth = 56k

total delay = 100 + 100 + 2000 = 2200

[(10000000/56) + 2200] x 256 = (178571 + 2200) x 256 = 180771 x 256 = 46277376

E o custo total até o Roteador 3 é de:

minimum bandwidth = 128k

total delay = 100 + 100 + 1000 = 1200

[(10000000/128) + 1200] x 256 = (78125 + 1200) x 256 = 79325 x 256 = 20307200

Portanto para alcançar a Rede A, o Roteador Um escolhe a rota no Roteador Três.

Observe que os valores de largura de banda e de retardo que usamos são os valores configurados na interface através da qual o roteador alcança seu próximo salto em direção à rede de destino. Por exemplo, o Roteador 2 anunciou a Rede A com o retardo configurado em sua interface Ethernet; o Roteador 4 adicionou o retardo configurado em sua Ethernet e o Roteador 1 adicionou o retardo configurado em seu serial.

Distância Factível, Distância Informada e Sucessor Possível

A distância factível é a melhor métrica ao longo de um caminho para uma rede de destino, incluindo a métrica para o vizinho que anuncia esse caminho. A distância informada é a medição total ao longo de um caminho para uma rede de destino conforme anunciado por um vizinho upstream. O sucessor possível é um caminho cuja distância informada é inferior à distância factível (melhor caminho atual). A Figura 3 ilustra esse processo:

eigrp3.gif

O Roteador 1 detecta que ele não tem rotas para a Rede A: um através do roteador três e outro através do roteador quatro.

  • A rota até o Roteador 4 tem um custo de 46277376 e uma distância informada de 307200.

  • A rota até o Roteador 4 tem um custo de 46277376 e uma distância informada de 307200.

Observe que, em cada caso, o EIGRP calcula a distância informada do roteador que anuncia a rota para a rede. Em outras palavras, a distância informada do Roteador Quatro é a métrica para chegar à Rede A do Roteador Quatro, e a distância informada do Roteador Três é a métrica para chegar à Rede A do Roteador Três. O EIGRP seleciona a rota através do roteador três como o melhor caminho e utiliza a métrica através do roteador três como a distância factível. Como a distância informada para esta rede pelo Roteador quatro é menor do que a distância factível, o Roteador um considera o caminho pelo Roteador quatro um sucessor possível.

Quando o link entre os Roteadores 1 e 3 é desativado, o Roteador 1 examina cada caminho que conhece para a Rede A e descobre que há sucessor possível por meio do Roteador 4. O Roteador 1 usa essa rota, utilizando a métrica por meio do Roteador 4 como a nova distância factível. A rede converge instantaneamente e as atualizações dos vizinhos downstream são o único tráfego do protocolo de roteamento.

Vejamos um cenário mais complexo, mostrado na Figura 4.

eigrp4.gif

Há duas rotas para a Rede A a partir do Roteador 1: uma até o Roteador 2, com métrica de 46789376 e outra até o Roteador 4, com métrica de 20307200. O Roteador 1 escolhe a menor dessas duas métricas como a sua rota para a Rede A, e essa métrica se torna a distância factível. Em seguida, analisemos o caminho até a Rota 2, para ver se ele se qualifica como um sucessor possível. A distância informada do roteador dois é 46277376, que é maior do que a distância factível, portanto, este caminho não é um sucessor possível. A essa altura, se você precisasse olhar na tabela de topologia do Roteador 1 (por meio de show ip eigrp topology), você veria apenas uma entrada para a Rede A até o Roteador 4. (Na verdade, há duas entradas na tabela de topologia no Roteador 1, mas apenas uma será um sucessor possível, portanto, a outra não será exibida na show ip eigrp topology; você pode ver as rotas que não são sucessores possíveis, por meio de show ip eigrp topology all-links).

Vamos supor que o link entre os Roteadores 1 e 4 esteja desativado. O Roteador 1 detecta ter pedido sua única rota para a Rede A, e consulta cada um de seus vizinhos (nesse caso, apenas o Roteador 2) para ver se eles têm uma rota para a Rede A. Como o Roteador 2 tem uma rota para a Rede A, ele responde à consulta. Como o Roteador Um não possui mais a melhor rota até o Roteador Quatro, ele aceita a rota até o Roteador Dois para a Rede A.

Decidindo se um Caminho é Sem Circuito

De que forma o EIGRP usa os conceitos de distância factível, distância informada e sucessor possível para determinar se um caminho é válido, e não um circuito? Na Figura 4a, o Roteador 3 examina as rotas para a Rede A. Como o horizonte dividido está desativado (por exemplo, se estas forem interfaces de Frame Relay), o Roteador 3 mostra três rotas para a Rede A: até o Roteador 4, até o Roteador 2 (o caminho é 2, 1, 3, 4) e ate o Roteador 1 (o caminho é 1, 2, 3, 4).

eigrp21.gif

Se o roteador 3 aceitar todas essas rotas, ocorrerá um circuito de roteamento. O Roteador 3 acredita poder chegar até a Rede A pelo Roteador 2, mas o caminho até o Roteador 2 passa pelo Roteador 3 para chegar à Rede A. Se a conexão entre o Roteador 4 e o Roteador 3 for desativada, o Roteador 3 acreditará poder chegar até a Rede A por um dos outros caminhos, mas, por causa das regras para determinação de sucessores possíveis, ele nunca usará esses caminhos alternativos. Vejamos as métricas para entender por quê:

  • métrica total até a Rede A pela Rota 4: 20281600

  • métrica total até a Rede A pela Rota 2: 47019776

  • métrica total até a Rede A pela Rota 1: 47019776

Como o caminho até o Roteador 4 tem a melhor métrica, o Roteador 3 instala essa rota na tabela de encaminhamento e usa 20281600 como a distância factível até a Rede A. O Roteador 3 então computa a distância informada até a Rede A pelos Roteadores 2 e 1. 47019776 para o caminho pelo Roteador 2 e 47019776 para o caminho pelo Roteador 1. Como as duas métricas são superiores à distância factível, o Roteador 3 não instala nenhuma das rotas como um sucessor possível para a Rede A.

Imagine que o link entre os Roteadores 3 e 4 esteja desativado. O Roteador três consulta cada um de seus vizinhos em busca de uma rota alternativa para a Rede A. O roteador dois recebe a consulta e, como ela vem de seu sucessor, pesquisa cada uma das outras entradas de sua tabela de topologia para ver se há um sucessor adequado. A única outra entrada na tabela de topologia é do Roteador 1, com uma distância informada igual à última melhor métrica conhecida pelo Roteador 3. Como a distância informada por meio do Roteador 1 não é inferior à última distância factível conhecida, o Roteador 2 marca a rota como inalcançável e consulta cada um de seus vizinhos - nesse caso, apenas o Roteador 1 - para obter um caminho para a Rede A.

O Roteador 3 também envia uma consulta da Rede A para o Roteador 1. O Roteador Um examina a tabela de topologia e percebe que o outro único caminho para a Rede A é através do Roteador Dois com uma distância informada igual à última distância factível conhecida através do Roteador Três. Mais uma vez, como a distância informada pelo Roteador 2 não é inferior à última distância factível conhecida, esse roteador não é um sucessor possível. O Roteador Um marca a rota como inalcançável e consulta seu único vizinho, o Roteador Dois, sobre um caminho para a Rede A.

Esse é o primeiro nível das consultas. O Roteador 3 consultou cada um dos vizinhos, em uma tentativa de encontrar uma rota para a Rede A. Os Roteadores 1 e 2, por sua vez, marcaram a rota como inalcançável e consultaram cada um dos seus vizinhos restantes, em uma tentativa de encontrar um caminho para a Rede A. Quando o Roteador 2 recebe a consulta do Roteador 1, ele examina a topologia da tabela de topologia e observa que o destino está marcado como inalcançável. O Roteador 2 responde para o Roteador 1 que a Rede A é inalcançável. Quando o roteador 1 recebe a consulta do roteador 2, ele envia de volta uma resposta informando que a rede A não pode ser alcançada. Agora os Roteadores 1 e 2 concluíram, ambos, que a Rede A é inalcançável, e eles respondem à consulta original do Roteador 3. A rede convergiu, e todas as rotas retornam ao estado passivo.

Horizonte Dividido e Poison Reverse

No exemplo anterior, supomos que o horizonte dividido não estava em vigor, para mostrar como o EIGRP utiliza a distância factível e a distância informada para determinar a probabilidade de uma rota ser um circuito. Em alguns casos, no entanto, o EIGRP usa o horizonte dividido para evitar circuitos de roteamento, também. Antes de tratar dos detalhes de como o EIGRP usa o horizonte dividido, vamos rever o que é e como funciona o split horizon. A regra de horizonte dividido diz:

  • Nunca anuncie uma rota fora da interface por meio da qual você a aprendeu.

Por exemplo, na Figura 4a, se o Roteador 1 estiver conectado aos Roteadores 2 e 3 por uma única interface multiponto (como Frame Relay) e o Roteador 1 aprendeu sobre a Rede A do Roteador 2, ele não anunciará a rota para a Rede A de volta para a mesma interface para o Roteador 3. O Roteador 1 supõe que o Roteador 3 aprenda sobre a Rede A diretamente do Roteador 2.

eigrp21.gif

O poison é outra forma de evitar circuitos de roteamento. A regra diz:

  • Assim que você identificar uma rota por meio de uma interface, anuncie-a como inacessível por meio da mesma interface.

Digamos que os roteadores na Figura 4a estejam com a opção poison reverse habilitada. Quando o Roteador 1 identifica a Rede A à partir do Roteador 2, ele anuncia a Rede A como sendo de alcance impossível através de seu enlace para os Roteadores 2 e 3. O Roteador 3, se mostrar algum caminho para a Rede A pelo Roteador 1, remove esse caminho por causa do anúncio de inalcançável. O EIGRP combina essas duas regras para ajudar a evitar circuitos de roteamento.

O EIGRP usa horizonte dividido ou anuncia uma rota como inalcançável quando:

  • dois roteadores estão em modo de inicialização (trocando tabelas de topologia pela primeira vez)

  • anuncia uma alteração na tabela de topologia

  • enviando uma consulta

Examinemos cada uma dessas situações.

Modo de inicialização

Quando dois roteadores se tornarem vizinhos pela primeira vez, eles trocam tabelas de topologia durante o modo de inicialização. Para cada entrada de tabela que um roteador recebe durante o modo de inicialização, ele anuncia a mesma entrada de volta para o seu novo vizinho com uma métrica máxima (poison route).

Alteração da tabela de topologia

Na Figura 5, o Roteador 1 usa a variância para balancear o tráfego destinado à Rede A, entre os dois links seriais – o link de 56k entre os Roteadores 2 e 4, e o link de 128k, entre os Roteadores 3 e 4 (consulte a seção Balanceamento de carga para obter um esclarecimento sobre variação).

eigrp5.gif

O Roteador 2 vê o caminho até o Roteador Três como um sucessor possível. Se o link entre os Roteadores 2 e 4 for desativado, o Roteador 2 simplesmente faz a nova convergência no caminho até o Roteador 3. Como a regra horizonte dividido declara que você nunca deve anunciar uma rota fora da interface por meio da qual a conheceu, o Roteador dois normalmente não enviaria uma atualização. No entanto, isso deixa o Roteador um com uma entrada de tabela de topologia inválida. Quando um roteador altera a tabela de topologia de modo a alterar a interface através da qual alcança a rede, ele desativa o horizonte dividido e o poison reverse da rota antiga em todas as interfaces. Nesse caso, o Roteador Dois desativa o horizonte dividido para essa rota e anuncia a Rede A como inalcançável. O Roteador 1 ouve esse anúncio e libera sua rota para a Rede A por meio do Roteador 2, a partir da sua tabela de roteamento.

Consultas

As consultas resultam em um horizonte dividido apenas quando um roteador receber uma consulta ou atualização do sucessor que está usando para o destino na consulta. Vejamos a rede na Figura 6.

eigrp6.gif

O Roteador 3 recebe uma consulta a respeito de 10.1.2.0/24 (que ele alcança por meio do Roteador 1) do Roteador 4. Se o 3 não tem um sucessor para esse destino em razão de uma sincronização de link ou outra condição temporária de rede, ele envia uma consulta a cada um dos vizinhos, nesse caso, os Roteadores 1, 2 e 4. Se, no entanto, o Roteador 3 receber uma consulta ou atualização (como uma alteração de métrica) do Roteador 1 para o destino 10.1.2.0/24, ele não enviará uma consulta de volta ao Roteador 1, porque o Roteador 1 é o seu sucessor nessa rede. Em vez disso, ele envia consultas apenas aos Roteadores 2 e 4.

Rotas “stuck in active” (travadas em modo ativo)

Às vezes, as consultas demoram muito a ser respondidas. Se, efetivamente, o roteador que emitiu a consulta desistir e limpar sua conexão para o roteador que não está respondendo, reiniciando, efetivamente, a sessão vizinha. Isso é conhecido como uma rota Stuck-In-Active (SIA). As rotas SIA mais básicas ocorrem quando uma consulta demora muito para chegar à outra extremidade da rede, e para uma resposta retornar. Por exemplo, na Figura 7, o Roteador 1 está gravando um grande número de roteadores SIA do Roteador 2.

eigrp7.gif

Depois de um pouco de investigação, o problema é reduzido para o retardo no link por satélite entre os roteadores dois e três. Existem duas soluções possíveis para esse tipo de problema. A primeira é aumentar a quantidade de tempo que o roteador espera após o envio de uma consulta antes de declarar a rota SIA. Você pode alterar essa configuração, utilizando o comando timers active-time.

A melhor solução, no entanto, é recriar a rede para reduzir o intervalo de consultas (poucas consultas passam pelo link do satélite). O intervalo de consulta é coberto na seção Intervalo de consulta. Porém, o intervalo de consulta em si não é uma razão comum para rotas SIA informadas. Com mais freqüência, um roteador na rede não é capaz de responder a uma consulta por um destes motivos:

  • o roteador está muito ocupado para responder à consulta (geralmente, devido a uma utilização elevada da CPU)

  • o roteador está com problemas de memória e não é possível alocar a memória para processar a consulta ou construir o pacote de resposta

  • o circuito entre os dois roteadores não está em boas condições - pacotes suficientes são passados para manter o relacionamento vizinho ativo, mas algumas consultas ou respostas estão sendo perdidas entre os roteadores

  • links unidirecionais (um link em que o tráfego só pode fluir em uma direção, devido a uma falha)

Solução de Problemas de rotas SIA

A solução de problemas de rotas SIA normalmente é um processo de três passos:

  1. Encontrar as rotas reportadas consistentemente como SIA.

  2. Encontrar o roteador que esteja falhando consistentemente em responder a consultas dessas rotas.

  3. Descubra o motivo pelo qual o roteador não está recebendo nem respondendo consultas.

O primeiro passo deve ser bastante simples. Se você estiver registrando mensagens de console, uma investigação rápida do log indicará que rotas são marcadas SIA com mais freqüência. O segundo passo é mais difícil. O comando que reúne essas informações é o show ip eigrp topology active:

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

A 10.2.4.0/24, 0 successors, FD is 512640000, Q
    1 replies, active 00:00:01, query-origin: Local origin
         via 10.1.2.2 (Infinity/Infinity), Serial1
    1 replies, active 00:00:01, query-origin: Local origin
         via 10.1.3.2 (Infinity/Infinity), r, Serial3
    Remaining replies:
         via 10.1.1.2, r, Serial0

Os vizinhos que exibem um R, ainda têm que responder (o temporizador ativo mostra por quanto tempo a rota esteve ativa). Observe que esses vizinhos podem não aparecer na seção Respostas restantes, mas podem aparecer entre os demais RDBs. Preste atenção especial às rotas que possuem respostas pendentes e que estão ativas há algum tempo, geralmente, de dois a três minutos. Execute esse comando diversas vezes e você começará a ver quais vizinhos não estão respondendo às consultas (ou quais interfaces parecem ter muitas consultas não respondidas). Examine esse vizinho para ver se ele está aguardando consistentemente por respostas de algum dos respectivos vizinhos. Repita esse processo até encontrar o roteador que não esteja respondendo consistentemente a consultas. Você pode procurar problemas no link para esse vizinho, essa utilização de memória ou CPU ou outro problema com esse vizinho.

Se você passar por uma situação em que o intervalo de consulta pareça ser o problema, é sempre melhor reduzir o intervalo de consulta do que aumentar o temporizador SIA.

Redistribuição

Esta seção examina diferentes cenários que envolvem redistribuição. Os exemplos abaixo mostram o mínimo necessário para configurar a redistribuição. A redistribuição pode causar problemas potenciais, como o roteamento não otimizado, os circuitos de roteamento ou a convergência lenta. Para evitar esses problemas, consulte “Evitando Problemas devidos à Redistribuição” em Redistributing Routing Protocols (Redistribuindo protocolos de roteamento)

Redistribuição entre dois sistemas EIGRP autônomos

Na Figura 8, os roteadores são configurado da seguinte maneira:

eigrp8.gif

Roteador 1

router eigrp 2000

               !--- O "2000" é o sistema autônomo 
            
 network 172.16.1.0 0.0.0.255

Roteador 2

router eigrp 2000
 redistribute eigrp 1000 route-map to-eigrp2000
 network 172.16.1.0 0.0.0.255
!
router eigrp 1000
 redistribute eigrp 2000 route-map to-eigrp1000
 network 10.1.0.0 0.0.255.255

route-map to-eigrp1000 deny 10
match tag 1000
!
route-map to-eigrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

Roteador 3

router eigrp 1000
 network 10.1.0.0 0.0.255.255

O Roteador 3 está anunciando a rede 10.1.2.0/24 para o Roteador 2 por meio do sistema autônomo 1000; o Roteador 2 está redistribuindo essa rota no sistema autônomo 2000 e anunciando este ao Roteador 1.

Observação: As rotas do EIGRP 1000 são rotuladas 1000 antes de serem redistribuídas para o EIGRP 2000. Quando as rotas do EIGRP 2000 forem redistribuídas de volta ao EIGRP 1000, as rotas com rótulos 1000 serão negadas, para garantir uma topologia sem loop. Para obter mais informações sobre a redistribuição entre protocolos de roteamento, consulte Redistributing Routing Protocols (Redistribuindo Protocolos de Roteamento).

No roteador 1, vemos:

one# show ip eigrp topology 10.1.2.0 255.255.255.0
IP-EIGRP topology entry for 10.1.2.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776
  Routing Descriptor Blocks:
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
      Composite metric is (46763776/46251776), Route is External
      Vector metric:
        Minimum bandwidth is 56 Kbit
        Total delay is 41000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2
      External data:
        Originating router is 10.1.2.1
        AS number of route is 1000
        External protocol is EIGRP, external metric is 46251776
        Administrator tag is 1000 (0x000003E8)

Observe que, embora o link entre os Roteadores 1 e 2 tenha uma largura de banda de 1,544Mb, a largura de banda mínima mostrada nessa entrada da tabela de topologia é de 56k. Isso significa que o EIGRP preserva todas as métricas ao redistribuir entre dois sistemas autônomos EIGRP.

Redistribuição entre EIGRP e IGRP em dois sistemas autônomos diferentes

Na Figura 9, alteramos as configurações da seguinte maneira:

eigrp9.gif

Roteador 1

router eigrp 2000
 network 172.16.1.0

Roteador 2

router eigrp 2000
 redistribute igrp 1000 route-map to-eigrp2000
 network 172.16.1.0
!
router igrp 1000
 redistribute eigrp 2000 route-map to-igrp1000
 network 10.0.0.0
!

route-map to-igrp1000 deny 10
match tag 1000
!
route-map to-igrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

Roteador 3

router igrp 1000
 network 10.0.0.0

A configuração do Roteador 1 é exibida abaixo:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776
  Routing Descriptor Blocks:
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
      Composite metric is (46763776/46251776), Route is External
      Vector metric:
        Minimum bandwidth is 56 Kbit
        Total delay is 41000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 10.1.1.1
        AS number of route is 1000
        External protocol is IGRP, external metric is 180671
        Administrator tag is 1000 (0x000003E8)

As métricas de IGRP são preservadas quando as rotas são redistribuídas no EIGRP com um sistema diferente autônomo, mas são dimensionadas com a multiplicação da métrica IGRP pela constante 256. Existe uma advertência à redistribuição entre IGRP e EIGRP que deve ser observada. Se a rede estiver diretamente conectada ao roteador que está realizando a redistribuição, ele anunciará a rota com a métrica de 1.

Por exemplo, a rede 10.1.1.0/24 está diretamente conectada ao Roteador Dois e o IGRP está fazendo o roteamento para essa rede (há uma instrução de rede sob o roteador de IGRP que compreende essa interface). O EIGRP não está fazendo roteamento para essa rede, contudo está aprendendo sobre a interface diretamente conectada por meio da redistribuição do IGRP. No roteador um, a entrada da tabela de topologia para 10.1.1.0/24 mostra:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856
  Routing Descriptor Blocks:
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
      Composite metric is (2169856/1), Route is External

      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 20000 microseconds
        Reliability is 0/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 10.1.1.1
        AS number of route is 1000
        External protocol is IGRP, external metric is 0
        Administrator tag is 1000 (0x000003E8)

Observe que a distância informada do roteador dois, que está em negrito, é 1".

Redistribuição Entre EIGRP e IGRP no Mesmo Sistema Autônomo

As seguintes alterações foram feitas às configurações do roteador na Figura 10:

eigrp10.gif

Roteador 1

router eigrp 2000
 network 172.16.1.0 

Roteador 2

router eigrp 2000
 network 172.16.1.0
!
router igrp 2000
 network 10.0.0.0

Roteador 3

router igrp 2000
 network 10.0.0.0

E o Roteador 1 é configurado desta maneira:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776
  Routing Descriptor Blocks:
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
      Composite metric is (46763776/46251776), Route is External
      Vector metric:
        Minimum bandwidth is 56 Kbit
        Total delay is 41000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 10.1.1.1
        AS number of route is 2000
        External protocol is IGRP, external metric is 180671
        Administrator tag is 0 (0x00000000)

Essa configuração se parece surpreendentemente como a saída anterior quando estávamos redistribuindo entre dois sistemas autônomos diferentes executando o IGRP e o EIGRP. A rede 10.1.1.0/24 diretamente conectada é tratada da mesma forma nas duas situações:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856
  Routing Descriptor Blocks:
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
      Composite metric is (2169856/1), Route is External
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 20000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 10.1.1.1
        AS number of route is 2000
        External protocol is IGRP, external metric is 0
        Administrator tag is 0 (0x00000000)

Então, essa rede, que está diretamente conectada ao Roteador 1, é redistribuída de IGRP para EIGRP com uma métrica de 1 - a mesma métrica vista na redistribuição entre dois sistemas autônomos diferentes.

Existem duas advertências com a redistribuição EIGRP/IGRP no mesmo sistema autônomo:

  • Rotas EIGRP internas sempre têm preferência sobre as rotas EIGRP ou IGRP externas.

  • As métricas da rota EIGRP externa são comparadas com as mesmas métricas IGRP (a distância administrativa é ignorada).

Vamos examinar essas advertências da Figura 11:

eigrp11.gif

O Roteador 1 anuncia 10.1.4.0/24 no IGRP do sistema autônomo 100; o Roteador 4 anuncia 10.1.4.0/24 como externo no IGRP do sistema autônomo 100; o Roteador 2 executa tanto o EIGRP quanto o IGRP no sistema autônomo 100.

Se ignorarmos a rota EIGRP anunciada pelo roteador 4 (desativando o link entre os roteadores 2 e 4, por exemplo), o roteador 2 mostra:

two# show ip route 10.1.4.0
Routing entry for 10.1.4.0/24
  Known via "igrp 100", distance 100, metric 12001
  Redistributing via igrp 100, eigrp 100
  Advertised by igrp 100 (self originated)
                eigrp 100
  Last update from 10.1.1.2 on Serial1, 00:00:42 ago
  Routing Descriptor Blocks:
  * 10.1.1.2, from 10.1.1.2, 00:00:42 ago, via Serial1
      Route metric is 12001, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 0

Observe que a distância administrativa é de 100. Quando adicionamos a rota EIGRP, o Roteador 2 mostra:

two# show ip route 10.1.4.0
Routing entry for 10.1.4.0/24
  Known via "eigrp 100", distance 170, metric 3072256, type external
  Redistributing via igrp 100, eigrp 100
  Last update from 10.1.2.2 on Serial0, 00:53:59 ago
  Routing Descriptor Blocks:
  * 10.1.2.2, from 10.1.2.2, 00:53:59 ago, via Serial0
      Route metric is 3072256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1

Observe que as métricas dessas duas rotas são as mesmas após serem dimensionadas do IGRP para o EIGRP (consulte a seção Métricas:

  • 12001 x 256 = 3072256

onde 12001, uma métrica IGRP, vai até o Roteador 1; e 3072256, uma métrica EIGRP, vai até o Roteador 4.

O roteador Dois prefere a rota externa EIGRP com a mesma métrica (depois de escalar) e uma maior distância administrativa. Isso é verdadeiro sempre que ocorrer redistribuição automática entre EIGRP e IGRP dentro do mesmo sistema autônomo. O roteador sempre prefere o caminho com a métrica de custo mais baixa e ignora a distância administrativa.

Redistribuição Para Outros Protocolos e De Outros Protocolos

A redistribuição entre EIGRP e outros protocolos – por exemplo, RIP e OSPF – funciona da mesma maneira que qualquer outra redistribuição. É sempre melhor usar a métrica padrão ao redistribuir entre protocolos. Você deve estar ciente de dois problemas ao fazer a redistribuição entre EIGRP e outros protocolos:

  • As rotas redistribuídas no EIGRP não são sempre resumidas - veja a seção Sumarização para obter uma explicação.

  • As rotas externas de EIGRP têm distância administrativa de 170.

Redistribuição de Rotas Estáticas em Interfaces

Quando você instala uma rota estática em uma interface e configura uma instrução de rede utilizando o eigrp de roteador, que inclui a rota estática, o EIGRP redistribui essa rota como se ela fosse uma interface diretamente conectada. Vejamos a rede na Figura 12.

eigrp12.gif

O roteador um tem uma rota estática para a rede 172.16.1.0/24 configurada por meio da interface Serial 0:

ip route 172.16.1.0 255.255.255.0 Serial0

E o Roteador 1 também tem uma instrução de rede para o destino dessa rota estática:

router eigrp 2000
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary 

O Roteador Um redistribui essa rota, mesmo que não redistribua rotas estáticas, porque o EIGRP o considera uma rede diretamente conectada. No Roteador 2, isso se parece com o seguinte:

two# show ip route
    ....
        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       10.1.1.0/24 is directly connected, Serial0
    D       10.1.2.0/24 [90/2169856] via 10.1.1.1, 00:00:47, Serial0
         172.16.0.0/24 is subnetted, 1 subnets
    D       172.16.1.0 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

Observe que a rota para 172.16.1.0/24 aparece em uma rota EIGRP interna, no Roteador 2.

Sumarização

Existem dois tipos de sumário no EIGRP: resumos automáticos e sumários de manual.

Sumarização Automática

O EIGRP executa uma sumarização automática a cada vez que cruza um limite entre duas redes principais diferentes. Por exemplo, na Figura 13, o Roteador 2 anuncia apenas a rede 10.0.0.0/8 para o Roteador 1, porque a interface que o Roteador 2 usa para alcançar o Roteador 1 encontra-se em uma rede principal diferente.

eigrp13.gif

No Roteador Um, se parece com o seguinte:

one# show ip eigrp topology 10.0.0.0
IP-EIGRP topology entry for 10.0.0.0/8
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 11023872
  Routing Descriptor Blocks:
  172.16.1.1 (Serial0), from 172.16.1.2, Send flag is 0x0
      Composite metric is (11023872/10511872), Route is Internal
      Vector metric:
        Minimum bandwidth is 256 Kbit
        Total delay is 40000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

Esse roteador não está marcado de forma nenhuma como uma rota de sumário; ele tem a aparência de uma rota interna. A métrica é a melhor dentre as rotas resumidas. Observe que a largura de banda mínima nessa rota é de 256k, embora haja links na rede 10.0.0.0 com largura de banda de 56k.

No roteador que está realizando a sumarização, uma rota é criada para null0 para o endereço sumarizado:

two# show ip route 10.0.0.0
Routing entry for 10.0.0.0/8, 4 known subnets
  Attached (2 connections)
  Variably subnetted with 2 masks
  Redistributing via eigrp 2000

C       10.1.3.0/24 is directly connected, Serial2
D       10.1.2.0/24 [90/10537472] via 10.1.1.2, 00:23:24, Serial1
D       10.0.0.0/8 is a summary, 00:23:20, Null0
C       10.1.1.0/24 is directly connected, Serial1

A rota para 10.0.0.0/8 é marcada como um sumário até Null0. A entrada da tabela de topologia para essa rota de resumo tem esta aparência:

two# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10511872
  Routing Descriptor Blocks:
  0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0
          (note: the 0.0.0.0 here means this route is originated by this router)
      Composite metric is (10511872/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 256 Kbit
        Total delay is 20000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0

Para fazer o Roteador 2 anunciar os componentes da rede 10.0.0.0 em vez de um sumário, configure para no auto-summary no processo EIGRP, no Roteador 2:

No Roteador 2

router eigrp 2000
 network 172.16.0.0
 network 10.0.0.0
 no auto-summary

Com o sumário automático desligado, o roteador um agora vê todos os componentes da rede 10.0.0.0:

one# show ip eigrp topology
IP-EIGRP Topology Table for process 2000

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 10.1.3.0/24, 1 successors, FD is 46354176
         via 20.1.1.1 (46354176/45842176), Serial0
P 10.1.2.0/24, 1 successors, FD is 11049472
         via 20.1.1.1 (11049472/10537472), Serial0
P 10.1.1.0/24, 1 successors, FD is 11023872
         via 20.1.1.1 (11023872/10511872), Serial0
P 172.16.1.0/24, 1 successors, FD is 2169856
         via Connected, Serial0

Existem algumas advertências ao se lidar com a sumarização de rotas externas que serão abordadas mais adiante na seção Sumarização automática de rotas externas.

Sumarização Manual

O EIGRP permite sumarizar rotas internas e externas em praticamente qualquer limite de bit usando o resumo manual. Por exemplo, na Figura 14, o Roteador 2 está resumindo 192.1.1.0/24, 192.1.2.0/24 e 192.1.3.0/24 no bloco CIDR 192.1.0.0/22.

eigrp14.gif

A configuração do Roteador 2 é exibida abaixo:

two# show run
....
!
interface Serial0
 ip address 10.1.50.1 255.255.255.0
 ip summary-address eigrp 2000 192.1.0.0 255.255.252.0
 no ip mroute-cache
!
....

two# show ip eigrp topology
IP-EIGRP Topology Table for process 2000

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 10.1.10.0/24, 1 successors, FD is 45842176
         via Connected, Loopback0
P 10.1.50.0/24, 1 successors, FD is 2169856
         via Connected, Serial0
P 192.1.1.0/24, 1 successors, FD is 10511872
         via Connected, Serial1
P 192.1.0.0/22, 1 successors, FD is 10511872
         via Summary (10511872/0), Null0
P 192.1.3.0/24, 1 successors, FD is 10639872
         via 192.1.1.1 (10639872/128256), Serial1
P 192.1.2.0/24, 1 successors, FD is 10537472
         via 192.1.1.1 (10537472/281600), Serial1

Observe o comando ip summary-address, na interface Serial0, e a rota de sumário via Null0. No Roteador 1, vemos isso como uma rota interna:

  one# show ip eigrp topology
IP-EIGRP Topology Table for process 2000

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 10.1.10.0/24, 1 successors, FD is 46354176
         via 10.1.50.1 (46354176/45842176), Serial0
P 10.1.50.0/24, 1 successors, FD is 2169856
         via Connected, Serial0
P 192.1.0.0/22, 1 successors, FD is 11023872
         via 10.1.50.1 (11023872/10511872), Serial0

Sumarização automática de rotas externas

O EIGRP não fará o resumo automático das rotas externas, a menos que haja um componente da mesma rede principal que seja uma rota interna. Para ilustrar, vejamos a Figura 15.

eigrp15.gif

O Roteador 3 está injetando rotas externas em 192.1.2.0/26 e 192.1.2.64/26 no EIGRP, por meio do comando redistribute connected, como mostrado nas configurações a seguir.

Roteador 3

interface Ethernet0
 ip address 192.1.2.1 255.255.255.192
!
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Ethernet2
 ip address 10.1.2.1 255.255.255.0
!router eigrp 2000
 redistribute connected
 network 10.0.0.0
 default-metric 10000 1 255 1 1500

Com essa configuração no Roteador Três, a tabela de roteamento no Roteador Um mostra:

  one# show ip route
....
     10.0.0.0/8 is subnetted, 2 subnets
D       10.1.2.0 [90/11023872] via 10.1.50.2, 00:02:03, Serial0
C       10.1.50.0 is directly connected, Serial0
     192.1.2.0/26 is subnetted, 1 subnets
D EX    192.1.2.0 [170/11049472] via 10.1.50.2, 00:00:53, Serial0
D EX    192.1.2.64 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

Embora o sumário automático normalmente faça com o que o Roteador 3 sumarize as rotas 192.1.2.0/26 e 192.1.2.64/26 em um destino de rede principal (192.1.2.0/24), ele não faz isso porque as duas rotas são externas. No entanto, se você reconfigurar o link entre os Roteadores 2 e 3 para 192.1.2.128/26 e adicionar instruções dessa rede nos Roteadores 2 e 3, o sumário automático 192.1.2.0/24 será gerado no Roteador 2.

Roteador 3

 interface Ethernet0
 ip address 192.1.2.1 255.255.255.192
!
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Serial0
 ip address 192.1.2.130 255.255.255.192
!
router eigrp 2000
 network 192.1.2.0

Agora o roteador dois gera o sumário para 192.1.2.0/24:

two# show ip route
....
D       192.1.2.0/24 is a summary, 00:06:48, Null0
....

E o Roteador Um mostra somente a rota de sumário:

 one# show ip route 
....
     10.0.0.0/8 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial0
D    192.1.2.0/24 [90/11023872] via 10.1.50.2, 00:00:36, Serial0

Processamento e Intervalo de Consulta

Quando um roteador processa a consulta de um vizinho, as seguintes regras se aplicam:

Consulta de

Estado do roteador

Ação

vizinho (não o sucessor atual)

passivo

responder com as informações do sucessor atual

sucessor

passivo

tenta encontrar um novo sucessor; se obtiver êxito, responde com novas informações; do contrário, marca o destino como inalcançável e consulta todos os vizinhos, exceto o sucessor anterior.

qualquer vizinho

nenhum caminho por este vizinho antes da consulta

responde com o caminho conhecido atualmente

qualquer vizinho

desconhecido antes da consulta

responde que o destino é inalcançável

vizinho (não o sucessor atual)

ativo

se não houver um sucessor atual para esses destinos (normalmente, isso seria verdadeiro), responda com um inalcançável

se houver um bom sucessor, responda com as informações do caminho atual

sucessor

ativo

tenta encontrar um novo sucessor; se obtiver êxito, responde com novas informações; do contrário, marca o destino como inalcançável e consulta todos os vizinhos, exceto o sucessor anterior.

As ações na tabela acima afetam o intervalo da consulta na rede, determinando quantos roteadores recebem e respondem à consulta antes de a rede convergir na nova topologia. Para ver como essas regras afetam a forma como as consultas são tratadas, vejamos a rede na Figura 16, que está sendo executada em condições normais.

eigrp16.gif

O seguinte acontecimento pode ser esperado em relação à rede 192.168.3.0/24 (no lado extremo direito):

  • O Roteador Um tem dois caminhos para 192.168.3.0/24:

    • pelo Roteador Dois com uma distância de 46533485 e uma distância informada de 20307200

    • por meio do roteador três com uma distância de 20563200 e uma distância informada de 20307200

  • O Roteador Um escolhe o caminho por meio do Roteador Três e mantém esse caminho por meio do Roteador Dois, como um sucessor possível.

  • Os Roteadores 2 e 3 mostram um caminho para 192.168.3.0/24 por meio do Roteador 4.

Suponha que o 192.168.3.0/24 falhe. Que atividade podemos esperar encontrar nessa rede? As figuras 16 até 16h ilustram o processo.

O Roteador 5 marca 192.168.3.0/24 como inalcançável e consulta o Roteador 4:

eigrp16a.gif

O Roteador Quatro, após o recebimento de uma consulta de seu sucessor, localiza um novo sucessor possível para essa rede. Ele não localiza nenhum, então, marca 192.168.3.0/24 como inalcançável e consulta os Roteadores 2 e 3:

eigrp16b.gif

Os Roteadores 2 e 3, por sua vez, percebem que perderam a única rota possível para 192.168.3.0/24, e marcam-na como inalcançável; ambos enviam consultas ao Roteador 1:

eigrp16c.gif

A título de simplificar, suponhamos que o Roteador 1 receba a consulta do Roteador 3 primeiro e marque a rota como inalcançável. Então, o roteador um recebe a consulta do roteador dois. Embora outra ordem seja possível, todos eles terão o mesmo resultado final.

eigrp16d.gif

O Roteador 1 responde às duas perguntas com inalcançáveis; o Roteador 1 é agora passivo para.168.3.0/24:

eigrp16e.gif

Os Roteadores 2 e 3 respondem à consulta do Roteador 4; os Roteadores 2 e 3 agora são passivos para 192.168.3.0/24:

eigrp16f.gif

O Roteador 5, ao receber a resposta do Roteador 4, remove a rede 192.168.3.0/24 da respectiva tabela de roteamento; o Roteador 5 agora é passivo para a rede 192.168.3.0/24. O Roteador 5 envia atualizações de volta para o Roteador 4, de modo que a rota é removida da topologia e das tabelas de roteamento dos roteadores restantes.

eigrp16g.gif

É importante entender que, embora possa haver outros caminhos de consulta ou ordens de processamento, todos os roteadores na rede processam uma consulta da rede 192.168.3.0/24 quando esse link fica inativo. Alguns roteadores podem acabar processando mais de uma consulta (Roteador Um, neste exemplo). Na verdade, se as consultas precisassem alcançar os roteadores em uma ordem diferente, alguns acabariam processando três ou quatro consultas. Este é um bom exemplo de uma consulta não vinculada em uma rede EIGRP.

Como os Pontos de Sumarização Afetam o Intervalo de Consulta

Vejamos os caminhos para 10.1.1.0/24 na mesma rede:

  • O Roteador 2 tem uma entrada de tabela de topologia para a rede 10.1.1.0/24 com um custo de 46251885 por meio do Roteador 1.

  • O roteador três tem uma entrada de tabela de topologia para a rede 10.1.1.0/24 com um custo de 20281600 por meio do roteador um.

  • O Roteador três tem uma entrada de tabela de topologia para a rede 10.0.0.0/8 (porque os Roteadores 2 e 3 estão resumindo automaticamente para o limite de rede principal) por meio do Roteador 3 com uma métrica de 20307200 (a distância informada até o Roteador 2 é superior à métrica total até o Roteador 3, portanto, o caminho até o Roteador 2 não é um sucessor possível).

eigrp17.gif

Se 10.1.1.0/24 fica inativo, o Roteador 1 o marca como inalcançável e, em seguida, consulta cada um dos vizinhos (Roteadores 2 e 3) para obter um novo caminho para essa rede:

eigrp17a.gif

O Roteador 2, no recebimento da consulta do Roteador 1, marca a rota como inalcançável (porque a consulta se origina do seu sucessor) e, em seguida, consulta os Roteadores 4 e 3.

eigrp17b.gif

O Roteador 3, ao receber a consulta do Roteador 1, marca o destino como inalcançável e consulta os Roteadores 2 e 4.

eigrp17c.gif

O Roteador 4, ao receber a consulta dos Roteadores 2 e 3, responde que 10.1.1.0/24 é inalcançável (observe que o Roteador 4 não tem conhecimento da sub-rede em questão, pois ele só tem a rota 10.0.0.0/8).

eigrp17d.gif

Os Roteadores 2 e 3 respondem um para outro que 10.1.1.0/24 é inalcançável.

eigrp17e.gif

Como os Roteadores 2 e 3 agora têm consultas pendentes, ambos respondem ao Roteador 1 que 10.1.1.0/24 é inalcançável:

eigrp17f.gif

A consulta, nesse caso, é compactada pela sumarização automática nos Roteadores 2 e 3. O roteador cinco não participa do processo de consulta e não é envolvido na re-convergência da rede. As consultas também podem ser ligadas por sumarização manual, bordas de sistema autônomo e listas de distribuição.

Como os Limites do Sistema Autônomo Afetam o Intervalo de Consulta

Se um roteador estiver redistribuindo rotas entre dois sistemas EIGRP autônomos, ele responderá à consulta dentro das regras de processamento normais e iniciará uma nova consulta no outro sistema autônomo. Por exemplo, se o link para a rede anexada ao Roteador 3 fica inativo, o Roteador 3 marca a rota inalcançável e consulta o Roteador 2 para obter um novo caminho:

eigrp18.gif

O Roteador 2 responde que essa rede não pode ser acessada e ativa uma consulta no sistema autônomo 200 em direção ao Roteador 1. Quando o roteador três recebe a resposta para sua consulta original, ele remove a rota de sua tabela. O Roteador 3 agora é passivo para esta rede:

eigrp18a.gif

O Roteador 1 responde para o Roteador 2 e a rota fica passiva.

eigrp18b.gif

Embora a consulta original não tenha se propagado por toda a rede (ela foi limitada pela borda de sistema autônomo), a consulta original vaza para o segundo sistema autônomo na forma de uma nova consulta. Essa técnica pode ajudar a evitar problemas stuck in active (SAI) em uma rede, limitando o número de roteadores por que uma consulta deve passar antes de ser respondida, mas não soluciona o problema geral de que cada roteador deve processar a consulta. Na verdade, esse método de restrição de uma consulta pode agravar o problema impedindo a sumarização automática de rotas que, de outra forma, seriam resumidas (as rotas externas não são resumidas a menos que exista um componente externo na rede principal).

Como as Listas de Distribuição Afetam o Intervalo de Consulta

Em vez de bloquear a propagação de uma consulta, as listas de distribuição no EIGRP marcam qualquer consulta como inalcançável. Vejamos a Figura 19 como exemplo.

eigrp19.gif

Na figura acima:

  • O roteador três tem uma lista distribuída aplicada a suas interfaces seriais que só permite anunciar a rede B.

  • Os Roteadores 1 e 2 não têm conhecimento de que a Rede A é alcançável pelo Roteador 3 (o Roteador 3 não é usado como um ponto de trânsito entre os Roteadores 1 e 2.

  • O Roteador 3 utiliza o Roteador 1 como o caminho preferido para a Rede A e não usa o Roteador 2 como um sucessor possível.

Quando o Roteador 1 perde a conexão com a Rede A, ele marca a rota como inalcançável e envia uma consulta para o Roteador 3. O roteador 3 não anuncia um caminho para a Rede A devido à lista de distribuição nas respectivas portas seriais.

eigrp19a.gif

O Roteador 3 marca a rota como inalcançável e consulta o Roteador 2:

eigrp19b.gif

O Roteador 2 examina a tabela de topologia e percebe que ela tem uma conexão válida com a Rede A. Observe que a consulta não foi afetada pela lista de distribuição no Roteador 3.

eigrp19c.gif

O Roteador 2 responde que a Rede A é alcançável; o Roteador 3 agora tem uma rota válida.

eigrp19d.gif

O Roteador 3 cria a resposta para a consulta do Roteador 1, mas a lista de distribuição faz com que o Roteador 3 envie uma resposta de que a Rede A é inalcançável, embora o Roteador 3 tenha uma rota válida para a Rede A:

eigrp19e.gif

Pacotes de Ritmo

Alguns protocolos de roteamento consomem toda a largura de banda disponível em um link de largura de banda enquanto estão convergindo (adaptando-se para uma alteração na rede). O EIGRP evita esse congestionamento ritmando a velocidade na qual os pacotes são transmitidos em uma rede, usando apenas uma parte da largura de banda disponível. A configuração padrão do EIGRP é usar até 50 por cento da largura de banda disponível, mas isso pode ser alterado com o comando a seguir:

router(config-if)# ip bandwidth-percent eigrp 2 ? 
  <1-999999>  Maximum bandwidth percentage that EIGRP may use

Essencialmente, a cada vez que o EIGRP enfileira um pacote para ser transmitido a uma interface, ele usa a fórmula seguinte para determinar o tempo de espera antes do envio do pacote:

  • (8 * 100 * tamanho do pacote em bytes) / (largura de banda em kbps * porcentagem da largura de banda)

Por exemplo, se o EIGRP enfileira um pacote a ser enviado por uma interface serial que tenha uma largura de banda de 56k e o pacote é de 512 bytes, o EIGRP aguarda:

  • (8 * 100 * 512 bytes) / (56000 bits por segundo * 50% largura de banda) (8 * 100 * 512) / (56000 * 50) 409600 / 2800000 0.1463 segundos

Isso permite que um pacote (ou grupos de pacotes) de no mínimo 512 bytes seja transmitido nesse link antes de o EIGRP enviar o próprio pacote. O temporizador de ritmo determina quando o pacote é enviado e é, normalmente, expresso em milissegundos. O tempo de adequação do pacote no exemplo anterior é e 0.1463 segundos. Há um campo em show ip eigrp interface que exibe o temporizador de ritmo, conforme mostrado abaixo:

router# show ip eigrp interface
IP-EIGRP interfaces for process 2

                    Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0            1        0/0        28       0/15         127           0
Se1            1        0/0        44       0/15         211           0
router#

O tempo exibido corresponde ao intervalo de espaçamento para a unidade de transmissão máxima (MTU), o maior pacote que pode ser enviado pela interface.

Roteamento Padrão

Há duas maneiras de injetar uma rota padrão em um EIGRP: redistribuir uma rota estática ou resumir para 0.0.0.0/0. Use o primeiro método quando desejar dirigir todo o tráfego para destinos desconhecidos em uma rota padrão no centro da rede. Este método é eficaz para anunciar conexões com a Internet. Por exemplo:

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet)
!
router eigrp 100
 redistribute static
 default-metric 10000 1 255 1 1500

A rota estática redistribuída no EIGRP não precisa estar na rede 0.0.0.0. Se você usar outra rede, deverá usar o comando ip default-network para marcar a rede como uma rede padrão. Consulte Configurando um gateway de último recurso, para obter mais informações.

O resumo a uma rota padrão só é efetivo quando você quer oferecer uma rota padrão aos sites remotos. Como os resumos são configurados por interface, você não precisa se preocupar sobre o uso de listas distribuídas ou outros mecanismos para evitar que a rota padrão seja propagada em direção ao centro de sua rede. Observe que um sumário para 0.0.0.0/0 substitui uma rota padrão aprendida de qualquer outro protocolo de roteamento. A única forma de configurar um sumário padrão em um roteador usando esse método é configurar uma rota estática para 0.0.0.0/0. (Começando no Cisco IOS Software 12.0(4)T, você também pode configurar uma distância administrativa no final do comando summary-address, assim o resumo local não substitui a rota 0.0.0.0/0).

router eigrp 100
 network 10.0.0.0
!
interface serial 0
 encapsulation frame-relay
 no ip address
!
interface serial 0.1 point-to-point
 ip address 10.1.1.1
 frame-relay interface-dlci 10
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0

Função de Balanceamento de Carga

O EIGRP coloca até quatro rotas de custo igual na tabela de roteamento e, em seguida, o roteador balanceia a carga. O tipo de balanceamento de carga (por pacote ou por destino) depende do tipo de switching sendo realizado no roteador. Entretanto, o EIGRP também pode fazer o balanceamento de cargo por meio de links de custo desiguais.

Observação: Com o uso de trajetos máximos, você pode configurar o EIGRP para usar até seis rotas de igual custo.

Digamos que haja quatro caminhos para um determinado destino e as métricas desses caminhos sejam:

  • caminho 1: 1100

  • caminho 2: 1100

  • caminho 3: 2000

  • caminho 4: 4000

O roteador, por padrão, coloca o tráfego nos caminhos 1 e 2. Com o EIGRP, você pode usar o comando variance para instruir o roteador a também colocar tráfego nos caminhos 3 e 4. A variação é um multiplicador: o tráfego será colocado em qualquer link que tiver uma métrica inferior ao melhor caminho multiplicado pela variação. Para balancear a carga nos caminhos 1, 2 e 3, use a variação 2, porque 1100 x 2 = 2200, o que é maior do que a métrica até o caminho 3. De forma semelhante, para adicionar também o caminho 4, emita a variação 4 sob o comando router eigrp. Consulte Como Funciona o Balanceamento de Carga em Caminhos de Custos Desiguais (Variância) no IGRP e no EIGRP? ? para obter mais informações.

Como o roteador divide o tráfego entre esses caminhos? Ele divide a métrica por cada caminho pela maior métrica, arredonda para baixo para o inteiro mais próximo e usa esse número como a contagem da porção do tráfego.

router# show ip route 10.1.4.0
Routing entry for 10.1.4.0/24
  Known via "igrp 100", distance 100, metric 12001
  Redistributing via igrp 100, eigrp 100
  Advertised by igrp 100 (self originated)
                eigrp 100
  Last update from 10.1.2.2 on Serial1, 00:00:42 ago
  Routing Descriptor Blocks:
  * 10.1.2.2, from 10.1.2.2, 00:00:42 ago, via Serial1
      Route metric is 12001, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 0

Para este exemplo, as contagens da porção do tráfego são:

  • para os caminhos 1 e 2: 4000/1100 = 3

  • para o caminho 3: 4000/2000 = 2

  • para o caminho 4: 4000/4000 = 1

O roteador envia os três primeiros pacotes pelo caminho 1, os três pacotes seguintes pelo caminho 2, os dois pacotes seguintes pelo caminho 3 e o pacote seguinte pelo caminho 4. O roteador então reinicia enviando os três pacotes seguintes pelo caminho 1 e assim por diante.

Observação: Mesmo com a variância configurada, o EIGRP não enviará tráfego por um caminho de custo desigual se a distância informada for maior do que a distância viável para essa rota específica. Consulte a seção Distância factível, Distância Informada e Sucessor Possível para obter mais informações.

Usando as Métricas

Ao configurar inicialmente o EIGRP, lembre-se de duas regras básicas se estiver tentando influenciar a métrica do EIGRP:

  • A largura de banda deve sempre ser configurada para a largura de banda real da interface; as exceções a esta regra são os links seriais multiponto e outras situações de velocidade de mídia incompatível.

  • O retardo sempre deve ser usado para influenciar decisões de roteamento EIGRP.

Como o EIGRP usa a largura de banda de interface para determinar a taxa para envio de pacotes, é importante configurá-lo corretamente. Se for necessário influenciar o caminho que o EIGRP escolher, use sempre o retardo para fazê-lo.

Em larguras de banda menores, a largura de banda tem mais influência sobre a métrica total; em larguras de banda maiores, o retardo tem mais influência sobre a métrica total.

Usando Tarefas Administrativas na Redistribuição

Etiquetas administrativas externas são úteis para romper circuitos de roteamento de redistribuição entre o EIGRP e demais protocolos. Ao marcar a rota quando ela é redistribuída no EIGRP, você pode bloquear a redistribuição do EIGRP no protocolo externo. Um exemplo básico de configuração dessas etiquetas é ilustrado a seguir, mas esse exemplo não mostra a configuração inteira usada para romper os circuitos de distribuição.

eigrp20.gif

O Roteador 3, que redistribui as rotas conectadas no EIGRP, mostra:

three# show run

....

interface Loopback0
 ip address 172.19.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 loopback
 no keepalive
!
interface Serial0
 ip address 172.17.1.1 255.255.255.0

....

router eigrp 444
 redistribute connected route-map foo
 network 172.17.0.0
 default-metric 10000 1 255 1 1500

....

access-list 10 permit 172.19.0.0 0.0.255.255
route-map foo permit 10
 match ip address 10
 set tag 1

....

three# show ip eigrp topo
IP-EIGRP Topology Table for process 444

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 172.17.1.0/24, 1 successors, FD is 2169856
         via Connected, Serial0
         via Redistributed (2169856/0)
P 172.16.1.0/24, 1 successors, FD is 281600
         via Redistributed (281600/0)
P 172.19.1.0/24, 1 successors, FD is 128256, tag is 1
         via Redistributed (128256/0)

O Roteador Dois, que está redistribuindo rotas de EIGRP para RIP, mostra:

two# show run 

....

interface Serial0
 ip address 172.17.1.2 255.255.255.0
!
interface Serial1
 ip address 172.18.1.3 255.255.255.0

....

router eigrp 444
 network 172.17.0.0
!
router rip
 redistribute eigrp 444 route-map foo
 network 10.0.0.0
 network 172.18.0.0
 default-metric 1
!
no ip classless
ip route 1.1.1.1 255.255.255.255 Serial0
route-map foo deny 10
 match tag 1
!
route-map foo permit 20

....

two# show ip eigrp topo
IP-EIGRP Topology Table for process 444

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 172.17.1.0/24, 1 successors, FD is 2169856
         via Connected, Serial0
P 172.16.1.0/24, 1 successors, FD is 2195456
         via 172.17.1.1 (2195456/281600), Serial0
P 172.19.1.0/24, 1 successors, FD is 2297856, tag is 1
         via 172.17.1.1 (2297856/128256), Serial0

Observe a marca 1 em 172.19.1.0/24.

O Roteador 1, que está recebendo as rotas RIP redistribuídas pelo Roteador 2, mostra:

one# show run

....

interface Serial0
 ip address 172.18.1.2 255.255.255.0
 no fair-queue
 clockrate 1000000

router rip
 network 172.18.0.0

....

one# show ip route

Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0
R    172.17.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0
     172.18.0.0/24 is subnetted, 1 subnets
C       172.18.1.0 is directly connected, Serial0

Observe que 172.19.1.0/24 está ausente.

Compreendendo a Saída de Comando EIGRP

show ip eigrp topology

Este comando só exibe sucessores possíveis. Para exibir todas as entradas na tabela de topologia, use o comando show ip eigrp topology all-links. Una explicação de cada campo de saída segue a tabela.

show ip eigrp topology

eigrp22.gif

Explicações de Configurações

A significa ativo. Um P também pode ser exibido, significando Passivo.

10.2.4.0/24 é o destino ou a máscara.

0 successors mostra quantos sucessores (ou caminhos) estão disponíveis para esse destino; se a palavra successors estiver em maiúsculas, a rota estará em transição.

FD is 512640000 mostra a distância factível, qual a melhor métrica para alcançar esse destino ou a melhor métrica conhecida quando a rota ficou ativa.

tag is 0x0 pode ser definida e/ou filtrada com o uso de mapas de rotas com os comandos set tag e match tag.

Q significa uma consulta pendente. Este campo também pode ser: U, para atualização pendente ou R, para resposta pendente.

1 replies mostra o número de respostas pendentes.

active 00:00:01 mostra a extensão desta rota quando ativa.

query origin: Local origin mostra esta rota que originou a consulta. Este campo também pode ser: Origens múltiplas, significando que vários vizinhos enviaram consultas nesse destino, mas não o sucessor, ou a Origem do sucessor, significando que o sucessor originou a consulta.

via 10.1.2.2 mostra que tomamos conhecimento dessa rota a partir de um vizinho cujo endereço IP é 10.1.2.2. Esse endereço também pode ser: Conectado, se a rede estiver diretamente conectada a esse roteador, Redistribuído, se essa rota estiver sendo redistribuída para o EIGRP nesse roteador, ou Sumário, se se tratar de uma rota sumária gerada nesse roteador.

(Infinity/Infinity) mostra a métrica para alcançar esse caminho por meio do respectivo vizinho no primeiro campo, e a distância informada por meio desse vizinho no segundo campo.

r mostra que consultamos esse vizinho e estamos aguardando uma resposta.

Q é a sinalização de envio para essa rota, indicando que há uma consulta pendente. Este campo também pode ser: U, significando que há uma atualização pendente ou R, significando que há uma resposta pendente

Serial1 é a interface pela qual é possível alcançar esse vizinho.

Via 10.1.1.2 mostra o vizinho do qual estamos esperando uma resposta.

r indica que o vizinho foi consultado sobre a rota e que nenhuma resposta foi recebida ainda.

Serial0 é a interface pela qual é possível alcançar esse vizinho.

Via 10.1.2.2 (512640000/128256), Serial1 mostra que essa rota está sendo usada (indica qual caminho o próximo caminho/destino usará quando houver múltiplas rotas de custo igual).

show ip eigrp topology <network>

Esse comando exibe todas as entradas da tabela de topologia desse destino, e não apenas os sucessores possíveis. Una explicação de cada campo de saída segue a tabela.

show ip eigrp topology network

eigrp23.gif

Explicações de Configurações

State is Passive mostra que a rede está em estado passivo ou, em outras palavras, não estamos buscando um caminho para essa rede. As rotas quase sempre estão em estado passivo nas redes estáveis.

Query origin flag is 1 Se essa rota estiver ativa, este campo oferecerá informações sobre quem originou a consulta.

  • 0: Essa rota está ativa mas nenhuma consulta foi originada para ela (estamos procurando por um sucessor possível localmente).

  • 1: Esse roteador originou a consulta dessa rota (ou a rota é passiva).

  • 2: Vários computadores em difusão para esta consulta. Este roteador recebeu mais de uma consulta de mais de uma origem sobre esta rota.

  • 3: O roteador a partir do que aprendemos o caminho para essa rede está consultando outra rota.

  • 4: Origens de consultas múltiplas para esta rota, incluindo o roteador através do qual aprendemos esta rota. Semelhante ao 2, mas isso também significa que há uma string da origem de consulta que descreve as consultas pendentes desse caminho.

2 Successor(s) significa que há dois caminhos viáveis para essa rede.

FD is 307200 mostra a melhor métrica atual para essa rede. Se a rota estiver ativa, isto indica a métrica do caminho que estava sendo usada anteriormente para rotear pacotes nesta rede.

Blocos de Descritor de Roteamento Cada uma das entradas seguintes descreve um caminho para a rede.

  • 10.1.1.2 (Ethernet1) é o salto seguinte para a rede e a interface pela qual o próximo salto foi alcançado.

  • from 10.1.2.2 é a origem dessas informações do caminho.

  • Send flag is:

    • 0x0: Se existem pacotes que precisam ser enviados em relação a essa entrada, isso indica o tipo do pacote.

    • 0x1: Este roteador recebeu uma consulta para esta rede e necessita enviar uma resposta de unicast.

    • 0x2: Esta rota está ativa e deve ser enviada uma consulta de multicast.

    • 0x3: Esta rota foi alterada e uma atualização de multicast deve ser enviada.

Composite metric is (307200/281600) mostra o total dos custos calculados da rede. O primeiro número em parênteses é o custo total até a rede por esse caminho, incluindo o custo para o salto seguinte. O segundo número no parênteses é a distância informada ou, em outras palavras, o custo que o roteador de próximo salto utiliza.

Route is Internal significa que a rota foi originada dentro do Sistema autônomo (AS ) do EIGRP. Se a rota foi redistribuída nesse EIGRP AS, esse campo indica que a rota é Externa.

Vector metric mostra as métricas individuais usadas pelo EIGRP para calcular o custo em uma rede. O EIGRP não propaga as informações de custo total por toda a rede; as métricas de vetor são propagadas e cada roteador calcula o custo e a distância informada individualmente.

  • Minimum bandwidth is 10000 Kbit mostra a menor largura de banda no caminho para essa rede.

  • Total delay is 2000 microseconds mostra a soma dos retardos no caminho dessa rede.

  • Reliability is 0/255 mostra um fator de confiabilidade. Esse número é calculado dinamicamente e não é utilizado por padrão em cálculos métricos

  • Load is 1/255 indica a quantidade de carga transportada pelo link. Esse número é calculado dinamicamente e não é utilizado por padrão quando o EIGRP calcula o custo para usar esse caminho.

  • Minimum MTU is 1500 Este campo não é usado em cálculos métricos.

  • Hop count is 2 Isto não é usado em cálculos métricos, mas limita o tamanho máximo de um EIGRP AS. O número máximo de saltos que o EIGRP aceitará é 100, por padrão, embora o máximo possa ser configurado como 220 com hops máximos de métrica.

Se a rota for externa, as informações a seguir serão incluídas. Una explicação de cada campo de saída segue a tabela.

Rota Externa

eigrp24.gif

Explicações de Configurações

Originating Router mostra que esse é o roteador que injetou a rota no EIGRP AS.

External AS mostra o Sistema Autônomo de onde se originou essa rota (se houver um).

External Protocol mostra o protocolo de onde essa rota veio (se houver um).

external metric mostra a métrica interna no protocolo externo.

Etiqueta do administrador pode ser definida e/ou filtrada usando os mapas de rota com os comandos set tag e match tag.

show ip eigrp topology [active | pending | zero-successors]

Mesmo formato do show ip eigrp topology , mas também contém uma parte da tabela de topologia.

show ip eigrp topology all-links

O mesmo formato de saída de show ip eigrp topology , mas também mostra todos os links na tabela de topologia e não apenas possíveis sucessores.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 16406