Comutação LAN : Comutação e encaminhamento na camada três

Configurando o Roteamento InterVLAN e o Entroncamento ISL/802.1Q em Catalyst 2900XL/3500XL/2940/2950/2970 Series Switches Usando um Router Externo

22 Maio 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (22 Novembro 2005) | Feedback

Índice

Introdução
Antes de Iniciar
     Convenções
     Pré-requisitos
     Componentes Usados
     Observações Importantes
Configurar
     Diagrama de Rede
     Configurações
comandos debug e show
Exemplo de Saída do Comando show
     Switch Catalyst 3500XL
     Cisco 2600 Router
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento fornece amostras das configurações sobre o InterSwitchLink (ISL) e o truncamento 802.1q entre um switch Catalyst 3512-XL e um router Cisco 2600. Os resultados de cada comando são exibidos à medida que são executados. Os routers Cisco 3600 e 4500/4700 ou outros membros dos routers Cisco 2600 series, com interfaces FastEthernet e qualquer Catalyst 2900XL, 3500XL, 2940, 2950 ou 2970 podem ser usados nos cenários presentes neste documento para obter os mesmos resultados.

O entroncamento é um modo de transferir tráfego de vários VLANs em um link ponto-a-ponto entre dois dispositivos. Duas maneiras nas quais o entroncamento de Ethernet pode ser implementado são:

  • ISL (protocolo proprietário Cisco e não suportado pelos 2940 ou 2950 Series Switches)

  • 802.1Q (padrão IEE (Institute of Electrical and Electronics Engineers))

Vamos criar um tronco que transportará o tráfego de dois VLANs (VLAN1 e VLAN2) através de um único link entre o router Catalyst 3500 e Cisco 2600.

Estamos usando o router Cisco 2600 para fazer o roteamento Inter-VLAN entre o VLAN1 e o VLAN2. Os Catalyst 2900XL/3500XL/2940/2950/2970 Series Switches são switches Camada 2 (L2) e não conseguem fazer o roteamento ou a comunicação entre as VLANs. Para obter mais detalhes sobre o roteamento Inter-VLAN, consulte o capítulo Visão Geral de Roteamento Entre LANS Virtuais do Guia de Configuração de Serviços de Switching do Cisco IOS®, Release 12.1.

Para criar os exemplos neste documento, utilizamos os seguintes switches em um ambiente de laboratório, com configurações esclarecidas:

  • Switch Catalyst 3512XL executando o Cisco IOS 12.0(5.x)XU

  • Router Cisco 2621 executando Cisco IOS 12.1(3)T

  • Router Cisco 2621 executando Cisco IOS 12.1(1)T

As configurações apresentadas neste documento foram implementadas em um ambiente de laboratório isolado. Certifique-se de que compreende o impacto potencial de qualquer configuração ou comando em sua rede, antes de utilizá-lo. As configurações em todos os dispositivos foram limpas com o comando write erase para garantir uma configuração padrão.

Antes de Iniciar

Convenções

Para obter mais informações sobre convenções em documentos, consulte as Convenções de Dicas Técnicas da Cisco.

Pré-requisitos

Não existem pré-requisitos específicos para este documento.

Componentes Usados

Este documento não está restrito às versões específicas de software e de hardware.

Observações Importantes

Para Switches Catalyst 2900XL/3500XL/2940/2950/2970:

Os Catalyst 2940 e 2950 Series Switches oferecem suporte apenas a entroncamento 802.1q e não oferecem suporte a entroncamento ISL.

Em um switch Catalyst 2900XL de 4 MB de DRAM, o entroncamento somente é suportado com os seguintes módulos capazes de entroncamento:

  • WS-X2914-XL-V: Módulo de switch 10/100 ISL/802.1Q de 4 portas

  • WS-X2922-XL-V: Módulo de switch 1100BaseFX ISL/802.1Q de 2 portas

  • WS-X2924-XL-V: Módulo de switch 1100BaseFX ISL/802.1Q de 4 portas

  • WS-X2931-XL: Uplink de 1000BaseX para Catalyst 2900 XL

  • WS-X2932-XL: Uplink 1000BaseT para Catalyst 2900 XL

Consulte a Tabela 1 a seguir para obter uma lista atual de modelo de switches que suportam entroncamento:

Tabela 1

Modelos de Switches

Versão Mínima Necessária para o Entroncamento ISL

Versão Mínima Necessária para o Entroncamento IEEE 802.1Q

Versão Atual Necessária para o Entroncamento (ISL 802.1Q)

WS-C2916M-XL (Switch 4-Meg)

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição de Empreendimento)

11.2(8.6)SA6 (Edição Original)

C2912-XL

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição de Empreendimento)

12.0(5)WC(1) ou mais recente

C2924-XL

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição de Empreendimento)

12.0(5)WC(1) ou mais recente

WS-C2924C-XL

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição de Empreendimento)

12.0(5)WC(1) ou mais recente

WS-C2924M-XL

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição de Empreendimento)

12.0(5)WC(1) ou mais recente

WS-C2912MF-XL

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição de Empreendimento)

12.0(5)WC(1) ou mais recente

WS-C2924M-XL-DC

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) ou mais recente

WS-C3508G-XL

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição de Empreendimento)

12.0(5)WC(1) ou mais recente

WS-C3512-XL

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição Original)

12.0(5)WC(1) ou mais recente

WS-C3524-XL

11.2(8)SA4 (Edição de Empreendimento)

11.2(8)SA5 (Edição de Empreendimento)

12.0(5)WC(1) ou mais recente

WS-C3548-XL

12.0(5)XP (Edição de Empreendimento)

12.0(5)XP (Edição de Empreendimento)

12.0(5)WC(1) ou mais recente

WS-C3524-PWR-XL

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) ou mais recente

WS-C2940-8TF

ISL Sem Suporte

12.1(13)AY

12.1(13)AY ou mais recente para 802.1Q. ISL sem suporte.

WS-C2940-8TT

ISL Sem Suporte

12.1(13)AY

12.1(13)AY ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950-12

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950-24

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950C-24

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950T-24

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950G-12-EI

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950G-24-EI

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950G-48-EI

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950SX-24

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2950-24-EI-DC

ISL Sem Suporte

12.0(5)WC(1)

12.0(5)WC(1) ou mais recente para 802.1Q. ISL sem suporte.

WS-C2955T-12

ISL Sem Suporte

12.1(13)EA1

12.1(13)EA1 ou mais recente para 802.1Q. ISL sem suporte.

WS-C2955S-12

ISL Sem Suporte

12.1(13)EA1

12.1(13)EA1 ou mais recente para 802.1Q. ISL sem suporte.

WS-C2955C-12

ISL Sem Suporte

12.1(13)EA1

12.1(13)EA1 ou mais recente para 802.1Q. ISL sem suporte.

WS-C2970G-24T

12.1(11)AX

12.1(11)AX

12.1(11)AX ou mais recente

WS-C2970G-24TS

12.1(14)EA1

12.1(14)EA1

12.1(14)EA1 ou posterior

Observação: Na tabela acima, apenas WS-C2916M-XL é um switch DRAM de 4 MB. Todos os demais switches listados são do tipo DRAM de 8 MB. Para determinar se seu switch tem 4 MB ou 8 MB de DRAM, insira o comando show version no nível do usuário. Para obter mais informações, consulte a seção Como determinar a Quantidade de Memória do Switch Usando a Interface de Linha de Comando de Atualizando Software nos Switches Catalyst 2900-XL/3500-XL Usando a Interface de Linha de Comando.

Observação: Nos switches Catalyst 2900XL/3500XL/2940/2950/2970, uma interface VLAN, como por exemplo, int vlan 1, int vlan 2, int vlan x, pode ser criada para cada e toda VLAN que é configurada no switch. No entanto, apenas uma VLAN pode ser usada por vez como uma VLAn de gerenciamento. O endereço IP é atribuído à interface VLAN apenas da interface VLAN de gerenciamento. Se o endereço IP for atribuído a uma outra interface de VLAN que não seja usada para gerenciamento, essa interface não será exibida. É preferível criar a interface VLAN somente para a VLAN de gerenciamento.

Para routers Cisco 2600:

Para o entroncamento 802.1Q um VLAN não está rotulado. Esse VLAN é chamado de VLAN nativo. A VLAN nativa é usada para tráfego não rotulado quando a porta está no modo de entroncamento 802.1Q. Ao configurar o entroncamento 802.1Q, é muito importante lembrar-se de que a VLAN nativa deve ser configurada da mesma maneira de cada lado do link do tronco. É um erro comum não comparar as VLANs nativas ao configurar o entroncamento 802.1Q entre o router e o switch. Para obter detalhes sobre as VLANs nativas, consulte a seção IEEE 802.1Q de Fazendo a Ponte Entre VLANs IEEE 802.1Q, nos Novos Recursos na Versão 12.1(3)T.

Nesse exemplo de configuração, a VLAN nativa é a VLAN1, por padrão, tanto no router Cisco 2621 como no switch Catalyst 3512XL. Dependendo das suas necessidades de rede, pode ser que você tenha que usar uma VLAN nativa diferente da VLAn padrão, VLAN1. Os comandos foram mencionados na seção Configurações deste documento sobre como alterar a VLAN nativa no router Cisco 2600 e no switch Catalyst 3500XL.

Exemplos de configurações apresentados neste documento podem ser usados em routers Cisco 2600/3600/4500/4700 series com interfaces Fast Ethernet ou módulos de rede Fast Ethernet. Além disso, verifique se está utilizando a versão do Cisco IOS que suporta entroncamento de VLAN ISL/802.1Q. Para obter uma lista completa de routers Cisco 2600/3600/4500/4700 que ofereçam suporte a entroncamento VLAN ISL/802.1Q e as versões do Cisco IOS suportadas, consulte a Tabela 2 a seguir.

Tabela 2

Modelos de router

Versão Mínima Necessária para o Entroncamento ISL

Versão Mínima Necessária para o Entroncamento IEEE 802.1Q

Conjunto mínimo de recursos requeridos (ISL/802.1Q)

Cisco 2620

11.3(3a)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 2621

11.3(3a)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 2620

12.1(3a)T

12.1(3a)T

IP PLUS / IP PLUS

Cisco 2650

12.1(3a)T

12.1(3a)T

IP PLUS / IP PLUS

Cisco 3620

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 3640

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 3661

12.0(5)T

12.0(5)T

IP PLUS / IP PLUS

Cisco 3662

12.0(5)T

12.0(5)T

IP PLUS / IP PLUS

M do Cisco 4500

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

M do Cisco 4700

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Observação: A Tabela 2 lista apenas as versões mínimas ou de manutenção/atuais que oferecem suporte a esse exemplo de configuração. É possível que modelos de routers com determinados módulos de rede tenham versões mínimas do Cisco IOS diferentes. Para obter uma lista completa de software mínimo suportado para qualquer família de router, use o Software Advisor (clientes registrados somente) .

Observação: A versão mínima suportada pode, não necessariamente, ser a versão recomendada. Para determinar a melhor versão de manutenção para seu produto Cisco, procure bugs listados por componente do produto no Bug Toolkit (clientes registrados somente) .

Observação: A Tabela 2 lista o conjunto de recursos mínimos necessários para fazer roteamento Inter-VLAN IP e entroncamento para oferecer suporte a esse exemplo de configuração. Para obter uma lista completa de outros conjuntos de recursos suportados em diferentes versões do Cisco IOS e em diferentes plataformas, use a Área de Download de Software (clientes registrados somente) .

Configurar

Nesta seção, você vai conhecer informações para configurar os recursos descritos neste documento.

Observação: Para obter outras informações sobre os comandos utilizados neste documento, utilize a Ferramenta de Consulta de Comandos (clientes registrados somente) .

Diagrama de Rede

Este documento utiliza a configuração de rede apresentada no diagrama abaixo.

50a.jpg

Configurações

Este documento utiliza a configuração apresentada abaixo.

Observação: Os modelos do router com determinados módulos de rede podem ter versões do Cisco IOS com diferenças mínimas que suportam o entroncamento ISL.

  • Catalyst 3512-XL

  • Router Cisco 2600

  • Configuração 802.1Q no router para Versões do Cisco IOS anteriores a 12.1(3)T

Catalyst 3512-XL

Observação: A tela a seguir captura os comandos inseridos no switch 3512XL. Os comentários entre os comandos são adicionados em itálico azul para explicar certos comandos e etapas.

                  
                     !—Defina o modo privilegiado
                  
                  
                     !—e a senha Telnet no switch.
                  
switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z


                     !—Defina o endereço IP e o gateway padrão para a VLAN1 para propósitos de gerenciamento.
                  
3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end
                  
                     !—Defina o modo VTP.
!-- Em nosso exemplo, definidos o modo para ser transparente.
!-- Dependendo de sua rede, defina o Modo VTP apropriadamente.
!-- Para obter detalhes sobre o VTP,
!-- consulte
!-- Criando e Mantendo VLANs nos switches Catalyst 2900XL e 3500XL.
                  
3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.


                     !-- Adicionando VLAN2. A VLAN1 já existe por padrão.
                  
3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....


                     !—Ative o entroncamento na interface fastEthernet 0/1.
                  
3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk

                  
                     !-- Insira o encapsulamento de entroncamento como isl
                  
3512xl(config-if)#switchport trunk encapsulation isl
                  
                     ! -- ou como dot1q:
                  

3512xl(config-if)#switchport trunk encapsulation dot1q

                     !-- No caso de switches 2940/2950 series, nenhum dos dois comandos acima são usados,
!-- Os switches 2940/2950 series oferecem suporte apenas a encapsulamento 802.1q que é configurado automaticamente,
!-- quando o entroncamento é habilitado na interface usando o comando switchport mode trunk.

!-- No caso de dot1q, você precisa certificar-se de que
!-- a VLAN nativa corresponde no link.
!-- No 3512XL, por padrão, a VLAN nativa é 1.
!-- Dependendo do que sua rede precisa, você pode alterar
!-- a VLAN nativa para ser diferente da VLAN1,
!-- mas é muito importante que você altere a VLAN nativa
!-- no router adequadamente.
!-- Você pode alterar a VLAN nativa, se necessário, usando o seguinte comando:
!-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>

!-- Permita todas as VLANs no tronco.
                  
3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit

                  
                     ! -- O seguinte conjunto de comandos colocarão o FastEthernet 0/2
!-- na VLAN2 e habilitarão portfast na interface.
                  
3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit

                  
                     !—A FastEthernet 0/3 já está na VLAN1 por padrão.
!-- Habilite portfast na interface.
                  
3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z

                     !-- Para obter detalhes sobre por que habilitar portfast,
!-- consulte:
!-- Usando PortFast e outros Comandos para Corrigir Atrasos de Conectividade de Inicialização da Estação de Trabalho.
!-- Lembre-se de salvar a configuração.
                  
3512xl#write memory
Building configuration...

3512xl#

--------------------------------------------------------------------------------

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
  switchport mode trunk
!

                     !-- Se 802.1Q estiver configurado,
!-- você verá, em seu lugar, a seguinte saída
!-- sob interface FastEthernet0/1:
!-- interface FastEthernet0/1
!-- encapsulamento de tronco de porta de switch dot1q
!-- tronco de modo de porta de switch
                  
!
interface FastEthernet0/2
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

Router 2600

Observação: As seguintes capturas de tela mostram os comandos que foram inseridos no router Cisco 2600. Os comentários entre os comandos são adicionados em itálico azul para explicar certos comandos e etapas.

                  
                     !-- Defina o modo privilegiado
!-- e a senha Telnet no router.
                  
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


                     !-- Selecione FastEthernet 0/0 para a configuração do tronco.
!-- Nenhuma configuração L2 ou Camada 3 (L3) é feita aqui.
                  
c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit

                  
                     !—Ative o entroncamento na subinterface fastEthernet 0/0.1.
!-- Observe que os troncos reais são configurados nas subinterfaces.
                  
c2600(config)#int fastEthernet 0/0.1

                  
                     !-- Insira o encapsulamento de entroncamento como isl

                  c2600(config-subif)#encapsulation isl 1

                  
                     ! -- ou como dot1q:
!-- No caso de dot1q, você precisa certificar-se de que
!-- a VLAN nativa corresponde no link.
!-- No 3512XL, por padrão, a VLAN nativa é 1.
!-- No router, configure VLAN1 como a VLAN nativa.
                  
c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  <cr>
c2600(config-subif)#encapsulation dot1Q 1 native
                  
                     !-- No switch, se você tiver uma VLAn nativa diferente da VLAN1,
!-- no router, configure a mesma VLAn para ser a VLAN nativa,
!-- usando o comando acima.
                  
               

Observação: O comando encapsulation dot1Q 1 native foi adicionado no Cisco IOS versão 12.1(3)T. Se você estiver utilizando uma versão mais antiga do Cisco IOS, consulte a seção “Configuração de 802.1Q para versões anteriores a 12.1(3)T do Cisco IOS” deste documento para configurar o entroncamento 802.1Q no router.

                  
                     !-- Configure as informações L3 na subinterface 0/0.1.
                  
c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit

                  
                     !—Ative o entroncamento na subinterface fastEthernet 0/0.2.
!-- Observe que os troncos reais são configurados nas subinterfaces.
                  
c2600(config)#int fastEthernet 0/0.2

                  
                     !-- Insira o encapsulamento de entroncamento como isl
                  
c2600(config-subif)#encapsulation isl 2

                  
                     ! -- ou como dot1q:
                  
c2600(config-subif)#encapsulation dot1Q 2

                  
                     !-- Configure as informações L3 na subinterface 0/0.2.
                  
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


                     ! -- Lembre-se de salvar a configuração.
                  
c2600#write memory
Building configuration...
[OK]
c2600#

Observação: Para fazer com que esta configuração funcione e para efetuar ping com êxito, entre a estação de trabalho 1 e a estação de trabalho 2, é preciso verificar se os gateways padrão nas estações de trabalho estão configurados corretamente. Para a estação de trabalho1, o gateway padrão deve ser 10.10.11.1 e para a estação de trabalho2, o gateway padrão deve ser 10.10.10.1. Para obter detalhes sobre como definir os gateways padrão nas estações de trabalho, consulte suas respectivas seções neste documento.

Observação: O parágrafo a seguir é aplicável somente se o entroncamento 802.1Q tiver sido configurado entre o router e o switch.

Observação: Se você tiver seguido as etapas de configuração listadas nas seções acima e ainda não conseguir efetuar ping entre as VLANs (entre a estação de trabalho1 e a estação de trabalho2), há uma possibilidade de que você tenha se deparado com a Advertência CSCds42715, no qual a palavra-chave da VLAN nativa do 802.1Q não funciona adequadamente quando o switching rápido está habilitado. A correção de bug foi integrada às seguintes versões de código: 12.2(0.5), 12.2(0.5)T, 12.1(5)DC, 12.1(5)YB, 12.2(0.18)S, 12.1(5)YD02, 12.2(2)B, 12.2(15)ZN. Você pode verificar o status e uma breve descrição do bug usando o Bug Toolkit (clientes registrados somente) e inserindo o ID de bug CSCds42715.


--------------------------------------------------------------------------------

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
!

                     !-- Se 802.1Q estiver configurado,
!-- você verá, em seu lugar, a seguinte saída
!-- sob interface FastEthernet0/0.1:
!-- interface FastEthernet0/0.1
!-- encapsulamento dot1Q 1 nativo
!-- endereço ip 10.10.10.1 255.255.255.0
                  
!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!

                     !-- Se 802.1Q estiver configurado,
!-- você verá, em seu lugar, a seguinte saída
!-- under interface FastEthernet0/0.2:
!-- interface FastEthernet0/0.2
!-- encapsulation dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0
                  
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

Configuração 802.1Q no router para Versões do Cisco IOS anteriores a 12.1(3)T

Conforme descrito anteriormente neste documento, ao configurar o entroncamento 802.1Q, é muito importante corresponder a VLAN nativa através do link. Nas versões do Cisco IOS Software anteriores à 12.1(3)T não é possível definir a VLAN nativa explicitamente, já que o comando encapsulation dot1Q 1 native na subinterface não está disponível. Nas versões anteriores do Cisco IOS, é importante configurar a Interface VLAN nativa não como subinterface, que está na nossa VLAN1 de exemplo. Se configurada errado, o router esperará um quadro dot1q de tag na VLAN1 e o switch não está esperando uma tag na VLAN1. Como resultado, nenhum tráfego passará entre a VLAN1 no switch e no router. Nessas situações, sempre coloque a configuração para a VLAN nativa sob a interface principal e no tronco, crie subinterface para todas as outras VLANS.

Na configuração atual do laboratório, siga estas etapas para configurar o router Cisco 2600:

                  
                     !-- Defina o modo privilegiado
!-- e a senha Telnet no router.
                  
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


                     !-- Selecione FastEthernet 0/0 para a configuração do tronco.
                  
c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut

                  
                     !—Observe que o endereço IP para VLAN1 está configurado na  interface principal,
!-- e nenhum encapsulamento para VLAN1 será feito sob a subinterface.
                  
c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit

                  
                     !-- Configure o encapsulamento dot1q para VLAN 2
!-- na subinterface fastEthernet 0/0.2.
                  
c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#


                     !—Configurando as informações L3 na subinterface 0/0.2.
                  
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


                     ! -- Lembre-se de salvar a configuração.
                  
c2600#write memory
Building configuration...
[OK]
c2600#

Observação: Para fazer com que esta configuração funcione e para efetuar ping com êxito entre a estação de trabalho 1 e a estação de trabalho 2, é preciso verificar se os gateways padrão nas estações de trabalho estão configurados corretamente. Para a estação de trabalho1, o gateway padrão deve ser 10.10.11.1 e para a estação de trabalho2, o gateway padrão deve ser 10.10.10.1. Para obter detalhes sobre como definir os gateways padrão nas estações de trabalho, consulte suas respectivas seções neste documento.

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

comandos debug e show

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Alguns comandos show recebem suporte da Output Interpreter Tool (clientes registrados somente) , o que permite visualizar uma análise da saída do comandoshow.

No switch Catalyst 2900XL/3500XL/2940/2950/2970, use os seguintes comandos:

  • show int {FastEthernet | GigabitEthernet} <module/port> switchport

  • show vlan

  • show vtp status

No router Cisco 2600, use os seguintes comandos:

  • show vlan

  • show interface

Exemplo de Saída do Comando show

Switch Catalyst 3500XL

show int {FastEthernet | GigabitEthernet} <module/port> switchport

Esse comando é usado para verificar o status administrativo e operacional da porta. Também é usado para assegurar que a VLAN nativa corresponda em ambos os lados do tronco. A VLAN nativa é usada para tráfego não rotulado quando a porta está no modo de entroncamento 802.1Q. Consulte Criando e Mantendo VLANs em switches Catalyst 2900XL e 3500XL para obter detalhes sobre VLANs nativas.

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Modo Administrativo: tronco
Operational Mode: tronco
Encapsulamento de Entroncamento Administrativo: isl
Encapsulamento de Entroncamento Operacional: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
VLAN de Modo Nativo de Entroncamento: 1 (padrão)
VLANs de Entroncamento Habilitadas:   TODOS
VLANs de Entroncamento Ativas:   1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

Observação: Para o entroncamento 802.1Q, a saída do comando acima é alterada como se segue:

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Modo Administrativo: tronco
Operational Mode: tronco
Encapsulamento de Entroncamento Administrativo: dot1q
Encapsulamento de Entroncamento Operacional: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
VLAN de Modo Nativo de Entroncamento: 1 (padrão)
VLANs de Entroncamento Habilitadas:   TODOS
VLANs de Entroncamento Ativas:   1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

Esse comando é usado para verificar se as interfaces (portas) pertencem à VLAN correta. No nosso exemplo, apenas a interface Fa0/2 pertence à VLAN2 e as restantes são membros de VLAN1.

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

...(saída suprimida)

show vtp status

Este comando é utilizado para verificar a configuração do protocolo de entroncamento de VLAN (VTP) no switch. Em nosso exemplo, usamos o modo transparente. O modo VTP correto depende da topologia da rede. Para obter detalhes sobre VTP, consulte Criando e Mantendo VLANs em Switches Catalyst 2900XL e 3500XL.

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparente
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Cisco 2600 Router

show vlan

Este comando diz quais informações de L2 ou L3 estão configuradas para cada VLAN.

c2600#show vlan

            ID da LAN Virtual:  1 (Encapsulamento do Link Inter-Switch)

   vLAN Trunk Interface:   FastEthernet0/0.1

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38

ID da LAN Virtual:  2 (Encapsulamento do Link Inter-Switch)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

Observação: Para o entroncamento 802.1Q, a saída do comando acima é alterada como se segue:

c2600#show vlan

            ID da LAN Virtual:  1 (Encapsulamento IEEE 802.1Q)

   vLAN Trunk Interface:   FastEthernet0/0.1

            Isso é configurado como VLAN nativa para a seguinte interface: FastEthernet0/0

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2

ID da LAN Virtual:  2 (Encapsulamento IEEE 802.1Q)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

Observação: Para o entroncamento 802.1Q, com versões do Cisco IOS anteriores a 12.1(3)T, a saída do comando é alterada como se segue:

c2600#show vlan

            ID da LAN Virtual:  2 (Encapsulamento IEEE 802.1Q)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

Observação: Nenhum encapsulamento de IEEE 802.1Q é exibido para VLAN1 em nenhuma das sub-interfaces.

show interface

Esse comando é usado para verificar o status administrativo e operacional da interface.

c2600#show interfaces fastEthernet 0/0
            FastEthernet0/0 está funcionando, o line protocol está funcionando
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

c2600#show interfaces fastEthernet 0/0.1
            FastEthernet0/0.1 está funcionando, o line protocol está funcionando
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Endereço Internet é 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
            FastEthernet0/0.2 está funcionando, o line protocol está funcionando
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Endereço Internet é 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

Observação: Para o entroncamento 802.1Q, a saída do comando acima é alterada como se segue:

c2600#show interfaces fastEthernet 0/0.1
            FastEthernet0/0.1 está funcionando, o line protocol está funcionando
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Endereço Internet é 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
            FastEthernet0/0.2 está funcionando, o line protocol está funcionando
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Endereço Internet é 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14976