Tecnologias IBM : Dispositivos de segurança Cisco PIX 500 Series

Configurando o PIX Firewall e VPN Clients Usando PPTP, MPPE e IPSec

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (13 Outubro 2008) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Configurar
     Diagrama de Rede
     Configurações
     Cisco VPN 3000 Client 2.5.x ou Cisco VPN Client 3.x e 4.x
     Configuração de Cliente PPTP com Windows 98/2000/XP
Verificação
Solução de Problemas
     Comandos de Solução de Problemas
     Problemas Relacionados à Microsoft
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Neste exemplo de configuração, quatro tipos diferentes de clientes se conectam e criptografam o tráfego com o Cisco Secure PIX Firewall como extremidade final de túnel:

  • Usuários que executam o Cisco Secure VPN Client 1.1 no Microsoft Windows 95/98/NT

  • Usuários que executam o Cisco Secure VPN 3000 Client 2.5x no Microsoft Windows 95/98/NT

  • Usuários que executam clientes nativos de Point-to-Point Tunneling Protocol (PPTP) no Windows 98/2000/XP

  • Usuários que executam o Cisco VPN Client 3.x/4.x no Windows 95/98/NT/2000/XP

Neste exemplo, um único pool para IPsec e PPTP é configurado. Entretanto, os pools também podem ser criados separadamente.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Usados

As informações neste documento são baseadas nestas versões de hardware e software:

  • PIX Software Release 6.3.3

  • Cisco Secure VPN Client 1.1

  • Cisco VPN 3000 Client versão 2.5

  • Cisco VPN Client 3.x e 4.x

  • Clientes Microsoft Windows 2000 e Windows 98

Observação: Esta configuração foi testada no PIX Software Release 6.3.3 mas deverá funcionar na versão 5.2.x e 5.3.1. O PIX Software Release 6.x é necessário para o Cisco VPN Client 3.x e 4.x. (O suporte ao Cisco VPN 3000 Client 2.5 foi adicionado no PIX Software Release 5.2.x. A configuração também funciona para o PIX Software Release 5.1.x, exceto para a parte do Cisco VPN 3000 Client.) O IPsec e a PPTP/Microsoft Point-to-Point Encryption (MPPE) deverão ser criadas para funcionarem separadamente primeiro. Caso não funcionem separadamente, não funcionarão juntos.

Observação: O PIX 7.0 usa o comando inspect rpc para manipular pacotes RPC. O comando inspect sunrpc habilita ou desabilita a inspeção de aplicativo para o protocolo Sun RPC. Os serviços Sun RPC podem ser executados em qualquer porta no sistema. Quando um cliente tenta acessar um serviço RPC em um servidor, ele precisa saber em que porta aquele serviço específico está sendo executado. Ele faz isso enfileirando o processo de mapeador de porta na porta conhecida de número 111. O cliente envia o número do serviço de programa RPC e recebe de volta o número da porta. Desse momento em diante, o programa do cliente envia suas consultas RPC à nova porta.

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento foram iniciados com uma configuração vazia (padrão). Se a sua rede estiver ativa, certifique-se de entender o impacto potencial de todos os comandos.

Convenções

Para obter mais informações sobre convenções de documentos, consulte Convenções e Dicas Técnicas da Cisco.

Configurar

Nesta seção, você encontra as informações para configurar os recursos descritos neste documento.

Observação: Use a Ferramenta de Consulta de Comandos (clientes registrados somente) para obter informações adicionais sobre os comandos utilizados nesta seção.

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

pptpcrypto3.gif

Configurações

Este documento usa as configurações abaixo.

Cisco Secure PIX Firewall

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname goss-515A
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list 101 permit ip 10.99.99.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 172.18.124.152 255.255.255.0
ip address inside 10.99.99.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool bigpool 192.168.1.1-192.168.1.254
pdm history enable
arp timeout 14400
nat (inside) 0 access-list 101
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client configuration address initiate
crypto map mymap client configuration address respond
crypto map mymap interface outside
isakmp enable outside
                  
                     !--- Cisco Secure_VPNClient_key.
                  

                  isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp client configuration address-pool local bigpool outside

                  
                     !--- Política ISAKMP para o Cisco VPN Client 2.5 ou
!--- Cisco Secure VPN Client 1.1.
                  

                  isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5

                  
                     !--- Os VPN Clients 1.1 e 2.5 usam a política de grupo 1 Diffie-Hellman (D-H)
!--- (padrão do PIX).
                  

                  isakmp policy 10 group 1
isakmp policy 10 lifetime 86400

                  
                     !--- Política ISAKMP Policy para VPN Client 3.0 e 4.0.
                  

                  isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5

                  
                     !--- Os VPN Clients 3.0/4.0 usam a política de grupo 2 D-H
!--- e o código de PIX 6.0.
                  

                  isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000-all address-pool bigpool
vpngroup vpn3000-all dns-server 10.99.99.99
vpngroup vpn3000-all wins-server 10.99.99.99
vpngroup vpn3000-all default-domain password
vpngroup vpn3000-all idle-time 1800

                  
                     !--- VPN 3000 group_name and group_password.
                  

                  vpngroup vpn3000-all password ********
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe auto
vpdn group 1 client configuration address local bigpool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local

                  
                     !--- Nome de usuário PPTP e senha.
                  

                  vpdn username cisco password *********
vpdn enable outside
terminal width 80
Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
: end
goss-515A#

Cisco Secure VPN Client 1.1

1- TACconn
      My Identity
           Connection security: Secure
           Remote Party Identity and addressing
           ID Type: IP subnet
           10.99.99.0
            255.255.255.0
           Port all Protocol all

      Connect using secure tunnel
           ID Type: IP address
           172.18.124.152

      Pre-shared Key=CiscoSecure_VPNClient_key

      Authentication (Phase 1)
      Proposal 1
          Authentication method: pre-shared key
          Encryp Alg: DES
          Hash Alg: MD5
          SA life: Unspecified
          Key Group: DH 1

      Key exchange (Phase 2)
      Proposal 1
          Encapsulation ESP
          Encrypt Alg: DES
          Hash Alg: MD5
          Encap: tunnel
          SA life: Unspecified
          no AH

  2- Other Connections
         Connection security: Non-secure
         Local Network Interface
           Name: Any
           IP Addr: Any
           Port: All

Cisco VPN 3000 Client 2.5.x ou Cisco VPN Client 3.x e 4.x

Selecione Options (Opções) > Properties (Propriedades) > Authentication (Autenticação). Group-name e group password correspondem a group_name e group_password no PIX como em:

vpngroup vpn3000-all password ********
Host-name = 172.18.124.152 

Configuração de Cliente PPTP com Windows 98/2000/XP

Você pode entrar me contato com o fornecedor que oferece o cliente PPTP. Consulte Como Configurar o Cisco Secure PIX Firewall para Usar PPTP para obter mais informações sobre como fazer essa configuração.

Verificação

No momento, não existe um procedimento de verificação disponível para esta configuração.

Solução de Problemas

Esta seção fornece informações que podem ser utilizadas para solucionar problemas de configuração.

Comandos de Solução de Problemas

A Output Interpreter Tool (clientes registrados somente) (OIT) é compatível com alguns show comandos. Use a OIT para visualizar uma análise da saída de comando show.

Observação: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

Depuração IPsec de PIX

  • debug crypto ipsec — Mostra as negociações de IPSec da fase 2.

  • debug crypto isakmp — Exibe as negociações de Internet Security Association and Key Management Protocol (ISAKMP) da fase 1.

  • debug crypto engine — Exibe o tráfego que está criptografado.

Depuração PIX PPTP

  • debug ppp io — Exibe as informações de pacotes para a interface virtual PPTP PPP.

  • debug ppp error — Exibe mensagens de erro virtuais PPTP PPP.

  • debug vpdn error — Exibe mensagens de erro de protocolo PPTP.

  • debug vpdn packets — Exibe informações dos pacotes PPTP sobre o tráfego PPTP.

  • debug vpdn events — Exibe informações sobre alteração de evento de túnel PPTP.

  • debug ppp uauth — Exibe as mensagens de depuração de autenticação de usuário AAA da interface virtual PPTP PPP.

Problemas Relacionados à Microsoft


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14095