IP : Serviços de aplicação IP

Compartilhamento de Carga com HSRP

22 Maio 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (10 Agosto 2005) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes usados
     Teoria complementar
     Convenções
Configurar
     Diagrama de rede
     Configurações
     Observação Importante
Verificação
Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações relacionadas

Introdução

Este documento mostra um exemplo de como configurar o Protocolo de Roteamento de Hot-Standby (HSRP) para aproveitar os vários caminhos de um determinado destino.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes usados

Este documento não se restringe a versões específicas de software e de hardware.

As informações apresentadas neste documento foram criadas a partir dos dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento começaram com uma configuração vazia (padrão). Caso esteja trabalhando em uma rede ativa, certifique-se de ter compreendido o possível impacto dos comandos antes de utilizá-los.

Teoria complementar

O HSRP é geralmente usado para melhorar a resiliência em redes, mas isso pode causar uma diminuição na eficiência da rede. O exemplo neste documento possui dois caminhos da rede do host para a rede do servidor. Para redundância, o HSRP é executado entre o R1 e o R2, sendo que ambos podem se tornar o roteador ativo e assumir a "propriedade" do endereço IP virtual do HSRP. O segundo roteador se torna o roteador em espera e só se torna ativo se o roteador ativo atual ficar inativo. Para obter mais informações sobre roteadores ativos e em espera, consulte Como Utilizar os Comandos standby preempt e standby track .

Nós definimos o endereço de gateway padrão dos hosts como o endereço IP virtual de HSRP. Quando os hosts precisam enviar pacotes para a rede de servidores, eles os enviam para seu gateway padrão ou para qualquer roteador que estiver ativo. Como apenas um roteador está ativo, os pacotes do host para os servidores atravessam apenas um dos dois caminhos disponíveis.

Observação: Dependendo de como você configurar o R3, os pacotes que retornam dos servidores para os hosts podem ou não utilizar ambos os caminhos de retorno. Além disso, os pacotes que retornam dos servidores para os hosts não precisam passar pelo roteador ativo.

Para utilizar ambos os caminhos da rede do host para a rede do servidor, é possível configurar HSRP Multigrupo (MHSRP) entre R1 e R2. Essencialmente, o R1 é configurado com dois grupos de HSRP (por exemplo, grupo 1 e grupo 2) e o R2 também é configurado com os mesmos grupos de HSRP. Para o grupo 1, o R1 é o roteador ativo e o R2 é o roteador em espera. Para o grupo 2, o R2 é o roteador ativo e o R1 é o roteador em espera. Então, você configura metade dos gateways padrão dos hosts com o endereço IP virtual do grupo 1 de HSRP e a outra metade com o endereço IP virtual do grupo 2 de HSRP.

Convenções

Para obter mais informações sobre convenções de documentos, consulte Convenções e Dicas Técnicas da Cisco.

Configurar

Nesta seção, você encontra as informações para configurar as características descritas neste documento.

Observação: Para obter informações adicionais sobre os comandos utilizados neste documento, use a ferramenta Consulta de Comando (clientes registrados somente) .

Diagrama de rede

Este documento usa esta configuração de rede:

7a.gif

Configurações

Este documento usa estas configurações:

Configuração de MHSRP do R1

Current configuration:

interface Ethernet0
        ip address 171.16.6.5 255.255.255.0

        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

Configuração de MHSRP do R2

Current configuration:

interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

Observe a partir das configurações que, quando os dois roteadores começam a executar o HSRP primeiro, o R1 tem uma prioridade padrão de 100 para o grupo 1 e de 95 para o grupo 2. O R2 tem uma prioridade padrão de 100 para o grupo 2 e de 95 para o grupo 1. Portanto, o R1 é o roteador ativo do grupo 1 e o R2 é o roteador ativo do grupo 2. Este exemplo mostra que é possível realizar compartilhamento de carga com o MHSRP. No entanto, é necessário utilizar a prioridade e a antecipação de HSRP para ser bem-sucedido. O HSRP não tem efeito no tráfego de retorno.

Observação Importante

Diversos controladores Ethernet (Lance e QUICC) em produtos low-end podem ter somente um único endereço de Controle de Acesso de Mídia (MAC) unicast em seu filtro de endereço. Essas plataformas permitem somente um grupo de HSRP e alteram o endereço da interface para o endereço MAC virtual de HSRP quando o grupo fica ativo. O compartilhamento de carga em plataformas com esta limitação não é possível com HSRP. O comando use-bia foi introduzido para solucionar problemas que ocorrem quando você executa o HSRP em produtos low-end, conforme mencionado. Por exemplo, se você executa o HSRP e o DECnet nas mesmas interfaces, ocorrem problemas porque o DECnet e o HSRP tentam modificar o endereço MAC. Com o comando use-bia, é possível configurar o HSRP para usar o endereço MAC criado pelo processo DECnet. No entanto, é preciso estar ciente de que há algumas desvantagens no uso do comando use-bia, tais como:

  • Quando um roteador se torna ativo, o endereço IP virtual é movido para um endereço MAC diferente. O roteador recém-ativo envia uma resposta de Protocolo de Resolução de Endereços (ARP) gratuita, mas nem todas as implementações de host lidam com o ARP gratuito de modo correto.

  • A configuração de use-bia interrompe o proxy ARP. Um roteador em espera não pode cobrir o banco de dados do proxy ARP perdido do roteador que falhou.

Verificação

No momento, não existe um procedimento de verificação disponível para esta configuração.

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações relacionadas


Document ID: 13781