IP : Serviços de aplicação IP

Como Utilizar os Comandos standby preempt e standby track

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (10 Agosto 2005) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes usados
     Convenções
Informações complementares
Exemplos de Configurações
Discussões relacionadas da comunidade de suporte da Cisco
Informações relacionadas

Introdução

Este documento descreve como os comandos standby preempt e standby track funcionam juntos e quando você deve utilizar cada um deles.

O comando standby preempt habilita o roteador do Protocolo de Roteamento de Hot-Standby (HSRP) com a prioridade mais elevada para se tornar imediatamente o roteador ativo. A prioridade é determinada primeiro pelo valor de prioridade configurado e, em seguida, pelo endereço IP. Em cada caso, o valor mais alto tem maior prioridade. Quando um roteador com prioridade mais alta ocupa o lugar de um roteador com prioridade mais baixa, o roteador envia uma mensagem de Vitória. Quando um roteador ativo de prioridade mais baixa recebe uma mensagem de Vitória ou uma mensagem de Saudação de um roteador ativo de prioridade mais alta, ele passa para o estado de Fala e envia uma mensagem de despedida.

O comando standby track permite especificar uma outra interface no roteador que deverá ser monitorada pelo processo HSRP a fim de alterar a prioridade HSRP de um grupo específico. Se o protocolo da linha da interface especificada ficar inativo, a prioridade do HSRP é reduzida. Isso significa que outro roteador HSRP com prioridade mais alta pode se tornar o roteador ativo se ele tiver o comando standby preempt habilitado.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes usados

As informações neste documento são baseadas nestas versões de hardware e software:

  • Software Cisco IOS® Release 12.2(10b)

  • Routers Cisco 2503

As informações apresentadas neste documento foram criadas a partir dos dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento começaram com uma configuração vazia (padrão). Se a sua rede estiver ativa, certifique-se de entender o impacto potencial de todos os comandos.

Convenções

Consulte Convenções de dicas técnicas da Cisco para obter mais informações sobres as convenções de documentos.

Informações complementares

Este diagrama mostra um exemplo que utiliza o comando standby preempt em conjunto com o comando standby track.

6a.gif

Exemplos de Configurações

No diagrama de rede, o HSRP é configurado desta forma:

  • R1 é o roteador ativo e rastreia o estado de interface serial 0 do R1. Quando R1 é o roteador ativo, todo o tráfego dos hosts (Host 1, 2, 3) para os servidores é roteado através do R1.

  • R2 é o roteador em espera e rastreia o estado de interface serial 1 do R2.

  • Se a interface serial 0 do R1 ficar inativa, a prioridade do HSRP R1 será reduzida em 10. Nesse momento, a prioridade do HSRP R2 será superior à do R1 e o R2 assumirá a posição de roteador ativo. Quando R2 se tornar o roteador ativo, todo o tráfego dos hosts para os servidores será roteado através do R2.

Observação: O gateway padrão para os Hosts 1, 2 e 3 é configurado com o endereço IP virtual do HSRP (171.16.6.100, neste caso). Um protocolo de roteamento, por exemplo, RIP, é configurado no roteador para habilitar a conectividade entre os hosts e os servidores.

Estas são as configurações para cada roteador:

Roteador 1 (Cisco 2503)

interface Ethernet0
ip address 171.16.6.5 255.255.255.0

                     !--- Atribui um endereço IP à interface.
                  
no ip redirects
standby 1 ip 171.16.6.100

                     !--- Atribui um grupo em espera e um endereço IP em espera
                  
standby 1 priority 105

                     !--- Atribui uma prioridade (105, neste caso) à interface do roteador (e0)
!--- para um determinado número de grupo (1). O padrão é 100.
                  
standby 1 preempt

                     !--- Permite que o roteador se torne o roteador ativo quando a prioridade
!--- for maior do que a de todos os outros roteadores configurados do HSRP no grupo em espera recente.
!--- Se você não usar o comando standby preempt na configuração
!--- de um roteador, ele não irá se tornar o roteador ativo, mesmo que
!--- a prioridade seja maior do que a de todos os outros roteadores. 
                  
standby 1 track Serial0

                     !--- Indica que o HSRP rastreia a interface Serial0.
!--- A prioridade da interface também pode ser configurada, o que indica a
!--- quantidade em que a prioridade do roteador é reduzida quando
!--- a interface fica inativa. O padrão é 10.
                  
interface Serial0
ip address 171.16.2.5 255.255.255.0

Roteador 2 (Cisco 2503)

interface Ethernet0
ip address 171.16.6.6 255.255.255.0

                     !--- Atribui um endereço IP à interface.
                  
no ip redirects
standby 1 ip

                     !--- Indica o grupo em espera recente. Este é o endereço IP do roteador virtual
!--- não está configurado. Consulte a nota após essa tabela.
                  
standby 1 preempt

                     !--- Permite que o roteador se torne o roteador ativo quando a prioridade
!--- for maior do que a de todos os outros roteadores configurados do HSRP no grupo em espera recente.
!--- Se você não usar o comando standby preempt na configuração
!--- de um roteador, ele não irá se tornar o roteador ativo, mesmo que
!--- a prioridade seja maior do que a de todos os outros roteadores. 
                  
standby 1 track Serial1

                     !--- Indica que o HSRP rastreia a interface Serial1.
!--- A prioridade da interface também pode ser configurada, o que indica a
!--- quantidade em que a prioridade do roteador é reduzida quando
!--- a interface fica inativa. O padrão é 10.
!--- A prioridade também não está configurada, então o padrão é utilizado
!--- valor de prioridade de 100 é aplicado.
                  
interface Serial1
ip address 171.16.7.6 255.255.255.0

Observação: O R2 não possui um endereço IP em espera configurado. Isso é intencional para demonstrar que essa é uma configuração válida. Quando o R1 e o R2 trocam mensagens de saudação do HSRP, o R2 identifica o endereço IP em espera do R1. Para configurar o R2 com um endereço IP em espera (mesmo endereço em espera configurado no R1) também é uma configuração válida.

R1# show standby
Ethernet0 - Group 1
O estado local é Ativo, prioridade 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Endereço IP virtual é 171.16.6.100 configured
Active router is local
O roteador em espera é 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Interface do rastreamento de prioridade 1, 1 ativo:
            Interface    Decréscimo  State
Serial0         10      Ativa

R2# show standby
Ethernet0 - Group 1
O estado local é Em espera, prioridade 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Endereço IP virtual é 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Interface do rastreamento de prioridade 1, 1 ativo:
            Interface   Decréscimo  Estado
            Serial1        10      Ativa
         

Embora o R2 não tenha uma prioridade de HSRP configurada, a saída mostra a prioridade de R2 como o valor padrão de HSRP, 100. A saída de ambos os roteadores indica que os roteadores rastreiam o estado da serial 0. O estado do R1 é ativo e o estado do R2 é em espera. Por fim, ambos os roteadores são configurados com o comando standby preempt.

O que acontece se a interface serial 0 do R1 ficar inativa? A saída do comando show standby é semelhante a:

R1# show standby
Ethernet0 - Group 1
O estado local é Em espera, prioridade 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
O roteador em espera é local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Interface do rastreamento de prioridade 1, 0 ativo:
Interface    Decréscimo  Estado
Serial0         10      Inativa

R2# show standby
Ethernet0 - Group 1
O estado local é Ativo, prioridade 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
O roteador ativo é local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Interface do rastreamento de prioridade 1, 1 ativo:
Interface   Decréscimo  Estado
Serial1        10      Ativa
         

Observe na saída que a prioridade de HSRP do R1 é reduzida em 10 (para 95). Essa alteração torna a prioridade do R2 de 100 mais alta. Como o R2 foi configurado para standby preempt no momento em que a prioridade do R2 se tornou mais alta, ele se torna o roteador ativo e o R1 fica em espera. Agora, se a interface serial 0 do R1 voltar a ficar ativa, a prioridade do R1 será 105, novamente. Nesta situação, o R1 ocupa o lugar e, mais uma vez, se torna o roteador ativo de HSRP.

Observação: Se standby preempt não estiver configurado no R2, ele não terá enviado uma mensagem de vitória para o R1, o que faz com que o R2 se torne ativo. Em vez disso, o R1 teria permanecido como o roteador ativo.

Por exemplo, considere essa configuração:

standby priority 120
standby track serial 0
standby track serial 1

Uma prioridade de HSRP de 120 é configurada com o comando standby priority e o HSRP é configurado para rastrear o estado de duas interfaces, Serial0 e Serial 1. Como nenhum valor de decréscimo é especificado no comando standby track, a prioridade de HSRP é reduzida pelo valor padrão de 10 quando a interface rastreada fica inativa. Inicialmente, ambas as interfaces estão ativas e a prioridade de HSRP da interface é 120, como na saída do comando show standby:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, prioridade 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Ativa
            Serial1                       10      Ativa
R1#

Agora, a interface Serial 0 é desativada.

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

Isso reduz a prioridade de HSRP em 10—de 120 para o valor de 110. Você pode usar o comando show standby para verificar isso:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, prioridade 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Inativa  (protocolo de linha inativo)
            Serial1                       10      Ativa
R1#

Em seguida, a segunda interface rastreada—Serial 1—é desativada:

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

Isso, novamente, reduz a prioridade de HSRP em 10—de 110 para o valor de 100. Você pode usar o comando show standby para verificar isso:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, prioridade 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Inativa  (protocolo de linha inativo)
            Serial1                       10      Inativa  (protocolo de linha inativo)
R1#

Quando uma das interfaces seriais rastreadas (serial 0 ou serial 1) fica inativa, a prioridade resultante é 110. Quando ambas as interfaces seriais rastreadas (serial 0 e serial 1) ficam inativas, a prioridade resultante é 100.

Observação: Em algumas versões mais antigas do Cisco IOS, a redução da prioridade de HSRP não é cumulativa se você não definir explicitamente o valor de decréscimo no comando standby track. Consulte ID de bug CSCdp72834 (clientes registrados somente) para obter mais informações.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações relacionadas


Document ID: 13780