IP : Roteamento IP

Como Utilizar o HSRP para Fornecer Redundância em uma Rede BGP Multihomed

7 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (10 Maio 2006) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Informações Complementares
Configurar
     Diagrama de Rede
     Configurações
Verificação
     Pacotes que Retornam da Rede Local Para o Destino
     Pacotes que Retornam do Destino Para a Rede Local
Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento descreve como fornecer redundância em uma rede BGP (Protocolo de gateway limite) multihomed, na qual existem conexões com dois provedores de serviço da Internet (ISPs) separados. Em caso de falha de conectividade de um ISP, o tráfego é re-encaminhado dinamicamente por meio do outro ISP com o comando BGP set as-path {tag | prepend as-path-string} e HSRP (Hot Standby Router Protocol).

Pré-requisitos

Requisitos

Os leitores deste documento devem ter conhecimento dos seguintes tópicos:

Componentes Usados

Este documento não está restrito a versões específicas de software e de hardware.

As informações apresentadas neste documento foram criadas a partir dos dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento começaram com uma configuração esclarecida (padrão). Se a sua rede estiver ativa, certifique-se de entender o impacto potencial de todos os comandos.

Convenções

Para obter mais informações sobre convenções de documentos, consulte Convenções de Dicas Técnicas da Cisco.

Informações Complementares

O objetivo da configuração neste documento é obter a seguinte política de rede:

  • Todo o tráfego externo originado dos hosts na rede 192.168.21.0/24 e destinado à Internet deve ser roteador por meio de R1 para ISP-A. Entretanto, se houver falha no link ou no R1, todo o tráfego externo deve ser roteado por meio de R2 a ISP-B (e então para a Internet) sem intervenção manual.

  • Todo o tráfego de entrada destinado a um sistema autônomo, AS 100, a partir da Internet deve ser encaminhado por meio do R1. Caso o link de ISP-A para R1 falhe, o tráfego de entrada deve automaticamente ser re-encaminhado por meio do ISP-B para R2.

Estes requisitos podem ser atendidos com duas tecnologias: BGP e HSRP.

O primeiro objetivo de oferecer um caminho externo totalmente redundante pode ser realizado com HSRP. Em geral, os PCs não são capazes de coletar e trocar informações de roteamento. O endereço IP do gateway padrão é configurado estatisticamente em um PC e se o roteador do gateway sair do ar, o PC perde a conectividade para qualquer dispositivo além do seu segmento de rede local. Este é o caso mesmo que haja um gateway alternativo. O HSRP foi desenhado para atender a esses requisitos. Para obter mais informações, consulteRecursos e Funcionalidade do HSRP.

O segundo objetivo pode ser atingido com o comando BGP set as-path prepend, que permite que o BGP propague um caminho AS mais longo (anexando seu próprio número AS mais de uma vez) através de R2 ao link ISP-B para o prefixo 192.168.21.0/24. Desta forma, o tráfego destinado a 192.168.21.0/24 proveniente de fora do AS 100 utiliza o caminho AS mais curto por meio do ISP-A ao link R1. Se o caminho primário (ISP-A para R1) falhar, todo o tráfego será enviado pelo caminho AS mais longo (ISP-B para R2) para atingir a rede 192.168.21.0/24. Para obter mais informações sobre o comando BGP set as-path prepend, consulte o diagrama de atributos de AS_PATH no documento Estudos de Caso do BGP. Para saber mais sobre compartilhamento de carga no BGP com o comando set as-path prepend, consulteBGP ECourse – Balanceamento de Carga no BGP (Flash é exigido para visualização deste ECourse).

Configurar

Nesta seção, você encontra as informações para configurar os recursos descritos neste documento.

Observação: Para obter informações adicionais sobre os comandos utilizados neste documento, use a Ferramenta de Consulta de Comando (clientes registrados somente) .

Diagrama de Rede

Este documento usa a configuração de rede mostrada abaixo:

Neste diagrama, o roteador 1 (R1) e o roteador 2 (R2) estão no AS 100, que tem peer de BGP externo (eBGP) com ISP-A (AS 300) e ISP-B (AS 400) respectivamente. O roteador 6 (R6) é parte de AS 600, que possui correspondência eBGP com ISP-A e ISP-B. R1. R2 possui peering iBGP, necessário para atingir o roteamento ótimo. Por exemplo, ao tentar alcançar rotas internas de AS 400, R1 encaminha o tráfego para R2, em vez de usar o caminho mais longo por AS 300.

R1 e R2 também são configurados para HSRP por um segmento de Ethernet comum. Hosts no mesmo segmento de Ethernet possuem uma rota diferente que aponta para o endereço IP de standby HSRP 192.168.21.10.

hsrp_bgp-01.gif

Configurações

R1

Current configuration

hostname R1
!
interface serial 0
ip address 192.168.31.1 255.255.255.0
!
interface Ethernet1
  ip address 192.168.21.1 255.255.255.0
  standby 1 priority 105
  standby 1 preempt delay minimum 60
  standby 1 ip 192.168.21.10
  standby 1 track Serial0

                     !--- O comando
                           standby track serial rastreia o status
!--- da interface Serial0 e diminui a
!--- prioridade do grupo standby 1, se a interface cair.
!--- O comando 
                           standby preempt delay minimum 60 garante que
!--- o R1 ocupe o lugar como roteador ativo novamente. Este comando também garante que
!--- o roteador espere 60 segundos antes de fazer isto para fornecer tempo suficiente ao BGP
!--- para convergir e popular a tabela de roteamento. Isto evita que
!--- o tráfego seja enviado a R1 antes de estar pronto para ser encaminhado.
                  
!
!
router bgp 100
  no synchronization
  network 192.168.21.0
  neighbor 192.168.21.2 remote-as 100
  neighbor 192.168.21.2 next-hop-self
  neighbor 192.168.31.3 remote-as 300
  no auto-summary
!

R2

Current configuration:

hostname  R2
!
interface serial 0
ip address 192.168.42.2 255.255.255.0
!
interface Ethernet1
 ip address 192.168.21.2 255.255.255.0
 standby 1 priority 100
 standby 1 preempt
 standby 1 ip 192.168.21.10
!
!
router bgp 100
 no synchronization
 network 192.168.21.0
 neighbor 192.168.21.1 remote-as 100
 neighbor 192.168.21.1 next-hop-self
 neighbor 192.168.42.4 remote-as 400
 neighbor 192.168.42.4 route-map foo out

                     !--- Ele anexa AS 100 às atualizações BGP enviadas a AS 400
!--- para fazer um backup para o caminho ISP-A para R1.
                  
 no auto-summary
!
access-list 1 permit 192.168.21.0
route-map foo permit 10
 match ip address 1
 set as-path prepend 100

end

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Alguns show comandos são suportados pela ferramenta Output Interpreter (clientes registrados somente) , que permite que você veja uma análise da saída do comandoshow.

Quando você configura a redundância em qualquer rede, duas coisas devem ser levadas em conta:

  • A criação de um caminho redundante para pacotes que vão de uma rede local para uma rede de destino.

  • A criação de um caminho redundante para pacotes que voltam de uma rede de destino para uma rede local.

Pacotes que Retornam da Rede Local Para o Destino

Neste exemplo, a rede local é 192.168.21.0/24. Os roteadores R1 e R2 estão executando HSRP no segmento de Ethernet conectado à interface Ethernet1. O R1 está configurado como roteador ativo HSRP com uma prioridade standby de 105 e o R2 está configurado com uma prioridade standby de 100. O comando standby 1 track Serial0 (s0) no R1 permite que o processo HSRP monitore a interface. Se o estado da interface for interrompido, ele reduz a prioridade de HSRP. Quando o protocolo da linha da interface s0 fica inativo, a prioridade de HSRP é reduzida para 95 (o valor padrão pelo qual a prioridade é reduzida é 10). Isto faz com que o outro roteador HSRP, R2, tenha uma prioridade mais alta (uma prioridade de 100). O R2 se torna o roteador HSRP ativo e atrai o tráfego destinado ao endereço HSRP ativo 192.169.21.10.

Use o comando show standby para visualizar o roteador HSRP ativo quando a interface s0 em R1 estiver ativa:

R1#show standby
   Ethernet1 - Group 1
     Local state is Ativo, prioridade 105, may preempt
     Hellotime 3 sec, holdtime 10 sec
     Next hello sent in 0.338
Endereço IP virtual é configurado 192.168.21.10
     Active router is local
     Standby router is 192.168.21.2 expires in 8.280
     Virtual mac address is 0000.0c07.ac01
     13 state changes, last state change 00:46:10
     IP redundancy name is "hsrp-Et0-1"(default)
     Priority tracking 1 interface, 1 up:
     Interface                    Decrement   State
     Serial0                          10      Up

R2#show standby
   Ethernet1 - Group 1
     Status é Standby
     56 state changes, last state change 00:05:13
     Endereço IP virtual é 192.168.21.10
     Active virtual MAC address is 0000.0c07.ac01
     Local virtual MAC address is 0000.0c07.ac01 (default)
     Hello time 3 sec, hold time 10 sec
     Next hello sent in 1.964 secs
     Preemption enabled
     Active router is 192.168.21.1, priority 105 (expires in 9.148 sec)
     Standby router is local
     Prioridade 100 (default 100)
     IP redundancy name is "hsrp-Et0-1" (default)

R1#mostrar ethernet standby 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et1         1   105  P Active   local           192.168.21.2    192.168.21.10
R1#

R2#mostrar ethernet standby 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et1         1   100  P Standby  192.168.21.1    local           192.168.21.10
R2#

O comando show standby mostra o R1 como roteador HSRP ativo por causa de sua prioridade mais alta, de 105. Como R1 é o roteador ativo, ele possui o endereço de IP standby 192.168.21.10. Todo o tráfego de IP do host configurado com o gateway padrão para 192.168.21.10 é roteado por meio de R1.

Se você desativar a interface s0 no Roteador R1, o roteador HSRP ativo é alterado, pois o HSRP no R1 é configurado com comando standby track serial 0. Quando o protocolo da interface Serial 0 fica inativo, a prioridade de HSRP do R1 é reduzida em 10 (padrão) para 95. O status do R1 é alterado para "Standby". O R2 assume o papel de roteador ativo e assim passa a ter o endereço de IP standby 192.168.21.10. Assim, todo o tráfego destinado dos hosts no segmento 192.168.21.0/24 é roteado por R2. Os comandos debug e show confirmam o mesmo.

R1(config)# interface s0
R1(config-if)# shut
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active         -> Speak
 %LINK-5-CHANGED: Interface Serial0, changed state to administratively down
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby
 %LINK-3-UPDOWN: Interface Serial0, changed state to down:
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active       -> Speak
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 status Speak  -> Standby 
         

Observe que o R1 se torna o roteador standby.

Se o R2 entrar no status ativo, a saída terá esta aparência:

R2#
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 status Standby        -> Active 
         

Se você executar o comando show standby no R1 e R2, observe as prioridades de standby depois que a interface s0 ficar inativa no R1:

R1#show standby
Ethernet1 - Group 1
  Local state is Standby, prioridade 95 (confgd 105), pode tomar o lugar
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 0.808
  Virtual IP address is 192.168.21.10 configured
  Active router is 192.168.21.2, priority 100 expires in 9.008
  Standby router is local
  15 state changes, last state change 00:00:40
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 1 interface, 0 up:
    Interface               Decrement   State
    Serial0                      10     Down  (administratively down)
R1#

R2#show standby
Ethernet1 - Group 1
  Status ativo
    57 state changes, last state change 00:00:33
  Virtual IP address is 192.168.21.10
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (bia)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.648 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.21.1, priority 95 (expires in 7.096 sec)
  Prioridade 100 (default 100)
  IP redundancy name is "hsrp-Et0-1" (default)
R2#

R2#

R1#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et0         1   95   P Standby  192.168.21.2    local           192.168.21.10
R1#

R2#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et0         1   100  P Active   local           192.168.21.1    192.168.21.10
R2#

Observe que a prioridade standby de R1 foi reduzida de 105 para 95 e o R2 se tornou o roteador ativo.

Resumo

Em caso de falha de conectividade entre ISP-A e R1, o HSRP reduz a prioridade do grupo standby em R1. O R1 passa de ativo para standby. O R2 passa de um estado de standby para o estado ativo. O endereço de IP standby 192.168.21.10 se torna ativo no R2 e os hosts que enviam tráfego para a Internet utilizam o R2 e ISP-B, fornecendo um caminho alternativo para o tráfego de saída.

Para obter mais informações sobre o comando HSRP standby track , consulte Como Usar os Comandos standby preempt e standby track .

Pacotes que Retornam do Destino Para a Rede Local

De acordo com a política de rede definida na seção Material de suporte, como o ISP-A é o principal caminho e o ISP-B é o caminho de backup para o tráfego vindo em direção ao 192.168.21.0/24 (por motivos como uma conexão de largura de banda maior em direção ao ISP-A), você pode fazer com que o caminho AS através do ISP-B pareça mais longo anexando seu próprio número de AS nas atualizações BGP anunciadas em direção ao ISP-B no R2. Para fazer isso, configure um mapa de rota para o BGP vizinho 192.168.42.4 e, nesse mapa de rota, anexe seu próprio AS, usando o comando set as-path prepend . Aplique esse mapa de rotas às atualizações de saída do vizinho 192.168.42.4.

Observação: Em produção, você deve anexar o número AS mais de uma vez para garantir que a rota anunciada se torne menos preferida.

Esta é a tabela de BGP em R6 para a rede 192.168.21.0 quando a conectividade de BGP entre R1 para ISP-A e R2 para ISP-B está ativada:

R6#
               show ip bgp 192.168.21.0
BGP routing table entry for 192.168.21.0/24, version 30
Paths: (2 disponíveis, melhor #1) 
  Advertised to non peer-group peers:
    192.168.64.4
  300 100 
    192.168.63.3 from 192.168.63.3 (10.5.5.5)
      Origin IGP, localpref 100, valid, external, best, ref 2
  400 100 100
    192.168.64.4 from 192.168.64.4 (192.168.64.4)
      Origin IGP, localpref 100, valid, external

O BGP seleciona o melhor caminho como AS {300 100} por meio de ISP-A porque seu tamanho de caminho AS é menor se comparado ao caminho AS {400 100 100 } de ISP-B. O motivo de existir um caminho AS mais comprido a partir de ISP-B é devido à configuração anexada do caminho de AS em R2.

Quando a conectividade é interrompida entre o R1 e o ISP-A, o R6 deve escolher um caminho alternativo através do ISP-B para alcançar a rede 192.168.21.0/24 no AS 100:

R1(config)#interface s0
R1(config-if)#shut
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 

Esta é a tabela BGP em R6 para a rede 192.168.21.0/24:

R6#show ip bgp 192.168.21.0 
BGP routing table entry for 192.168.21.0/24, version 31
Paths: (1 disponível, melhor #1) 
  Advertised to non peer-group peers:
    192.168.63.3
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4)
      Origin IGP, localpref 100, valid, external, best

Para obter mais informações sobre configurações BGP em uma rede multihomed, consulteConfiguração Amostral para BGP com Dois Provedores de Serviço Diferentes (Multihoming).

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13768