IP : Roteamento IP

Compartilhamento de Carga com BGP em Ambientes Simples e Multihomed: Configurações Amostrais

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (23 Agosto 2005) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Compartilhamento de Carga com o Endereço Loopback em um Vizinho BGP
     Diagrama de Rede
     Configurações
     Verificação
     Solução de Problemas
Compartilhamento de Carga com Dual-Homed para um Provedor de Serviços de Internet (ISP) Através de um Único Roteador Local
     Diagrama de Rede
     Configurações
     Verificação
     Solução de Problemas
Compartilhamento de Carga com Dual-Homed para um ISP Através de Vários Roteadores Locais
     Diagrama de Rede
     Configurações
     Verificação
     Solução de Problemas
Compartilhamento de Carga com Multihomed para Dois ISPs Através de um Único Roteador Local
     Diagrama de Rede
     Configurações
     Verificação
     Solução de Problemas
Compartilhamento de Carga com Multihomed para Dois ISPs Através de Vários Roteadores Locais
     Diagrama de Rede
     Configurações
     Verificação
     Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

O compartilhamento de carga permite que um roteador distribua o tráfego de saída e de entrada entre múltiplos caminhos. Ao caminhos são derivados estatisticamente ou com protocolos dinâmicos, como:

  • Routing Information Protocol (RIP)

  • Enhanced Interior Gateway Routing Protocol (EIGRP)

  • Open Shortest Path First (OSPF) Protocol

  • Interior Gateway Routing Protocol (IGRP)

Por padrão, o Border Gateway Protocol (BGP) seleciona apenas um melhor caminho e não executa balanceamento de carga. Este documento mostra como realizar o compartilhamento de carga em cenários diferentes usando o BGP. Para obter mais informações sobre balanceamento de carga, consulte Como o Balanceamento de Carga Funciona?

Pré-requisitos

Requisitos

Verifique se estes requisitos são atendidos antes de tentar esta configuração:

Componentes Usados

Este documento não está restrito a versões específicas de software e de hardware.

As informações apresentadas neste documento foram criadas a partir dos dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento começaram com uma configuração esclarecida (padrão). Se a sua rede estiver ativa, certifique-se de entender o impacto potencial de todos os comandos.

Convenções

Consulte Convenções de Dicas Técnicas da Cisco para obter mais informações sobre as convenções de documentos.

Compartilhamento de Carga com o Endereço Loopback em um Vizinho BGP

Este cenário mostra como atingir o compartilhamento de carga quando há vários links de custo igual (até seis). Os links são desconectados em um roteador em um sistema autônomo local (AS) e em outro roteador em um AS remoto em um ambiente BGP single-homed. O Diagrama de Rede a seguir é um exemplo:

Observação: Use a Ferramenta de Consulta de Comando (clientes registrados somente) para encontrar informações adicionais sobre os comandos usados neste documento.

Diagrama de Rede

Esta seção usa esta configuração de rede:

40a.gif

Configurações

Esta seção usa estas configurações:

RoteadorA

interface loopback 0
 ip address 1.1.1.1 255.255.255.0

interface serial 0
 ip address 160.20.20.1 255.255.255.0
 no ip route-cache

interface serial 1
 ip address 150.10.10.1 255.255.255.0
 no ip route-cache

router bgp 11
neighbor 2.2.2.2 remote-as 10
neighbor 2.2.2.2 atualizar fonte loopback 0
                  
                     !--- Use o endereço IP da interface de loopback para conexões TCP.
                  
neighbor 2.2.2.2 ebgp-multihop
                  
                     !--- Você deve configurar ebgp-multihop sempre que as conexões externas de BGP (eBGP)
!--- não estiverem no mesmo endereço de rede.
                  

router eigrp 12
network 1.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary

RoteadorB

interface loopback 0
 ip address 2.2.2.2 255.255.255.0

interface serial 0
 ip address 160.20.20.2 255.255.255.0
 no ip route-cache

interface serial 1
 ip address 150.10.10.2 255.255.255.0
 no ip route-cache

router bgp 10
neighbor 1.1.1.1 remote-as 11
neighbor 1.1.1.1 atualizar fonte loopback 0
                  
                     !--- Use o endereço IP da interface de loopback para conexões TCP.
                  

neighbor 1.1.1.1 ebgp-multihop
                  
                     !--- Você deve configurar ebgp-multihop sempre que as conexões externas de BGP (eBGP)
!--- não estiverem no mesmo endereço de rede.
                  
router eigrp 12
network 2.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary

Observação: È possível utilizar rotas estáticas no lugar de um protocolo de roteamento para apresentar dois caminhos de custo igual para atingir o destino. Nesse caso, o protocolo de roteamento é EIGRP.

Verificação

Use esta seção para confirmar se a sua configuração está funcionando corretamente.

A Ferramenta de Interpretação de Saída (clientes registrados somente) (OIT) é compatível com alguns show comandos. Use a OIT para visualizar uma análise da saída de comando show.

A saída do comando show ip route mostra que ambos os caminhos para a rede 2.2.2.0 são aprendidos via EIGRP. A saída do comando traceroute indica que a carga está distribuída entre dois links em série. Neste cenário, o compartilhamento de carga ocorre por pacote. É possível utilizar o comando ip route-cache nas interfaces seriais para fazer o compartilhamento de carga por destino. Também é possível configurar compartilhamento de carga por pacote e por destino com o Cisco Express Forwarding. Para obter mais informações sobre como configurar o Cisco Express Forwarding, consulte Configurando o Cisco Express Forwarding.

RouterA# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/2297856] via 150.10.10.2, 00:00:45, Serial1
                [90/2297856] via 160.20.20.2, 00:00:45, Serial0
     160.20.0.0/24 is subnetted, 1 subnets
C       160.20.20.0 is directly connected, Serial0
     150.10.0.0/24 is subnetted, 1 subnets
C       150.10.10.0 is directly connected, Serial1

RouterA# traceroute 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 16 mseg
    150.10.10.2 8 mseg *
         

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.

Compartilhamento de Carga com Dual-Homed para um Provedor de Serviços de Internet (ISP) Através de um Único Roteador Local

Este cenário mostra como atingir o compartilhamento de carga quando houver vários links entre um AS remoto e um AS local. Os links são desconectados em um router no AS local e em vários roteadores no AS remoto em um ambiente BGP single-homed. O Diagrama de Rede a seguir é um exemplo:

Esta configuração de exemplo usa o comando maximum-paths . Por padrão, o BGP escolhe o melhor caminho entre os possíveis caminhos de custo semelhantes obtidos a partir de um AS. Entretanto, você pode alterar o número máximo de caminhos paralelos de custo igual que são permitidos. Para fazer a alteração, inclua o comando maximum-paths paths na configuração de BGP. Use um número entre 1 e 6 para o argumento de caminhos.

Diagrama de Rede

Esta seção usa esta configuração de rede:

40b.gif

Configurações

Esta seção usa estas configurações:

RoteadorA

interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial 0
 ip address 160.20.20.1 255.255.255.0
!
!
interface Serial 1
 ip address 150.10.10.1 255.255.255.0
!
!
router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 150.10.10.2 remote-as 10
network 1.0.0.0
maximum-paths 2

                     !--- Este comando especifica o número máximo de caminhos.
!--- a serem instalados na tabela de roteamento para o destino especificado.
                  
               

RoteadorB

interface Ethernet0
 ip address 2.2.2.1 255.255.255.0
!
interface Serial 0
 ip address 160.20.20.2 255.255.255.0
!
!
router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0
auto-summary

RoteadorC

interface Ethernet0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial 1
 ip address 150.10.10.2 255.255.255.0
!
!
router bgp 10
neighbor 150.10.10.1 remote-as 11
network 2.0.0.0
auto-summary

Verificação

Use esta seção para confirmar se a sua configuração está funcionando corretamente.

A Ferramenta de Interpretação de Saída (clientes registrados somente) (OIT) é compatível com alguns show comandos. Use a OIT para visualizar uma análise da saída de comando show.

A saída do comando show ip route mostra que ambos os caminhos para a rede 2.2.2.0 são aprendidos via BGP. A saída do comando traceroute indica que a carga está distribuída entre dois links em série. Neste cenário, o compartilhamento de carga ocorre por destino. O comando show ip bgp fornece as entradas válidas para a rede 2.0.0.0.

RouterA# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
B    2.0.0.0/8 [20/0] via 150.10.10.2, 00:04:23
               [20/0] via 160.20.20.2, 00:04:01
     160.20.0.0/24 is subnetted, 1 subnets
C       160.20.20.0 is directly connected, Serial0
     150.10.0.0/24 is subnetted, 1 subnets
C       150.10.10.0 is directly connected, Serial1

RouterA# traceroute 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 16 mseg
    150.10.10.2 8 mseg *

RouterA# show ip bgp

BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network 	Next Hop 	Metric 	LocPrf 	Weight Path
*> 1.0.0.0 	0.0.0.0 	        	0 	32768  i
*> 2.0.0.0 	160.20.20.2  0 			0 	10 i
*               150.10.10.2  0 			0 	10 i
         

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.

Compartilhamento de Carga com Dual-Homed para um ISP Através de Vários Roteadores Locais

Este cenário mostra como atingir o compartilhamento de carga quando há várias conexões ao mesmo ISP por vários roteadores locais. Os dois peers eBGP são finalizados em dois roteadores locais separados. O balanceamento de carga dos dois links não é possível porque o BGP escolhe um caminho melhor entre as redes, que e aprendido do eBGP e BGP interno (iBGP). O balanceamento de carga entre vários caminhos para AS 10 é a segunda melhor opção. Com este tipo de compartilhamento de carga, o tráfego para redes específicas, com base em políticas predefinidas, viaja por ambos os links. Além disso, cada link funciona como backup do outro link, em caso de falha.

Para simplificar, pressuponha a política de roteamento do BGP de AS 11 como:

  • AS 11 aceita as rotas locais de AS 10, juntamente com um padrão para o restante das rotas de Internet.

  • A política de tráfego externo é:

    • Todo o tráfego para a Internet vindo de R101 será enviado pelo link R101-R103.

    • Se o enlace R101-R103 falhar, todo o tráfego para a Internet vindo de R101 irá para R102 a AS 10.

    • De forma semelhante, todo o tráfego para a Internet vindo de R102 será enviado pelo link R102-R104.

    • Se o link R102-R104 falhar, todo o tráfego para a Internet de R102 passará pelo R101 para o AS 10.

  • A política de tráfego interno é:

    • O tráfego destinado à rede 192.168.11.0/24 da Internet deve vir do link R103-R101.

    • O tráfego destinado à rede 192.168.12.0/24 da Internet deve vir do link R104-R102.

    • Se um link para o AS 10 falhar, o outro enlace deve rotear o tráfego para todas as redes de volta ao AS 11 da Internet.

Para conseguir isto, o 192.168.11.0 é anunciado a partir de R101 para R103 com um AS_PATH mais curto que o anunciado de R102 para R104. O AS 10 encontra o melhor caminho por meio do link R103-R101. De forma semelhante, o 192.168.12.0 é anunciado com um caminho mais curto por meio do link R102-R104. O AS 10 prefere o link R104-R102 para tráfego vinculado a 192.168.12.0 em AS 11.

Para o tráfego externo, o BGP determina o melhor caminho com base nas rotas aprendidas por meio do eBGP. É preferível que estas rotas sejam aprendidas por meio do iBGP. Desta forma, o R101 aprende 10.10.34.0 do R103 por meio de eBGP e de R102 por meio de iBGP. O caminho externo tem preferência sobre o caminho interno. Desta forma, se você olhar para a tabela BGP na configuração R101, a rota para 10.10.34.0 seria via link R101-R103, com o próximo nó 10.10.13.3. No R102, a rota para 10.10.34.0 seria via o link R102-R104, com o próximo nó 10.10.24.4. Isto consegue o compartilhamento de carga para o tráfego destinado a 10.10.34.0. Um raciocínio semelhante se aplica às rotas padrão em R101 e R102. Para obter mais informações sobre os critérios de seleção de BGP, consulte Algoritmo de Seleção do Melhor Caminho BGP.

Diagrama de Rede

Esta seção usa esta configuração de rede:

40c.gif

Configurações

Esta seção usa estas configurações:

R101

hostname R101

!
interface Ethernet0/0
 ip address 192.168.11.1 255.255.255.0 secondary
 ip address 192.168.12.1 255.255.255.0
!
interface Serial8/0
 ip address 10.10.13.1 255.255.255.0
!
router bgp 11
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 network 192.168.12.0
 neighbor 10.10.13.3 remote-as 10
 neighbor 10.10.13.3 route-map R101-103-MAP out

                     !--- O caminho AS_PATH é aumentado para 192.168.12.0.
                  
 neighbor 192.168.12.2 remote-as 11
 neighbor 192.168.12.2 next-hop-self
 maximum-paths 2
 no auto-summary
!
access-list 1 permit 192.168.12.0
access-list 2 permit 192.168.11.0
route-map R101-103-MAP permit 10
 match ip address 1
 set as-path prepend 11 11 11
!
route-map R101-103-MAP permit 20
 match ip address 2

R102

hostname R102
!

interface Ethernet0/0
 ip address 192.168.11.2 255.255.255.0 secondary
 ip address 192.168.12.2 255.255.255.0
!
interface Serial8/0
 ip address 10.10.24.2 255.255.255.0
!
router bgp 11
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 network 192.168.12.0
 neighbor 10.10.24.4 remote-as 10
 neighbor 10.10.24.4 route-map R102-104-MAP out

                     !--- O caminho AS_PATH é aumentado para 192.168.11.0.
                  
 neighbor 192.168.12.1 remote-as 11
 neighbor 192.168.12.1 next-hop-self
 no auto-summary
!
access-list 1 permit 192.168.11.0
access-list 2 permit 192.168.12.0
route-map R102-104-MAP permit 10
 match ip address 1
 set as-path prepend 11 11 11
!
route-map R102-104-MAP permit 20
 match ip address 2
!

R103

hostname R103
!
interface Ethernet0/0
 ip address 10.10.34.3 255.255.255.0
!
interface Serial8/0
 ip address 10.10.13.3 255.255.255.0
!
router bgp 10
no synchronization
 bgp log-neighbor-changes
 network 10.10.34.0 mask 255.255.255.0
 neighbor 10.10.13.1 remote-as 11
 neighbor 10.10.13.1 default-originate
 neighbor 10.10.34.4 remote-as 10
 neighbor 10.10.34.4 next-hop-self
 no auto-summary
 !

R104

hostname R104
!

interface Ethernet0/0
 ip address 10.10.34.4 255.255.255.0

!
interface Serial8/0
 ip address 10.10.24.4 255.255.255.0
!
router bgp 10
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.24.2 remote-as 11
 neighbor 10.10.24.2 default-originate
 neighbor 10.10.34.3 remote-as 10
 neighbor 10.10.34.3 next-hop-self
 no auto-summary
!

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Alguns show comandos são suportados pela ferramenta Output Interpreter (clientes registrados somente) , que permite que você veja uma análise da saída do comandoshow.

Verificação Quando Ambos os Links Entre AS 11 e AS 10 Estão Ativos

Verificação do Tráfego de Saída

Observação: O sinal de maior que (>) na saída do comando show ip bgp representa o melhor caminho a utilizar para essa rede dentre os caminhos possíveis. Para obter mais informações, consulte Algoritmo de Seleção de Melhor Caminho BGP .

A tabela BGP em R101 mostra que o melhor caminho para todo o tráfego externo é via o link R101-R103. A saída do comando show ip route confirma as rotas na tabela de roteamento.

R101# show ip bgp

BGP table version is 5, local router ID is 192.168.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i0.0.0.0          192.168.12.2                  100      0 10 i
*>                  10.10.13.3                             0 10 i
            
               !--- Este é o próximo nó do R103.
            
* i10.10.34.0/24    192.168.12.2                  100      0 10 i
*>                  10.10.13.3               0             0 10 i
            
               !--- Este é o próximo nó do R103.
            
* i192.168.11.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R101# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is 10.10.13.3 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.13.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.13.3, 00:08:53
            
               !--- Este é o próximo nó do R103.
            
            B*   0.0.0.0/0 [20/0] via 10.10.13.3, 00:08:53
            
               !--- Este é o próximo nó do R103.
            
         

Seguem as tabelas de roteamento e BGP do R102. De acordo com a política, o R102 deve rotear todo o tráfego para AS 10 por meio do link R102-R104:

R102# show ip bgp

BGP table version is 7, local router ID is 192.168.12.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          10.10.24.4                             0 10 i
            
               !--- Este é o próximo nó do R104.
            
* i                 192.168.12.1                  100      0 10 i
*> 10.10.34.0/24    10.10.24.4                             0 10 i
            
               !--- Este é o próximo nó do R104.
            
* i                 192.168.12.1             0    100      0 10 i
* i192.168.11.0     192.168.12.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R102# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is 10.10.24.4 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.24.4, 00:11:21
            
               !--- Este é o próximo nó do R104.
            
            B*   0.0.0.0/0 [20/0] via 10.10.24.4, 00:11:21
            
               !--- Este é o próximo nó do R104.
            
         

Verificação do Tráfego de entrada de AS 10 para AS 11

As redes 192.168.11.0 e 192.168.12.0 pertencem ao AS 11. De acordo com a política, o AS 11 deve preferir o link R103-R101 para tráfego, destinado à rede 192.168.11.0 e o link R104-R102 para tráfego destinado à rede 192.168.12.0.

R103# show ip bgp

BGP table version is 4, local router ID is 10.10.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.34.0/24    0.0.0.0                  0         32768 i
*> 192.168.11.0     10.10.13.1               0             0 11 i
            
               !--- O próximo nó é R101.
            
*  192.168.12.0     10.10.13.1               0             0 11 11 11 11 i
*>i                 10.10.34.4               0    100      0 11 i
            
               !--- O próximo nó é R104.
            

R103# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is not set

B    192.168.12.0/24 [200/0] via 10.10.34.4, 00:04:46
            
               !--- O próximo nó é R104.
            
            B    192.168.11.0/24 [20/0] via 10.10.13.1, 00:04:46
            
               !--- O próximo nó é R101.
            
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.13.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

O melhor caminho para a rede 192.168.11.0 no R103 é via link R103-R101 e o melhor caminho para a rede 192.168.12.0 é via R104 a AS 11. Neste caso, o menor comprimento de caminho determina o melhor caminho.

De forma semelhante, no R104, a tabela de roteamento e BGP lembra isto:

R104# show ip bgp

BGP table version is 13, local router ID is 10.10.34.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.34.0/24    10.10.34.3               0    100      0 i
*>i192.168.11.0     10.10.34.3               0    100      0 11 i
*                   10.10.24.2               0             0 11 11 11 11 i
*> 192.168.12.0     10.10.24.2               0             0 11 i

R104# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is not set

B    192.168.12.0/24 [20/0] via 10.10.24.2, 00:49:06
            
               !--- O próximo nó é R102.
            
            B    192.168.11.0/24 [200/0] via 10.10.34.3, 00:07:36
            
               !--- O próximo nó é R103.
            
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Verificação em Caso de Falha do Link R101-R103

Quando há falha no link R101-R103, todo o tráfego deve ser roteado por R102. este diagrama ilustra esta alteração:

40d.gif

Desconecte o link R103-R101 no R103 para simular esta situação.

R103(config)# interface serial 8/0
R103(config-if)# shutdown

*May 1 00:52:33.379: %BGP-5-ADJCHANGE: neighbor 10.10.13.1 Down Interface flap
*May 1 00:52:35.311: %LINK-5-CHANGED: Interface Serial8/0, changed state to
 administratively down
*May 1 00:52:36.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial8/0, changed
 state to down

Verifique a rota externa para o AS 10.

R101# show ip bgp

BGP table version is 17, local router ID is 192.168.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          192.168.12.2                  100      0 10 i
            
               !--- Este é o próximo nó do R102.
            
            *>i10.10.34.0/24    192.168.12.2                  100      0 10 i
            
               !--- Este é o próximo nó do R102.
            
* i192.168.11.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R101# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is 192.168.12.2 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.34.0 [200/0] via 192.168.12.2, 00:01:34
            B*   0.0.0.0/0 [200/0] via 192.168.12.2, 00:01:34
            
               !--- Todo o tráfego de saída passa pelo R102.
            

R102# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is 10.10.24.4 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.24.4, 00:13:22
            B*   0.0.0.0/0 [20/0] via 10.10.24.4, 00:55:22
            
               !--- Todo o tráfego de saída no R102 passa pelo R104.
            
         

Verifique a rota de tráfego de entrada quando R101-R103 estiver inativo.

R103# show ip bgp

BGP table version is 6, local router ID is 10.10.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.34.0/24    0.0.0.0                  0         32768 i
            *>i192.168.11.0     10.10.34.4               0    100      0 11 11 11 11 i
*>i192.168.12.0     10.10.34.4               0    100      0 11 i

R103# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is not set

B    192.168.12.0/24 [200/0] via 10.10.34.4, 00:14:55
            
               !--- O próximo nó é R104.
            
            B    192.168.11.0/24 [200/0] via 10.10.34.4, 00:05:46
            
               !--- O próximo nó é R104.
            
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.34.0 is directly connected, Ethernet0/0

No R104, o tráfego de 192.168.12.0 e 192.168.12.0 passa pelo link R104-R102.

R104# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is not set

B    192.168.12.0/24 [20/0] via 10.10.24.2, 00:58:35
            
               !--- O próximo nó é R102.
            
            B    192.168.11.0/24 [20/0] via 10.10.24.2, 00:07:57
            
               !--- O próximo nó é R102.
            
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.

Compartilhamento de Carga com Multihomed para Dois ISPs Através de um Único Roteador Local

Neste cenário, o balanceamento de carga não é uma opção em um ambiente multihomed, então você só pode executar o compartilhamento de carga. O balanceamento de carga não é possível porque o BGP escolhe um único caminho melhor para um destino entre as rotas BGP aprendidas dos diferentes ASs. A idéia é definir uma métrica melhor para as rotas no intervalo de 1.0.0.0 a 128.0.0.0 aprendidas do ISP(A) e uma métrica melhor para o restante das rotas aprendidas do ISP(B). O Diagrama de Rede a seguir é um exemplo:

Consulte Configuração Amostral para BGP com Dois Provedores de Serviço Diferentes (Multihoming) para obter mais informações.

Diagrama de Rede

Esta seção usa esta configuração de rede:

40e.gif

Configurações

Esta seção usa estas configurações:

RoteadorA

interface Serial 0
 ip address 160.20.20.1 255.255.255.0
 no ip route-cache

interface Serial 1
 ip address 150.10.10.1 255.255.255.0
 no ip route-cache

router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 160.20.20.2 route-map UPDATES-1 in

                     !--- Isto permite que apenas as redes até 128.0.0.0.
                  
neighbor 150.10.10.2 remote-as 12
neighbor 150.10.10.2 route-map UPDATES-2 in

                     !--- Isto permite qualquer coisa acima da rede 128.0.0.0.
                  
auto-summary

route-map UPDATES-1 permit 10
match ip address 1
set weight 100

route-map UPDATES-1 permit 20
match ip address 2

route-map UPDATES-2 permit 10
match ip address 1

route-map UPDATES-2 permit 20
match ip address 2
set weight 100

access-list 1 permit 0.0.0.0  127.255.255.255
access-list 2 deny 0.0.0.0 127.255.255.255
access-list 2 permit any

RoteadorB

interface Loopback0
 ip address 2.2.2.2 255.255.255.0
int loopback 1
 ip address 170.16.6.5 255.255.255.0

interface Serial 0
 ip address 160.20.20.2 255.255.255.0
 no ip route-cache

router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0
network 170.16.0.0
auto-summary

RoteadorC

interface Loopback0
 ip address 170.16.6.6 255.255.255.0

interface Loopback1
 ip address 2.2.2.1 255.255.255.0

interface Serial 1
 ip address 150.10.10.2 255.255.255.0
 no ip route-cache

router bgp 12
neighbor 150.10.10.1 remote-as 11
network 2.0.0.0
network 170.16.0.0
auto-summary

Verificação

Use esta seção para confirmar se a sua configuração está funcionando corretamente.

A Ferramenta de Interpretação de Saída (clientes registrados somente) (OIT) é compatível com alguns show comandos. Use a OIT para visualizar uma análise da saída de comando show.

A saída do comando show ip route e a saída do comando traceroute mostram que qualquer rede inferior a 128.0.0.0 sai do RoteadorA por meio de 160.20.20.2. Esta rota é o próximo nó da interface de série 0. O restante das redes sai por 150.10.10.2, que é o próximo nó da interface de série 1.

RouterA# show ip route
            
               !--- Saída suprimida.
            
Gateway of last resort is not set
B 	170.16.0.0/16 [20/0] via 150.10.10.2, 00:43:43	
            
               !--- Este é o próximo nó para a série 1.
            
            B 	2.0.0.0/8 [20/0] via 160.20.20.2, 00:43:43
            
               !--- Este é o próximo nó para a série 0.
            
    160.20.0.0/24 is subnetted, 1 subnets
C 		160.20.20.0 is directly connected, Serial0
    150.10.0.0/24 is subnetted, 1 subnets
C 		150.10.10.0 is directly connected, Serial1

RouterA# show ip bgp

BGP table version is 3, local router ID is 160.20.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 Network Next Hop Metric LocPrf Weight Path
   Network          Next Hop            Metric LocPrf Weight Path
*  2.0.0.0          150.10.10.2              0             0 12 i
*>                  160.20.20.2              0           100 10 i
*  170.16.0.0       160.20.20.2              0             0 10 i
*>                  150.10.10.2              0           100 12 i

RouterA# traceroute  2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1   160.20.20.2 16 mseg * 16 mseg

RouterA# traceroute  170.16.6.6

Type escape sequence to abort.
Tracing the route to 170.16.6.6

1   150.10.10.2 4 mseg * 4 mseg
         

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.

Compartilhamento de Carga com Multihomed para Dois ISPs Através de Vários roteadores Locais

O balanceamento de carga não é possível em um ambiente multihomed com dois ISPs. O balanceamento de carga não é possível porque o BGP escolhe um único caminho melhor para um destino entre as rotas BGP aprendidas dos diferentes ASs. Entretanto, o compartilhamento de carga é possível nestas redes multihomed BGP. Com base em políticas predeterminadas, o fluxo de tráfego é controlado com diferentes atributos BGP.

Esta seção debate a configuração multihoming que possui uso mais freqüente. A configuração mostra como atingir o compartilhamento de carga. Consulte o Diagrama de Rede, em que o multihome de AS 100 atingir a confiabilidade e o compartilhamento de carga.

Observação: Os endereços IP deste exemplo seguem os padrões RFC 1918 leavingcisco.com de Espaço de Endereço Privado e não podem ser roteáveis na Internet.

Para simplificar, pressuponha a política de roteamento do BGP de AS 100 como:

  • O AS 10 aceita as rotas locais de ambos os provedores, juntamente com um padrão para o restante das rotas de Internet.

  • A política de tráfego externo é:

    • O tráfego destinado ao AS 300 passa pelo link R1-ISP(A).

    • O tráfego destinado ao AS 400 passa pelo link R2-ISP(B).

    • Todo o tráfego restante deve preferir a rota padrão 0.0.0.0 pelo link R1-ISP(A).

    • Em caso de falha do link R1-ISP(A), todo o tráfego deverá passar pelo link R2-ISP(B).

  • A política de tráfego interno é:

    • O tráfego destinado à rede 10.10.10.0/24 da Internet deve vir do link ISP(A)-R1 .

    • O tráfego destinado à rede 10.10.20.0/24 da Internet deve vir do link ISP(B)-R2 .

    • Se um ISP falhar, o outro deve rotear o tráfego de volta ao AS 100 da Internet para todas as redes.

Diagrama de Rede

Esta seção usa esta configuração de rede:

40f.gif

Configurações

Esta seção usa estas configurações:

R2

interface Ethernet0
 ip address 192.168.21.2 255.255.255.0
 !
interface Serial0
  ip address 192.168.42.2 255.255.255.0
router bgp 100
 no synchronization
 bgp log-neighbor-changes

                     !--- As duas linhas a seguir anunciam as redes para os peers BGP.
                  
 network 10.10.10.0 mask 255.255.255.0
 network 10.10.20.0 mask 255.255.255.0

                     !--- A próxima linha configura o iBGP no R1.
                  
  neighbor 192.168.21.1 remote-as 100
  neighbor 192.168.21.1 next-hop-self

                     !--- A próxima linha configura o eBGP no ISP(B).
                  
 neighbor 192.168.42.4 remote-as 400

                     !--- Este é o mapa de rotas de política de entrada do aplicativo
!--- de atributos a rotas específicas.
                  
 neighbor 192.168.42.4 route-map AS-400-INCOMING in

                     !--- Este é o mapa de rotas de política de saída  do aplicativo
!--- de atributos a rotas específicas.
                  
 neighbor 192.168.42.4 route-map AS-400-OUTGOING out
 no auto-summary
!
!

                     !--- Esta linha define a lista de acesso do caminho AS.
!--- A linha permite todas as rotas dentro do domínio de roteamento do provedor.
                  
ip as-path access-list 1 permit ^400$
!

                     !--- Estas duas linhas definem a lista de acesso.
                  
access-list 10 permit 10.10.10.0 0.0.0.255
access-list 20 permit 10.10.20.0 0.0.0.255

                     !--- As próximas três linhas configuram LOCAL_PREF para rotas
!--- que correspondem à lista de acesso 1 do AS.
                  
route-map AS-400-INCOMING permit 10
 match as-path 1
 set local-preference 150

                     !--- Aqui o mapa de rotas toma o lugar de AS 100 para atualizações BGP para redes
!--- permitidas pela lista de acesso 10.
                  
route-map AS-400-OUTGOING permit 10
 match ip address 10
 set as-path prepend 100

                     !--- esta linha anuncia a rede permitida pela
!--- lista de acesso 20 sem alterações nos atributos BGP.
                  
route-map AS-400-OUTGOING permit 20
 match ip address 20

R1

interface Serial0/0
 ip address 192.168.31.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.21.1 255.255.255.0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.0 mask 255.255.255.0
 network 10.10.20.0 mask 255.255.255.0

!--- Correspondência de IBGP com R2   
neighbor 192.168.21.2 remote-as 100
neighbor 192.168.21.2 next-hop-self
!

                     !--- Esta linha define o peering eBGP com ISP(A).
                  
neighbor 192.168.31.3 remote-as 300
!

                     !--- Este é o mapa de rotas de política de entrada do aplicativo
!--- de atributos a rotas específicas.
                  
 neighbor 192.168.31.3 route-map AS-300-INCOMING in
!

                     !--- Este é o mapa de rotas de política de saída  do aplicativo
!--- de atributos a rotas específicas.
                  
neighbor 192.168.31.3 route-map AS-300-OUTGOING out
 no auto-summary


                     !--- Esta linha define a lista de acesso do caminho AS.
!--- A linha permite todas as rotas dentro do domínio de roteamento do provedor.
                  
ip as-path access-list 1 permit ^300$
!

                     !--- Estas duas linhas definem a lista de acesso de IP.
                  
access-list 10 permit 10.10.20.0 0.0.0.255
access-list 20 permit 10.10.10.0 0.0.0.255


                     !--- As próximas três linhas configuram LOCAL_PREF para rotas correspondentes
!--- lista de acesso de caminhos AS 1.
                  
route-map AS-300-INCOMING permit 10
 match as-path 1
 set local-preference 200
!

                     !--- Aqui o mapa de rotas toma o lugar de AS 100 para atualizações BGP para redes
!--- permitidas pela lista de acesso 10.
                  
route-map AS-300-OUTGOING permit 10
 match ip address 10
 set as-path prepend 100
!

                     !--- Esta linha anuncia a rede permitida
!--- pela lista de acesso 20 sem alterações nos atributos BGP.
                  
route-map AS-300-OUTGOING permit 20
 match ip address 20
!

Verificação

Use esta seção para confirmar se a sua configuração está funcionando corretamente.

A Ferramenta de Interpretação de Saída (clientes registrados somente) (OIT) é compatível com alguns show comandos. Use a OIT para visualizar uma análise da saída de comando show.

Emita o comando show ip bgp para verificar se a política de entrada/saída funciona.

Observação: O sinal de maior que (>) na saída do comando show ip bgp representa o melhor caminho a utilizar para essa rede dentre os caminhos possíveis. Para obter mais informações, consulte Algoritmo de Seleção de Melhor Caminho BGP .

R1# show ip bgp

BGP table version is 6, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

BGP table version is 6, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.31.3                  200      0 300 i
            
               !--- Esta linha mostra que a rota padrão 0.0.0.0/0 é preferida
!--- via AS 300, ISP(A).
            
* i10.10.10.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 30.30.30.0/24    192.168.31.3             0    200      0 300 i
            *>i40.40.40.0/24    192.168.21.2             0    150      0 400 i
            
               !--- A rota para a rede 30.30.30.0/24 (AS 300) é preferida
!--- via o link R1-ISP(A).
!--- A rota para a rede 40.40.40.0/24 (AS 400) é preferida
!--- através do link R2-ISP(B).
            
         

Agora vejamos a saída de show ip bgp em R2:

R2# show ip bgp

BGP table version is 8, local router ID is 192.168.42.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  0.0.0.0          192.168.42.4                  150      0 400 i
*>i                 192.168.21.1                  200      0 300 i
            
               !--- Esta linha mostra que a rota padrão 0.0.0.0/0 é preferida
!--- através do AS 300, através do link R2-ISP(B).
            
*> 10.10.10.0/24    0.0.0.0                  0         32768 i
* i                 192.168.21.1             0    100      0 i
*> 10.10.20.0/24    0.0.0.0                  0         32768 i
* i                 192.168.21.1             0    100      0 i
*>i30.30.30.0/24    192.168.21.1             0    200      0 300 i
            *> 40.40.40.0/24    192.168.42.4             0    150      0 400 i
            
               !--- A rota para a rede 30.30.30.0/24 (AS 300) é preferida
!--- via o link R1-ISP(A).
!--- A rota para a rede 40.40.40.0/24 (AS 400) é preferida
!--- através do link R2-ISP(B).
            
         

Emita o comando show ip bgp no Roteador 6 para observar a política de entrada para as redes 10.10.10.0/24 e 10.10.20.0/24:

R6# show ip bgp

BGP table version is 15, local router ID is 192.168.64.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    192.168.63.3                           0 300 100 100 i
            
               !--- Esta linha mostra que a rede 10.10.10.0/24 é roteada por meio de AS 300
!--- com o link ISP(A)-R1.
            
*                   192.168.64.4                           0 400 100 100 100 i
*  10.10.20.0/24    192.168.63.3                           0 300 100 100 i
*> 10.10.10.0/24    192.168.63.3                           0 300 100 100 i
            
               !--- Esta linha mostra que a rede 10.10.20.0/24 é roteada por meio de AS 400
!--- com o link ISP(B)-R2.
            
*> 30.30.30.0/24    192.168.63.3             0             0 300 i
*> 40.40.40.0/24    192.168.64.4             0             0 400 i

Desligue o link R1-ISP(A) no R1 e observe a tabela BGP. Todo o tráfego para a Internet será roteador pelo link R2-ISP(B).

R1(config)# interface serial 0/0
R1(config-if)# shutdown

*May  2 19:00:47.377: %BGP-5-ADJCHANGE: neighbor 192.168.31.3 Down Interface flap
*May  2 19:00:48.277: %LINK-5-CHANGED: Interface Serial0/0, changed state to
 administratively  down
*May 23 12:00:51.255: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed
 state to down

R1# show ip bgp

BGP table version is 12, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          192.168.21.2                  150      0 400 i

               !--- O melhor caminho padrão agora é por meio do link R2-ISP(B).
            
* i10.10.10.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*>i40.40.40.0/24    192.168.21.2             0    150      0 400 i

R2# show ip bgp

BGP table version is 14, local router ID is 192.168.42.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.42.4                  150      0 400 i

               !--- A melhor rota padrão agora é por meio de ISP(B) com
!--- preferência local de 150.
            
* i10.10.10.0/24    192.168.21.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 40.40.40.0/24    192.168.42.4             0    150      0 400 i

Veja a rota da rede 10.10.10.0/24 no roteador 6:

R6# show ip bgp

BGP table version is 14, local router ID is 192.168.64.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    192.168.64.4                           0 400 100 100 i

               !--- A rede 10.10.10.0 está acessível via ISP(B), que anunciou
!--- a rede com o anexo do caminho AS.
            
*> 10.10.20.0/24    192.168.64.4                           0 400 100 i
*> 30.30.30.0/24    192.168.63.3             0             0 300 i
*> 40.40.40.0/24    192.168.64.4             0             0 400 i

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13762