Multiprotocol Label Switching (MPLS) : MPLS

Configurando uma VPN MPLS Básica

22 Maio 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (28 Julho 2013) | Inglês (16 Novembro 2007) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Produtos Relacionados
     Convenções
Configurar
     Diagrama de Rede
     Procedimentos de Configuração
     Configurações
Verificação
Solução de Problemas
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento fornece uma configuração amostral de uma VPN MPLS (Multiprotocol Label Switching) sobre ATM quando o BGP (Border Gateway Protocol) ou o RIP (Routing Information Protocol) estiverem presentes no site do cliente.

Quando utilizado com o MPLS, o recurso VPN permite que vários sites se interconectem de forma transparente por uma rede do provedor de serviços. Uma rede de provedor de serviços pode suportar vários VPNs de IP diferentes. Cada um deles é exibido a seus usuários como uma rede privada, separada de todas as outras redes. Dentro de uma VPN, cada site pode enviar pacotes IP a outro site na mesma VPN.

Cada VPN está associada a uma ou mais instâncias de roteamento/encaminhamento (VRFs) de VPN. Um VRF consiste em uma tabela de IP routing, uma tabela de CEF (Cisco Express Forwarding) derivada e um conjunto de interfaces que usam essa tabela de encaminhamento.

O roteador mantém um roteamento separado e uma tabela de CEF para cada VRF. Isto evita que as informações sejam enviadas para fora da VPN e permite que a mesma sub-rede seja usada em várias VPNs sem causar problemas de duplicação de endereço IP.

O roteador que utiliza o BGP de multiprotocolo (MP-BGP) distribui as informações de roteamento de VPN usando as comunidades estendidas de MP-BGP.

Consulte os URLs a seguir para obter mais informações sobre a propagação de atualizações por meio de uma VPN:

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Usados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

Roteadores P e PE

  • O recurso MPLS VPN está incluído no Software Cisco IOS® Versão 12.2(6h).

  • Qualquer roteador Cisco da série 7200 ou superior oferece suporte a funcionalidade PE. O Cisco 2691, assim como qualquer roteador da série 3640 ou superior oferece suporte a funcionalidade PE.

Roteadores C e CE

  • Você pode usar qualquer roteador que possa trocar informações de roteamento com seu roteador PE.

As informações apresentadas neste documento foram criadas a partir dos dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento começaram com uma configuração esclarecida (padrão). Caso esteja trabalhando em uma rede ativa, certifique-se de ter compreendido o possível impacto dos comandos antes de utilizá-los.

Produtos Relacionados

Para implementar o recurso MPLS, você deve ter um roteador da faixa do Cisco 2600 ou superior. Para selecionar o IOS Cisco obrigatório com o recurso MPLS, utilize o Software Advisor (clientes registrados somente) . Verifique também a memória Flash e RAM adicional exigida para executar o recurso MPLS nos roteadores. Podem ser utilizadas interfaces WIC-1T, WIC-2T e seriais.

Convenções

Para obter mais informações sobre convenções em documentos, consulte Convenções de Dicas Técnicas da Cisco.

As letras abaixo representam os tipos diferentes de roteadores e switches usados.

  • P - Roteador central do provedor.

  • PE - Roteador de ponta do provedor.

  • CE - Roteador de ponta do cliente.

  • C - Roteador do cliente.

Este diagrama mostra uma configuração típica ilustrando as convenções mencionadas anteriormente.

mplsvpn.gif

Configurar

Nesta seção, você encontra as informações para configurar os recursos descritos neste documento.

Observação: Para obter informações adicionais sobre os comandos utilizados neste documento, use a Ferramenta de Consulta de Comando (clientes registrados somente) .

Diagrama de Rede

Este documento utiliza a configuração de rede apresentada no diagrama abaixo.

new_mpls_vpn_basic1.gif

Procedimentos de Configuração

Para obter mais informações, consulte Redes Privadas Virtuais MPLS.

Habilitando ip cef

Use o seguinte procedimento para habilitar o ip cef. Para um desempenho melhorado, utilize ip cef distributed (onde disponível). Complete as etapas a seguir no PEs após a configuração do MPLS (configuração de tag-switching ip nas interfaces).

  1. Crie um VRF para cada VPN conectada utilizando o comandoip vrf <VPN routing/forwarding instance name> .

    Quando fizer isso:

    • Especifique o distinguidor de rota correto para a VPN. Isto é utilizado para estender o endereço IP para que seja possível identificar a que VPN ele pertence.

                              rd <VPN route distinguisher>
                              
                           
    • Defina as propriedades de importação e exportação das comunidades estendidas MP-BGP. Elas são utilizadas para filtrar o processo de importação e exportação.

                              route-target [export|import|both] <target VPN extended community>
                              
                           
  2. Configure os detalhes de encaminhamento das respectivas interfaces utilizando o comando ip vrf forwarding <VPN routing/forwarding instance name> e lembre-se de definir o endereço IP após fazer isto.

  3. Dependendo do protocolo de roteamento PE-CE sendo usado, é possível configurar rotas estáticas ou protocolos de roteamento (RIP, OSPF ou BGP) entre PE e CE. As configurações detalhadas estão disponíveis no MPLS, na Página de Suporte ATM.

Configurando o MP-BGP

Configure o MP-BGP entre os roteadores PE. Há várias formas de configurar o BGP, como utilizar o refletor de rota ou métodos de confederação. O método utilizado aqui, configuração de vizinho direto, é o mais simples e menos escalável.

  1. Declare os diferentes vizinhos.

  2. Insira o comando address-family ipv4 vrf <VPN routing/forwarding instance name> para cada VPN presente neste roteador PE.

    Execute uma ou mais das etapas a seguir, se necessário:

    • Redistribua as informações de OSPF, RIP e roteamento estático.

    • Redistribua as informações de roteamento conectado.

    • Ative a vizinhança BGP com os roteadores CE.

  3. Entre no modo address-family vpnv4 e execute as tarefas a seguir:

    • Ative os vizinhos.

    • Especifique que comunidade estendida deve ser usada. Isto é obrigatório.

Configurações

Este documento usa a configuração mostrada abaixo.

Pescara

Current configuration:
!
version 12.2
!
hostname Pescara
!
ip cef
!


                     
!--- Comandos Cliente A.
                  
ip vrf Customer_A

                     !--- Habilita o roteamento de VPN e o encaminhamento da tabela de roteamento (VRF).
!--- Este comando pode ser utilizado no modo global ou
!--- no modo de configuração do roteador. 
                  
 rd 100:110

                     !--- O distinguidor de rota cria tabelas de roteamento e encaminhamento
!--- para um VRF.
                  
 route-target export 100:1000

                     !--- Cria listas de comunidades de importação e exportação de rota-alvo estendidos
!--- para o VRF especificado.
                  
 route-target import 100:1000
!


                     !--- Comandos Cliente B.
                  
ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
 ip router isis


                     !--- Comandos Cliente A.
                  
interface Loopback101
ip vrf forwarding Customer_A

                     !--- Associa uma ocorrência VRF a uma interface ou sub-interface.
                  
 ip address 200.0.4.1 255.255.255.0

                     !--- Loopback101 e  102 utilizam o mesmo endereço IP, 200.0.4.1.
!--- Isto é permitido porque eles pertencem a dois
!--- VRFs de clientes diferentes. 
                  
 no ip directed-broadcast
!


                     !--- Comandos Cliente B.
                  
interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.4.1 255.255.255.0

                     !--- Loopback101 e  102 utilizam o mesmo endereço IP, 200.0.4.1.
!--- Isto é permitido porque eles pertencem a dois
!--- VRFs de clientes diferentes.
                  
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no fair-queue
!
interface Serial2/0.1 point-to-point
 description link to Pauillac
 bandwidth 512
 ip address 10.1.1.14 255.255.255.252
 no ip directed-broadcast
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 401
!
router isis
 net 49.0001.0000.0000.0004.00
 is-type level-1
!
router bgp 100
 bgp log-neighbor-changes

                     !--- Permitir conexão de redefinições de vizinho BGP.
                  
 neighbor 10.10.10.6 remote-as 100

                     !--- Adiciona uma entrada à tabela de vizinho BGP ou BGP multiprotocolo.
                  
 neighbor 10.10.10.6 update-source Loopback0

                     !--- Habilita as sessões BGP a utilizarem uma interface operacional específica
!--- para conexões TCP.
                  
!


                     !--- Comandos Cliente A e B.
                  
 address-family vpnv4

                     !--- Para inserir o modo de configuração da família de endereços
!--- para configuração de sessões de roteamento, como BGP,
!--- que utiliza 4 prefixos de endereço de versão de VPN padrão.
                  
 neighbor 10.10.10.6 activate
 neighbor 10.10.10.6 send-community both
 
                     !--- Envia o atributo de comunidade a um vizinho BGP.
                  
 exit-address-family
 !


                     !--- Comandos Cliente B.
                  
 address-family ipv4 vrf Customer_B

                     !--- Para inserir o modo de configuração da família de endereços
!--- para configuração de sessões de roteamento, como BGP,
!--- que utiliza 4 prefixos de endereço de versão de VPN padrão.
                  
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


                     !--- Comandos Cliente A.
                  
 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
!
ip classless
!
end

Pesaro

Current configuration:
!
version 12.1
!
hostname Pesaro
!


                     !--- Comandos Cliente A.
                  
ip vrf Customer_A
 rd 100:110
 route-target export 100:1000
 route-target import 100:1000
!


                     !--- Comandos Cliente B.
                  
ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
ip cef

!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
 ip router isis


                     !--- Comandos Cliente A.
                  
interface Loopback101
 ip vrf forwarding Customer_A
 ip address 200.0.6.1 255.255.255.0
!


                     !--- Comandos Cliente B.
                  
interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.6.1 255.255.255.0
!


                     !--- Comandos Cliente A.
                  
interface Loopback111
 ip vrf forwarding Customer_A
 ip address 200.1.6.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 random-detect
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwidth 512
 ip address 10.1.1.22 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 603
!
router isis
 net 49.0001.0000.0000.0006.00
 is-type level-1
!
router bgp 100
 neighbor 10.10.10.4 remote-as 100
 neighbor 10.10.10.4 update-source Loopback0
 !


                     !--- Comandos Cliente B.
                  
 address-family ipv4 vrf Customer_B
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


                     !--- Comandos Cliente A.
                  
 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


                     !--- Comandos Cliente A e B.
                  
 address-family vpnv4
 neighbor 10.10.10.4 activate
 neighbor 10.10.10.4 send-community both
 exit-address-family
!
ip classless
!
end

Pomerol

Current configuration:
!
version 12.0
!
hostname Pomerol
!
ip cef

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis

!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.6 255.255.255.252
 no ip directed-broadcast
 ip router isis
 tag-switching mtu 1520
 tag-switching ip
 frame-relay interface-dlci 301
!
interface Serial0/1.2 point-to-point
 description link to Pulligny
 ip address 10.1.1.9 255.255.255.252
 no ip directed-broadcast
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 303
!
interface Serial0/1.3 point-to-point
 description link to Pesaro
 ip address 10.1.1.21 255.255.255.252
 no ip directed-broadcast
 ip router isis
 tag-switching ip

 frame-relay interface-dlci 306
!
router isis
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny

Current configuration:
!
version 12.1
!
hostname Pulligny
!
!
ip cef

!
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.2 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 201
!
interface Serial0/1.2 point-to-point
 description link to Pomerol
 ip address 10.1.1.10 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 203
!
router isis
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1
!
ip classless
!
end

Pauillac

!
version 12.1
!
hostname pauillac
!
ip cef

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 tag-switching ip
 no fair-queue
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwith 512
 ip address 10.1.1.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 102
!
interface Serial0/0.2 point-to-point
 description link to Pulligny ip address 10.1.1.5 255.255.255.252

 ip router isis
 tag-switching ip
 frame-relay interface-dlci 103
!
interface Serial0/0.3 point-to-point
 description link to Pescara
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 104
!
router isis
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Alguns show comandos são suportados pela ferramenta Output Interpreter (clientes registrados somente) , que permite que você veja uma análise da saída do comandoshow.

  • show ip vrf - Verifica se o VRF correto existe.

  • show ip vrf interfaces - Verifica as interfaces ativadas.

  • show ip route vrf Customer_A - Verifica as informações de roteamento nos roteadores PE.

  • traceroute vrf Customer_A 200.0.6.1 - Verifica as informações de roteamento nos roteadores PE.

  • show ip bgp vpnv4 tag - Verifica o BGP.

  • show ip cef vrf Customer_A 200.0.6.1 detail - Verifica as informações de roteamento nos roteadores PE.

Mais comandos estão detalhados no Guia de Solução de Problemas do MPLS VPN.

Segue um resultado de comando amostral show ip vrf .

Pescara#show ip vrf 
  Name                             Default RD          Interfaces
  Customer_A                       100:110             Loopback101
  Customer_B                       100:120             Loopback102

Segue um resultado de comando amostral show ip vrf interfaces.

Pesaro#show ip vrf interfaces
Interface              IP-Address      VRF                              Protocol
Loopback101            200.0.6.1       Customer_A                       up
Loopback111            200.1.6.1       Customer_A                       up
Loopback102            200.0.6.1       Customer_B                       up      

Os comandos show ip route vrf a seguir mostram o mesmo prefixo 200.0.6.0/24 em ambas as saídas. Isto ocorre porque o PE remoto possui a mesma rede para dois clientes, Cliente_A e Cliente_B, permitido em uma solução MPLS VPN comum.

Pescara#show ip route vrf Customer_A
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR

Gateway of last resort is not set

C    200.0.4.0/24 is directly connected, Loopback101
B    200.0.6.0/24 [200/0] via 10.10.10.6, 05:10:11
B    200.1.6.0/24 [200/0] via 10.10.10.6, 04:48:11

Pescara#show ip route vrf Customer_B
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
	   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
	   * - candidate default, U - per-user static route, o - ODR
	   P - periodic downloaded static route

Gateway of last resort is not set
C 200.0.4.0/24 is directly connected, Loopback102

B 200.0.6.0/24 [200/0] via 10.10.10.6, 00:03:24

Executando um traceroute entre dois sites do Cliente_A, é possível ver a pilha de rótulos usada pela rede MPLS (se estiver configurada para fazer isto por mpls ip ttl ...).

Pescara#traceroute vrf Customer_A 200.0.6.1

Type escape sequence to abort.
Tracing the route to 200.0.6.1

  1 10.1.1.13 [MPLS: Rótulos 20/26 Exp 0] 400 msec 276 msec 264 msec
  2 10.1.1.6 [MPLS: Rótulos 18/26 Exp 0] 224 msec 460 msec 344 msec
  3 200.0.6.1 108 msec *  100 msec

Observação:  Exp 0 é um campo experimental usado por Quality of Service (QoS).

Solução de Problemas

No momento, não há informações de solução de problemas específicas para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13733