Voz : Qualidade de voz

VoIP sobre Frame Relay com Quality of Service (Fragmentação, Formatação de Tráfego, Prioridade LLQ /IP RTP)

2 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (2 Fevereiro 2006) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes usados
     Convenções
Diretrizes de Desenho de QoS para VoIP sobre Frame Relay
     Prioridade Estrita para Tráfego de Voz (LLQ ou Prioridade de RTP IP)
     FRTS para Voz
     Fragmentação (FRF.12)
     Redução de Largura de Banda
Configurar
     LLQ
     Prioridade IP RTP
     Traffic Shaping para Voz
     Fragmentação (FRF.12)
     Diagrama de rede
     Configurações
Verificação e Solução de Problemas
     Comandos de Prioridade LLQ / IP RTP
     Comandos de Fragmentação
     Comandos de Interface / Frame Relay
     Problemas Conhecidos
     Exibição de Amostra e Saída de Comando de Depuração
Discussões relacionadas da comunidade de suporte da Cisco
Informações relacionadas

Introdução

Este documento fornece um exemplo de configuração para Voz sobre IP em uma rede de Frame Relay com Quality of Service (QoS). Este documento inclui informações técnicas de background sobre os recursos configurados, diretrizes de desenho e estratégias de solução de problemas e verificação básica.

É importante observar que a configuração deste documento possui dois roteadores de voz conectados à rede de Frame Relay. Em muitas topologias, no entanto, os roteadores ativados por voz podem existir em todos os locais. Geralmente, os roteadores de voz usam a conectividade LAN para outros roteadores que estejam conectados à WAN. Isso é importante porque, se os roteadores de voz não estiverem diretamente conectados à rede Frame Relay, todos os comandos de configuração da WAN devem ser configurados em tais roteadores conectados à WAN e não nos roteadores de voz, conforme demonstrado nas configurações deste documento.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes usados

As informações neste documento são baseadas nestas versões de hardware e software:

  • Roteador Cisco 3640 com Cisco IOS® Software Release 12.2.6a (Enterprise Plus)

  • Cisco 2621 Router com Cisco IOS® Software Release 12.2.6a (Enterprise Plus)

  • LLQ (enfileiramento de baixa latência) nos PVCs (circuitos virtuais permanentes do Frame Relay). Esse recurso foi apresentado no Cisco IOS Software Release 12.1.(2)T.

  • A Prioridade de Protocolo de Transporte em Tempo Real de IP Frame Relay, introduzida no Cisco IOS Software Release 12.0(7)T.

  • Fragmentação de Frame Relay Forum (FRF).12, apresentada no Cisco IOS Software Release 12.0(4)T.

  • As Cisco IOS Software Releases posteriores a 12.0.5T possuem aprimoramentos significativos de desempenho para RTP compactado (cRTP).

As informações apresentadas neste documento foram criadas a partir dos dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento começaram com uma configuração vazia (padrão). Se a sua rede estiver ativa, certifique-se de entender o impacto potencial de todos os comandos.

Convenções

Para obter mais informações sobre convenções de documentos, consulte Convenções de dicas técnicas da Cisco.

Diretrizes de Desenho de QoS para VoIP sobre Frame Relay

Há dois requisitos básicos para uma boa qualidade de voz:

Para garantir os requisitos mencionados, utilize estas orientações:

Prioridade Estrita para Tráfego de Voz (LLQ ou Prioridade de RTP IP)

Há dois métodos principais para fornecimento de prioridade estrita a tráfego de voz:

  • Funcionalidade IP RTP Priority (também chamada de Fila de Prioridade/Weighted Fair Queuing (PQ/WFQ))

  • LLQ (também chamado de PQ / Class Based Weighted Fair Queuing (PQ/CBWFQ))

Prioridade IP RTP

A prioridade IP RTP de Frame Relay cria uma fila de prioridade estrita em um PVC Frame Relay para um conjunto de fluxos de pacotes RTP pertencentes a um intervalo de portas de destino de protocolo de datagrama de usuários (UDP). Apesar de portas reais utilizadas serem negociadas dinamicamente entre os dispositivos de ponta ou gateways, todos os produtos Cisco VoIP utilizam a mesma faixa de porta de UDP (16384 a 32767). Quando o roteador reconhece o tráfego de VoIP, ele o coloca no PQ exato. Quando o PQ fica vazio, as outras filas são processadas com base no WFQ padrão. A prioridade IP RTP não fica ativa até haver congestionamento na interface. Esta imagem ilustra a operação da prioridade IP RTP:

pq-wfq.gif

Observação: A Prioridade RTP IP permite interromper o PQ quando houver largura de banda disponível na fila padrão (WFQ). Entretanto, ela policia estritamente o conteúdo do PQ quando houver congestionamento na interface.

LLQ

O LLQ é um recurso que fornece uma PQ estrita ao CBWFQ. O LLQ permite uma PQ dentro de CBWFQ no nível da classe. Com LLQ, dados sensíveis a retardo (na PQ) são tirados da fila e enviados primeiro. Em VoIP com implementação LLQ, o tráfego de voz é colocado na PQ padrão.

A PQ é policiada para garantir que filas justas não fiquem sem largura de banda. Ao configurar o PQ, especifique a quantidade máxima, em Kbps, de largura de banda disponível para o PQ. Quando a interface fica congestionada, a PQ recebe atenção até a carga atingir o valor configurado em Kbps na instrução de prioridade. O tráfego em excesso é eliminado para evitar o problema com o recurso de grupos de prioridade em produtos Cisco anteriores em que as PQs de nível inferior ficam sem atividade.

Observação: Com LLQ para Frame Relay, as filas são configuradas por PVC. Cada PVC possui uma PQ e um número atribuído de filas justas.

llq.gif

Este método é mais complexo e flexível que Prioridade IP RTP. A escolha entre eles deve ser baseada nos padrões de tráfego na rede real e nas necessidades verdadeiras.

LLQ x Prioridade IP RTP

Esta tabela resume as principais diferenças entre LLQ e Prioridade IP RTP e fornece diretrizes de quando utilizar cada método.

LLQ

Prioridade IP RTP

Correspondência de tráfego de voz com base em:

  • Listas de acesso. Por exemplo, intervalo de portas UDP, endereços de hosts, campos ToS (Tipo de Serviço) do cabeçalho IP (por exemplo, Precedência IP, DSCP [Ponto de Código de Serviços Diferenciados]).

  • intervalo de portas IP RTP.

  • Campos IP ToS —DSCP e/ou Precedência de IP.

  • Protocolos e Interfaces de Entrada.

  • Todos os critérios de correspondência válidos utilizados no CBWFQ.

Vantagens:

  • Mais flexibilidade no modo como o tráfego é correspondido e direcionado para o PQ estrito e para o CBWFQ.

  • É capaz de configurar classes adicionais para garantir a largura de banda para outro tráfego, como sinalização de VoIP e vídeo.

Desvantagens: Configuração complexa.

Correspondência de tráfego de voz com base em:

  • Baseado no intervalo de porta RTP/UDP: 16384-32767

Vantagens: Configuração simples.

Desvantagens:

  • Tráfego (sinalização de VoIP) de protocolo RTCP atendido na fila WFQ.

    Observação: O protocolo RTP usa RTCP para controlar a entrega de pacotes RTP. Enquanto as portas RTP utilizam números pares, as portas RTCP utilizam números ímpares no intervalo de 16384 a 32767. A prioridade IP RTP coloca portas RTP no PQ, enquanto as portas RTCP são tratadas no WFQ padrão.

  • Lida com o tráfego de VoIP no PQ. Entretanto, o tráfego restante que necessita de tratamento preferencial e garantia de largura de banda é tratado pelo WFQ. Apesar de WFQ diferenciar fluxos com pesos (com base na Precedência de IP), ele não garante largura de banda para nenhum fluxo.

Diretrizes:

  • A escolha entre eles deve ser baseada nos padrões de tráfego na rede real e nas necessidades verdadeiras.

  • Se você precisar fornecer prioridades estritas ao tráfego de voz e o tráfego restante puder ser tratado como tipo simples (dados), a Prioridade IP RTP funciona bem para a sua rede com uma configuração simples.

  • Se você planeja priorizar o tráfego de voz baseado em outros critérios que não sejam portas UDP. Por exemplo, Differentiated Services (DiffServ) Per Hop Behavior (PHB) e LLQ.

FRTS para Voz

O FRTS fornece parâmetros úteis para o gerenciamento da congestão do tráfico de rede nas redes do frame relay. O FRTS elimina gargalos nas redes de Frame Relay com conexões de alta velocidade ao site central e conexões de baixa velocidade aos sites de ramificação. Você pode configurar os valores de reforço de taxas para limitar a taxa na qual os dados são enviados do circuito virtual (VC) ao site central.

Essas definições são relacionadas ao FRTS:

  • Taxa de Informações Comprometidas (CIR)—Taxa (bits por segundo) garantida pelo provedor de Frame Relay para transferência de dados. Os valores de CIR são configurados pelo provedor de serviços Frame Relay e configurados pelo usuário no roteador.

    Observação: A taxa de acesso da porta/interface pode ser maior que a CIR. A taxa é ponderada por um período de Intervalo de Medida de taxa Comprometida (Tc).

  • Intermitência comprometida (Bc)—O número máximo de bits a rede de Frame Relay compromete para transferir por um Tc (Intervalo de Medida da Taxa Comprometida). Tc = Bc / CIR.

  • Intermitência Excedente (Be)—O número máximo de bits não comprometidos que o switch de Frame Relay tenta transferir além do CIR durante o Tc (Intervalo de Medida da Taxa Comprometida).

  • Intervalo de Medida de Taxa Comprometida (Tc)—Intervalo em que os bits de Bc ou (Bc + Be) são transmitidos. Tc é calculado como Tc = Bc / CIR. O valor de Tc não é diretamente configurado nos roteadores Cisco. É calculado após os valores de Bc e CIR serem calculados. Tc não pode exceder 125 ms.

  • Notificação de Congestionamento Explícito Inverso (BECN) — Um bit no cabeçalho da estrutura do Frame Relay, que indica o congestionamento na rede. Quando um switch de Frame Relay reconhece um congestionamento, ele configura o bit BECN em quadros destinados ao roteador de origem e instrui o roteador a reduzir a taxa de transmissão.

A configuração do FRTS para o tráfego de voz é diferente do Traffic Shaping apenas para dados. Ao configurar o FRTS para qualidade de voz, os parâmetros de tráfego de dados são comprometidos. Para obter mais informações sobre estas restrições, consulte a seção Fragmentação (FRF.12) neste documento.

Fragmentação (FRF.12)

Um grande desafio na integração de dados de voz é controlar o retardo máximo de unidirecional de ponta a ponta para tráfego sensível ao tempo, como voz. Para uma boa qualidade de voz, este retardo deve ser inferior a 150 ms. Uma parte importante deste retardo é o retarde de serialização na interface. A Cisco recomenda que ele seja 10 e não exceda 20 ms. O retardo de serialização é o tempo que se leva para colocar os bits em uma interface.

Serialization Delay = frame size (bits) / link bandwidth (bps)

Por exemplo, um pacote de 1500-bytes leva 214 ms para sair do roteador em um link de 56 Kbps. Se um pacote de dados de 1500 bytes que não seja em tempo real for enviado, os pacotes de dados em tempo real (voz) são colocados em fila até a transmissão do pacote de dados maior. Este retardo é inaceitável para tráfego de voz. Se pacotes de dados em tempo não real são fragmentados em estruturas menores, eles são intercalados com quadros em tempo real (voz). Desta forma, os quadros de dados e voz podem ser conduzidos juntos em links de baixa velocidade sem causar retardo excessivo ao tráfego de voz em tempo real.

lfi.gif

Para obter mais informações sobre fragmentação, consulte Fragmentação de Frame Relay para Voz.

Observação: Nos casos em que há uma conexão semi-T1 dedicada (768 kbps), provavelmente não é necessário um recurso de fragmentação. Entretanto, você ainda precisa de um mecanismo de QoS (Prioridade IP RTP ou LLQ, neste caso). A semi-T1 ou velocidades maiores oferecem largura de banda suficiente para permitir que pacotes de voz entrem e saiam da fila dentro da faixa de retardo de serialização recomendada (10 ms, não mais que 20 ms). Além disso, talvez não seja necessário usar o cRTP, que ajuda a economizar largura de banda por meio da compactação de cabeçalhos RTP IP, no caso de T1 completo.

Redução de Largura de Banda

cRTP

Com base no RFC 2508 leavingcisco.com, o recurso cRTP compacta o cabeçalho do pacote IP/UDP/RTP de 40 bytes para 2 ou 4 bytes. Isto reduz o consumo desnecessário de largura de banda. Estamos falando em um esquema de compactação de nó a nó. Portanto, o cRTP deve ser configurado nas duas extremidades do link, a menos que a opção passiva esteja configurada.

Observação: O cRTP não é necessário para garantir uma boa qualidade de voz. Ele é um recurso que reduz o consumo de largura de banda. Configure o cRTP após atender a todas as outras condições e a qualidade de voz estar boa. Esse procedimento economiza tempo na solução de problemas, isolando os problemas potenciais de cRTP.

Monitorar a utilização da CPU do roteador. Desabilite o cRTP se estiver acima de 75 por cento. Em taxas de link mais altas, a economia de largura de banda do cRTP pode ter menos importância que a carga adicional de CPU. A Cisco recomenda o uso de cRTP somente com link menores que 768 Kbps, a menos que o roteador esteja executando em baixa taxa de utilização da CPU.

Observação: Na ausência de um padrão, cRTP para Frame Relay foi desenvolvido no encapsulamento patenteado da Cisco. Portanto, ele não funciona com encapsulamento de Internet Engineering Task Force (IETF) de Frame Relay. Recentemente, a FRF.20 for finalizada para possibilitar a compactação de cabeçalhos RTP em encapsulamento IETF. Contudo, na última atualização deste documento (maio de 2002), o FRF.20 não é suportado.

Consulte Protocolo de Transporte Compactado em Tempo Real para obter mais informações.

Seleção de Codificador/Decodificador (Codec)

Use codecs de baixa taxa de bits nos segmentos das chamadas VoIP. G.729 (8 Kbps) é o codec padrão para o peer de discagem de VoIP.

Observação: Embora DTMF (Dual Tone Multifrequency) seja normalmente transportada com precisão ao usar codecs de voz de altas taxas de bits (como G.711), codecs de taxas baixas (como G.729 e G.723.1) são altamente otimizados para padrões de voz e tendem a distorcer tons DTMF. Esta abordagem pode resultar em problemas no acesso a sistemas interativos de resposta de voz (IVR). O comando dtmf relay resolve o problema de distorção DTMF. Ele transporta tons de DMTF para "fora da banda" ou separados do fluxo de voz codificado. Se você utilizar codecs de taxa baixa de bits (G.729, G.723) acione o comando dtmf relay sob o peer de discagem de VoIP.

Habilitar Detecção de Atividade de Voz (VAD)

Uma conversa comum pode conter de 35 a 50 por cento de silêncio. Os pacotes de silêncio são suprimidos com o uso de VAD. Para o planejamento de largura de banda para VoIP, pressuponha que o VAD reduz a largura de banda em 35 por cento. O VAD está configurado por padrão sob os peers de discagem de VoIP.

Configurar

Nesta seção, você encontra as informações para configurar os recursos descritos neste documento.

Observação: Para obter informações adicionais sobre os comandos utilizados neste documento, use a Ferramenta de Consulta de Comandos (clientes registrados somente) .

LLQ

Use este procedimento para configurar LLQ:

  1. Crie um mapa de classe para tráfego VoIP e defina critérios de correspondência.

    Estes comandos explicam como concluir esta tarefa:

    maui-voip-sj(config)#class-map ?
           WORD 		class-map name
           match-all 	Logical-AND all matching statements under this classmap
           match-any 	Logical-OR all matching statements under this classmap
    maui-voip-sj(config)#class-map match-all voice-traffic
    
                         !--- Escolha um nome descritivo de classe. 
                      
    
    maui-voip-sj(config-cmap)#match ?
      access-group         Access group
      any                  Any packets
      class-map            Class map
      cos                  IEEE 802.1Q/ISL class of service/user priority values
      destination-address  Destination address
      input-interface      Select an input interface to match
      ip                   IP specific values
      mpls                 Multi Protocol Label Switching specific values
      not                  Negate this match result
      protocol             Protocol
      qos-group            Qos-group
      source-address       Source address
    
                         !--- neste exemplo, a opção de correspondência de grupo de acesso
    !--- é utilizada, devido à sua flexibilidade (utiliza uma lista de acesso).
                      
    
    maui-voip-sj(config-cmap)#match access-group ?
      <1-2699>  Access list index
      name      Named Access List
    maui-voip-sj(config-cmap)#match access-group 102
    
                      
                         !---  Crie a lista de acesso para corresponder ao mapa de classes do grupo de acesso:
                      
    
    maui-voip-sj(config)#access-list 102 permit udp any any range 16384 32767
                      
                         !--- A forma mais fácil e segura de correspondência com portas UDP de 16384 a 32767.
    !--- Este é o intervalo de portas que os produtos Cisco IOS H.323 utilizam para transmitir
    !--- pacotes VoIP.
                      
                   

    Estas listas de acesso também são usadas para correspondência de tráfego de voz com o comando match access-group:

                      access-list 102 permit udp any any precedence critical
                      
                         !--- Esta lista filtra o tráfego com base no TOS de pacote IP: Campo de precedência.
    !--- Observação: Certifique-se de que o restante do tráfego que não seja de voz não utilize o
    !--- mesmo valor de precedência.
                      
    
                      access-list 102 permit udp any any dscp ef
                      
                         !--- Para que a lista funcione, certifique-se de que os pacotes VoIP estão marcados
    !--- com o código dscp ef antes de saírem na interface WAN LLQ.
    !--- Para obter mais informações sobre DSCP, consulte
    !--- Implementando políticas de Quality of Service com o DSCP.
    !--- Observação: Se os pontos finais não forem confiáveis no que diz respeito à marcação de pacotes,
    !--- marque o tráfego de entrada aplicando uma política de serviço de entrada em uma
    !--- interface de entrada. Este procedimento está fora do escopo.
    !--- deste documento. 
                      
    
                      access-list 102 permit udp host 192.10.1.1 host 192.20.1.1
                      
                         !---  esta lista de acesso pode ser utilizada em casos em que os
    !--- dispositivos de voz não aceitam precedência ou marcação DSCP e você
    !--- não pode determinar o intervalo de portas UDP VoIP.   
                      
                   

    Estes são os outros métodos de correspondência que podem ser utilizados em vez dos comandos de grupo de acesso:

    • A funcionalidade IP RTP Priority passou a ser implementada para LLQ a partir do Cisco IOS Software Release 12.1.2.T e posterior. Este recurso atende o conteúdo de classe de prioridade que vê as portas UDP configuradas. Isto está sujeito a limitação de serviço de apenas portas pares no PQ.

                              class-map voice
                              match ip rtp 16384 16383
                           
    • Estes dois métodos funcionam sob a premissa de que os pacotes VoIP são marcados nos hosts de origem ou combinados e marcados no roteador antes da operação de LLQ de saída ser aplicada:

                              class-map voice
                              match ip precedence 5
                           

      OU

                              class-map voice
                              match ip dscp ef
                           

      Observação: No Cisco IOS Software Release 12.2.2T e posterior, os peers de discagem VoIP podem marcar portador de voz e pacotes de sinalização antes da operação de LLQ. Isto permite uma maneira escalável de marcar e corresponder pacotes VoIP por meio de valores de código DHCP para LLQ. Para obter mais informações, consulte Classificando Sinalização VoIP e Mídia com DSCP para QoS.

      Router(config-dial-peer)#ip qos dscp ?
                           
  2. Crie um mapa de classes para sinalização VoIP e defina critérios de correspondência (opcional).

    Utilize estes comandos para concluir esta tarefa:

                      class-map voice-signaling
                      match access-group 103
    !
    access-list 103 permit tcp any eq 1720 any
                      access-list 103 permit tcp any any eq 1720
                   

    Observação: É possível estabelecer chamadas de VoIP usando H.323, o protocolo SIP, o protocolo MGCP ou o protocolo SCCP - protocolo proprietário usado pelo Cisco Call Manager. O exemplo anterior pressupõe o H.323 Fast Connect. Esta lista funciona como referência das portas usadas pela sinalização VoIP e canais de controle:

    • H.323/H.225 = TCP 1720

    • H.323/H.245 = TCP 11xxx (Standard Connect)

    • H.323/H.245 = TCP 1720 (Fast Connect)

    • H.323/H.225 RAS = TCP 1719

    • SCCP = TCP 2000-2002 (CM Encore)

    • ICCP = TCP 8001-8002 (CM Encore)

    • MGCP = UDP 2427, TCP 2428 (CM Encore)

    • SIP= UDP 5060, TCP 5060 (configurável)

  3. Crie um mapa de política e o associe aos mapas de classe VoIP.

    A finalidade deste mapa de classes é definir como os recursos de link são compartilhados ou atribuídos às diferentes classes de mapas. Utilize estes comandos para concluir esta tarefa:

    maui-voip-sj(config)#policy-map VOICE-POLICY
                      
                         !--- Escolha um nome descritivo de mapa de política.
                      
    
    maui-voip-sj(config-pmap)#class voice-traffic
    maui-voip-sj(config-pmap-c)#priority ?
     <8-2000000>  Kilo Bits per second
    
                         !--- Configure a classe de tráfego de voz para o PQ
    !--- (comando de prioridade) estrito e atribua a largura de banda.
                      
    
    maui-voip-sj(config-pmap)#class voice-signaling
    maui-voip-sj(config-pmap-c)#bandwidth 8
                      
                         !--- Atribua 8 à classe de sinalização de voz.
                      
    
    maui-voip-sj(config-pmap)#class class-default
    maui-voip-sj(config-pmap-c)#fair-queue
                      
                         !--- O tráfego de dados restante é tratado como WFQ.
                      
                   

    Observação: Apesar de ser possível colocar em fila vários tipos de tráfego em tempo real para o PQ, a Cisco recomenda que você direcione apenas tráfego de voz para ele. O tráfego em tempo real, como vídeo, apresenta uma potencial variação no retardo (o PQ é uma fila PEPS (primeiro que entra, primeiro que sai)). O tráfego de voz requer o retardo não varie para evitar problemas de sincronização.

    Observação: A soma dos valores de instruções priority e bandwidth devem ser menores ou iguais a minCIR para o PVC. Caso contrário, o comando service-policy não pode ser atribuído ao link. minCIR por padrão é metade de CIR. Para exibir as mensagens de erro, certifique-se de que o comando logging console esteja habilitado para console de registro e o comando terminal monitor esteja habilitado para acesso Telnet.

    Para obter mais informações sobre os comandos bandwidth e priority, consulte Comparando os Comandos bandwidth priority de uma Política de Serviço de QoS.

  4. Habilite LLQ aplicando o mapa de políticas à interface de saída WAN.

    Use os comandos para habilitar o LLQ:

    maui-voip-sj(config)#map-class frame-relay VoIPovFR
    maui-voip-sj(config-if)#service-policy output VOICE-POLICY
                      
                         !--- A política de serviço é aplicada ao PVC.
    !--- indiretamente com sua configuração
    !--- na classe de mapa associada ao PVC.
                      
                   

Prioridade IP RTP

Se você não utilizar LLQ, utilize estas diretrizes:

Router(config-map-class)#frame-relay ip rtp priority
            starting-rtp-port
largura de banda de intervalo de portas.
         
  • starting-rtp-port - O número da porta UDP inicial. O número mais baixo de porta para onde os pacotes são enviados. Para VoIP, defina esse valor como 16384.

  • port-range—A faixa de portas de UDP de destino. O número, adicionado a starting-rtp-port, resulta no número mais alto da porta UDP. Para VoIP, defina esse valor como 16383.

  • largura de banda—Largura de banda máxima permitida em kbps na fila de prioridade. Defina este número com base no número de chamadas simultâneas, adicionando a largura de banda de cada chamada suportada pelo sistema.

Configuração de exemplo:

map-class frame-relay VoIPovFR  frame-relay cir 64000
 frame-relay BC 600
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80
 frame-relay ip rtp priority 16384 16383 45
         

Traffic Shaping para Voz

Use estas diretrizes ao configurar o traffic shaping para voz:

  • Não exceda o CIR do PVC.

  • Desative o Frame Relay adaptive shaping.

  • Define um valor baixo de Bc para que o Tc (intervalo de modelagem) seja de 10 ms (Tc = Bc/CIR). Configure o valor Bc para forçar o valor Tc desejado.

  • Defina o Valor Be como 0.

Para obter mais informações sobre estas diretrizes, consulte Frame Relay Traffic Shaping para VoIP e VoFR.

Observação: Alguns clientes usam PVCs separados para dados e voz. Se você tiver dois PVCs separados e quiser intermitência no PVC de dados enquanto você estiver no ou abaixo do CIR do PVC de voz, a qualidade de voz será prejudicada, pois estes PVCs utilizam a mesma interface física. Nestes casos, o provedor de Frame Relay, assim como o roteador, deve priorizar o PVC de voz. O último pode ser feito com PVC Interface Priority Queueing (PIPQ), disponível a partir do Cisco IOS Software Release 12.1(1)T.

Fragmentação (FRF.12)

Ative a fragmentação para os links de baixa velocidade (menos de 768 kbps). Defina o tamanho dos fragmentos para que os pacotes de voz não serem fragmentados e não sofrerem retardo de serialização maior que 20 ms. Defina o tamanho da fragmentação com base na menor velocidade de porta entre os roteadores. Por exemplo, se houver uma topologia de Frame Relay de hub e spoke em que o hub tenha velocidade T1 e os roteadores remotos tenham velocidades de porta de 64 K, o tamanho da fragmentação deve ser definido para a velocidade de 64 K em ambos os roteadores. Qualquer outro PVC que compartilhe a mesma interface deve configurar a fragmentação para o tamanho usado pelo PVC de voz. Utilize este gráfico para determinar os valores de tamanho de fragmentação.

Velocidade mais baixa de link no caminho

Tamanho de Fragmentação Recomendado (para Serialização em 10 ms)

56 Kbps

70 bytes

64 Kbps

80 bytes

128 Kbps

160 bytes

256 Kbps

320 bytes

512 Kbps

640 bytes

768 Kbps

1000 bytes

1536 Kbps

1600 bytes

Configuração de exemplo:

            map-class frame-relay VoIPovFR 
            
               !--- Parte da saída foi omitida.   
            
            frame-relay fragment 80
         

Observação: Para 1536 Kbps, tecnicamente não há necessidade de fragmentação. Entretanto, a fragmentação é necessário para ativar o sistema de filas PEPS para garantir a qualidade de voz. Um tamanho de fragmento de 1600 ativa a PEPS dupla. Entretanto, como 1600 bytes é superior à unidade de transmissão máxima de interface em série comum (MTU), grandes pacotes de dados não são fragmentados.

Diagrama de rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

VoIP_FR.gif

Configurações

Este documento usa a configuração mostrada abaixo:

  • maui-voip-sj (Cisco 3640)

  • maui-voip-austin (Cisco 3640)

maui-voip-sj (Cisco 3640)

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
nome de host maui-voip-sj
!
logging buffered 10000 debugging
enable secret 5 $1$MYS3$TZ6bwrhWB25b2cVpEVgBo1
!
ip subnet-zero
!

                     !--- Definição da sinalização de voz e de mapas de classe de tráfego.
!--- a classe de "tráfego de voz" utiliza a lista de acesso 102 para seus critérios de correspondência.
!--- a classe de "sinalização de voz" utiliza a lista de acesso 103 para seus critérios de correspondência.
                  
                  sinalização de voz de correspondência total de mapa de classe
 grupo de acesso de correspondência 103
tráfego de voz de correspondência total de mapa de classe
  grupo de acesso de correspondência 102
!

                     !--- O mapa de políticas define como os recursos de link são atribuídos
!--- às diferentes classes de mapa. Nesta configuração, PQ estrito
!--- está atribuído à classe de tráfego de voz
!--- com largura de banda máxima de 45 Kbps.
                  

                  policy-map VOICE-POLICY
  classe de tráfego de voz
  prioridade 45
  classe de sinalização de voz
  largura de banda 8

                  
                     !--- Atribui uma fila para tráfego de sinalização de voz que garante 8 Kbps.
!--- Observe que isto é opcional e não tem nada a ver com uma boa qualidade
!--- de voz. Em vez disso, esta é uma forma de garantir a sinalização.
                  

                  class class-default
  fair-queue

                  
                     !--- A classe class-default é utilizada para classificar o tráfego que
!--- não está dentro de uma das classes definidas.
!--- O comando fair-queue associa as filas WFQ de classe padrão.
                  
!
interface Ethernet0/0
  ip address 172.22.113.3 255.255.255.0
  half-duplex
!
interface Serial0/0
 bandwidth 128
 no ip address
 encapsulation frame-relay
 no fair-queue
frame-relay traffic-shaping
 frame-relay ip rtp header-compression
                  
                     !---  Ativa o traffic shaping e o cRTP. Se o traffic-shaping não estiver
!--- habilitado, a classe do mapa não é iniciada e o FRF.12 e LLQ
!--- não funcionam.
                  
!
interface Serial0/0.1 point-to-point
 bandwidth 128
 endereço ip 192.168.10.2 255.255.255.252
 frame-relay interface-dlci 300
  classe VOIPovFR
                  
                     !--- Este comando vincula a subinterface a uma classe de mapa VoIPovFR.
!--- Consulte o comando map-class frame-relay VoIPovFR aqui:
!--- Observação: A palavra VoIPovFR é selecionada pelo usuário.
!
                  
ip classless
ip route 172.22.112.0 255.255.255.0 192.168.10.1
!
map-class frame-relay VOIPovFR
 no frame-relay adaptive-shaping
                  
                     !--- Desative o Frame Relay BECNS. Observe também que Be é igual a 0 por padrão.
                  
                  frame-relay cir 64000
 frame-relay bc 640
                  
                     !--- Tc = BC/CIR. Neste caso, Tc é forçado para o mínimo
!--- valor configurável de 10 ms.
                  
                  frame-relay be 0
 frame-relay mincir 64000
                  
                     !--- Apesar de o formato adaptável estar desativado, torne o CIR igual ao minCIR
!--- como segurança dupla. Por padrão, o valor de minCIR é metade do valor de CIR.
                  
                  service-policy output VOICE-POLICY
                  
                     !--- Ativa o LLQ no PVC.
                  
                  frame-relay fragment 80
                  
                     !--- Liga a fragmentação FRF.12 e define o tamanho de fragmento em 80 bytes.
!--- Este valor se baseia na velocidade da porta no link mais lento.
!--- Este comando também ativa a PEPS dupla.
                  
!
access-list 102 permit udp any any range 16384  32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!

                     !--- access-list 102 lida com o tráfego de VoIP
!--- com base no intervalo de portas UDP.
!--- Portas pares e ímpares são colocadas no PQ.
!--- access-list 103 corresponde o protocolo de sinalização VoIP. Nesse
!--- caso, H.323 V2 é usado com o recurso de início rápido.
                  
!
voice-port 1/0/0
!
dial-peer voice 1 pots
 destination-pattern 5000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 6000
 session target ipv4:192.168.10.1
 dtmf-relay cisco-rtp
 ip precedence 5

maui-voip-austin (Cisco 3640)

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
nome de host maui-voip-austin
!
boot system flash slot1:c3640-is-mz.122-6a.bin
logging buffered 1000000 debugging
!
ip subnet-zero
!
sinalização de voz de correspondência total de mapa de classe
grupo de acesso de correspondência 103
tráfego de voz de correspondência total de mapa de classe
  grupo de acesso de correspondência 102
!
policy-map voice-policy
  classe de sinalização de voz
   largura de banda 8
  classe de tráfego de voz
    prioridade 45
  class class-default
   fair-queue
!
interface Ethernet0/0
 ip address 172.22.112.3 255.255.255.0
 no keepalive
 half-duplex
!
interface Serial0/0
 largura de banda 64
 no ip address
  frame-relay de encapsulamento
 no ip mroute-cache
 no fair-queue
  frame-relay traffic-shaping
 frame-relay ip rtp header-compression
!
interface Serial0/0.1 point-to-point
 largura de banda 64
 ip address 192.168.10.1 255.255.255.252
 frame-relay interface-dlci 400
  classe VOIPovFR
!
ip classless
ip route 172.22.113.0 255.255.255.0 192.168.10.2
!
map-class frame-relay VOIPovFR
no frame-relay adaptive-shaping
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 service-policy output voice-policy
 frame-relay fragment 80
access-list 102 permit udp any any range 16384  32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
voice-port 1/0/0
!
dial-peer voice 1 pots
 destination-pattern 6000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 5000
 session target ipv4:192.168.10.2
 dtmf-relay cisco-rtp
 ip precedence 5

Verificação e Solução de Problemas

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

A Output Interpreter Tool (clientes registrados somente) é compatível com alguns comandos show. Isto permite que você visualize uma análise da saída de comando show.

Comandos de Prioridade LLQ / IP RTP

Os comandos show e debug ajudam na verificação das configurações de prioridade de LLQ e IP RTP.

  • show policy-map interface serial interface# —Este comando é útil para visualizar a operação de LLQ e quedas no PQ. Para obter mais informações sobre os diversos campos deste comando, consulte Entendendo os contadores de pacotes na saída de show policy-map interface.

  • show policy-map policy_map_name - Exibe informações sobre a configuração de mapa de políticas.

  • show queue interface-type interface-number -- Lista a configuração de enfileiramento e as estatísticas consideráveis para uma determinada interface.

  • debug priority-- Exibe eventos de PQ e se ocorreram quedas nesta fila. Para obter mais informações, consulte Solucionando Problemas de Quedas de Saída com Filas de Prioridade.

  • show class-map class_name - Exibe informações sobre a configuração de mapa de classes.

  • show call active voice—Verifica a existência de pacotes no nível de DSP.

  • show frame-relay ip rtp header-compression — Exibe as estatísticas de compressão de cabeçalho de RTP.

Comandos de Fragmentação

Utilize os comandos debug e show para ajudar na verificação e a solucionar problemas de configurações de fragmentação.

  • show frame-relay fragment- Exibe informações sobre a fragmentação de Frame Relay que ocorre no roteador Cisco.

  • debug frame-relay fragment — Exibe mensagens de eventos ou mensagens de erro relacionadas a fragmentação de Frame Relay. É habilitado apenas no nível do PVC na interface selecionada.

Comandos de Interface / Frame Relay

Utilize os comandos show para ajudar na verificação e solucionar problemas de configurações de Frame Relay/Interface.

  • show traffic-shape queue interface —Exibe informações sobre os elementos em fila no nível do identificador de conexão de data-link VC (DLCI). Usado para verificar a operação da prioridade IP RTP em Frame Relay. Quando há congestionamento no link, os fluxos de voz são identificados com peso zero. Isto indica que o fluxo de voz utiliza o PQ. Consulte uma saída de exemplo aqui.

  • show traffic-shape—Exibe informações como valores configurados de Tc, Bc, Be e CIR. Consulte uma saída de exemplo aqui.

  • show frame-relay pvc dlci-# – Exibe informações como parâmetros de modelagem de tráfego, valores de fragmentação e pacotes descartados. Consulte uma saída de exemplo aqui. Consulte também Solução de Problemas de Frame Relay.

Problemas Conhecidos

Um bug foi identificado em per VC LLQ, em que o PQ foi intensivamente vigiado mesmo quando não havia congestionamento na interface. Este bug foi resolvido e agora os pacotes que não estão em conformidade são sofrem queda apenas se o congestionamento ocorrer no VC. Isto torna o comportamento do VC LLQ igual a outras interfaces que usam LLQ. Esse comportamento foi alterado no Cisco IOS Software Release 12.2(3) e posterior.

Exibição de Amostra e Saída de Comando de Depuração

Esta é a amostra de saída de comando show e debug usada para verificação e solução de problemas.

            
               !--- Para capturar seções desta saída, a largura de banda de LLQ PQ
!--- foi diminuída e o tráfego de dados maiores foi colocado
!--- no link para forçar quedas de pacotes.

!--- A largura de banda de fila de prioridade é diminuída para 10 Kbps do PQ.
!--- Observação: Para redefinir os contadores, utilize o comando clear counters. 
            

maui-voip-sj#show policy-map inter ser 0/0.1
  Serial0/0.1: DLCI 300 -

  Service-policy output: VOICE-POLICY

Class-map: voice-traffic (match-all)
         26831 packets, 1737712 bytes
         5 minute offered rate 3000 bps, drop rate 2000 bps
         Match: access-group 102
         Weighted Fair Queueing
         Prioridade Estrita   
         Output Queue: Conversation 24
         Largura de banda 10 (Kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 26311/1704020
         (total drops/bytes drops) 439/28964

   Class-map: voice-signaling (match-all)
         80 packets, 6239 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 62/4897
         (depth/total drops/no-buffer drops) 0/0/0

   Class-map: class-default (match-any)
         14633 packets, 6174492 bytes
         5 minute offered rate 10000 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 0/0/0



               !--- Esses comandos são úteis para verificar a configuração de LLQ. 
            

maui-voip-austin#show policy-map voice-policy
            Política de voz de mapa de políticas
   Sinalização de voz de classe
        Weighted Fair Queueing
           Bandwidth 8 (kbps) Max Threshold 64 (packets)
   Tráfego de voz de classe
        Weighted Fair Queueing
         Prioridade Estrita
             Largura de banda 45 (kbps) Intermitência 1125 (Bytes)
            Padrão de classe da classe
        Weighted Fair Queueing
           Flow based Fair Queueing Max Threshold 64 (packets)

maui-voip-austin#show class-map
 Class Map match-all voice-signaling (id 2)
         Match access-group  103
 Class Map match-any class-default (id 0)
         Match any
 Class Map match-all voice-traffic (id 3)
         Match access-group 102


               !--- Saída de comando de verificação de Frame Relay.
            

maui-voip-sj#show frame-relay fragment
interface         dlci  frag-type    frag-size  in-frag    out-frag   dropped-frag
Serial0/0.1       300   end-to-end      80         4          4          0

maui-voip-sj#show frame-relay pvc 300

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 300, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 7 output pkts 7 in bytes 926
         out bytes 918 dropped pkts 0 in FECN pkts 0
         in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
         in DE pkts 0 out DE pkts 0
         out bcast pkts 2 out bcast bytes 598
         pvc create time 1w2d, last time pvc status changed 1w2d
      service policy VOICE-POLICY

            Saída de política de serviço: VOICE-POLICY

            Class-map: tráfego de voz (correspondência total)
         0 packets, 0 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
      Correspondência:    grupo de acesso 102
         Weighted Fair Queueing
      Prioridade Estrita   
         Output Queue: Conversation 24
         Bandwidth 45 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 0/0
         (total drops/bytes drops) 0/0

 Class-map: voice-signaling (match-all)
         0 packets, 0 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 0/0
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: class-default (match-any)
         7 packets, 918 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 0/0/0


 Output queue size 0/max total 600/drops 0
 fragment type end-to-end tamanho do fragmento 80
 cir 64000 bc 640 be 0 limite 80 intervalo 10
 mincir 64000 byte increment 80 BECN response no
 frags 13 bytes 962 frags delayed 8 bytes delayed 642

 shaping inactive
 traffic shaping drops 0


               !--- Nesta saída de comando de verificação de Frame Relay
!--- , a largura de banda PQ é diminuída e o tráfego pesado
!--- é colocado na interface forçar quedas.

            
maui-voip-sj#show frame-relay pvc 300

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 300, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 483 output pkts 445 in bytes 122731
         out bytes 136833 dropped pkts 0 in FECN pkts 0
         in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
         in DE pkts 0 out DE pkts 0
         out bcast pkts 4 out bcast bytes 1196
         pvc create time 1w2d, last time pvc status changed 1w2d
         service policy VOICE-POLICY

 Service-policy output: VOICE-POLICY

 Class-map: voice-traffic (match-all)
         352 packets, 22900 bytes
         5 minute offered rate 2000 bps, drop rate 2000 bps
         Match: access-group 102
         Weighted Fair Queueing
         Strict Priority
         Output Queue: Conversation 24
         Bandwidth 10 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 352/22900
         (total drops/bytes drops) 169/11188

 Class-map: voice-signaling (match-all)
         7 packets, 789 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 7/789
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: class-default (match-any)
         79 packets, 102996 bytes
         5 minute offered rate 4000 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 5/0/0
         Output queue size 5/max total 600/drops 169
         fragment type end-to-end fragment size 80
         cir 64000 bc 640 be 0 limit 80 interval 10
         mincir 64000 byte increment 80 BECN response no
         frags 2158 bytes 178145 frags delayed 1968 bytes delayed 166021

 shaping active
         traffic shaping drops 169


               !--- Observe que o intervalo Tc é igual a 10 ms,
!--- CIR é igual a 64000 BPS e BC é igual a 640. 
            

maui-voip-sj#show traffic-shape
Interface  Se0/0.1
       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
300           64000     80     640       0          10        80         -



               !--- Esta saída é capturada em um ambiente isolado de laboratório em que
!--- os roteadores são configurados com Prioridade IP RTP em vez de LLQ.
            

maui-voip-austin#show frame-relay PVC 100

PVC Statistics for interface Serial0/1 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1.1

  input pkts 336           output pkts 474          in bytes 61713
  out bytes 78960          dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  PVC create time 1w0d, last time PVC status changed 1w0d
 Current fair queue configuration:
   Discard      Dynamic       Reserved
   threshold    queue count   queue count
   64            16              2
 Output queue size 0/max total 600/drops 0
  tipo de fragmento ponta a ponta         tamanho de fragmento 80
            cir 64000     BC   640      be 0     limit 125    intervalo 10
  mincir 32000    byte increment 125   BECN response no
  frags 1091      bytes 82880     frags delayed 671      bytes delayed 56000
  modelagem inativa   
  traffic shaping drops 0
  parâmetros de prioridade de rtp de ip IP 16384 32767 45000

            
               Este comando exibe informações sobre os peers de discagem de VoIP.   
            

maui-voip-austin#show dial-peer voice 2
VoiceOverIpPeer2
        information type = voice,
        tag = 2, destination-pattern = `5000',
        answer-address = `', preference=0,
        group = 2, Admin state is up, Operation state is up,
        incoming called-number = `', connections/maximum = 0/unlimited,
        application associated:
     tipo= voip, session-target = `ipv4:192.168.10.2',
        technology prefix:
     precedência de ip = 5, UDP checksum = disabled,
         session-protocol = cisco, req-qos = best-effort,
         acc-qos = best-effort,
     dtmf-relay = cisco-rtp,
        fax-rate = voice,   payload size =  20 bytes
     codec = g729r8,    tamanho de payload =  20 bytes,
        Expect factor = 10, Icpif = 30,signaling-type = cas,
     VAD = ativado, Poor QOV Trap = disabled,
        Connect Time = 165830, Charged Units = 0,
        Successful Calls = 30, Failed Calls = 0,
        Accepted Calls = 30, Refused Calls = 0,
        Last Disconnect Cause is "10",
        Last Disconnect Text is "normal call clearing.",
        Last Setup Time = 69134010.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações relacionadas


Document ID: 12156