Switches de LAN : Virtual LANs/VLAN Trunking Protocol (VLANs/VTP)

Criando VLANs de Ethernet em Catalyst Switches

17 Julho 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (9 Julho 2007) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Produtos Relacionados
      Convenções
Diferença entre o CatOS e o Cisco IOS System Software
Configurar a VLAN nos Catalyst Switches que Executam o CatOS
      Criar VLANs e Portas
      Remover Portas ou VLANs
      Dicas para Troubleshooting
Configurar a VLAN nos Catalyst 2900XL, 3500XL, 2950, 2970 e 2940 Series Switches
      Criar VLANs e Portas
      Remover Portas ou VLANs
Configurar uma Porta MultiVLAN no Catalyst 2900XL/3500XL
Configurar a VLAN nos Catalyst 3550, 3750, 4500/4000 e 6500/6000 Switches que Executam o Cisco IOS Software
      Criar VLANs e Portas
      Atribuir Várias Portas a uma Única VLAN
      Remover VLANs
      Como Isolar a Comunicação entre Duas VLANs
      Como Configurar VLANs de Intervalo Estendido em um Catalyst 6500 Series Switch
      Dicas para Troubleshooting
Verificação
Troubleshooting
      Erro de Valor Inconsistente de TLB nos Switches IOS
      Recuperar o Arquivo vlan.dat nos Switches IOS
      Não Foi Possível Criar VLANs no Intervalo Estendido
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento contém informações básicas sobre como criar VLANs nos switches Catalyst que executam o Catalyst OS (CatOS) e o Cisco IOS® System Software. Os exemplos de comandos em cada seção usam um switch Catalyst de cada uma das seções de configuração.

Pré-requisitos

Requisitos

A Cisco recomenda que você tome conhecimento sobre as informações nesta seção.

As VLANs consistem em um mecanismo que permite que administradores de rede criem domínios de broadcast lógicos que podem ser distribuídos por um único switch ou por vários switches, independentemente da proximidade física. Essa função é útil para reduzir o tamanho de domínios de broadcast ou para permitir que grupos ou usuários sejam logicamente agrupados sem a necessidade de estarem fisicamente localizados no mesmo lugar.

Para criar VLANs, é necessário decidir como configurar estes itens:

  • Qual nome de domínio de VLAN Trunk Protocol (VTP) e o modo VTP deve ser usado no switch

  • Quais portas do switch pertencerão a qual VLAN

  • Se você precisa que haja comunicação entre as VLANs ou se elas ficarão isoladas

    Se você precisa de comunicação entre VLANs, é necessário usar um dispositivo de roteamento da Camada 3, como um roteador Cisco externo ou um módulo de roteador interno. Aqui estão alguns exemplos:

    • Placa da Camada 3 WS-X4232 para Catalyst 4500/4000 Switches com Supervisor Engine I e Supervisor Engine II

    • Route Switch Module (RSM) ou Route Switch Feature Card (RSFC) para Catalyst 5500/5000 Switches

    • Multilayer Switch Module (MSM) ou Multilayer Switch Feature Card (MSFC) para Catalyst 6500/6000 Switches

    Alguns switches possuem software e hardware de suporte interno para realizarem roteamento entre VLANs. Com o roteamento entre VLANs, nenhum dispositivo externo, módulo ou daughter cards são necessários. Aqui estão apresentados exemplos desses switches:

    • Catalyst 3550/3750/6500 com Supervisor Engine 720

    • Catalyst 4500/4000 com Supervisor Engine II+, Supervisor Engine III e Supervisor Engine IV

Para obter mais informações sobre a configuração do roteamento entre VLANs em uma MSFC, um RSM, uma RSFC ou em um roteador externo, consulte os seguintes documentos:

Nota: Este documento pressupõe que você possua uma conectividade básica com o switch, seja por console ou através de acesso Telnet. Consulte estes documentos para obter mais informações sobre como obter conectividade básica para os switches:

Componentes Utilizados

As informações neste documento são baseadas nas seguintes versões de hardware e software:

  • Catalyst 6009 Switch que executa o software CatOS 5.5(x)

  • Catalyst 3524XL Switch que executa o Cisco IOS Software Release 12.0(5.x)XU

  • Catalyst 4507 Switch com Supervisor Engine IV (WS-X4515) que executa o Cisco IOS Software Release 12.1(13)EW1

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Produtos Relacionados

As informações contidas neste documento também podem ser usadas com estes switches:

  • Catalyst 4500/4000/2948G/2980G/4912G Switches

  • Catalyst 5000/2926G Series Switches

  • Catalyst 6500/6000 Series Switches

  • Catalyst 2900XL/3500XL/2950/3550/3750 Switches

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Diferença entre o CatOS e o Cisco IOS System Software

CatOS no Supervisor Engine e Cisco IOS Software na MSFC (híbrido): uma imagem CatOS pode ser usada como o software do sistema para executar o Supervisor Engine nos Catalyst 6500/6000 Switches. Se a MSFC opcional estiver instalada, uma imagem do Cisco IOS Software separada será utilizada para executar a MSFC.

Cisco IOS Software no Supervisor Engine e na MSFC (nativo): uma única imagem do Cisco IOS Software pode ser usada como o software do sistema para executar tanto o Supervisor Engine como a MSFC nos Catalyst 6500/6000 Switches.

Nota: Consulte Comparação entre Sistemas Operacionais Cisco Catalyst e Cisco IOS para o Cisco Catalyst 6500 Series Switch para obter mais informações.

Configurar a VLAN nos Catalyst Switches que Executam o CatOS

Criar VLANs e Portas

Execute os passos nesta seção para criar uma VLAN.

Antes de poder criar uma VLAN, o switch deve estar no modo de servidor VTP ou no modo transparente VTP. Se o switch for um servidor VTP, é necessário definir um nome de domínio VTP antes de poder adicionar VLANs.

  1. Definir um nome de domínio VTP.

    Você deve definir o nome de domínio VTP independentemente do:

    • Número de switches na rede, seja um único ou vários

    • Uso do VTP para propagar VLANs para outros switches na rede

    Esta é a configuração de VTP padrão no switch:

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000
    

    Execute o comando set vtp para definir o modo e o nome do domínio.

    CatosSwitch> (enable)set vtp domain ?
    
      <name>                     Domain name
    
    CatosSwitch> (enable)set vtp domain cisco ?
    
      mode                       Set VTP mode
      passwd                     Set VTP password
      pruning                    Set VTP pruning
      v2                         Set VTP version 2
    
    CatosSwitch> (enable)set vtp domain cisco mode ?
    
      client                     VTP client mode
      server                     VTP server mode
      transparent                VTP transparent mode
    
    CatosSwitch> (enable)set vtp domain cisco mode server
    
    VTP domain cisco modified
    

    Nota: Consulte Compreendendo o VTP (VLAN Trunk Protocol) para obter mais informações sobre o VTP.

  2. Execute o comando show vtp domain para verificar a configuração do VTP.

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             1               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000
    

    Nota: Caso tenha a saída de um comando show vtp domain de seu dispositivo Cisco, você poderá usar o Output Interpreter (somente clientes registrados) para exibir possíveis problemas e correções.

  3. Depois de definir e verificar o domínio VTP, comece a criar VLANs no switch.

    Por padrão, há apenas uma única VLAN para todas as portas. Essa VLAN é denominada default. Você não pode renomear nem excluir a VLAN 1.

    Execute o comando show vlan para exibir os parâmetros de todas as VLANs configuradas no domínio administrativo.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/1-48
                                                            4/1-16
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      ibm  -        0      0
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    1    static     disabled
    1002 static     disabled
    1003 static     disabled
    1004 static     disabled
    1005 static     disabled
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
    1003 7       7       off
    
    1. Execute o comando set vlan para criar VLANs.

      CatosSwitch> (enable)set vlan
      
      Usage: set vlan <vlan> <mod/port>
             (An example of mod/port is 1/1,2/1-12,3/1-2,4/1-12)
             set vlan <vlan_num> [name <name>] [type <type>] [state <state>]
                                 [pvlan-type <pvlan_type>]
                                 [said <said>] [mtu <mtu>]
                                 [ring <hex_ring_number>]
                                 [decring <decimal_ring_number>]
                                 [bridge <bridge_number>] [parent <vlan_num>]
                                 [mode <bridge_mode>] [stp <stp_type>]
                                 [translation <vlan_num>] [backupcrf <off|on>]
                                 [aremaxhop <hopcount>] [stemaxhop <hopcount>]
                                 [rspan]
             (name = 1..32 characters, state = (active, suspend)
              type = (ethernet, fddi, fddinet, trcrf, trbrf)
              said = 1..4294967294, mtu = 576..18190
              pvlan-type = (primary,isolated,community,none)
              hex_ring_number = 0x1..0xfff, decimal_ring_number = 1..4095
              bridge_number = 0x1..0xf, parent = 2..1005, mode = (srt, srb)
              stp = (ieee, IBM, auto), translation = 1..1005
              hopcount = 1..13)
      Set vlan commands:
      ----------------------------------------------------------------------------
      set vlan                     Set vlan information
      set vlan mapping             Map an 802.1q vlan to an Ethernet vlan
      
      CatosSwitch> (enable)set vlan 2 name cisco_vlan_2
      
      Vlan 2 configuration successful
      
    2. Execute o comando show vlan para verificar a configuração da VLAN.

      CatosSwitch> (enable)show vlan
      
      VLAN Name                             Status    IfIndex Mod/Ports, Vlans
      ---- -------------------------------- --------- ------- --------------------
      1    default                          active    5       1/1-2
                                                              3/1-48
                                                              4/1-16
      2    cisco_vlan_2                     active    75
      1002 fddi-default                     active    6
      1003 token-ring-default               active    9
      1004 fddinet-default                  active    7
      1005 trnet-default                    active    8
      
      
      VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
      ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
      1    enet  100001     1500  -      -      -      -    -        0      0
      2    enet  100002     1500  -      -      -      -    -        0      0
      1002 fddi  101002     1500  -      -      -      -    -        0      0
      1003 trcrf 101003     1500  -      -      -      -    -        0      0
      1004 fdnet 101004     1500  -      -      -      -    -        0      0
      1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
      
      !--- Saída suprimida.
      
      
    3. Se desejar adicionar portas à VLAN, execute o comando set vlan número_da_vlan mod/portas.

      CatosSwitch> (enable)set vlan 2 3/1-12
      
      VLAN 2 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      2     3/1-12
            15/1
      

      Nota: Você também pode criar a VLAN e adicionar as portas a ela com todas as informações em um único comando.

      Por exemplo, se desejar criar a terceira VLAN e depois atribuir as portas de 3/13 a 3/15 a essa VLAN, execute este comando:

      CatosSwitch> (enable)set vlan 3 3/13-15
      
      Vlan 3 configuration successful
      VLAN 3 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      3     3/13-15
            15/1
      
  4. Execute o comando show vlan para verificar a configuração da VLAN.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/16-48
                                                            4/1-16
    2    cisco_vlan_2                     active    75      3/1-12
    3    VLAN0003                         active    76      3/13-15
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    2    enet  100002     1500  -      -      -      -    -        0      0
    3    enet  100003     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
    
    !--- Saída suprimida.
    
    

Remover Portas ou VLANs

Para remover portas de uma VLAN, execute o comando set vlan número_da_vlan mod/portas e coloque as portas em outra VLAN. Essa remoção é basicamente o que acontece quando você atribui uma porta a qualquer VLAN, porque todas as portas inicialmente pertencem à VLAN 1.

Execute o comando clear vlan para excluir uma VLAN. As portas são desativadas porque elas permanecem como parte daquela VLAN, e a VLAN não existe mais. O switch exibe um aviso e oferece a você a oportunidade de cancelar a solicitação atual.

CatosSwitch> (enable)clear vlan 3

This command will deactivate all ports on vlan 3
in the entire management domain.
Do you want to continue(y/n) [n]? y

Vlan 3 deleted

CatosSwitch> (enable)show vlan

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- ------------------------
1    default                          active    5       1/1-2
                                                        3/16-48
                                                        4/1-16
2    cisco_vlan_2                     active    75      3/1-12
1002 fddi-default                     active    6
1003 token-ring-default               active    9
1004 fddinet-default                  active    7
1005 trnet-default                    active    8

VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1    enet  100001     1500  -      -      -      -    -        0      0
2    enet  100002     1500  -      -      -      -    -        0      0
1002 fddi  101002     1500  -      -      -      -    -        0      0
1003 trcrf 101003     1500  -      -      -      -    -        0      0
1004 fdnet 101004     1500  -      -      -      -    -        0      0
1005 trbrf 101005     1500  -      -      -      IBM  -        0      0

!--- Saída suprimida.

Nota: As portas de 3/13 a 3/15 não são exibidas na saída do comando show vlan porque a remoção da VLAN 3 desativa essas portas. As portas não serão exibidas até que você as adicione novamente em outra VLAN.

Dicas para Troubleshooting

Esta seção fornece dicas para troubleshooting que você pode encontrar ao criar VLANs em switches Catalyst que executam o CatOS:

  • Se você criar uma VLAN quando não houver um nome de domínio VTP definido, a seguinte mensagem de erro será exibida:

    Cannot add/modify VLANs on a VTP server without a domain name.
    

    Para corrigir isso, crie um nome de domínio VTP no switch. A seção Criar VLANs e Portas fornece o procedimento.

  • Se você criar uma VLAN em um switch que esteja no modo cliente VTP, a seguinte mensagem de erro será exibida:

    Cannot add/modify VLANs on a VTP client.
    

    Nota: Um switch só poderá criar VLANs se estiver no modo de servidor VTP ou no modo transparente VTP. Consulte Compreendendo o VTP (VLAN Trunk Protocol) para obter mais informações sobre o VTP.

  • As portas estão no estado inactive na saída do comando show port mod/porta. Esse estado significa que a VLAN à qual as portas pertencem originalmente foram excluídas, geralmente por causa do VTP. Você pode recriar essa VLAN ou corrigir a configuração do VTP de modo que a VLAN seja restabelecida no domínio VTP. Este é um exemplo do comando show port mod/porta:

    CatosSwitch> (enable)show port 3/1
    
    Port  Name               Status     Vlan       Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ----- ------------
     3/1                     inactive   2            auto  auto 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status     InlinePowered     PowerAllocated
                                       Admin Oper   Detected mWatt mA @42V
    ----- ------------- -------------- ----- ------ -------- ----- --------
     3/1  none          none           -     -      -        -     -
    
    !--- Saída suprimida.
    
    

    Caso você possua a saída de um comando show-tech support de seu dispositivo Cisco, o Output Interpreter poderá ser utilizado (somente clientes registrados) para exibir possíveis problemas e correções.

    CatosSwitch> (enable)show vlan 2
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
    
  • As interfaces de VLAN criadas nos módulos de roteamento (RSM, RSFC, MSM ou MSFC) aparecem apenas quando a VLAN correspondente está disponível no switch. Para que a interface da VLAN esteja inteiramente ativa, o que significa que ela estará administrativamente ativa e o protocolo de linha estará ativo, certifique-se de que há pelo menos uma porta como membro da VLAN com um dispositivo ativo conectado a ela. Consulte a seção Requisitos deste documento para obter diretrizes de configuração.

Configurar a VLAN nos Catalyst 2900XL, 3500XL, 2950, 2970 e 2940 Series Switches

Criar VLANs e Portas

Nota: A saída que você vê poderá ser diferente de algumas saídas de comando exibidas nesta seção. A diferença depende do modelo do seu switch.

Conclua essas etapas para criar uma VLAN.

  1. Decida se vai usar o VTP na sua rede.

    Com o VTP, você pode fazer alterações de configuração de forma centralizada em um único switch e pode comunicar automaticamente essas alterações a todos os outros switches na rede. O modo VTP padrão nos switches Catalyst 2900XL, 3500XL, 2950, 2970 e 2940 é o modo de servidor. Consulte Compreendendo o VTP (VLAN Trunk Protocol) para obter mais informações sobre o VTP.

    Nota: Execute o comando show vtp status para verificar o status do VTP nos XL Series Switches.

    3524XL#show vtp status
    
    VTP Version                     : 2
    Configuration Revision          : 0
    Maximum VLANs supported locally : 254
    Number of existing VLANs        : 5
    VTP Operating Mode              : Server
    
    !--- Este é o modo padrão.
    
    VTP Domain Name                 :
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0xBF 0x86 0x94 0x45 0xFC 0xDF 0xB5 0x70
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
    
  2. Depois de definir e verificar o domínio VTP, comece a criar VLANs no switch.

    Por padrão, há apenas uma única VLAN para todas as portas. Essa VLAN é denominada default. Você não pode renomear nem excluir a VLAN 1.

    Execute o comando show vlan para verificar as informações da VLAN.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0
    

    Execute este conjunto de comandos no modo privilegiado para criar outra VLAN:

    3524XL#vlan database
    
    !--- Você deve entrar no banco de dados de VLANs para configurar qualquer VLAN.
    
    3524XL(vlan)#vtp server
    
    Device mode already VTP SERVER.
    
    !--- Você pode ignorar esse comando se o switch já estiver no modo de servidor e você
    !--- desejar que o switch permaneça nele.
    
    

    Nota: Um switch só poderá criar VLANs se estiver no modo de servidor VTP ou no modo transparente VTP. Consulte Compreendendo o VTP (VLAN Trunk Protocol) para obter mais informações sobre o VTP.

    524XL(vlan)#vlan ?
    
      <1-1005>  ISL VLAN index
    
    3524XL(vlan)#vlan 2 ?
    
      are        Maximum number of All Route Explorer hops for this VLAN
      backupcrf  Backup CRF mode of the VLAN
      bridge     Bridging characteristics of the VLAN
      media      Media type of the VLAN
      mtu        VLAN Maximum Transmission Unit
      name       Ascii name of the VLAN
      parent     ID number of the Parent VLAN of FDDI or Token Ring type VLANs
      ring       Ring number of FDDI or Token Ring type VLANs
      said       IEEE 802.10 SAID
      state      Operational state of the VLAN
      ste        Maximum number of Spanning Tree Explorer hops for this VLAN
      stp        Spanning tree characteristics of the VLAN
      tb-vlan1   ID number of the first translational VLAN for this VLAN (or zero
                 if none)
      tb-vlan2   ID number of the second translational VLAN for this VLAN (or zero
                 if none)
    
    3524XL(vlan)#vlan 2 name ?
    
      WORD  The ASCII name for the VLAN
    
    3524XL(vlan)#vlan 2 name cisco_vlan_2
    
    VLAN 2 added:
        Name: cisco_vlan_2
    
    3524XL(vlan)#exit
    
    !--- Você deve sair do banco de dados de VLANs para que as alterações
    !--- sejam efetivadas.
    
    APPLY completed.
    Exiting....
    3524XL#
    

    Nota: O modo VTP poderá mudar de cliente para transparente se o switch tentar aprender ou passar um número de VLANs superior ao que ele suporta. Verifique sempre se os switches que são executados em modo de cliente oferecem suporte ao mesmo número de VLANs que os switches no modo de servidor enviam.

  3. Execute o comando show vlan para garantir que a VLAN seja criada.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    2    cisco_vlan_2                     active
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1
    
  4. Você pode adicionar portas (interfaces) à VLAN recém-criada.

    Vá para o modo de configuração de interface de todas as interfaces que deseja adicionar à nova VLAN.

    Nota: Você pode atribuir as portas de um Catalyst Switch de Camada 2 a várias VLANs, mas o switch oferece suporte a apenas uma interface de VLAN de gerenciamento ativa por vez e outras interfaces virtuais comutadas (SVIs) não ficam no estado up/up devido à funcionalidade da Camada 2. Portanto, o switch oferece suporte a apenas um endereço de Camada 3 de gerenciamento ativo. Em um Catalyst Switch de Camada 2, você pode executar o comando opcional management na nova SVI para encerrar automaticamente a VLAN 1 e transferir o endereço IP para a nova VLAN.

    Switch#configure terminal
    
    Switch(config)#interface vlan 2
    
    Switch(config-subif)#management
    
    Switch(config-subif)#^Z
    
    Switch#show ip interface brief
    Interface                  IP-Address      OK? Method Status   Protocol
    VLAN1                      10.0.0.2        YES manual up       down
    VLAN2                      20.0.0.2        YES manual up       up
    FastEthernet0/1            unassigned      YES unset  up       up
    FastEthernet0/2            unassigned      YES unset  up       up
    
    !--- Saída suprimida.
    
    

    Execute este conjunto de comandos no modo privilegiado para adicionar uma determinada interface à VLAN:

    3524XL#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    3524XL(config)#interface fastethernet 0/2
    
    3524XL(config-if)#switchport access ?
    
      vlan  Set VLAN when interface is in access mode
    
    3524XL(config-if)#switchport access vlan ?
    
      <1-1001>  VLAN ID of the VLAN when this port is in access mode
      dynamic   When in access mode, this interfaces VLAN is controlled by VMPS
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- Estes comandos atribuem a interface Fast Ethernet 0/2 à VLAN 2.
    
    3524XL(config-if)#exit
    
    3524XL(config)#interface fastethernet 0/3
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- Estes comandos atribuem a interface Fast Ethernet 0/2 à VLAN 2.
    
    3524XL(config-if)#end
    
    3524XL#
    00:55:26: %SYS-5-CONFIG_I: Configured from console by console
    
    3524XL#write memory
    
    !--- Isto salva a configuração.
    
    Building configuration...
    
  5. Execute o comando show vlan para verificar a configuração da VLAN.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    Fa0/2, Fa0/3
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0
    

Remover Portas ou VLANs

Para remover portas da VLAN, execute o comando no switchport access vlan número_da_vlan no modo de configuração de interface. Após a porta ter sido removida de uma VLAN que não seja VLAN 1 (a VLAN padrão), essa porta será automaticamente adicionada novamente à VLAN padrão.

Por exemplo, se você desejar remover a interface Fast Ethernet 0/2 a partir de cisco_vlan_2 (VLAN 2), execute este conjunto de comandos no modo privilegiado:

3524XL#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

3524XL(config)#interface fastethernet 0/2

3524XL(config-if)#no switchport access vlan 2

!--- Estes dois comandos removem a interface Fast Ethernet 0/2 da VLAN 2.

3524XL(config-if)#end

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,

!--- Nota: Fast Ethernet 0/2 é adicionada novamente à VLAN padrão.

                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
2    cisco_vlan_2                     active    Fa0/3
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Para excluir a VLAN, execute o comando no vlan número_da_vlan no modo de banco de dados de VLANs. As interfaces nessa VLAN permanecem como parte da VLAN e são desativadas porque não mais pertencem a nenhuma VLAN.

Por exemplo, se você desejar excluir cisco_vlan_2 do switch, execute este conjunto de comandos no modo privilegiado:

3524XL#vlan database

!--- Este comando inicia o modo de banco de dados de VLANs.

3524XL(vlan)#no vlan 2

!--- Este comando remove a VLAN do banco de dados.

Deleting VLAN 2...

3524XL(vlan)#exit

APPLY completed.
Exiting....

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

!--- Saída suprimida.

Observe que a porta Fast Ethernet 0/3 não é exibida na saída do comando show vlan. Essa remoção da VLAN 2 desativa essa porta. A menos que você adicione novamente a porta à outra VLAN, ela não estará visível nem utilizável.

3524XL#show interfaces fastethernet 0/3

FastEthernet0/3 is down, line protocol is down

!--- Saída suprimida.

Para que a interface se torne utilizável, certifique-se de que ela pertença a alguma VLAN. No caso desta seção do documento, você deverá adicionar a interface Fast Ethernet 0/3 à VLAN padrão (VLAN 1) para que a interface se torne utilizável.

Caso possua a saída de um comando show-tech support de seu dispositivo Cisco, você poderá usar o Output Interpreter (somente clientes registrados) para exibir possíveis problemas e correções.

Nota: No caso dos Catalyst 3550 Switches, você ainda poderá usar a interface sem adicioná-la a uma VLAN. No entanto, você precisa fazer com que essa interface seja de Camada 3. Consulte a seção Configurando Interfaces da Camada 3 de Configurando Características de Interfaces para obter mais informações sobre interfaces da Camada 3 nos Catalyst 3550 Switches.

Configurar uma Porta MultiVLAN no Catalyst 2900XL/3500XL

O recurso de porta multiVLAN nos switches Catalyst 2900XL/3500XL permite que você configure uma única porta em duas ou mais VLANs. Esse recurso permite que usuários de VLANs diferentes acessem um servidor ou roteador sem implementar o recurso de roteamento entre VLANs. Uma porta multiVLAN executa as funções normais de switching em todas as VLANs que lhe foram atribuídas. O tráfego de VLAN na porta multiVLAN não é encapsulado como no trunking.

Nota: Estas são as limitações à implementação dos recursos de porta multiVLAN:

  • Você não poderá configurar uma porta multiVLAN quando um tronco estiver configurado no switch. Você poderá conectar a porta multiVLAN somente a um roteador ou servidor. O switch faz automaticamente a transição para o modo transparente VTP quando o recurso de porta multiVLAN está habilitado, o que desabilita o VTP. Nenhuma configuração de VTP é necessária.

  • Há suporte do recurso de porta multiVLAN somente nos Catalyst 2900XL/3500XL Series Switches. Não há suporte para esse recurso nos Catalyst 4500/4000, 5500/5000 ou 6500/6000 Series Switches ou qualquer outro switch Catalyst.

  1. Determine a porta a ser configurada como multiVLAN.

    Aqui, as três VLANs são criadas em um Catalyst 3512XL Switch e uma porta do switch está conectada a um roteador externo. Este exemplo configura a porta conectada ao roteador como uma porta multiVLAN.

    6-3512xl#show vlan
    
    VLAN Name                             Status      Ports
    ---- -------------------------------- ---------   -----------------------------
    1    default                          active      Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                      Fa0/8, Fa0/9, Fa0/10, Fa0/11,
                                                      Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active      Fa0/2, Fa0/4
    3    VLAN0003                         active      Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
    6    VLAN0006                         active
    

    No exemplo, a porta Fast Ethernet 0/1 está conectada a um roteador externo. Para obter mais informações sobre como criar VLANs e atribuir portas a elas, consulte a seção Configurar a VLAN nos Catalyst 2900XL, 3500XL, 2950, 2970 e 2940 Series Switches deste documento.

  2. Configure a porta Fast Ethernet 0/1 no modo multiVLAN e adicione VLANs atribuídas à porta multiVLAN.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface fastethernet 0/1
    
    6-3512xl(config-if)#switchport mode multi
    
    !--- Este comando altera o modo da porta Fast Ethernet 0/1 para multi.
    
    6-3512xl(config-if)#switchport multi vlan ?
    
      LINE    VLAN IDs of VLANs to be used in multi-VLAN mode
      add     add VLANs to the current list
      remove  remove VLANs from the current list
    
    6-3512xl(config-if)#switchport multi vlan 1,2,3
    
    !--- Este comando atribui VLANs 1, 2 e 3 à porta multi-VLAN Fast Ethernet 0/1.
    
    6-3512xl(config-if)#^Z
    
    6-3512xl#
    
  3. Execute os comandos show interface id_da_interface switchport e show vlan para verificar a configuração.

    6-3512xl#show interface fastethernet 0/1 switchport
    
    Name: Fa0/1
    Operational Mode: multi
    
    !--- A porta está no modo multi-VLAN.
    
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE
    
    Priority for untagged frames: 0
    
    Override vlan tag priority: FALSE
    
    Voice VLAN: none
    
    Appliance trust: none
    
    6-3512xl#show vlan brief
    
    VLAN Name                             Status       Ports
    ---- -------------------------------- ---------    ----------------------------
    1    default                          active       Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                       Fa0/8, Fa0/9, Fa0/10, Fa0/1
                                                       Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active       Fa0/1, Fa0/2, Fa0/4
    
    !--- Nota: Anteriormente, a porta Fast Ethernet 0/1 estava apenas na VLAN 1.
    !--- Agora, a porta está atribuída a várias VLANs 1, 2 e 3.
    
    3    VLAN0003                         active       Fa0/1, Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
    
  4. Execute o comando ping do switch para o roteador a fim de verificar a operação da multiVLAN.

    O comando ping recebe uma resposta do roteador toda vez que o endereço IP de gerenciamento é atribuído a qualquer uma das VLANs 1, 2 ou 3.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#ip address 192.168.1.1 255.255.255.0
    
    !--- O endereço IP de gerenciamento é atribuído à VLAN 1.
    
    6-3512xl(config-if)#^Z
    
    6-3512xl#
    23:56:54: %SYS-5-CONFIG_I: Configured from console by console
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- Você pode executar o ping do roteador a partir da VLAN 1.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#no ip address
    
    !--- O endereço IP de gerenciamento é removido da VLAN 1.
    
    6-3512xl(config-if)#shutdown
    
    6-3512xl(config-if)#exit
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shutdown
    
    !--- O endereço IP de gerenciamento é atribuído à VLAN 2.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- Você pode executar o ping do roteador a partir da VLAN 2.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1004 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#no ip address
    
    !--- O endereço IP de gerenciamento é removido da VLAN 2.
    
    6-3512xl(config-subif)#shutdown
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#interface vlan 3
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shut
    
    !--- O endereço IP de gerenciamento é atribuído à VLAN 3.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- Você pode executar o ping do roteador a partir da VLAN 3.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/205/1004 ms
    

Configurar a VLAN nos Catalyst 3550, 3750, 4500/4000 e 6500/6000 Switches que Executam o Cisco IOS Software

Criar VLANs e Portas

Esta seção usa o Catalyst 4500 Switch para comandos de configuração de exemplo, mas as tarefas de configuração também se aplicam a outros switches que executem a Camada 3 (ou o Cisco IOS Software). Esses outros switches incluem os Catalyst 3550, 3570 e 6500 Series Switches que executam o Cisco IOS Software. Antes de poder criar uma VLAN, o switch deve estar no modo de servidor VTP ou no modo transparente VTP. Se o switch for um servidor VTP, será necessário definir um nome de domínio VTP antes de adicionar VLANs. Você deve definir um nome de domínio VTP independentemente do:

  • Número de switches na rede, seja um único ou vários

  • Uso do VTP para propagar VLANs para outros switches na rede

Consulte Compreendendo e Configurando o VTP para obter mais informações sobre como configurar o VTP nos módulos do Supervisor Engine baseados no Cisco IOS Software do Catalyst 4500/4000. Consulte o Guia de Configuração do Software referente à plataforma do switch em questão para obter informações sobre a configuração do VTP para outras plataformas de switch Catalyst. Consulte as Páginas de Suporte a Produtos de LAN para localizar o Guia de Configuração do Software.

Você pode criar VLANs no modo de banco de dados de VLANs ou no modo de configuração global. É necessário criar VLANs com numeração superior a 1005 no modo de configuração global. O modo VTP tem que ser definido como transparente para criar essas VLANs. As VLANs com numeração superior a 1005 não são anunciadas pelo VTP. Além disso, as VLANs com numeração superior a 1005 são armazenadas no arquivo de configuração do switch e não no arquivo .dat da VLAN. O local padrão do arquivo .dat da VLAN nos Catalyst 4000 Switches com Supervisor Engine IV é o diretório cat4000_flash.

Switch#dir cat4000_flash:

Directory of cat4000_flash:/

1 -rw- 676 <no date> vlan.dat

524260 bytes total (523584 bytes free)

Nota: Um Catalyst 6500 Switch que executa o Cisco IOS Software permite que você crie VLANs no modo de servidor sem um nome de domínio VTP.

O comando show vtp status mostra as informações do VTP no switch.

Switch#show vtp status

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xA4 0x18 0x78 0x52 0x5A 0x1B 0x2E 0x14
Configuration last modified by 0.0.0.0 at 5-28-01 05:17:02
Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface)
  1. Execute o comando show vlan para verificar as informações da VLAN.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Gi1/1, Gi1/2, Gi3/1, Gi3/2
                                                    Gi3/3, Gi3/4, Gi3/5, Gi3/6
                                                    Gi3/7, Gi3/8, Gi3/9, Gi3/10
                                                    Gi3/11, Gi3/12, Gi3/13, Gi3/14
                                                    Gi3/15, Gi3/16, Gi3/17, Gi3/18
    
    !--- Saída suprimida.
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    
    Primary Secondary Type              Ports
    ------- --------- ----------------- ------------------------------------------
    
  2. Entre no modo correto, seja ele o modo de banco de dados ou de configuração global.

    Execute o comando vlan database no modo privilegiado para entrar no modo de banco de dados de VLANs.

    Switch#vlan database
    
    Switch(vlan)#
    
  3. Execute o comando vlan número_da_vlan para configurar uma VLAN.

    Switch(vlan)#vlan 2
    
    VLAN 2 added:
    Name: VLAN0002
    
    Switch(vlan)#apply
    
    APPLY completed.
    

    Nota: Para que a configuração tenha efeito, você pode executar o comando apply ou sair do modo de banco de dados de VLANs. Os métodos de saída com a palavra-chave end e com Ctrl-Z não funcionam no modo de banco de dados de VLANs. Execute o comando exit para sair desse modo.

    Execute estes comandos para executar a configuração da VLAN no modo de configuração global:

    Switch(config)#vlan 3
    
    Switch(config-vlan)#exit
    
    Switch(config)#
    
  4. Execute o comando show run para visualizar as VLANs com numeração superior a 1005 na configuração em execução.

    Switch#show running-config
    
    Building configuration...
    
    Current configuration : 2975 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname Switch
    !
    !
    ip subnet-zero
    !
    spanning-tree extend system-id
    !
    redundancy
    mode rpr
    main-cpu
    auto-sync standard
    !
    !
    vlan 2000
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    
    !--- Saída suprimida.
    
    

No Cisco IOS Software, as interfaces estão no estado shutdown por padrão, diferentemente do que acontece nos switches baseados no CatOS. No CatOS, a porta será ativada se ela detectar a presença de um link físico.

Por padrão, as interfaces do Cisco IOS Software são as interfaces da Camada 2 nos Catalyst 3550, 3750 e 4500 Series Switches. As interfaces são da Camada 3 nos Catalyst 6500/6000 Series Switches. Você pode configurar a interface como de Camada 2 com o comando switchport no modo de configuração de interface. É necessário executar esse comando antes de atribuir uma interface a uma VLAN se a interface estiver no modo de Camada 3. O comando usado para atribuir uma interface a uma VLAN é switchport access vlan número_da_vlan.

Nota: Se a interface estiver configurada como de Camada 3, o que significa que o comando no switchport está configurado, você não poderá atribuí-la a uma VLAN.

Para associar as portas às VLANs no Cisco IOS Software, esta configuração mínima é necessária:

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport

!--- Este comando será necessário se a interface estiver no modo da Camada 3.

Switch(config-if)#switchport access vlan 2

Switch(config-if)#no shutdown

Execute o comando show interface gigabitethernet módulo/interface switchport para verificar o status da interface da Camada 2.

Switch#show interface gigabitethernet 3/1 switchport

Name: Gi3/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 2 (VLAN0002)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Voice VLAN: none (Inactive)
Appliance trust: none

Se a porta estiver configurada como um tronco, o qual consiste em uma porta capaz de transportar mais de uma VLAN, o comando switchport trunk native vlan poderá ser útil. O comando será útil se a VLAN nativa da interface tiver sido alterada ou precisar mudar seus padrões. A VLAN nativa é aquela usada se a interface estiver prestes a transformar-se em uma interface de Camada 2. Se você não definir explicitamente uma VLAN nativa, a VLAN 1 torna-se a nativa por padrão. Esteja ciente de que um cabeçalho IEEE 802.1Q não é adicionado quando dados são enviados na VLAN nativa. Certifique-se de que as portas de tronco em ambos os dispositivos conectados possuam a mesma VLAN nativa. Uma incompatibilidade nas VLANs nativas pode causar problemas de roteamento entre VLANs, entre outros.

Esta mensagem é exibida quando a VLAN nativa é incompatível nos dois switches Cisco:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEhernet1/1 (2),
 with D-R3550-9B GigabitEthernet0/1 (1)

Nesta mensagem de exemplo, a VLAN nativa é a VLAN 2 em um dos switches, mas a VLAN 1 é a nativa do switch vizinho.

Execute o comando show interfaces módulo/interface trunk para ver informações sobre VLAN nativa, encapsulamento e VLAN de trunking.

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 1
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Se você usar a configuração padrão, a VLAN nativa será definida como VLAN 1. Para alterar a VLAN nativa na interface com trunking, execute o comando switchport trunk native vlan número_da_vlan.

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport trunk native vlan 2

Execute este comando para verificar:

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 2
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Atribuir Várias Portas a uma Única VLAN

Você pode atribuir as várias interfaces em um switch a uma única VLAN. Execute estes comandos:

  1. Switch(config)#interface range fastethernet [mod/slot - mod/slot]
    
  2. Switch(config-if-range)#switchport access vlan vlan_number
    
    
  3. Switch(config-if-range)#switchport mode access
    
  4. Switch(config-if-range)#no shut
    

Nota: Não há suporte para o comando interface range em todas as releases do software. O comando interface range possui suporte no Cisco IOS Software Release 12.1(13)EW e posterior.

Remover VLANs

Para remover uma VLAN do banco de dados de VLANs, execute o comando no vlan número_da_vlan no modo de banco de dados de VLANs ou de configuração global. Este exemplo usa o banco de dados de VLANs para remover a VLAN 2.

Switch#vlan database

Switch(vlan)#no vlan 2

Deleting VLAN 2...

Switch(vlan)#apply

APPLY completed.

O modo de configuração global não registra mensagens de console que indiquem a exclusão da VLAN. No entanto, você pode executar o comando show vlan para verificar a exclusão da VLAN.

Como Isolar a Comunicação entre Duas VLANs

Esta seção não aborda VLANs privadas. As VLANs privadas fornecem isolamento de Camada 2 entre as portas da mesma VLAN privada (VLAN isolada) ou entre VLANs privadas (VLANs de comunidade).

Há dois cenários em que você deve tentar isolar duas VLANs.

Isolamento entre Duas VLANs da Camada 2

Uma VLAN de Camada 2 é a VLAN criada no switch e não configurada com o comando interface vlan <número_da_vlan>. Os hosts localizados nas diferentes VLANs de Camada 2 não podem se comunicar entre si.

Execute estes passos para criar uma VLAN de Camada 2 e isolá-la de VLANs mais antigas:

  1. Crie a nova VLAN no banco de dados. Quando você sair do modo de banco de dados de VLANs, as alterações de configuração serão aplicadas.

    Switch#vlan database
    
    !--- Você deve entrar no modo de banco de dados de VLANs para
    !--- configurar qualquer VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#vlan 6
    VLAN 6 added:
        Name: VLAN0006
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
    
  2. Verifique se a VLAN foi criada no banco de dados de VLANs. A nova VLAN deverá ser exibida na saída do comando show vlan.

  3. Não defina um endereço IP para as VLANs recém-criadas.

  4. Configure interfaces físicas que conectem os clientes à VLAN correspondente.

    Switch(config)#interface fastEthernet 2/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    
    witch(config)#interface fastEthernet 2/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 6
    Switch(config-if)#no shut
    
  5. Atribua a cada host um endereço IP estático, uma máscara de sub-rede e não defina um gateway padrão. Isso fará com que os hosts nas portas fa 2/1 e 2/2 não se comuniquem entre si. Os dispositivos pertencentes a uma VLAN só alcançam dispositivos dentro da mesma VLAN.

Isolamento entre Duas VLANs da Camada 3

Quando você cria uma VLAN e atribui um endereço IP com o comando interface vlan <número_da_vlan>, a VLAN torna-se uma VLAN de Camada 3. Nos switches de Camada 3, os hosts entre as duas VLANs podem se comunicar entre si (se estiverem configurados com o gateway padrão como o endereço IP da interface de VLAN). Você pode usar ACLs para negar a comunicação entre as VLANs.

Esta seção mostra um exemplo de como isolar a comunicação entre uma VLAN de Camada 3 recém-criada e uma VLAN mais antiga.

Neste exemplo, o 3750 Switch possui duas VLANs antigas (VLAN 1 e VLAN 2). A VLAN recém-criada é a VLAN 5. A VLAN 1, a VLAN 2 e a VLAN 5 são VLANs de Camada 3. As ACLs são implementadas para negar o tráfego de modo que a VLAN 1 e a VLAN 2 não possam se comunicar com a VLAN 5 e esta, por sua vez, não possa se comunicar com a VLAN 1 ou a VLAN 2.

  • VLAN 1 - 10.10.10.0 /24

  • VLAN 2 - 172.16.1.0 /24

  • VLAN 5 - 192.168.1.0 /24

  1. Crie a nova VLAN no banco de dados. Nesse caso, a nova VLAN é a VLAN 5. Quando você sair do modo de banco de dados de VLANs, as alterações de configuração serão aplicadas.

    Switch#vlan database
    
    !--- Você deve entrar no modo de banco de dados de VLANs
    !--- para configurar qualquer VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
    
  2. Verifique se a VLAN foi criada no banco de dados de VLANs. Verifique a saída do comando show vlan.

  3. Defina um endereço IP para a VLAN recém-criada.

    Switch(config)#interface vlan 5
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config)#no shut
    
  4. Configure interfaces físicas que conectem os clientes à VLAN correspondente.

    Switch(config)#interface fastEthernet 2/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    

    É necessário configurar três listas de acesso, uma para cada VLAN.

    • Essa lista de acesso impede que o tráfego proveniente da VLAN 1 chegue à VLAN 5.

      
      !--- Alguns comandos nesta saída são quebrados
      !--- em uma segunda linha devido a restrições de espaço.
      
      Switch#configure terminal
      Switch(config)#access-list 101 deny
      ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 101 permit ip 10.10.10.0 0.0.0.255 any
      
    • Essa lista de acesso impede que o tráfego proveniente da VLAN 2 chegue à VLAN 5.

      Switch#configure terminal
      Switch(config)#access-list 102 deny ip 172.16.1.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 102 permit ip 172.16.1.0 0.0.0.255 any
      
    • Essa lista de acesso impede que o tráfego proveniente da VLAN 5 chegue à VLAN 1 e à VLAN 2.

      Switch#configure terminal
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 10.10.10.0 0.0.0.255
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
      Switch(config)#access-list 105 permit ip 192.168.1.0 0.0.0.255 any
      

    E, uma vez configuradas, aplique as listas de acesso às interfaces VLAN 1, VLAN 2 e VLAN 5, respectivamente

    Switch#configure terminal
    Switch(config)#interface vlan 1
    Switch(config-if)#ip access-group 101 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 2
    Switch(config-if)#ip access-group 102 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 5
    Switch(config-if)#ip access-group 105 in
    Switch(config-if)#end
    

Como Configurar VLANs de Intervalo Estendido em um Catalyst 6500 Series Switch

Para configurar VLANs estendidas nos Catalyst 6500 Series Switches que executam o Cisco IOS, insira o comando spanning-tree extend system-id. Em seguida, a VLAN estendida deverá ser criada no modo de configuração e não no modo de banco de dados de VLANs.

Execute estes passos para criar VLANs estendidas nos Catalyst 6500 Series Switches que executam o Cisco IOS:

  1. Abra o console no switch:

    Switch>enable
    Switch#
    
  2. Entre no modo de configuração:

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#
    
  3. Insira o comando spanning-tree extend system-id no modo de configuração:

    Switch(config)#spanning-tree extended system-id
    
  4. Insira o comando vtp mode transparent no modo de configuração:

    Switch(config)#vtp mode transparent
    
  5. Crie a VLAN no modo de configuração:

    Switch(config)#vlan 1311
    Notice
    Switch(config-vlan)#exit
    
  6. Saia do modo de configuração:

    Switch(config)#exit
    
  7. Execute o comando show vlan para verificar as informações da VLAN.

    Switch#show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active
    101  VLAN0101                         active    Gi4/8, Gi4/10
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    1311 VLAN1311                         active  
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    101  enet  100101     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    1311 enet  101311     1500  -      -      -        -    -        0      0
    

Dicas para Troubleshooting

Esta seção fornece dicas para troubleshooting que você pode encontrar durante a criação de VLANs em switches Catalyst que executam o software Cisco IOS.

Em switches que executam o Cisco IOS Software, você pode usar o próprio switch para roteamento entre VLANs em vez de usar um roteador externo. Quando uma SVI é criada, ela não cria automaticamente uma VLAN no banco de dados de Camada 2. Para que uma SVI apareça, uma VLAN deve ser criada no modo de banco de dados de VLANs ou (em versões mais recentes do Cisco IOS Software) no modo de configuração global. Para que a SVI esteja totalmente ativa, o que significa que esteja administrativamente funcional com protocolo de linha ativado, certifique-se de que pelo menos uma porta membro dessa VLAN esteja com um dispositivo ativo conectado à porta.

Essa mesma questão se aplica quando você copia configurações de um switch diferente ou restaura configurações com VLANs que foram criadas no modo de banco de dados de VLANs. Também é necessário substituir o arquivo de banco de dados de VLANs (vlan.dat) ou recriar as VLANs, conforme mostra o procedimento da seção Criar VLANs e Portas deste documento. Se você copiar a configuração de outro switch, o banco de dados de VLANs não será copiado.

Se a VLAN de Camada 2 não for criada no switch, as interfaces SVI aparecerão como UP/DOWN na saída do comando show ip interface brief quando a configuração for aplicada ao switch. Certifique-se de que todas as VLANs anteriores criadas no modo de banco de dados de VLANs ou o modo de configuração global ainda existem após a cópia da configuração para o switch.

Verificação

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Erro de Valor Inconsistente de TLB nos Switches IOS

O erro de valor inconsistente de TLB (bridging de conversão) ocorre quando você cria uma VLAN em um switch Cisco IOS que recebeu recentemente uma atualização de VTP de um switch CatOS ou que foi convertido do CatOS. Isso acontece porque o CatOS e o Cisco IOS possuem alguns valores padrão diferentes para a VLAN de bridge de conversão. As VLANs de conversão convertem FDDI (Fiber Distributed Data Interface) ou Token Ring em Ethernet. As VLANs de bridge de conversão (tb) para as VLANs 1, 1002 e 1003 são diferentes no CatOS e têm o valor 0 por padrão. As VLANs de bridge de conversão padrão de fábrica nos switches Cisco IOS são:

Vlan ID      tb1        tb2
--------     -----     -----
1            1002      1003
1002         1         1003
1003         1         1002

Um switch Cisco IOS que recebeu recentemente uma atualização de VTP de um switch CatOS ou que foi convertido do CatOS substitui os valores padrão de tb. Se você tentar criar qualquer VLAN depois disso, a seguinte mensagem de erro será gerada:

VLAN 1002 TLB 1 VLAN 1 has inconsistent TLB values (0 / 0)

Como solução alternativa para esse problema, altere os valores padrão de tb do switch Cisco IOS para as VLANs 1, 1002 e 1003 de modo que correspondam aos valores do CatOS.

switch#vlan data
switch(vlan)#no vlan 1002 tb-vlan1 tb-vlan2
switch(vlan)#no vlan 1003 tb-vlan1 tb-vlan2
switch(vlan)#apply
APPLY completed.
switch(vlan)#exit
APPLY completed.Exiting....

Recuperar o Arquivo vlan.dat nos Switches IOS

No caso dos Cisco Catalyst Switches que executam o Cisco IOS Software, as informações de VLANs estão em um arquivo separado chamado vlan.dat. Se esse arquivo for excluído acidentalmente e o switch for recarregado, todas as VLANs disponíveis no switch serão perdidas. As informações das VLANs estarão presentes no switch até que ele seja recarregado.

Execute estes passos para recuperar o arquivo vlan.dat:

  1. Execute o comando show vlan para confirmar a disponibilidade das informações da VLAN.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/10, Fa0/11, Fa0/12, Gi0/1
                                                    Gi0/2
    10   VLAN0010                         active
    11   VLAN0011                         active
    20   VLAN0020                         active
    21   VLAN0021                         active
    30   VLAN0030                         active
    31   VLAN0031                         active
    40   VLAN0040                         active
    41   VLAN0041                         active
    50   Vlan50                           active
    100  100thVLAN                        active
    
  2. Se o switch estiver no modo de servidor VTP ou no modo transparente VTP, faça todas as modificações no banco de dados de VLANs.

    As seguintes modificações podem ser feitas nesse banco de dados:

    • Criar qualquer VLAN.

    • Excluir qualquer VLAN.

    • Modificar as propriedades de qualquer VLAN existente.

    Se o switch estiver no modo de cliente VTP, faça as modificações no banco de dados de VLANs em qualquer servidor VTP do mesmo domínio.

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 50
    
    Switch(config-vlan)#name 50thVLAN
    
    Switch(config-vlan)#end
    Switch#
    

    Após serem feitas quaisquer alterações no banco de dados de VLANs, o switch criará automaticamente o arquivo vlan.dat.

  3. Execute o comando show flash: para verificar se o arquivo vlan.dat foi criado.

    Switch#show flash:
    
    Directory of flash:/
    
        2  -rwx           5   Mar 01 1993 00:04:47  private-config.text
        3  -rwx     2980487   Mar 02 1993 06:08:14  c2950-i6q4l2-mz.121-19.EA1a.bin
        4  -rwx        1156   Mar 01 1993 01:51:27  vlan.dat
       16  -rwx        1014   Mar 01 1993 00:04:47  config.text
        6  drwx        4096   Mar 02 1993 03:49:26  html
        7  -rwx     3121383   Mar 02 1993 03:47:52  c2950-i6q4l2-mz.121-22.EA9.bin
    
    7741440 bytes total (65536 bytes free)
    

Não Foi Possível Criar VLANs no Intervalo Estendido

% Failed to create VLANs [dec]
VLAN(s) not available in Port Manager.

As portas LAN de Camada 3, as interfaces WAN e as subinterfaces, além de alguns recursos do software, como RSPAN, usam VLANs internas no intervalo estendido. Não é possível usar uma VLAN de intervalo estendido alocada para uso interno.

Para exibir as VLANs usadas internamente, execute o comando show vlan internal usage. Você pode configurar a alocação de VLANs internas em ordem ascendente (de 1006 para cima) ou em ordem descendente (de 4094 para baixo).

Switch(config)#vlan internal allocation policy {ascending | descending}


!--- Insira a palavra-chave ascending para alocar as VLANs internas em ordem crescente a partir de 1006.
!--- Insira a palavra-chave descending para alocar as VLANs internas em ordem decrescente a partir de 4094.

Switch(config)#end
Switch#reload

cuidado Cuidado: Não é necessário executar o comando reload imediatamente. Execute esse comando durante uma janela de manutenção planejada. A política de alocação de VLANs internas é aplicada somente após uma recarga.

Se a recarga de dispositivos não for uma opção, como solução alternativa, você poderá usar a Conversão de VLAN. Nas portas de tronco, você pode converter um número de VLAN em outro, o que transferirá todo o tráfego recebido em uma VLAN para a outra. Consulte a seção Configurando a Conversão de VLANs de Configurando VLANs para obter mais informações.

Nota: Os switches que executam softwares da família de produtos Catalyst não oferecem suporte à configuração das VLANs 1006-1024. Se você configurar essas VLANs, verifique se elas não se estendem aos switches que executam esses softwares.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 10023