IP : Serviços de aplicação IP

Recursos e Funcionalidade do Protocolo de Roteamento de Hot-Standby

23 Março 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (28 Julho 2013) | Inglês (25 Maio 2006) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Background e Operações de HSRP
     Mecanismos de Descoberta do Roteador Dinâmico
     Operação HSRP
Endereçamento HSRP
Versão do Cisco IOS e Matriz de Funcionalidade de HSRP
Imagens de Inicialização do Cisco IOS e Funcionalidade de HSRP
Recursos HSRP
     Preempção
     Acompanhamento de Interface
     Endereço Operação Antecipada de Uso
     Vários Grupos de HSRP
     Endereço MAC Configurável
     Suporte de Syslog
     Depuração HSRP
     Depuração HSRP Aprimorada
     Autenticação
     Redundância de IP
     Base de Informações de Gerenciamento SNMP
     Suporte de HSRP para Virtual Private Networks com Multiprotocol Label Switching
     Suporte de HSRP para Redirecionamentos ICMP
Interface de HSRP e Suporte de Mídia
     Ethernet
     Token Ring
     802.1Q
     ISL
     FDDI
     Atualização MAC
     Interface Virtual do Grupo de Bridge
     Subinterfaces
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento descreve os recursos e a funcionalidade do HSRP (Protocolo de Roteamento de Hot-Standby).

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Usados

Este documento não se restringe a versões específicas de software e de hardware.

Convenções

Para obter mais informações sobre convenções de documentos, consulte Convenções de Dicas Técnicas da Cisco.

Background e Operações de HSRP

Uma maneira de obter um tempo de ativação da rede de quase 100% é usar o HSRP, que fornece redundância de rede para redes IP, garantindo que o tráfego do usuário se recupere imediatamente e de forma transparente a partir das primeiras falhas de nó nos dispositivos de extremidade de rede ou nos circuitos de acesso.

Compartilhando um endereço IP e um endereço MAC (Camada 2), dois ou mais roteadores podem agir como um roteador "virtual" simples. Os membros do grupo de roteadores virtuais transferem continuamente mensagens de status. Dessa maneira, um roteador pode assumir a responsabilidade de roteamento de outro, caso ele saia da comissão por razões planejadas ou não planejadas. Os hosts continuam encaminhando os pacotes IP para um endereço IP e MAC consistente e é transparente a comutação de dispositivos realizando o roteamento.

Mecanismos de Descoberta do Roteador Dinâmico

A seguir estão descrições de mecanismos de descoberta do roteador dinâmico disponíveis para hosts. Muitos desses mecanismos não fornecem a elasticidade de rede exigida por administradores de rede. Isso é devido ao fato de o protocolo não estar configurado inicialmente para fornecer a elasticidade de rede ou porque é impossível que cada host em uma rede execute o protocolo. Além do que está listado abaixo, é importante observar que vários hosts permitem apenas que você configure um gateway padrão.

Protocolo de Resolução de Endereço Proxy

Alguns hosts de IP usam ARP (Protocolo de Resolução de Endereço) do proxy para selecionar um roteador. Quando um host executa o ARP do proxy, envia uma requisição ARP para o endereço IP do host remoto que desejar contatar. Um roteador da rede, o Roteador A, responde em nome do host remoto e fornece seu próprio endereço MAC. Com o ARP do proxy, o host se comporta como se o host remoto estivesse conectado ao mesmo segmento da rede. Se o Roteador A falhar, o host continuará a enviar pacotes destinados ao host remoto para o endereço MAC do Roteador A, mesmo que esses pacotes não tenham para onde ir e sejam perdidos. Você pode aguardar pelo ARP para obter o endereço MAC de outro roteador, o Roteador B, no segmento local enviando outra requisição ARP, ou reinicializar o host para forçá-lo a enviar uma requisição ARP. Em qualquer um dos casos, por um tempo significativo, o host não pode se comunicar com o host remoto, mesmo que o protocolo de roteamento tenha sido convergido e o Roteador B esteja preparado para transferir pacotes que de alguma forma passam pelo Roteador A.

Protocolo de Roteamento Dinâmico

Alguns hosts de IP executam (ou espionam) um protocolo de roteamento dinâmico, como o RIP (Routing Information Protocol) ou o OSPF (Abrir Caminho Mais Curto Primeiro) para descobrir roteadores. A desvantagem de usar o RIP é que ele é lento para se adaptar às alterações na topologia. Executar um protocolo de roteamento dinâmico em cada host pode não ser viável por diversas razões, entre as quais a sobrecarga administrativa, a sobrecarga de processamento ou a falta de uma implementação de protocolo para algumas plataformas.

Protocolo de Descoberta do Roteador ICMP

Alguns hosts de IP mais recentes usam o IRDP (Protocolo de Descoberta do Roteador ICMP) (RFC 1256 leavingcisco.com) para localizar um novo roteador quando uma rota se torna indisponível. Um host que executa o IRDP ouve mensagens de saudação de multicast do roteador configurado e usa um roteador alternativo quando não recebe mais essas mensagens de saudação. Os valores do temporizador padrão de IRDP indicam que isso não é adequado para a detecção de falhas do primeiro nó. A taxa de anúncio padrão é um a cada 7 a 10 minutos, e o tempo de vida padrão é de 30 minutos.

Protocolo de Configuração de Host Dinâmico

O DHCP (Protocolo de Configuração de Host Dinâmico) (RFC 1531 leavingcisco.com) fornece um mecanismo para transmissão de informações de configuração para hosts em uma rede TCP/IP. Um host que executa um cliente DHCP solicita informações de configuração de um servidor DHCP quando é inicializado na rede. Essas informações de configuração geralmente consistem em um endereço IP e um gateway padrão. Não haverá mecanismo para switching para um roteador alternativo se o gateway padrão falhar.

Operação HSRP

Uma grande classe de implementações de host herdadas que não suportam descoberta dinâmica é capaz de configurar um roteador padrão. Executar um mecanismo de descoberta de roteador dinâmico em cada host pode não ser adequado por diversas razões, incluindo sobrecarga administrativa, sobrecarga de processo, problemas de segurança ou falta de implementação de um protocolo para algumas plataformas. O HSRP fornece serviços de failover para esses hosts.

Usando o HSRP, um conjunto de roteadores trabalha de comum acordo para apresentar a ilusão de um único roteador virtual para os hosts na LAN. Esse conjunto é conhecido como grupo de HSRP ou grupo em espera. Um único roteador eleito no grupo é responsável por encaminhar os pacotes que os hosts enviam ao roteador virtual. Esse roteador é conhecido como o roteador Ativo. Outro roteador é eleito como roteador em espera. Em caso de falha do roteador Ativo, o Standby assume as funções de encaminhamento de pacotes do Ativo. Embora um número arbitrário de roteadores possa executar o HSRP, apenas o roteador ativo encaminhará os pacotes enviados ao roteador virtual.

Para minimizar o tráfego da rede, apenas os roteadores Ativo e em Espera enviam mensagens de HSRP periódicas depois de o protocolo ter concluído o processo de eleição. Se o roteador Ativo falhar, o roteador em Espera assumirá o lugar do roteador Ativo. Se o roteador em Espera falhar ou se tornar um roteador Ativo, então outro roteador será escolhido como roteador em Standby.

Em uma LAN específica, diversos grupos em standby recente podem coexistir e se sobrepor. Cada grupo em standby emula um único roteador virtual. Os roteadores individuais podem participar de vários grupos. Nesse caso, o roteador mantém um estado separado e temporizadores para cada grupo.

Cada grupo em standby tem um único endereço MAC e um único endereço IP conhecidos.

Endereçamento HSRP

Na maioria dos casos, quando você configura roteadores para fazerem parte de um grupo HSRP, eles ouvem o endereço MAC do HSRP desse grupo e também os seus próprios endereços de operação. A exceção são roteadores cujos controladores Ethernet reconhecem apenas um único endereço MAC (por exemplo, o controlador Lance nos roteadores Cisco 2500 e Cisco 4500). Esses roteadores usam o endereço MAC de HSRP quando forem o roteador Ativo; caso contrário, usam o endereço de operação antecipada.

O HSRP usa o seguinte endereço MAC em todas as mídias, exceto Token Ring:

0000.0c07.ac**   (where ** is the HSRP group number)

As interfaces Token Ring usam endereços funcionais para o endereço MAC do HSRP. Os endereços funcionais são os únicos mecanismos gerais de multicast disponíveis. Há um número limitado de endereços funcionais de Token Ring disponível e muitos deles são reservados para outras funções. Você pode usar os três endereços a seguir com HSRP:

c000.0001.0000   (group 0)
c000.0002.0000   (group 1)
c000.0004.0000   (group 2)

Observação: Quando o HSRP é executado em um ambiente SRB (conexão de ligação de rota de origem) de vários anéis e os roteadores HSRB residem em anéis diferentes, o uso de endereços funcionais pode causar confusão de RIF (Campo de Informações de Roteamento). Por exemplo, em um ambiente SRB é possível que o roteador HSRP em espera se localize em um anel diferente do roteador ativo. Quando esse roteador em espera se torna ativo, as estações no mesmo anel como o antigo roteador ativo precisam de um novo RIF para enviar pacotes para o novo roteador ativo. No entanto, como o roteador em standby (recém-ativado) está usando o mesmo endereço funcional do roteador ativo anterior, as estações não estão cientes de que devem enviar exploradores de envio para um novo RIF. Por essa razão, o comando use-bia foi introduzido.

Versão do Cisco IOS e Matriz de Funcionalidade de HSRP

Este documento mostra os recursos HSRP suportados pelas versões do Cisco IOS® Software. Clique no recurso para visualizar uma descrição detalhada. Um número de versão temporária indica em que versão um recurso apareceu primeiro ou uma versão em que a funcionalidade desse recurso foi alterada.

Recurso

10.0

10.2

10.3

11.0

11.1

11.2

11.3

12.0

12.0T

12.1

12.1T

Preempção

X

X

X

X

X

X

X

X

X

X

X

Vários Grupos (MHSRP)

X

X

X

X

X

X

X

X

X

Ethernet 802.10 SDE

X

X

X

X

X

X

X

Acompanhamento de Interface

X

X

X

X

X

X

X

Use BIA

8.0

X

X

X

X

X

X

Retardo da Apropriação

X

X

6.1

X

X

X

PISTA de Ethernet

X

X

X

X

X

X

LANE de Token Ring

X

X

X

X

X

ISL

X

X

X

X

X

Suporte de Syslog

X

X

X

X

X

Intervalo de Atualização MAC

1.0

X

X

X

SNMP MIB

3.0

X

X

MHSRP e Use BIA

3.4

X

X

Redundância de IP

3.4

X

X

BVI

6.2

X

X

802.1Q

8.1

X

X

Depuração HSRP Aprimorada

0.2

X

Redirecionamentos HSRP de ICMP

3

MPLS VPNs de HSRP

3

Imagens de Inicialização do Cisco IOS e Funcionalidade de HSRP

A funcionalidade de HSRP foi incluída nas imagens de inicialização do Cisco IOS até a integração da identificação do bug Cisco CSCec16720 (apenas clientes registrados). A identificação do bug Cisco CSCec16720 removeu o HSRP das imagens de inicialização com exceção de:

  • c7200-boot-mz

  • c7200-kboot-mz

  • c10k-eboot-mz

  • c4500-boot-mz

  • c7200-boot-mz

  • c7200-kboot-mz

  • c7400-kboot-mz

  • ubr7200-boot-mz

  • c6400r-boot-mz

  • rpm-boot-mz

  • rpmxf-boot-mz

  • Rsp-boot-mz

  • urm-wboot-mz

  • c5350-boot-mz

  • c5400-boot-mz

  • c7301-boot-mz

  • c5850-boot-mz

  • c4gwy-cboot-mz

  • ubr910-rboot-mz

  • ubr910-rboot-mz

  • ubr925-k8boot-mz

  • c5850tb-boot-mz

Recursos HSRP

Preempção

O recurso de preempção de HSRP permite que o roteador com a prioridade mais alta se torne imediatamente o roteador Ativo. A prioridade é determinada, primeiro, pelo valor de prioridade que você configura e, então, pelo endereço IP. Em cada caso, o valor mais alto tem maior prioridade.

Quando um roteador com prioridade mais alta se apropria de um roteador com prioridade mais baixa, ele envia uma mensagem de vitória. Quando um roteador ativo de prioridade mais baixa recebe uma mensagem de vitória ou de saudação de um roteador ativo de prioridade mais alta, ele passa para o estado de fala e envia uma mensagem de renúncia.

Retardo da Preempção

O recurso de retardo da preempção permite que a apropriação seja retardada para um período de tempo configurável, permitindo que o roteador preencha sua tabela de roteamento antes de se tornar um roteador ativo.

Antes do Cisco IOS Software versão 12.0(9), o retardo começava quando o roteador recarregava. No Cisco IOS versão 12.0(9), o retardo começa quando a preempção é tentada pela primeira vez.

Para configurar a prioridade e a preempção de HSRP, use o comando standby [group] [priority number] [preempt [delay [minimum] seconds] [sync seconds]].

Consulte a Documentação para obter mais informações sobre como configurar o HSRP.

Acompanhamento de Interface

O acompanhamento de interface permite especificar uma outra interface no roteador que deverá ser monitorada pelo processo HSRP a fim de alterar a prioridade de HSRP de um grupo específico.

Se o protocolo de linha da interface especificada for desativado, a prioridade de HSRP desse roteador será reduzida, permitindo que outro roteador HSRP com prioridade mais alta se torne ativo (se ele tiver preempção habilitada).

Para configurar o acompanhamento de interface de HSRP, use o comando standby [group] track interface [priority].

Quando várias interfaces controladas estão desativadas, a prioridade é reduzida em uma quantidade cumulativa. Se você definir explicitamente o valor de decréscimo, esse valor será reduzido com base nessa quantidade se a interface estiver desativada e os decréscimos serão cumulativos. Se você não definir uma diminuição explícita de valor, o valor será diminuído em 10 para cada interface desativada, e as diminuições serão acumulativas.

O exemplo a seguir usa a seguinte configuração, com o valor de decréscimo padrão de 10.

Observação: Quando um número do grupo HSRP não for especificado, o número do grupo padrão será 0.

interface ethernet0
     ip address 10.1.1.1 255.255.255.0
     standby ip  10.1.1.3
     standby priority 110
     standby track serial0
     standby track serial1

O comportamento de HSRP com essa configuração é:

  • 0 interface desativada = nenhuma diminuição (a prioridade é 110)

  • 1 interface inativa = redução de 10 (a prioridade torna-se 100)

  • 2 interfaces desativada = diminuído por 10 (a prioridade torna-se 90)

O comportamento de HSRP acima é verdadeiro mesmo que os valores de decréscimo estejam configurados explicitamente, como a seguir.

interface ethernet0
     ip address 10.1.1.1 255.255.255.0
     standby ip  10.1.1.3
     standby priority 110
     standby track serial0 10
     standby track serial1 10

Antes do Cisco IOS versão 12.1, se um roteador fosse iniciado com uma interface inativa, o rastreamento de interface HSRP consideraria a interface como ativa.

Esse defeito tem a identificação do bug Cisco CSCdp32289 (clientes registrados somente) .

Endereço Operação Antecipada de Uso

O recurso BIA (endereço operação antecipada de uso), permite que grupos de HSRP usem o endereço MAC de operação antecipada da interface, em vez de um endereço MAC de HSRP. Use BIA foi implementado pela primeira vez no Cisco IOS versão 11.1(8). Para configurar o HSRP para usar a BIA, use o comando standby use-bia [scope interface].

O comando use-bia foi implementado para superar as limitações do uso de um endereço funcional para o endereço MAC de HSRP em interfaces Token Ring.

Observação: Quando o HSRP é executado em um ambiente de conexão de ligação roteado de origem e de vários anéis e os roteadores HSRP residem em anéis diferentes, o uso dos endereços funcionais pode causar confusão de RIF. Por essa razão, o comando use-bia foi introduzido.

O recurso use-bia permite também o uso de DECnet, Xerox Network Systems (XNS) e HSRP no mesmo roteador, permitindo que o endereço MAC de DECnet (a BIA) seja usado como o endereço MAC de HSRP. O comando use-bia é útil também em situações de comunicação de rede em que uma BIA do dispositivo foi configurada em outros dispositivos na LAN.

No entanto, o comando use-bia tem inúmeras desvantagens:

  • Quando um roteador se torna ativo, o endereço IP virtual é movido para um endereço MAC diferente. O roteador recém-ativo envia uma resposta ARP gratuita, mas nem todas as implementações de host lidam com o ARP gratuito de modo correto.

  • O Proxy ARP é interrompido quando use-bia é configurado. Um roteador em standby não pode cobrir o banco de dados ARP do proxy perdido de um roteador que falhou.

  • Antes da versão 12.0(3.4)T do Cisco IOS, apenas um grupo de HSRP seria permitido se use-bia estivesse configurado.

Ao configurar o comando use-bia em uma subinterface, ele é realmente mostrado na interface principal e é aplicado em todas as subinterfaces. No Cisco IOS versão 12.0(6.2) e posterior, o comando use-bia é estendido com as palavras-chave da interface de escopo opcional para permitir que seja aplicado a uma única subinterface.

Esse defeito tem a identificação do bug Cisco CSCdm25468 (clientes registrados somente) .

Vários Grupos de HSRP

O recurso de vários grupos de HSRP (MHSRP) foi adicionado no Cisco IOS versão 10.3. Esse recurso permite também redundância e compartilhamento de carga dentro de redes e permite que roteadores redundantes sejam utilizados mais plenamente. Enquanto um roteador estiver encaminhando ativamente o tráfego para um grupo de HSRP, ele poderá ficar em espera ou no estado de escuta para outro grupo.

A partir do Cisco IOS versão 12.0(3.4)T, você pode usar o comando use-bia com vários grupos de HSRP habilitados.

Endereço MAC Configurável

Normalmente você usa o HSRP para ajudar as estações finais a localizar o primeiro gateway de nós para roteamento IP. As estações finais são configuradas com um gateway padrão. Entretanto, o HSRP pode fornecer a primeira redundância de nó para outros protocolos. Alguns protocolos, como o APPN (Rede peer-to-peer avançada), usam o endereço MAC para identificar o primeiro salto para o roteamento.

Nesse caso, é normalmente necessário ser capaz de especificar o endereço MAC virtual usando o comando standby mac-address. O endereço IP virtual não é importante para esses protocolos. A sintaxe real do comando é standby [group] mac-address mac-address.

Observação: Você não pode usar esse comando em uma interface Token Ring.

Suporte de Syslog

O suporte a mensagens de syslog para informações de HSRP foi adicionado ao Cisco IOS versão 11.3. Esse recurso permite registro mais eficiente e rastreamento dos roteadores ativo e em espera nos servidores de syslog.

Depuração HSRP

Antes da versão 12.1 do Cisco IOS, o comando de depuração de HSRP era relativamente simples. Para ativar a depuração HSRP, deve-se simplesmente usar o comando debug standby, que habilita a saída do estado de HSRP e as informações do pacote de todos os grupos em standby em todas as interfaces.

Uma condição de depuração foi adicionada ao Cisco IOS versão 12.0(2.1) que permite que a saída do comando standby debug seja filtrada com base na interface e no número de grupo. O comando utiliza o paradigma debug condition introduzido no Cisco IOS versão 12.0, como a seguir: debug condition standby interface group . A interface especificada deve ser uma interface válida capaz de suportar o HSRP. O grupo pode ser qualquer grupo (0-255).

Você pode definir condições de depuração para grupos que não existem, o que permite capturar informações de depuração durante a inicialização de um novo grupo.

Você deve habilitar a ordem standby debug para qualquer saída de depuração a ser produzida. Se você não configurar nenhuma condição standby debug, a saída de depuração será produzida para todos os grupos em todas as interfaces. Se você configurar pelo menos uma condição standby debug, então a saída standby debug será filtrada de acordo com todas as condições standby debug.

Depuração HSRP Aprimorada

Antes do Cisco IOS versão 12.1(0.2), a depuração de HSRP era de uso limitado, pois as informações ficavam perdidas no ruído de mensagens de saudação periódicas. Assim, o recurso de depuração avançada foi adicionado ao Cisco IOS 12.1(0.2).

A tabela a seguir explica as opções de comando para depuração avançada.

Comando

Descrição

debug standby

Exibe todos os erros, eventos e pacotes de HSRP.

debug standby terse

Exibe todos os erros, eventos e pacotes de HSRP, exceto pacotes de saudações e anúncios.

debug standby errors

Exibe os erros de HSRP.

debug standby events [[all | terse] | [icmp | protocol | redundancy | track]] [detail]

Exibe os eventos de HSRP.

debug standby packets [[all | terse] | [advertise | coup | hello | resign]] [detail]

Exibe os pacotes de HSRP.

Você pode filtrar a saída debug, usando a depuração condicional de interface e de grupo de HSRP. Para habilitar a depuração condicional de interface, use o comando debug condition interface interface . Para habilitar a depuração condicional de HSRP, use o comando debug condition standby interface group .

Uma condição de depuração de interface se aplica quando você não define nenhuma condição standby debug. A depuração de HSRP está ainda mais aprimorada no Cisco IOS versão 12.1(1.3), com base em melhorias feitas na tabela de estados de HSRP.

Esse defeito tem a identificação do bug Cisco CSCdp57811 (clientes registrados somente) .

Essas melhorias apresentam os eventos da tabela de estados de HSRP. Na saída abaixo, a/, b/, c/, etc., referem-se a eventos da máquina de estado finito de HSRP, que estão documentados em RFC 2281 leavingcisco.com.

SB1: Ethernet0/2 Init: a/HSRP enabled
SB1: Ethernet0/2 Active: b/HSRP disabled (interface down)
SB1: Ethernet0/2 Listen: c/Active timer expired (unknown)
SB1: Ethernet0/2 Active: d/Standby timer expired (20.0.0.3)
SB1: Ethernet0/2 Speak: f/Hello rcvd from higher pri Speak router
SB1: Ethernet0/2 Active: g/Hello rcvd from higher pri Active router
SB1: Ethernet0/2 Speak: h/Hello rcvd from lower pri Active router
SB1: Ethernet0/2 Standby: i/Resign rcvd
SB1: Ethernet0/2 Active: j/Coup rcvd from higher pri router
SB1: Ethernet0/2 Standby: k/Hello rcvd from higher pri Standby router
SB1: Ethernet0/2 Standby: l/Hello rcvd from lower pri Standby router
SB1: Ethernet0/2 Active: m/Standby mac address changed
SB1: Ethernet0/2 Active: n/Standby IP address configured

Autenticação

O recurso de autenticação HSRP consiste em uma chave de texto claro compartilhada com os pacotes de HSRP. Esse recurso impede que o roteador de prioridade mais baixa conheça o endereço IP de standby e os valores do cronômetro em standby do roteador de prioridade mais alta.

Para configurar a string de autenticação de HSRP, use o comando standby authentication string .

Redundância de IP

O HSRP fornece redundância stateless para roteamento IP. O HSRP, por si só, limita-se a manter o próprio estado. Ele supõe que cada roteador constrói e mantém suas próprias tabelas de roteamento, independentemente de outros roteadores. O recurso de redundância de IP fornece um mecanismo que permite que o HSRP forneça um serviço a aplicativos clientes para que possam implementar failover de estado.

A redundância de IP não fornece um mecanismo para aplicativos de correspondentes para trocar informações de estado. Isso é deixado para os próprios aplicativos e será essencial se os aplicativos tiverem de fornecer failover de estado.

A redundância de IP está implementada atualmente (desde janeiro de 2000) apenas no Mobile IP Home Agents. A seguir está uma configuração de exemplo:

configure terminal
 router mobile
 ip mobile home-agent standby hsrp-group1
!
interface e0/2
 no shutdown
 ip address 20.0.0.1 255.0.0.0
 standby 1 ip 20.0.0.11
 standby 1 name hsrp-group1

Observação: A partir do Cisco IOS versão 12.1(3)T, a palavra-chave redundancy é aceita em adição à palavra-chave standby. A palavra-chave standby será removida em uma versão posterior do Cisco IOS. Portanto, o comando correto será ip mobile home-agent redundancy hsrp-group1.

Os usos futuros de redundância de IP podem incluir:

  • NAT – Necessário fornecer gateways redundantes.

  • IPSEC – Necessário sincronizar as informações de estado para operação quando o HSRP estiver em uso.

  • Servidor DHCP - Servidores DHCP implementados em vários roteadores.

  • NBAR, CBAC – Necessário refletir estados de firewall para roteamento assimétrico.

  • GPRS – Necessário encontrar uma maneira de rastrear o estado de TCP.

  • PIX

Base de Informações de Gerenciamento SNMP

O suporte MIB (Base de Informações de Gerenciamento) SNMP foi adicionado ao Cisco IOS versão 12.0(3.0)T. Há dois MIBs relevantes para HSRP:

  • ciscoMgmt 106: O módulo MIB para gerenciamento de HSRP

  • ciscoMgmt 107: O módulo de MIB de extensão para gerenciamento de HSRP

Antes do Cisco IOS versão 12.0(6.1)T, uma passagem da MIB estendida para HSRP quando uma BVI (Bridge Group Virtual Interface) está presente causa um defeito no roteador.

Esse defeito tem a identificação do bug Cisco CSCdm61257 (clientes registrados somente) .

Suporte de HSRP para Virtual Private Networks com Multiprotocol Label Switching

O suporte de HSRP para Virtual Private Networks com Multiprotocol Label Switching (VPNs MPLS) foi adicionado ao Cisco IOS versão 12.1(3)T.

O HSRP em uma interface MPLS VPN é útil quando existe um cabo Ethernet conectado entre duas Pes (Pontas de Provedor) e você possui um dos seguintes:

  • Um Edge de cliente (CE) com uma rota padrão para o endereço IP virtual de HSRP.

  • Um ou mais hosts com o endereço IP virtual de HSRP configurado como o gateway padrão.

O diagrama de rede abaixo mostra duas PEs com HSRP em execução entre suas interfaces VPN de roteamento e encaminhamento (VRF). Configuramos o CE com o endereço IP virtual do HSRP como rota padrão. E configuramos o HSRP para rastrear as interfaces que conectam as PEs ao restante da rede do provedor. Por exemplo, se a interface E1 da PE1 falhar, a prioridade de HSRP será reduzida de modo que a PE2 assumirá o encaminhamento de pacotes para o endereço IP/MAC virtual.

hsrpguide4a.gif

As configurações estão a seguir.

Router PE1

Router PE2

                  conf terminal
!
ip cef
!
ip vrf vrf1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface ethernet0
 no shutdown
 ip vrf forwarding vrf1
 ip address 10.2.0.1 255.255.0.0
 standby 1 ip 10.2.0.20
 standby 1 priority 105
 standby 1 preempt delay minimum 10
 standby 1 timers 3 10
 standby 1 track ethernet1 10
 standby 1 track ethernet2 10
                  conf terminal
!
ip cef
!
ip vrf vrf1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface ethernet0
 no shutdown
 ip vrf forwarding vrf1
 ip address 10.2.0.2 255.255.0.0
 standby 1 ip 10.2.0.20
 standby 1 priority 100
 standby 1 preempt delay minimum 10
 standby 1 timers 3 10
 standby 1 track ethernet1 10
 standby 1 track ethernet2 10

Você pode usar os seguintes comandos para verificar se o endereço IP virtual de HSRP está no ARP VRF correto e nas tabelas do Cisco Express Forwarding:

ed1-pe1# show ip arp vrf vrf1
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.0.1                -   00d0.bbd3.bc22  ARPA   Ethernet0/2
Internet  10.2.0.20               -   0000.0c07.ac01  ARPA   Ethernet0/2

ed1-pe1# show ip cef vrf vrf1
Prefix              Next Hop             Interface
0.0.0.0/0           10.3.0.4             Ethernet0/3
0.0.0.0/32          receive
10.1.0.0/16         10.2.0.1             Ethernet0/2
10.2.0.0/16         attached             Ethernet0/2
10.2.0.1/32         receive
10.2.0.20/32        receive
224.0.0.0/24        receive
255.255.255.255/32  receive

Suporte de HSRP para Redirecionamentos ICMP

O HSRP está baseado no conceito de que os roteadores de peer que estão protegendo uma sub-rede podem fornecer acesso a todas as demais sub-redes que compõem a rede. Portanto, é irrelevante saber qual roteador se tornou o roteador HSRP ativo, pois todos os roteadores possuíam rotas para cada sub-rede.

O HSRP utiliza um endereço IP virtual especial e um endereço MAC virtual, que são conectados de modo lógico ao roteador ativo de HSRP. Os redirecionamentos ICMP são desativados automaticamente em uma interface quando usam HSRP nessa interface. Do IOS 12.1(3)T em diante, o recurso Redirecionamentos ICMP habilita o ICMP a redirecionar em interfaces configuradas com HSRP. Consulte Suporte de HSRP para Redirecionamentos ICMP para obter mais detalhes. Isso é feito para evitar que os hosts sejam redirecionados para longe do endereço IP virtual do HSRP. É possível que os dois (ou mais) roteadores de uma sub-rede não tenham conectividade idêntica à do restante da rede. Ou seja, para um endereço IP de destino específico, um roteador ou o outro deve ter um caminho muito melhor até aquele endereço ou pode até mesmo ser o único roteador conectado àquele endereço.

O protocolo ICMP permite que um roteador redirecione uma estação final para enviar pacotes de um determinado destino para outro roteador na mesma sub-rede. Isso se o primeiro roteador souber que o outro roteador tem um caminho melhor para aquele destino em particular. Como foi no caso dos gateways padrão, se o roteador ao qual uma estação final foi redirecionada para um destino específico falhar, pacotes da estação final para aquele destino não foram entregues. No HSRP padrão, é exatamente isso o que acontece. Por essa razão, recomendamos desabilitar os redirecionamentos de ICMP se o HSRP estiver ativado.

A extensão do relacionamento entre redirecionamentos ICMP e HSRP fornece uma solução para esse problema, permitindo a obtenção de vantagens sobre os benefícios dos dois redirecionamentos HSRP e ICMP. Dois (ou mais) grupos de HSRP são executados em cada sub-rede, com pelo menos o mesmo número de grupos de HSRP configurados que o de roteadores participantes. As prioridades são configuradas de forma que cada roteador seja mestre de pelo menos um grupo de HSRP. Quando um roteador é determinado a redirecionar uma estação final para um roteador diferente em um destino específico, então, em vez de redirecionar a estação final para o endereço IP desse outro roteador, ele encontra um grupo de HSRP que está sendo tratado como mestre por esse roteador e redireciona a estação final para o endereço IP virtual correspondente. Se o roteador de destino falhar, o HSRP garantirá que outro roteador assuma sua função e talvez redirecione a estação final para outro roteador também virtual.

Interface de HSRP e Suporte de Mídia

Esta seção explica as interfaces e mídias o HSRP suporta e as possíveis advertências ao executar o HSRP sobre essas mídias.

Desde o Cisco IOS Software versão 10.0, a funcionalidade de HSRP foi disponibilizada na Ethernet, Token Ring e FDDI (Fiber Distributed Data Interface). As interfaces Fast Ethernet e ATM também são suportadas pelo HSRP.

LANs Virtuais (VLANs) permitem que as topologias de redes lógicas se sobreponham à infra-estrutura comutada física de tal modo que qualquer grupo arbitrário de portas de LAN possa ser combinado em um grupo de usuários autônomos ou comunidade de interesses. Suporte de HSRP VLAN foi adicionado ao Cisco IOS versão 11.1 para IEEE 802.10 Secure Data Exchange (SDE) e ao Cisco IOS versão 11.3 para Cisco Inter-Switch Link (ISL).

Ethernet

Diversos controladores Ethernet (Lance e QUICC) em produtos low-end podem ter somente um único endereço MAC de envio único em seu filtro de endereço. Nessas plataformas, é permitido somente um grupo de HSRP, e o endereço da interface é alterado para endereço MAC virtual de HSRP quando o grupo fica Ativo. Caso esteja usando HSRP em roteadores com diversas interfaces desse tipo, você deverá configurar cada interface com um número de grupo HRSRP diferente.

Observação: O roteador Cisco 7200 também usa o controlador Lance Ethernet, mas suporta MHSRP no software.

A Cisco recomenda que você tenha no máximo 24 Processadores de Interface Ethernet HSRP (EIPs) devido ao tempo que demora para atualizar os filtros de endereço para o HSRP. Mais de vinte e quatro HSRP EIPs podem causar instabilidade e carga excessiva para a CPU.

Esse defeito tem a identificação do bug Cisco CSCdj29595 (clientes registrados somente) .

Se você tiver mais de vinte e quatro EIPs, tente substituir os EIPs por VIPs (Processadores de Interface Versáteis) e adaptadores de porta Ethernet. Os VIPs foram aprovados para até oitenta grupos de HSRP. Você pode também reduzir o número de grupos de HSRP e aumentar o tempo de saudação e de espera do HSRP.

Token Ring

Uma limitação da execução do HSRP em uma interface Token Ring é que você não pode reprogramar o filtro de endereços no conjunto de chips Token Ring, do mesmo modo que pode na emulação de Ethernet, FDDI ou ATM. O Token Ring usa endereços funcionais, dos quais há apenas um pequeno número disponível que não entra em conflito com outros usos do espaço de endereço funcional.

Ao executar o HSRP em um ambiente de Ligação de Rota de Origem (SRB), o uso de endereços funcionais pode causar confusão de RIF. Consulte a seção Endereçamento HSRP para obter mais informações. Além disso, tente configurar o comando use-bia.

802.1Q

A Cisco recomenda o uso do Cisco IOS versão 12.0(8.1)T ou posterior para HSRP por 802.1Q.

ISL

O HSRP sobre ISL está disponível no Cisco IOS versões 11.2(6)F, 11.3 e 12.X. É recomendado usar a versão 12.0(7) ou posterior para evitar o problema descrito na identificação do bug Cisco CSCdm68811 (clientes registrados somente) .

FDDI

Um adaptador de porta FDDI retira quadros do anel se perceber que um de seus próprios endereços MAC está localizado na fonte MAC. Se um evento de rede fizer com que os roteadores fiquem ativos, então os dois roteadores enviarão pacotes de saudação de HSRP com o mesmo endereço MAC virtual. Cada roteador retira erroneamente o pacote de saudação do outro roteador da rede e ambos permanecem ativos.

Esse defeito tem a identificação do bug Cisco CSCdj30049 (clientes registrados somente) .

A solução desse problema no Cisco IOS versão 11.2(11.1) é para que roteadores HSRP em um ambiente FDDI possam usar seu próprio endereço MAC exclusivo de operação antecipada para trocar mensagens e executar o protocolo de HSRP. Para assegurar que os switches e bridges de aprendizagem coloquem em cache a entrada de porta correta para o endereço MAC virtual, o roteador ativo também envia mensagens usando o endereço MAC de HSRP.

Observação: A CAM (memória de conteúdo endereçável) do hardware do roteador Cisco 4500 em uma interface FDDI talvez não seja preenchida corretamente depois de uma recarga, caso você tenha configurado várias redes RIP e grupos de HSRP. A única solução nesse momento é limpar as interfaces para restaurar a CAM. Esse defeito tem a identificação do bug Cisco CSCdm93122 (clientes registrados somente) .

Atualização MAC

Os roteadores HSRP em um ambiente FDDI usam seu próprio endereço MAC exclusivo de operação antecipada para trocar mensagens e executar o protocolo de HSRP. Para garantir que switches e bridges de aprendizado armazenem em cache a entrada de porta correta para o endereço MAC virtual, o roteador ativo também envia mensagens de atualização periódica usando o endereço MAC de HSRP. Esse defeito tem a identificação do bug Cisco CSCdj30049 (clientes registrados somente) .

Se você não tiver um switch ou um bridge de aprendizagem em sua rede, poderá desabilitar o envio de pacotes de atualização, conforme mostrado abaixo:

interface fddi 1/0/0
 ip address 10.1.1.1 255.255.255.0
 standby ip 10.1.1.250
 standby mac-refresh 0

Interface Virtual do Grupo de Bridge

O suporte de HSRP a BVIs (Interfaces Virtuais do Grupo de Bridge) foi adicionado no Cisco IOS versão 12.0(6.2)T.

Subinterfaces

Grupos HSRP em subinterfaces devem ter um número de grupo exclusivo entre todos os outros grupos em todas as subinterfaces na mesma interface principal. Isso ocorre porque as subinterfaces não recebem um índice exclusivo de interface SNMP. Se houvesse dois grupos com o número N em diferentes subinterfaces, o grupo N da subinterface 1 e o grupo N da subinterface 2 pareceriam ser o mesmo grupo, no MIB.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 9234