IP : Roteamento IP

Redistribuindo Protocolos de Roteamento

24 Maio 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (22 Março 2012) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Métricas
Distância Administrativa
Sintaxe e Exemplos de Configuração de Redistribuição
     IGRP e EIGRP
     OSPF
     RIP
     IS-IS
     Rotas Conectadas
Evitando Problemas Devido à Redistribuição
     Exemplo 1
     Exemplo 2
     Exemplo 3
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

A utilização de um protocolo de roteamento para anunciar rotas que são aprendidas por alguns outros meios, como por um outro protocolo de roteamento, rotas estáticas ou rotas conectadas diretamente, é chamada de redistribuição. Embora executar um protocolo de roteamento único por toda a inter-rede IP seja desejável, o roteamento multiprotocolo é comum por diversas razões, por exemplo, fusões de empresas, diversos departamentos gerenciados por vários administradores de rede e ambientes com diversos fornecedores. A execução de protocolos de roteamento diferentes faz normalmente parte de um projeto de rede. Em qualquer caso, ter um ambiente de vários protocolos torna a redistribuição uma necessidade.

As diferenças nas características dos protocolos de roteamento, como métricas, distância administrativa, recursos com e sem classe, podem afetar a redistribuição. É necessário levar essas diferenças em consideração para que a redistribuição seja bem-sucedida.

Pré-requisitos

Requisitos

Não existem pré-requisitos específicos para este documento.

Componentes Usados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Cisco IOS Software® Versão 12.2(10b)

  • Cisco 2500 Series Routers

As informações apresentadas neste documento foram criadas a partir dos dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento foram iniciados com uma configuração vazia (padrão). Caso esteja trabalhando em uma rede ativa, certifique-se de ter compreendido o possível impacto dos comandos antes de utilizá-los.

Convenções

Para obter mais informações sobre convenções em documentos, consulte Convenções de dicas técnicas da Cisco.

Métricas

Quando você redistribuir um protocolo para outro, lembre-se de que as métricas de cada protocolo têm um papel importante na redistribuição. Cada protocolo usa métricas diferentes. Por exemplo, a métrica RIP (Protocolo de Informações de Roteamento) é baseada na contagem de nós, mas o IGRP (Protocolo de Roteamento de Gateway Interior) e o EIGRP (Protocolo de Roteamento de Gateway Interior Aprimorado) usam uma métrica composta com base na largura de banda, no atraso, na confiabilidade, na carga e na MTU (unidade de transmissão máxima), em que a largura de banda e o atraso são os únicos parâmetros usados por padrão. Quando as rotas forem redistribuídas, é necessário definir uma métrica que seja compreensível para o protocolo de recebimento. Há dois métodos para definir métricas ao redistribuir rotas.

redist-a.gif

Você só pode definir a métrica para essa redistribuição específica:

router rip
redistribute static metric 1
redistribute ospf 1 metric 1

Ou você pode usar a mesma métrica como um padrão para toda a redistribuição (o uso do comando default-metric economiza trabalho, pois elimina a necessidade de definir a métrica separadamente para cada redistribuição.):

router rip
redistribute static
redistribute ospf 1
default-metric 1

Distância Administrativa

Se um roteador estiver executando mais de um protocolo de roteamento e aprender uma rota para o mesmo destino usando os dois protocolos de roteamento, qual rota deverá ser selecionada como a melhor rota? Cada protocolo usa seu próprio tipo de métrica para determinar a melhor rota. Não é possível comparar rotas com tipos de métrica diferentes. As distâncias administrativas resolvem esse problema. As distâncias administrativas são atribuídas a origens de rota para que a rota da origem preferencial seja escolhida como o melhor caminho. Consulte Seleção de Rotas nos Cisco Routers para obter mais informações sobre distâncias administrativas e seleção de rotas.

As distâncias administrativas ajudam com a seleção de rotas entre protocolos de roteamento diferentes, contudo podem causar problemas de redistribuição. Esses problemas podem estar na forma de circuitos de roteamento, problemas de convergência ou roteamento ineficiente. Consulte abaixo para obter uma topologia e uma descrição de um possível problema.

redist-b.gif

Na topologia acima, se R1 estiver executando RIP, e R2 e R5 estiverem executando RIP e IGRP e redistribuindo RIP para IGRP, significa que existe um problema potencial. Por exemplo, R2 e R5 estão ambos aprendendo sobre a rede 192.168.1.0 a partir de R1 usando RIP. Esse conhecimento é redistribuído no IGRP. O R2 aprende sobre a rede 192.168.1.0 até R3 e R5 aprende sobre ela a partir de R4 usando IGRP. O IGRP tem uma distância administrativa menor que o RIP (100 versus 120); entretanto, a rota do IGRP é a que é usada na tabela de roteamento. Agora, há um circuito de roteamento em potencial. Mesmo se o horizonte dividido ou qualquer outro recurso destinado a ajudar os circuitos de roteamento entrar em ação, haverá um problema de convergência.

Se R2 e R5 também estiverem redistribuindo o IGRP para o RIP (também conhecida como redistribuição mútua) e a rede 192.168.1.0 não estiver diretamente conectada a R1 (R1 está aprendendo com outro roteador a fazer upstream), haverá um problema potencial, pois R1 aprenderá a rede a partir de R2 ou R5 com uma métrica melhor do que a da fonte original.

Observação: Os mecanismos de redistribuição de rota são propriedade dos roteadores Cisco. As regras para redistribuição em um roteador Cisco ditam que a rota redistribuída esteja presente na tabela de roteamento. Não é suficiente que a rota esteja presente na topologia de roteamento ou no banco de dados. As rotas com uma AD (Distância Administrativa) menor são sempre instaladas na tabela de roteamento. Por exemplo, se uma rota estática for redistribuída no IGRP no R5 e, subseqüentemente, o IGRP a redistribuiu no RIP no mesmo roteador (R5), a rota estática não será redistribuída no RIP, pois ela nunca foi inserida na tabela de roteamento do IGRP. Isso se deve ao fato de que as rotas estáticas têm uma AD de 1 e as rotas do IGRP têm uma AD de 100 e a rota estática está instalada na tabela de roteamento. Para redistribuir a rota estática no IGRP no R5, você precisa usar o comando redistribute static sob o comando router rip.

O comportamento padrão para RIP, IGRP e EIGRP é anunciar as rotas conectadas diretamente quando uma instrução network do protocolo de roteamento incluir a sub-rede da interface conectada. Há dois métodos para obter uma rota conectada:

  • Uma interface está configurada com um endereço IP e uma máscara; essa sub-rede correspondente é considerada uma rota conectada.

  • Uma rota estática está configurada com apenas uma interface enviada e não com um salto seguinte de IP; isso também é considerado uma rota conectada.

Router# conf t
   Router(config)# ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)# end

   Router# show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

Um comando network configurado no EIGRP, RIP ou IGRP que inclua (ou "aborde") qualquer um desses tipos de rotas conectadas inclui essa sub-rede para anúncio.

Por exemplo, se uma interface tiver o endereço 10.0.23.1 e a máscara 255.255.255.0, a sub-rede 10.0.23.0/24 será uma rota conectada e será anunciada por esses protocolos de roteamento quando uma instrução network estiver configurada como a seguir:

router rip | igrp # | eigrp #
   network 10.0.0.0

Essa rota estática, 10.0.77.0/24, também é anunciada por esses protocolos de roteamento, pois ela é uma rota conectada e é "coberta" pela instrução network.

Consulte a seção Evitando Problemas Devidos à Redistribuição deste documento para obter dicas sobre como evitar esse problema.

Sintaxe e Exemplos de Configuração de Redistribuição

IGRP e EIGRP

A saída abaixo mostra um roteador IGRP/EIGRP redistribuindo rotas estáticas, de OSPF (Open Shortest Path First ), de RIP e de IS-IS (Intermediate System-to-Intermediate System).

router igrp/eigrp 1
network 131.108.0.0
redistribute static
redistribute ospf 1
redistribute rip
redistribute isis
default-metric 10000 100 255 1 1500

O IGRP e o EIGRP precisam de cinco métricas ao redistribuir outros protocolos: largura de banda, atraso, confiabilidade, carga e MTU, respectivamente. Segue um exemplo de métrica de IGRP:

Métrica

Valor

largura de banda

Em unidades de kilobits por segundo; 10.000 para Ethernet

atraso

Em unidades de dezenas de microssegundos; para Ethernet, ela é100 x 10 microssegundos = 1 ms

confiabilidade

255 para 100 por cento de confiabilidade

load

Carga efetiva no link expressa com um número de 0 a 255 (255 é 100 por cento de carga)

MTU

MTU mínimo do caminho, geralmente igual ao da interface Ethernet, que é de 1.500 bytes

Processos IGRP e EIGRP múltiplos podem ser executados no mesmo roteador, com redistribuição entre eles. Por exemplo, IGRP1 e IGRP2 podem ser executados no mesmo roteador. Entretanto, a execução de dois processos do mesmo protocolo no mesmo roteador é raramente necessária e pode consumir memória e CPU do roteador.

A redistribuição de IGRP/EIGRP em outro processo IGRP/EIGRP não exige nenhuma conversão métrica, portanto não há necessidade de definir métricas ou usar o comando default-metric durante a redistribuição.

OSPF

A saída a seguir mostra um roteador OSPF redistribuindo rotas RIP, IGRP, EIGRP, IS-IS e estáticas.

router ospf 1
network 131.108.0.0 0.0.255.255 area 0
redistribute static metric 200 subnets
redistribute rip metric 200 subnets
redistribute igrp 1 metric 100 subnets
redistribute eigrp 1 metric 100 subnets
redistribute isis metric 10 subnets

A métrica OSPF é um valor de custo baseado em 108/largura de banda do link em bits/s. Por exemplo, o custo do OSPF de Ethernet é 10: 108/107 = 10

Observação: Se uma métrica não for especificada, o OSPF colocará o valor padrão 20 ao redistribuir as rotas de todos os protocolos, exceto as rotas BGP (Protocolo de Gateway de Borda), que recebem uma métrica 1.

Quando houver uma rede principal que esteja incluída em uma sub-rede, você precisará usar a sub-rede de palavra-chave para redistribuir protocolos no OSPF. Sem essa palavra-chave, o OSPF apenas redistribui grandes redes que não são sub-redes.

É possível executar mais de um processo de OSPF no mesmo roteador; entretanto, a execução de mais um processo do mesmo protocolo é raramente necessária e consome memória e CPU do roteador.

Você não precisa definir métrica nem usar o comando default-metric ao redistribuir um processo de OSPF para outro.

RIP

Observação: Os princípios deste documento se aplicam às versões I e II do RIP.

A saída a seguir mostra um roteador RIP redistribuindo rotas IGRP, EIGRP, OSPF, IS-IS e estáticas.

router rip
network 131.108.0.0
redistribute static
redistribute igrp 1
redistribute eigrp 1
redistribute ospf 1
redistribute isis
default-metric 1

A métrica RIP é composta de contagem de nós e a métrica máxima válida é 15. Qualquer coisa acima de 15 é considerada infinita; você pode usar 16 para descrever uma métrica infinita no RIP. Ao redistribuir um protocolo no RIP, a Cisco recomenda que você use uma métrica baixa, como 1. Uma métrica alta, como 10, limita ainda mais o RIP. Se você definir uma métrica de 10 para rotas redistribuídas, essas rotas só poderão ser anunciadas a roteadores acima de 5 saltos de distância, no ponto em que a métrica (contagem de nós) excede 15. Definindo a métrica como 1, você habilita uma rota para realizar o número máximo de saltos em um domínio RIP. Mas isso aumentará a possibilidade de circuitos de roteamento, se houver vários pontos de redistribuição e um roteador aprender a rede com uma melhor métrica a partir do ponto de redistribuição do que a partir da fonte original, conforme explicado na seção Distância Administrativa deste documento. Portanto, você deve garantir que a métrica não seja muito alta, para evitar que ela seja anunciada a todos os roteadores, nem tão baixa, levando a circuitos de roteamento quando houver vários pontos de redistribuição.

IS-IS

A saída a seguir mostra um roteador IS-IS redistribuindo rotas OSPF, EIGRP, IGRP, RIP e estáticas.

router isis
network 49.1234.1111.1111.1111.00
redistribute static
redistribute rip metric 20
redistribute igrp 1 metric 20
redistribute eigrp 1 metric 20
redistribute ospf 1 metric 20

A métrica IS-IS deve estar entre 1 e 63. Não há opção de métrica padrão em IS-IS—você deve definir uma métrica para cada protocolo, conforme mostrado no exemplo acima. Se nenhuma métrica for especificada para as rotas que estão sendo redistribuídas no IS-IS, um valor de métrica 0 será usado por padrão.

Rotas Conectadas

A redistribuição de redes conectadas diretamente nos protocolos de roteamento não é uma prática comum e não é mostrada em nenhum dos exemplos acima por essa razão. No entanto, é importante observar que isso pode ser feito, direta e indiretamente. Para redistribuir rotas conectadas diretamente, use o comando de configuração do roteador redistribute connected. Você deve também definir uma métrica nesse caso. Você pode também redistribuir indiretamente rotas conectadas em protocolos de roteamento, conforme mostrado no exemplo a seguir.

redist-cnctd.gif

Nesse exemplo, o Roteador B tem duas interfaces Fast Ethernet. FastEthernet 0/0 está na rede 10.1.1.0/24 e FastEthernet 0/1 está na rede 20.1.1.0/24. O Roteador B está executando EIGRP com o Roteador A e OSPF com o Roteador C. O Roteador B está redistribuindo mutuamente entre os processos de EIGRP e OSPF. Essas são informações de configuração pertinentes do Roteador B:

Router B

interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0

interface FastEthernet0/1
 ip address 20.1.1.4 255.255.255.0

router eigrp 7
 redistribute ospf 7 metric 10000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7
 log-adjacency-changes
 redistribute eigrp 7 subnets
 network 20.1.1.0 0.0.0.255 area 0

Se você observar a tabela de roteamento do Roteador B, verá o seguinte:

routerB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

Na tabela de configuração e roteamento, acima, há três aspectos a serem observados:

  • As redes em questão estão na tabela de roteamento do Roteador B como redes conectadas diretamente.

  • A rede 10.1.1.0/24 faz parte do processo EIGRP e a rede 20.1.1.0/24 faz parte do processo OSPF.

  • O Roteador B está redistribuindo mutuamente entre EIGRP e OSPF.

As tabelas de roteamento dos Roteadores A e C são fornecidas a seguir.

routerA# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0


routerC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet1
O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

O Roteador A aprendeu sobre a rede 20.1.1.0/24 via EIGRP, que é mostrado como uma rota externa, pois foi redistribuído do OSPF para o EIGRP. O Roteador C aprendeu sobre a rede 10.1.1.0/24 via OSPF como uma rota externa, pois foi redistribuído do EIGRP para o OSPF. Embora o Roteador B não esteja redistribuindo redes conectadas, ele não anuncia a rede 10.1.1.0/24, que faz parte do processo EIGRP redistribuído no OSPF. De forma semelhante, o Roteador B anuncia a rede 20.1.1.0/24, que faz parte do processo OSPF redistribuído em EIGRP.

Consulte Redistribuindo Redes Conectadas no OSPF para obter mais informações sobre rotas conectadas que estão sendo redistribuídas no OSPF.

Evitando Problemas Devido à Redistribuição

Na seção sobre distância administrativa , você viu como a redistribuição pode potencialmente causar problemas, como roteamento abaixo do ideal, circuitos de roteamento ou convergência lenta. Evitar esses tipos de problemas é realmente muito simples—nunca anuncie as informações recebidas originalmente do processo de roteamento X novamente para o processo de roteamento X.

Exemplo 1

redist-b.gif

Na topologia acima, R2 e R5 estão fazendo a redistribuição mútua. O RIP está sendo redistribuído no IGRP e o IGRP está sendo redistribuído no RIP, conforme mostrado na configuração abaixo.

R2:

router igrp 7
network 181.16.0.0

redistribute rip metric 1 1 1 1 1

router rip
network 178.1.0.0
redistribute igrp 7 metric 2

R5:

router igrp 7
network 181.16.0.0

redistribute rip metric 1 1 1 1 1

router rip
network 178.1.0.0
redistribute igrp 7 metric 2

Com a configuração acima, você pode encontrar qualquer problema descrito. Para evitar, filtre as atualizações de roteamento desta forma:

R2:

router igrp 7
network 181.16.0.0

redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1

router rip
network 178.1.0.0
redistribute igrp 7 metric 2

access-list 1 deny 192.168.1.0
            access-list 1 permit any
         

R5:

router igrp 7
network 181.16.0.0

redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1

router rip
network 178.1.0.0

redistribute igrp 7 metric 2

access-list 1 deny 192.168.1.0
            access-list 1 permit any
         

As listas de distribuição adicionadas às configurações, conforme mostrado acima, filtram quaisquer atualizações do IGRP provenientes da interface serial 1 dos roteadores. Se as rotas das atualizações forem permitidas pela lista de acesso 1, o roteador as aceitará na atualização; caso contrário, não as aceitará. Neste exemplo, está sendo informado aos roteadores que eles não deverão aprender a rede 192.168.1.0 por meio de atualizações do IGRP recebidas na interface serial 1; portanto, o único conhecimento que esses roteadores têm da rede 192.168.1.0 é por meio do RIP de R1.

Além disso, lembre-se de que, nesse caso, não é necessário usar a mesma estratégia de filtro do processo RIP, pois o RIP tem uma distância administrativa maior do que o IGRP. Se as rotas originadas no domínio do IGRP foram realimentadas no R2 e no R5 por meio do RIP, as rotas do IGRP ainda terão precedência.

Exemplo 2

redist-c.gif

Usando a topologia conforme descrito acima, podemos demonstrar outro método (que, às vezes, é preferível) para evitar problemas de redistribuição. Esse método usa mapas de rotas para configurar marcações para várias rotas. Os processos de roteamento podem então ser redistribuídos com base nas marcas. Observe que a redistribuição com base nas marcas não funciona com a versão 1 do RIP ou IGRP.

Um dos problemas que você pode executar na topologia acima é o seguinte:

R1 anuncia a rede 192.168.1.0 para R2. Em seguida, R2 a redistribui para EIGRP. R5 aprende a rede via EIGRP e a redistribui para RIPv2. Dependendo da métrica definida pelo R5 para a rota RIPv2, o R6 pode preferir a rota menos desejável, passando por R5 em vez de passar por R1 para chegar à rede. A configuração a seguir ajuda a prevenir isso, pela configuração de marcas e conseqüente redistribuição usando-as como base.

R2:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

               !--- Redistribui rotas RIP que são
            
            
               !--- permitidas pelo route-map rip_to_eigrp
               
            


router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

               !--- Redistribui rotas EIGRP e define as marcas
            
            
               !--- de acordo com a eigrp_to_rip route-map
               
            

route-map rip_to_eigrp deny 10
match tag 88
instrução 
               !--- Route-map para negar todas as rotas que tiverem uma marca "88"
            
            
               !--- de serem redistribuídas no EIGRP
            
            
               !--- Observe que as rotas marcadas com "88" devem estar nas rotas EIGRP
            
            
               !--- que são redistribuídas no RIPv2
            

route-map rip_to_eigrp permit 20
set tag 77
instrução 
               !--- Route-map para definir a marca 
            
            
               !--- nas rotas RIPv2 redistribuídas no EIGRP para "77"
            

route-map eigrp_to_rip deny 10
match tag 77
instrução 
               !--- Route-map para negar quaisquer rotas que tenham uma marca
            
            
               !--- "77" de serem redistribuídas no RIPv2
            
            
               !--- Observe que as rotas marcadas com "77" devem estar nas rotas RIPv2
            
            
               !--- que são redistribuídas no EIGRP
            


route-map eigrp_to_rip permit 20
set tag 88
instrução 
               !--- Route-map para definir a marca nas rotas redistribuídas do EIGRP
            
            
               !--- no RIPv2 para "88"
            
         

R5:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

               !--- Redistribui rotas RIPv2 que são permitidas 
            
            
               !--- pelo route-map rip_to_eigrp
               
            


router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

               !--- Redistribui rotas EIGRP e define as marcas 
            
            
               !--- de acordo com a eigrp_to_rip route-map
               
            


route-map rip_to_eigrp deny 10
match tag 88
instrução 
               !--- Route-map para negar todas as rotas que tiverem uma marca 
            
            
               !--- "88" de serem redistribuídas no EIGRP
            
            
               !--- Observe que as rotas marcadas com "88" devem estar nas rotas EIGRP
            
            
               !--- que são redistribuídas no RIPv2
            

route-map rip_to_eigrp permit 20
set tag 77
instrução 
               !--- Route-map para definir a marca nas rotas rip 
            
            
               !--- redistribuídas no EIGRP para "77"
            

route-map eigrp_to_rip deny 10
match tag 77

               !--- Route-map para negar todas as rotas que tiverem uma marca 
            
            
               !--- "77" de serem redistribuídas no RIPv2
            
            
               !--- Observe que as rotas marcadas com "77" devem estar nas rotas RIPv2
            
            
               !--- que são redistribuídas no EIGRP
            

route-map eigrp_to_rip permit 20
set tag 88
instrução 
               !--- Route-map para definir a marca nas rotas EIGRP 
            
            
               !--- redistribuídas no RIPv2 para "88"
            

         

Com a configuração executada acima, você pode verificar algumas das rotas específicas da tabela de roteamento para ver se as marcas foram definidas. A seguir, é mostrada a saída do comando show ip route para rotas específicas no R3 e no R1:

R3# show ip route 178.1.10.8
Routing entry for 178.1.10.8/30
  Known via "eigrp 7", distance 170, metric 2560512256
  Tag 77, type external
  Redistributing via eigrp 7
  Last update from 181.16.2.10 on Serial0, 00:07:22 ago
  Routing Descriptor Blocks:
  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0
      Route metric is 2560512256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1


R1# show ip route 181.16.2.4
Routing entry for 181.16.0.0/16
  Known via "rip", distance 120, metric 2
  Tag 88
  Redistributing via rip
  Last update from 178.1.10.5 on Serial0, 00:00:15 ago
  Routing Descriptor Blocks:
  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0
      Route metric is 2, traffic share count is 1

Exemplo 3

A redistribuição pode ocorrer também entre diferentes processos do mesmo protocolo de roteamento. A configuração a seguir é um exemplo de uma política de redistribuição usada para redistribuir dois processos EIGRP em execução no mesmo roteador ou em vários roteadores:

router eigrp 3
 redistribute eigrp 5 route-map to_eigrp_3
 default-metric 10000 100 255 1 1500

               !--- Redistribui o EIGRP 5 no EIGRP 3, definindo as marcas 
            
            
               !--- de acordo com o mapa de rota "to_eigrp_3"
            


router eigrp 5
 redistribute eigrp 3 route-map to_eigrp_5
 default-metric 10000 100 255 1 1500

               !--- Redistribui EIGRP 3 no EIGRP 5
            
            
               !--- As rotas com a marca 33 não serão redistribuídas
            
            
               !--- devido ao mapa de rota "to_eigrp_5"
!--- Embora o comando default-metric não seja necessário
!--- quando estiver redistribuindo entre processos EIGRP diferentes,
!--- você pode usá-lo opcionalmente, conforme mostrado acima para anunciar
!--- as rotas com valores específicos para calcular a métrica.
            

route-map to_eigrp_3 deny 10
match tag 55

               !--- A instrução de mapa de rota usada para proibir quaisquer rotas que tenham uma marca
            
            
               !--- "55" de serem redistribuídas no EIGRP 3
            
            
               !--- Observe que as rotas marcadas com "55" devem estar nas rotas EIGRP 3
            
            
               !--- que são redistribuídas no EIGRP 5
            

route-map to_eigrp_3 permit 20
 set tag 33

               !--- Instrução de mapa de rota usada para definir a marca nas rotas
            
            
               !--- redistribuídas do EIGRP 5 para o EIGRP 3 para "33"
            

route-map to_eigrp_5 deny 10
 match tag 33

               !--- A instrução de mapa de rota usada para proibir quaisquer rotas que tenham uma marca 
            
            
               !--- "33" de serem redistribuídas no EIGRP 5
            
            
               !--- Observe que as rotas marcadas com "33" devem estar nas rotas EIGRP 5
            
            
               !--- que são redistribuídas no EIGRP 3
            

route-map to_eigrp_5 permit 20
set tag 55

               !--- Instrução de mapa de rota usada para definir a marca nas rotas
            
            
               !--- redistribuídas do EIGRP 3 para o EIGRP 5 para "55"
            

         

Há apenas alguns exemplos de estratégias de filtragem usadas para o objetivo deste documento, no entanto, pode haver outras estratégias válidas que você pode usar. Consulte a seção Filtrando Informações de Roteamento em Configurando Recursos Independentemente dos Protocolos de Roteamento de IP para obter mais informações.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 8606