Discar e acessar : Conexões assíncronas

Configurando um Servidor Terminal/Comm

14 Julho 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (29 Janeiro 2008) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Cabeamento
Estratégia de Design
Configuração
      Diagrama de Rede
      Configurações
      Resumo de Comandos
      Alternar entre Sessões Ativas
      Terminar Sessões Ativas
Verificação
Troubleshooting
      Procedimento de Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Um servidor comm ou de terminal normalmente fornece acesso out-of-band a vários dispositivos. Um servidor de terminal é um roteador com várias portas assíncronas de baixa velocidade que são conectadas a outros dispositivos seriais, por exemplo, modems ou portas de console em roteadores ou switches.

O servidor de terminal permite o uso de um único ponto para acessar as portas do console de vários dispositivos. O servidor de terminal elimina a necessidade de configurar cenários de backup, como modems em portas auxiliares para cada dispositivo. Você também poderá configurar um único modem na porta auxiliar do servidor de terminal para oferecer serviço dial-up a outros dispositivos quando ocorrer uma falha de conectividade da rede.

Este documento mostra como configurar um servidor de terminal para acessar somente as portas de console em outros roteadores através do Telnet reverso. O Telnet reverso permite que você estabeleça uma conexão Telnet no mesmo dispositivo a partir do qual você está realizando o telnet, mas em uma interface diferente. Para obter mais informações sobre Telnet reverso, consulte Estabelecendo uma Sessão de Telnet Reversa com um Modem.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

As informações deste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Cabeamento

Os Cisco 2509 - 2515 Series Routers usam um conector de 68 pinos e um cabo breakout. Esse cabo (CAB-OCTAL-ASYNC) fornece oito portas assíncronas de cabo invertido RJ-45 em cada conector de 68 pinos. Você pode conectar cada porta assíncrona de cabo invertido RJ-45 à porta de console de um dispositivo. O roteador 2511 permite que no máximo 16 dispositivos sejam acessados remotamente. Além disso, os módulos de rede assíncronos de alta densidade NM-16A ou NM-32A estão disponíveis para os Cisco 2600 e 3600 Series Routers a fim de oferecer a mesma funcionalidade. Para obter mais informações sobre cabeamento, consulte o Guia de Conexão de Cabos Seriais e o Guia de Cabeamento para Portas de Console e AUX.

Nota: As portas assíncronas do conector de 68 pinos são dispositivos DTE (data terminal equipment). Dispositivos DTE para DTE exigem um cabo invertido (modem nulo) e dispositivos DTE para DCE (circuit-terminating equipment) exigem um cabo direto. O cabo CAB-OCTAL-ASYNC é invertido. Portanto, você pode conectar cada cabo diretamente às portas de console de dispositivos com interfaces RJ-45. Entretanto, se a porta de console do dispositivo ao qual você se conectar for uma interface de 25 pinos (DCE), utilize o adaptador RJ-45 para 25 pinos identificado como "Modem" (para inverter o "cabo") a fim de concluir a conexão.

Esta tabela mostra os tipos de portas de console e auxiliares dos roteadores e dos switches Cisco:

Tipo de interface

Interface DB25

Interface RJ-45

Console

DCE

DTE

AUX

DTE

DTE

Estratégia de Design

Configure o servidor de terminal de forma que você possa acessá-lo de qualquer lugar. Para que o servidor de terminal fique acessível, atribua um endereço Internet público registrado e coloque o servidor fora do firewall. Se você fizer isso, os problemas de firewall não interromperão sua conexão. Você poderá sempre manter a conectividade com o servidor de terminal e acessar os dispositivos conectados. Se você estiver preocupado com a segurança, configure as listas de acesso para permitirem acesso ao servidor de terminal apenas a partir de certos endereços. Para obter uma solução de segurança mais eficiente, você também pode configurar a autenticação, autorização e contabilidade (AAA) baseadas em servidor, por exemplo, RADIUS ou TACACS+. Para obter mais informações sobre AAA, consulte o Estudo de Caso de Implementação do Cisco AAA.

É possível configurar um modem na porta auxiliar do servidor de terminal para backup de discagem em caso de falha na conexão principal (pela Internet). Esse modem elimina a necessidade de configurar um backup de discagem para cada dispositivo. O servidor de terminal é conectado por meio de suas portas assíncronas às portas de console dos outros dispositivos. Para obter mais informações sobre como conectar um modem à porta AUX, consulte Guia de Conexão Modem-Roteador.

Use o comando ip default gateway e aponte para o roteador do próximo salto na Internet. Esse comando permite sua conectividade com o servidor de terminal através da Internet mesmo que o roteamento não esteja habilitado. Por exemplo, o servidor de terminal está no modo ROMMON (monitor de ROM) como resultado de uma reinicialização incorreta após uma interrupção de energia.

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para obter mais informações sobre os comandos usados neste documento, utilize a Command Lookup Tool (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

Com_Srv.gif

Configurações

Este documento utiliza esta configuração:

  • Cisco 2511

Cisco 2511

aus-comm-server#show running-config
!
version 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

!--- O host 3600-3 está conectado à porta 14 do servidor comm.
!--- Certifique-se de que o endereço IP seja de uma interface no servidor comm.

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

!--- Este endereço é usado nos comandos IP host.
!--- Trabalhe com as interfaces de loopback, que são virtuais e estão sempre disponíveis.

 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

!---  Use um endereço IP público para garantir a conectividade.

No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

!--- Este é o gateway padrão quando o roteamento está desativado.
!--- Por exemplo, se o roteador estiver no modo de inicialização ROM.

ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

!--- Configure a rota padrão para a rede externa.

no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

!--- A sessão é encerrada após 20 minutos de inatividade.

no exec

!--- Sinais indesejados do dispositivo conectado não são iniciados.
!--- Uma sessão EXEC garante que a linha nunca fique indisponível
!--- devido a um processo EXEC invasor.

 exec-timeout 0 0

!--- Isto desativa exec timeout transport input all.
!--- Permite que todos os protocolos usem a linha.
!--- Configure as linhas 1 - 16 com pelo menos a entrada de transporte Telnet.

line aux 0

!--- A porta auxiliar pode fornecer backup de discagem para a rede.
!--- Nota: Esta configuração não implementa o modem em AUX port modem InOut.
!--- Permite que a porta auxiliar ofereça suporte a conexões de discagem externa e interna.

 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted>
login
!
end

Nota: Se você usar o 3600 como o servidor de acesso, consulte Como as Linhas Assíncronas São Numeradas nos Cisco 3600 Series Routers para obter detalhes sobre números de linha.

Resumo de Comandos

ip host — Use este comando para definir o mapeamento de nome para endereço do host estático no cache do host. Para remover o mapeamento, use a forma no do comando.

  • ip host name [número_da_porta_tcp] endereço1 [endereço2...endereço8]

    • nome — Este campo indica o nome do host. O campo de nome não corresponde ao nome real do roteador ao qual você deseja se conectar. No entanto, você deve escolher o nome que deseja usar no Telnet reverso. Ao usar este comando e o campo de nome, você não precisa saber o número da porta do dispositivo remoto.

    • número-da-porta-tcp — Este campo representa o número da porta TCP ao qual você deseja se conectar quando usa o nome de host definido junto com um comando EXEC connect ou telnet. Como na configuração de exemplo usamos um Telnet reverso, o número da porta deverá ser 2000+número da linha.

    • endereço1 — Este campo representa um endereço IP associado. Na configuração de exemplo, usamos o endereço IP de loopback.

transport input — Use este comando para definir os protocolos a serem utilizados quando você se conectar a uma linha específica do roteador.

  • transport input {all | lat | mop | nasi | none | pad | rlogin | telnet | v120}

    • all — Seleciona todos os protocolos.

    • none — Impede a seleção de qualquer protocolo na linha. Nesse caso, a porta se torna inutilizável para conexões de entrada.

    Nota:  No exemplo de configuração, as linhas assíncronas usam a configuração mínima do comando transport input telnet. Portanto, você pode executar o Telnet nos dispositivos da linha assíncrona.

telnet — Use este comando EXEC para fazer login em um host com suporte a Telnet.

  • telnet host [porta] [palavra-chave]

    • hostEste campo indica o nome ou o endereço IP de um host. O host pode ser um dos campos de nome definidos no comando ip host.

    • porta — Este campo indica um número de porta TCP decimal. A porta do roteador Telnet (23 decimal) no host é o número decimal padrão de porta TCP. Para executar um Telnet reverso, o número da porta deve ser 2000+número da linha. Os números de linha vão de 1 a 16 na nossa configuração. Use o comando show line EXEC para exibir as linhas disponíveis.

Alternar Entre Sessões Ativas

Conclua estas etapas para alternar entre sessões ativas:

  1. Use a seqüência de escape Ctrl-Shift-6 e, depois, x para sair da sessão atual.

  2. Use o comando show sessions para exibir todas as conexões abertas.

    aus-comm-server#show sessions
    Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3
    

    Nota: O asterisco (*) indica a sessão atual do terminal.

  3. Digite o número da sessão (conn) para se conectar ao dispositivo correspondente. Por exemplo, para se conectar ao 2511-1, digite 1, que é o número da conexão. No entanto, se pressionar a tecla Enter, você será conectado à sessão de terminal atual que, nesse caso, é o roteador 2511-3.

Terminar Sessões Ativas

Conclua estas etapas para terminar uma sessão de Telnet específica:

  1. Use a seqüência de escape Ctrl-Shift-6 e, depois, x para sair da sessão de Telnet atual.

    Nota: Certifique-se de que é possível executar a seqüência de escape com segurança para suspender uma sessão de Telnet. Alguns pacotes de emulador de terminal não são capazes de enviar a seqüência correta, Ctrl-Shift-6, x.

  2. Execute o comando show sessions para exibir todas as conexões abertas.

  3. Execute o comando disconnect [connection] para desconectar a sessão necessária.

Verificação

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

Alguns comandos show são aceitos pela Output Interpreter Tool (somente clientes registrados) , o que permite exibir uma análise da saída do comando show.

  • show ip interface brief — indica se a interface usada para a sessão de Telnet está ativada.

Troubleshooting

Esta seção fornece informações que você pode usar para solucionar problemas em sua configuração.

Procedimento de Troubleshooting

Siga estas instruções para solucionar problemas em sua configuração.

Se você não conseguir se conectar ao roteador selecionado com um nome configurado no comando ip host:

  1. Verifique se o endereço da porta está configurado corretamente.

  2. Verifique se o endereço (interface) usado para o Telnet reverso está no estado up/up. A saída do comando show ip interface brief fornece essa informação. A Cisco recomenda o uso de loopbacks porque eles estão sempre ativados.

  3. Certifique-se de estar com o tipo correto de cabos. Por exemplo, você não deve usar um cabo de crossover para estender o comprimento. Consulte a seção Cabeamento para obter mais informações.

  4. Estabeleça uma conexão Telnet com a porta do endereço IP para testar a conectividade direta. É necessário estabelecer uma sessão de Telnet tanto no dispositivo externo como no servidor de terminal. Por exemplo, telnet 172.21.1.1 2003.

  5. Verifique se o comando transport input telnet está abaixo da linha do dispositivo de destino. O dispositivo de destino é aquele que está conectado ao servidor de terminal.

  6. Use um PC/terminal burro para se conectar diretamente ao console do roteador de destino. O roteador de destino é o dispositivo conectado ao servidor de terminal. Esta etapa o ajuda a identificar a presença de um problema de porta.

  7. Se você estiver desconectado, verifique os timeouts. Você pode removê-los ou ajustá-los.

    Nota: Se você encontrar falhas de autenticação, lembre-se de que o servidor de terminal realiza a primeira autenticação (se configurada), enquanto o dispositivo ao qual você tenta se conectar realiza a segunda autenticação (se configurada). Verifique se o AAA está configurado corretamente tanto no servidor de terminal como no dispositivo conectado.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 5466