Switches : Switches Cisco Nexus 9000 Series

Configurar e verifique a unidade de transmissão máxima em Plataformas do nexo de Cisco

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (11 Agosto 2015) | Feedback

Introdução

Este documento descreve como configurar e verificar a unidade de transmissão máxima (MTU) no Switches do nexo de Cisco.

Contribuído pela caça de Amanda, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Configurar

Mergulhe 3 configurações MTU

MTU em uma configuração do Switched Virtual Interface (SVI)

Switch(config)#interface vlan 1
Switch(config-if)#mtu 9216

MTU em uma configuração de porta da camada 3

Switch(config)#interface ethernet 1/1
Switch(config-if)#no switchport
Switch(config-if)#mtu 9216

Configurações da camada 2 MTU

A camada 2 MTU pode ser ajustada com a política de QoS da rede ou configurando a porta própria no Switches que apoia a porta per. MTU. A porta per. MTU dos apoios somente do nexo 3048, 3064, 7000, 7700, 9000, e 9300.

Nexo 3100, configuração 3500, 5000, 5500, e 6000

A fim configurar o MTU elevado nos 5000, 5500, e 6000 switchess do nexo 3100, 3500, criar uma política da rede-qos ou alterar uma política existente a fim especificar o MTU elevado. Esta configuração aplica-se a todas as portas. Isto inclui todas as portas do prolongamento da tela de Cisco (FEX) conectadas ao interruptor. A porta per. MTU não é apoiada.

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Nexo 3048, configuração 3064, 7000, 7700, 9000, e 9300

A fim configurar o MTU em uma base por porto, esta configuração é precisada:

Switch(config)#interface ethernet 1/1
Switch(config-if)#mtu 9216

Configuração do nexo 7000

Quando você configura FEX MTU, uma política de QoS mais extensiva está precisada na versão 6.2 e mais recente:

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom
(config-cmap-nqos)#match cos 0-7

Nota: Se você não é certo que o molde para se usar, incorpora o tipo comando do sistema do mapa de política da mostra da rede-qos a fim considerar o molde atualmente usado.

Switch(config)#policy-map type network-qos nq-8e-custom template 8e    
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Configuração 2000 do nexo

Nota: O nexo 2000 MTU é ajustado com a configuração do Jumbo Frames no interruptor do pai. Para o Switches do pai que permite o jumbo em uma base por porto, configurar o canal de porta da tela FEX (FPC). Se o interruptor do pai exige uma política da rede-qos então o jumbo está ajustado com a configuração da política de QoS do interruptor do pai. Estas mudanças são abaixadas automaticamente ao FEX em ambos os casos.

Canal de porta da tela (FPC) na configuração de switch do nexo do pai

interface port-channel136
switchport mode fex-fabric
fex associate 136
vpc 136
mtu 9216

Nota: O nexo 7000 não permite que você ajuste FEX MTU com o FPC na versão 6.2 e mais recente. Você deve pelo contrário criar uma política de QoS feita sob encomenda enquanto a configuração seguinte mostra.

Permita o Jumbo Frames na configuração do nexo 7000 FEX

Nota: Altere o molde atualmente em uso. A fim encontrar o template atual no uso, incorpore o tipo comando do sistema do mapa de política da mostra da rede-qos.

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom 
(config-cmap-nqos)#match cos 0-7

Switch(config)#policy-map type network-qos nq-8e-custom template 8e
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Política de QoS da rede na configuração de switch do nexo do pai

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A ferramenta Output Interpreter (clientes registrados somente) apoia determinados comandos de exibição. Use a ferramenta Output Interpreter a fim ver uma análise do emissor de comando de execução.

Camada 3 MTU

Verifique a camada 3 MTU em todas as Plataformas do nexo com o comando do x/y do eth da relação da mostra como este exemplo mostra:

Nexus#show interface ethernet 1/19
Ethernet1/19 is up
Dedicated Interface
Hardware: 100/1000/10000 Ethernet, address: 547f.ee5d.413c (bia 547f.ee5d.40fa)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Verifique SVI MTU com o comando x vlan da relação da mostra como esta saída mostra:

Leaf3#show interface vlan 1
Vlan1 is down (Non-routable VDC mode), line protocol is down
Hardware is EtherSVI, address is 547f.eed8.ec7c
Internet Address is 1.1.1.1/23
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Camada 2 MTU

Esta seção descreve como verificar a camada 2 MTU pela plataforma. Os comandos são executados do interruptor do pai.

Nexo 3100, 3500, 5000, 5500, e 6000

Nexus#show queuing interface ethernet 1/1
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 100
RX Queuing
qos-group 0
q-size: 469760, HW MTU: 9216 (9216 configured)

Nexo 3000, 7000, 7700, 9000

Nexus#show interface ethernet 1/12
Ethernet1/12 is up
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 7c0e.ceca.f183 (bia 7c0e.ceca.f183)
MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec

Nexo 2000

Nota: Quando você muda o FEX MTU, o FEX aumenta seu MTU a uma quantidade mais alta mas predeterminada que não combine o valor configurado exatamente. O dispositivo do pai reforça o MTU configurado no canal de porta da tela FEX (FPC).

Para FEX conectado ao nexo 5000, 6000, e 7000:

Nexus#show queuing interface ethernet 136/1/1
if_slot 68, ifidx 0x1f870000
Ethernet136/1/1 queuing information:
Input buffer allocation:
Qos-group: 0
frh: 3
drop-type: drop
cos: 0 1 2 3 4 5 6 7
xon xoff buffer-size
---------+---------+-----------
19200 78080 90880

Queueing:
queue qos-group cos priority bandwidth mtu
--------+------------+--------------------+---------+----------------+--------
3 0 0 1 2 3 4 5 6 WRR 100 9280

Para FEX conectado ao nexo 9000:

9396-B#show interface ethernet 104/1/1
Ethernet104/1/1 is up
admin state is up,
Hardware: 100/1000 Ethernet, address: 5475.d0e0.e5c2 (bia 5475.d0e0.e5c2)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Troubleshooting

Esta seção fornece a informação que você pode se usar a fim pesquisar defeitos sua configuração.

A ferramenta Output Interpreter (clientes registrados somente) apoia determinados comandos de exibição. Use a ferramenta Output Interpreter a fim ver uma análise do emissor de comando de execução.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

Às vezes é necessário verificar as mudanças no software. A fim fazer isto, verifique o gerente da porta Ethernet (ethpm) a fim verificar que as mudanças estiveram empurradas através do software em toda a plataforma:

Switch#show system internal ethpm info interface eth 6/5 | egrep -i mtu
medium(broadcast), snmp trap(on), MTU(4000)

É igualmente possível nos módulos M1, M2, F1 e F2 verificar no hardware que as mudanças estiveram abaixadas:

module-1#show hardware internal mac port 20 state | i MTU
GD: Port speed Undecided GD MTU 10240 (fixed to max), PL MTU 9238 mode 0

Defeitos conhecidos

Identificação de bug Cisco CSCuf20035 - (nexo 7000) as mudanças FEX MTU não tomam o efeito em filas FEX.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 118994