Switches : Switches Cisco Nexus 7000 Series

Exemplo da configuração rspan do 7000 Series Switch do nexo

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar uma sessão remota do Switched Port Analyzer (RSPAN) em um 7000 Series Switch do nexo que monitore o tráfego entre portas Ethernet em dois 7000 Series Switch diferentes do nexo.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Tenha o conhecimento básico da configuração em 7000 Series Switch do nexo

  • Tenha o conhecimento básico do Switched Port Analyzer remoto (o RSPAN)

Componentes Utilizados

A informação neste documento é baseada em dispositivos do 7000 Series NX-OS do nexo.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Você pode usar o Switched Port Analyzer (SPAN) a fim analisar o tráfego de rede que passa com as portas ou os VLAN do interruptor, que enviam uma cópia do tráfego a uma porta do destino onde o analisador de rede conecte ao interruptor.

A fim estender o PERÍODO, o RSPAN permite a monitorização remota dos switch múltiplos através de sua rede. O 7000 Series Switch do nexo é limitado no que pode fazer com RSPAN. Um RSPAN VLAN não pode ser usado como um destino do PERÍODO. Consequentemente, o 7000 Switch do nexo pode somente usar o RSPAN como um trânsito VLAN ou uma fonte VLAN e puxar dados do RSPAN VLAN. Você não pode colocar qualquer coisa no RSPAN VLAN do 7000 Switch do nexo.

Configurar

Este exemplo de configuração usa portas de origem em dois 7000 Series Switch diferentes do nexo e uma porta do destino em um 7000 Switch do nexo onde o analisador de rede conecte. Os Ethernet separados 1/1 de link estabelecem-se entre os dois dispositivos: um link como um destino do período e o outro ligam como o acesso ao RSPAN VLAN.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113438-rspan-nexus-7000-01.jpg

Este exemplo usa as portas alistadas nesta tabela:

Dispositivo Porta de origem Porta de Destino
Nexo 1 Ethernet 2/15 e 2/16 Ethernet 1/1
Nexo 2 Ethernet 1/1, 2/26 a 2/28 Ethernet 2/37 2/40

Do 1 Switch do nexo, o tráfego do PERÍODO da fonte é levado à porta do destino e copiado no RSPAN VLAN. O tráfego é enviado então sobre o link ao 2 Switch do nexo nos Ethernet 1/1 de relação. Em seguida, o tráfego de VLAN RSPAN é enviado à porta do destino onde o dispositivo, tal como um dispositivo switchprobe ou a outra ponta de prova ou dispositivo de segurança do Remote Monitoring (RMON), pode receber e analisar os pacotes.

Configurações

Este documento utiliza as seguintes configurações:

Nexo 1
Nexus1#configure terminal


!--- Configure the interface VLAN 15 as RSPAN VLAN.

Nexus1(config)#vlan 15 
Nexus1(config-vlan)#remote-span
Nexus1(config-vlan)#exit



!--- Configure the switchport interface as a SPAN destination.

Nexus1(config)#interface ethernet 1/1
Nexus1(config-if)#switchport monitor
Nexus1(config-if)#no shutdown
Nexus1(config-if)#exit



!--- Configure the SPAN session.

Nexus1(config)#monitor session 1


!---Configure the source port.

Nexus1(config-monitor)#source interface ethernet 2/15-16


!--- Configure the destination port.

Nexus1(config-monitor)#destination interface ethernet 1/1


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus1(config-monitor)#no shut
Nexus1(config-monitor)#exit

Nexo 2
Nexus2#configure terminal


!--- Configuration of interface VLAN 15 as RSPAN VLAN.

Nexus2(config)#vlan 15 
Nexus2(config-vlan)#remote-span
Nexus2(config-vlan)#exit


!--- Configure the switchport interface to access in RSPAN VLAN.

Nexus2(config)#interface ethernet 1/1
Nexus2(config-if)#switchport mode access
Nexus2(config-if)#switchport access vlan 15
Nexus2(config-if)#no shutdown
Nexus2(config-if)#exit



!--- Configure the switchport interfaces as a SPAN destination.

Nexus2(config)#interface ethernet 2/37-40
Nexus2(config-if)#switchport monitor
Nexus2(config-if)#exit



!--- Configure the SPAN session.

Nexus2(config)#monitor session 1


!--- Configure the source port.

Nexus2(config-monitor)#source interface ethernet 2/26-28
Nexus2(config-monitor)#source vlan 15


!--- Configure the destination port.

Nexus2(config-monitor)#destination interface ethernet 2/37-40


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus2(config-monitor)#no shut
Nexus2(config-monitor)#exit

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Estão aqui alguns dos comandos de verificação do PERÍODO e RSPAN:

Nexo 1:

  • Use o comando show monitor a fim indicar o estado das sessões de RSPAN.

    Nexus1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • Use o comando do [session session_number] da sessão de monitor da mostra a fim indicar a configuração de sessão ERSPAN.

    Nexus1# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/15       Eth1/16
        tx            : Eth1/15       Eth1/16
        both          : Eth1/15       Eth1/16
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
    destination ports : Eth1/1
    
    Legend: f = forwarding enabled, l = learning enabled
  • Use o comando all da sessão de monitor da mostra a fim indicar toda a configuração das sessões ERSPAN no dispositivo.

Nexo 2:

  • Use o comando show monitor a fim indicar o estado das sessões ERSPAN.

    Nexus2# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • Use o comando do [session session_number] da sessão de monitor da mostra a fim indicar a configuração de sessão ERSPAN.

    Nexus2# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/21       Eth1/22       Eth1/23
        tx            : Eth1/21       Eth1/22       Eth1/23
        both          : Eth1/21       Eth1/22       Eth1/23
    source VLANs      :
        rx            : 15
        tx            : 15
        both          : 15
    filter VLANs      : filter not specified
    destination ports : Eth1/27       Eth1/28       Eth1/29       Eth1/30
    
    Legend: f = forwarding enabled, l = learning enabled

Informações Relacionadas


Document ID: 113438