IP : Protocolo IP multicast

Configurar perfis do mVPN para o IPv6 dentro do Cisco IOS

18 Junho 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (21 Abril 2016) | Feedback

Índice

Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento descreve como configurar cada perfil do VPN multicast (mVPN) dentro do ® do Cisco IOS para o IPv6 somente.

Nota: As configurações que são descritas neste documento aplicam-se ao Roteadores da ponta de provedor (PE).

Contribuído por Luc De Ghein, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

Antes que você continue com a configuração que está descrita neste documento, verifique se há um apoio para um perfil do mVPN na plataforma específica que executa o Cisco IOS.

Componentes Utilizados

A informação neste documento é baseada em todas as versões do Cisco IOS.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Informações de Apoio

Nota: O VRF que é usado durante todo este documento é VRF um.

Um perfil do mVPN é configurado para o contexto global ou pelo roteamento virtual/transmissão (VRF). Somente a maneira mais nova de definir um VRF (definição VRF) pode ser usada a fim permitir o IPv6 para perfis do mVPN. Aqui está um exemplo:

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !
 address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family
 !
 address-family ipv6
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

O roteamento de transmissão múltipla para o IPv6 deve ser permitido para os perfis no contexto global. Adicionalmente, a versão 6 da transmissão múltipla independente de protocolo (PIMv6) deve ser permitida na interface de loopback global. Isto é verdadeiro se o comando do roteamento de transmissão múltipla do IPv6 está permitido, e se a interface de loopback tem um endereço do IPv6 ou o comando enable do IPv6 está configurada na interface de loopback.

ipv6 multicast-routing

O roteamento de transmissão múltipla para o IPv6 deve ser permitido no VRF para os perfis no contexto VRF.

ipv6 multicast-routing vrf one

É uma boa prática permitir o registo do protocolo multiponto da distribuição de rótulo (MLDP) com este comando global para os perfis com MLDP:

mpls mldp logging notifications

O PIM para o IPv6 está permitido à revelia nas relações no contexto global ou VRF se o comando respectivo do vrf um do roteamento de transmissão múltipla do IPv6 ou do roteamento de transmissão múltipla do IPv6 é configurado.

interface Ethernet0/0
 vrf forwarding one
 ip address 10.2.1.1 255.255.255.0
 ip pim sparse-mode
 ipv6 address 2001:DB8:1::1/64

Isto significa que o comando pim do IPv6 está permitido à revelia nas relações. Para os perfis com VRF, a ponta de provedor 6 virtual (6VPE) deve ser plenamente operacional para o tráfego de unicast. Para o perfil 7, a ponta de provedor 6 (6PE) deve ser plenamente operacional para o tráfego de unicast.

Nota: Para que o Multicast trabalhe, o unicast deve ser plenamente operacional.

Configurar

Esta seção descreve como configurar os perfis do mVPN dentro do Cisco IOS.

Nota: Use a Command Lookup Tool ( somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

VPN-ID

O VPN-ID que é configurado para o VRF é exigido somente para os perfis que usam MLDP como o protocolo de árvore do núcleo e optam pela árvore de distribuição do Multicast (MDT).

vrf definition one
 rd 1:1
 vpn id 1000:2000

IPv4 e IPv6 permitidos para o mVPN

Para os perfis com padrão MDT e Generic Routing Encapsulation (GRE), se o mVPN é permitido para o IPv4 e o IPv6, a seguir o mesmo padrão MDT deve ser usado para ambas as famílias do endereço (AF).

Você não pode misturar perfis diferentes para os AF diferentes.

Para os perfis com o MDT dividido com MLDP, se o mVPN é permitido para o IPv4 e o IPv6, um MDT dividido diferente é sinalizado para cada AF para o mesmo roteador de PE da raiz. A árvore MLDP terá um identificador global diferente (GID) no valor opaco. A mesma relação da interface virtual do caminho comutado por rótulo (LSPVIF) é usada para ambos os AF.

Está aqui um exemplo onde o perfil 14 seja usado para o IPv4 e o IPv6 AF:

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !
 address-family ipv4
  mdt auto-discovery mldp
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family
 !
 address-family ipv6
  mdt auto-discovery mldp
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

A fonte 10.100.1.6 e 2001:DB8:2::6 é atrás do mesmo roteador de PE PE2 da fonte. A entrada do banco de dados da informação de roteamento de transmissão múltipla (MRIB) para o grupo de transmissão múltipla do IPv4 e o grupo do Multicast IPv6 usa etiqueta diferente uma entrada comutada do Multicast (LS) ou a entrada MLDP no banco de dados no roteador de PE do ingresso, assim que ambos os grupos são enviados em árvores diferentes MLDP.

PE2#show mpls mldp database opaque_type gid 
LSM ID : 5   Type: P2MP   Uptime : 02:18:54
  FEC Root           : 10.100.1.2 (we are the root)
  Opaque decoded     : [gid 65536 (0x00010000)]
  Opaque length      : 4 bytes
  Opaque value       : 01 0004 00010000
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : 5
  Replication client(s):
    MDT  (VRF one)
      Uptime         : 02:18:54      Path Set ID  : None
      Interface      : Lspvif1       
    10.100.1.4:0
      Uptime         : 00:32:50      Path Set ID  : None
      Out label (D)  : 20            Interface    : Ethernet2/0*
      Local label (U): None          Next Hop     : 10.1.2.4

LSM ID : 6   Type: P2MP   Uptime : 00:37:06
  FEC Root           : 10.100.1.2 (we are the root)
  Opaque decoded     : [gid 131072 (0x00020000)]
  Opaque length      : 4 bytes
  Opaque value       : 01 0004 00020000
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : 6
  Replication client(s):
    MDT  (VRF one)
      Uptime         : 00:37:06      Path Set ID  : None
      Interface      : Lspvif1       
    10.100.1.4:0
      Uptime         : 00:18:38      Path Set ID  : None
      Out label (D)  : 22            Interface    : Ethernet2/0*
      Local label (U): None          Next Hop     : 10.1.2.4
PE2#show ip mfib vrf one 232.1.1.1                 
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   FS Pkt Count/PS Pkt Count
VRF one
 (10.100.1.6,232.1.1.1) Flags:
   SW Forwarding: 374/0/100/0, Other: 122/0/122
   Ethernet0/0 Flags: A
   Lspvif1, LSM/6 Flags: F
     Pkts: 374/0
PE2#show ipv6 mfib vrf one route FF3E::4000:1      
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   FS Pkt Count/PS Pkt Count
VRF one
 (2001:DB8:2::6,FF3E::4000:1)
   Ethernet0/0 A
   Lspvif1, LSM/5 F

perfis do mVPN

Esta seção descreve as configurações requerida para cada perfil.

Padrão MDT do perfil 0 - GRE - Sinalização do C-mcast PIM

Use esta configuração para o perfil 0:

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt default 232.1.1.1
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
 address-family ipv4 mdt
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Nota: O mdt do IPv4 da endereço-família é exigido para o padrão MDT que é construído para o Multicast do IPv6 PIM/IP. Você deve ter o IPv6 permitido na interface de loopback, assim que significa que deve haver um endereço do IPv6 ou um comando enable do IPv6 configurado na interface de loopback. Se o Multicast é permitido para o IPv4 no VRF também, a seguir o IPv6 e o IPv4 usam o mesmo padrão MDT (o mesmo grupo de transmissão múltipla no contexto global) e a mesma interface de túnel no roteador de PE.

Padrão MDT do perfil 1 - MLDP MP2MP - Sinalização do C-mcast PIM

Use esta configuração para o perfil 1:

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Perfil 2 MDT dividido - MLDP MP2MP - Sinalização do C-mcast PIM       

O perfil 2 não é apoiado atualmente no Cisco IOS, e o MLDP não apoia o MDT dividido com Multiponto-à-multiponto (MP2MP).

Padrão MDT do perfil 3 - GRE - BGP-AD - Sinalização do C-mcast PIM

Use esta configuração para o perfil 3:

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt auto-discovery pim
  mdt default 232.1.1.1
  route-target export 123:456
  route-target import 123:456
 exit-address-family

interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Nota: Porque a Protocolo-auto descoberta do gateway de borda (BGP-AD) para o PIM é usada, há já não uma necessidade para o IPv4 MDT AF, que seja precisada para o perfil 0. Você deve ter o IPv6 permitido na interface de loopback, assim que significa que deve haver um endereço do IPv6 ou um comando enable do IPv6 configurado na interface de loopback. Se o Multicast é permitido para o IPv6 no VRF também, a seguir o IPv6 e o IPv4 usam o mesmo padrão MDT (o mesmo grupo de transmissão múltipla no contexto global) e a mesma interface de túnel no roteador de PE.

Perfil 4 MDT dividido - MLDP MP2MP - BGP-AD - Sinalização do C-mcast PIM

O perfil 4 não é apoiado atualmente no Cisco IOS, e MLDP não apoia o MDT dividido com MP2MP.

Perfil MDT dividido 5 - MLDP P2MP - BGP-AD - Sinalização do C-mcast PIM

O perfil 5 não é apoiado atualmente no Cisco IOS, e a sinalização PIM não é apoiada sobre o MDT dividido. 

Perfil 6 VRF MLDP - Sinalização in-band

Use esta configuração para o perfil 6:

vrf definition one
 rd 1:1
 !
 address-family ipv6
  route-target export 123:456
  route-target import 123:456
 exit-address-family
!

interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64

ipv6 multicast-routing vrf one
ipv6 multicast vrf one mpls source Loopback0
ipv6 multicast vrf one mpls mldp

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
!
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Perfile a sinalização in-band global 7 MLDP

Use esta configuração para o perfil 7:

ipv6 multicast-routing
ipv6 multicast mpls source Loopback0
ipv6 multicast mpls mldp

interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 2001:DB8:2::6 remote-as 65002
 !
!
 address-family ipv6
  redistribute connected
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-label
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Estática global do perfil 8 - P2MP-TE         

O perfil 8 não é apoiado atualmente no Cisco IOS.

Padrão MDT do perfil 9 - MLDP - MP2MP - BGP-AD - Sinalização do C-mcast PIM

Use esta configuração para o perfil 9:

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Perfile a estática 10 VRF - P2MP TE - BGP-AD 

O perfil 10 não é apoiado atualmente no Cisco IOS, e BGP-AD não é apoiado para a engenharia de tráfego point-to-multipoint (P2MP TE).        

Padrão MDT do perfil 11 - GRE - BGP-AD - Sinalização do C-mcast BGP

Use esta configuração para o perfil 11:

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt auto-discovery pim
  mdt default 232.1.1.1
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
 address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Nota: Porque BGP-AD para o PIM é usado, há já não uma necessidade para o IPv4 MDT AF, que seja precisada para o perfil 0. Você deve ter o IPv6 permitido na interface de loopback, assim que significa que deve haver um endereço do IPv6 ou um comando enable do IPv6 configurado na interface de loopback. Se o Multicast é permitido para o IPv6 no VRF também, a seguir o IPv6 e o IPv4 usam o mesmo padrão MDT (o mesmo grupo de transmissão múltipla no contexto global) e a mesma interface de túnel no roteador de PE.

Padrão MDT do perfil 12 - MLDP - P2MP - BGP-AD - Sinalização do C-mcast BGP

Use esta configuração para o perfil 12:

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !        
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family

Padrão MDT do perfil 13 - MLDP - MP2MP - BGP-AD - Sinalização do C-mcast BGP

Use esta configuração para o perfil 13:

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Perfil 14 MDT dividido - MLDP P2MP - BGP-AD - Sinalização do C-mastro BGP

Use esta configuração para o perfil 14:

vrf definition one
 rd 1:1
!        
 address-family ipv6
  mdt auto-discovery mldp
mdt strict-rpf interface
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 2001:DB8:2::6 remote-as 65002
 !
!
 address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate exit-address-family

Perfil 15 MDT dividido - MLDP MP2MP - BGP-AD - Sinalização do C-mastro BGP

O perfil 15 não é apoiado atualmente no Cisco IOS, e MLDP não apoia o MDT dividido com MP2MP.

Estática do padrão MDT do perfil 16 - P2MP TE - BGP-AD - Sinalização do C-mcast BGP

O perfil 16 não é apoiado atualmente no Cisco IOS.

Padrão MDT do perfil 17 - MLDP - P2MP - BGP-AD - Sinalização do C-mcast PIM

Use esta configuração para o perfil 17:

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !        
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family

Estática do padrão MDT do perfil 18 - P2MP TE - BGP-AD - Sinalização do C-mcast PIM

O perfil 18 não é apoiado atualmente no Cisco IOS.

Padrão MDT do perfil 19 - IR - BGP-AD - Sinalização do C-mcast PIM    

O perfil 19 e a replicação do ingresso (IR) não são apoiados atualmente no Cisco IOS.         

Padrão MDT do perfil 20 - P2MP-TE - BGP-AD - PIM - sinalização do C-mcast

O perfil 20 e os Auto-túneis TE P2MP não são apoiados atualmente no Cisco IOS.

Padrão MDT do perfil 21 - IR - BGP-AD - BGP - sinalização do C-mcast 

O perfil 21 e IR não é apoiado atualmente no Cisco IOS.         

Padrão MDT do perfil 22 - P2MP-TE - BGP-AD BGP - sinalização do C-mcast

O perfil 22 e os Auto-túneis TE P2MP não são apoiados atualmente no Cisco IOS.  

Perfil 23 MDT dividido - IR - BGP-AD - Sinalização do C-mcast PIM

O perfil 23 e IR não é apoiado atualmente no Cisco IOS.      

Perfil 24 MDT dividido - P2MP-TE - BGP-AD - Sinalização do C-mcast PIM 

O perfil 24 e os Auto-túneis TE P2MP não são apoiados atualmente no Cisco IOS.  

Perfil 25 MDT dividido - IR - BGP-AD - Sinalização do C-mcast BGP 

O perfil 25 e IR não é apoiado atualmente no Cisco IOS.         

Perfil 26 MDT dividido - P2MP TE - BGP-AD - Sinalização do C-mcast BGP 

O perfil 26 e os Auto-túneis TE P2MP não são apoiados atualmente no Cisco IOS.

Verificar

Não há atualmente nenhum procedimento de verificação disponível para estas configurações.

Troubleshooting

Não há atualmente nenhuma informação de Troubleshooting específica disponível para estas configurações.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 118984