IP : Multicast

Configurar perfis do mVPN dentro do Cisco IOS

18 Junho 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (21 Abril 2016) | Feedback

Índice

Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento descreve como configurar cada perfil do VPN multicast (mVPN) dentro do ® do Cisco IOS.

Nota: As configurações que são descritas neste documento aplicam-se ao Roteadores da ponta de provedor (PE).

Contribuído por Luc De Ghein, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

Antes que você continue com a configuração que está descrita neste documento, verifique se há um apoio para um perfil do mVPN na plataforma específica que executa o Cisco IOS.

Componentes Utilizados

A informação neste documento é baseada em todas as versões do Cisco IOS.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Configurar

Esta seção descreve como configurar os perfis do mVPN dentro do Cisco IOS.

Nota: Use a Command Lookup Tool ( somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

perfis do mVPN

Nota: Não todos os perfis são apoiados atualmente no Cisco IOS.

Nota: O roteamento virtual/transmissão (VRF) que é usada durante todo este documento é VRF um. O Rosen MLDP foi rebatizado para optar pelo MDT.

Um perfil do mVPN é configurado para o contexto global ou pelo VRF. Você pode usar o método velho ou novo a fim definir um VRF quando você configura perfis do mVPN no Cisco IOS.

Está aqui um exemplo do método velho:

ip vrf one
rd 1:1
route-target export 1:1
route-target import 1:1

Está aqui um exemplo do método novo:

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family

Para os perfis no contexto global, o roteamento de transmissão múltipla deve ser permitido:

ip multicast-routing

Para os perfis no contexto VRF, o roteamento de transmissão múltipla deve ser permitido para o VRF:

ip multicast-routing vrf one

Você pode permitir o registo do protocolo multiponto da distribuição de rótulo (MLDP) com este comando global para os perfis com MLDP:

mpls mldp logging notifications

A transmissão múltipla independente de protocolo (PIM) deve ser permitida para o roteador da ponta de provedor (PE) no link da borda do Borda-cliente do fornecedor (PE-CE) para ambos os casos (globais ou contexto VRF):

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

FRR para MLDP

Rápido redistribua (FRR) para MLDP está disponível no Cisco IOS. O tráfego multicast para que MLDP é o protocolo do plano do controle deve usar um túnel preliminar da engenharia de tráfego (TE) a fim ter o tráfego protegido pelo FRR. O túnel TE preliminar pode ser um túnel TE manual ou um auto-túnel preliminar. O link deve ser protegido por TE FRR, qualquer um por um túnel do backup manual ou um auto-túnel alternativo.

Este exemplo usa um túnel manual do backup preliminar e manual.

Este comando global deve ser configurado para que MLDP use túneis TE do Multiprotocol Label Switching (MPLS):

mpls mldp path traffic-eng

Esta configuração é usada para a interface protegida que é usada pelo túnel preliminar do um-salto:

interface Ethernet3/0
 ip address 10.1.6.6 255.255.255.0
 load-interval 30
 mpls ip
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel0
 ip rsvp bandwidth 10000
end

Esta configuração é usada para o túnel alternativo:

interface Tunnel0
 ip unnumbered Loopback0
 load-interval 30
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3

Esta configuração é usada para o túnel preliminar do um-salto:

interface Tunnel1
 ip unnumbered Loopback0
 load-interval 30
 mpls ip
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3-direct
 tunnel mpls traffic-eng fast-reroute

Nota: A configuração dos mpls IP é exigida no túnel preliminar porque MLDP deve ser permitido no túnel protegido. O autoroute anuncia que a configuração está exigida a fim se assegurar de que o túnel TE esteja usado para enviar o tráfego.

MBB para MLDP

Faça antes da característica da ruptura (MBB) é apoiado no Cisco IOS, mas somente no método que usa um retardo fixo depois que o trajeto novo está disponível. Não há nenhuma pergunta/reconhece o mecanismo no Cisco IOS.

Este é o comando global que é usado a fim configurar o retardo fixo MBB:

P1(config)#mpls mldp make-before-break delay ?
<0-60000> Delay in milliseconds

O valor padrão não é 0, tão lá é nenhum MBB à revelia.

Perfis

Esta seção descreve as configurações requerida para cada perfil do mVPN.

Padrão MDT do perfil 0 - GRE - Sinalização do C-mcast PIM

Use esta configuração para o perfil 0:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
ip multicast-routing
ip multicast-routing vrf one

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
  neighbor 10.100.1.7 route-reflector-client
exit-address-family
!
address-family ipv4 mdt
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Nota: Para este perfil, o PIM deve ser permitido na interface de loopback global. A árvore de distribuição do Multicast do IPv4 da família do endereço (AF) (MDT) deve ser usada para todos os tipos de sinalização PIM no núcleo (não somente para o Source Specific Multicast (SSM) PIM).

Padrão MDT do perfil 1 - MLDP MP2MP - Sinalização do C-mcast PIM

Use esta configuração para o perfil 1:

vrf definition one
rd 1:2
vpn id 1000:2000
!
address-family ipv4
  mdt default mpls mldp 10.100.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one

mpls mldp logging notifications

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.2.9 remote-as 65002
  neighbor 10.2.2.9 activate
exit-address-family

Perfil 2 MDT dividido - MLDP MP2MP - Sinalização do C-mcast PIM

     

O perfil 2 não é apoiado atualmente no Cisco IOS, e MLDP não apoia o MDT dividido com Multiponto-à-multiponto (MP2MP).

Padrão MDT do perfil 3 - GRE - BGP-AD - Sinalização do C-mcast PIM

Use esta configuração para o perfil 3:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

  

Nota: Para este perfil, o PIM deve ser permitido na interface de loopback global. Porque a Protocolo-auto descoberta do gateway de borda (BGP-AD) para o PIM é usada, há já não uma necessidade para o IPv4 MDT AF, que seja precisada para o perfil 0.

Perfil 4 MDT dividido - MLDP MP2MP - BGP-AD - Sinalização do C-mcast PIM

O perfil 4 não é apoiado atualmente no Cisco IOS, e MLDP não apoia o MDT dividido com MP2MP.

Perfil MDT dividido 5 - MLDP P2MP - BGP-AD - Sinalização do C-mcast PIM

O perfil 5 não é apoiado atualmente no Cisco IOS, e a sinalização PIM não é apoiada sobre o MDT dividido.

Perfil 6 VRF MLDP - Sinalização in-band

Use esta configuração para o perfil 6:

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
ip multicast vrf one mpls mldp


!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!


ip pim vrf one mpls source Loopback0

Perfile a sinalização in-band global 7 MLDP

Use esta configuração para o perfil 7:

ip multicast-routing

ip multicast mpls mldp

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!

interface Ethernet2/0
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip pim mpls source Loopback0

Estática global do perfil 8 - P2MP-TE

Esta seção descreve as configurações requerida para o perfil 8 no Roteadores da extremidade principal TE e da extremidade traseira TE.

Roteador de extremidade principal TE

Use esta configuração para o perfil 8 no roteador de extremidade principal TE:

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
mpls traffic-eng destination list name from-PE3
ip 10.100.1.1 path-option 1 dynamic
ip 10.100.1.2 path-option 1 dynamic
ip 10.100.1.4 path-option 1 explicit name to-PE4

interface Tunnel0
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.1.1.1 source 10.2.3.10
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name from-PE3
!

interface Ethernet1/0
ip address 10.1.10.3 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000

!
router ospf 1
network 10.1.7.0 0.0.0.255 area 0
network 10.1.10.0 0.0.0.255 area 0
network 10.100.0.0 0.0.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

Nota: Uma lista do destino é exigida para o Roteadores da extremidade traseira do túnel TE (P2MP) point-to-multipoint. A path-opção para o roteador da extremidade traseira pode ser explícita ou dinâmica.

Roteador da extremidade traseira TE

Use esta configuração para o perfil 8 no roteador da extremidade traseira TE:

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000
        

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip mroute 10.2.3.0 255.255.255.0 10.100.1.3

Nota: O mroute estática é exigido para a fonte para o roteador de extremidade principal TE no contexto global.

Padrão MDT do perfil 9 - MLDP - MP2MP - BGP-AD - Sinalização do C-mcast PIM

Use esta configuração para o perfil 9:

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

Perfile a estática 10 VRF - P2MP TE - BGP-AD

O perfil 10 não é apoiado atualmente no Cisco IOS, e BGP-AD não é apoiado para P2MP TE.

Padrão MDT do perfil 11 - GRE - BGP-AD - Sinalização do C-mcast BGP

Use esta configuração para o perfil 11:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1 
  mdt overlay use-bgp
route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

Nota: Para este perfil, o PIM deve ser permitido na interface de loopback global. Porque BGP-AD para o PIM é usado, há já não uma necessidade para o IPv4 MDT AF, que seja precisada para o perfil 0.

Padrão MDT do perfil 12 - MLDP - P2MP - BGP-AD - Sinalização do C-mcast BGP

Use esta configuração para o perfil 12:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Padrão MDT do perfil 13 - MLDP - MP2MP - BGP-AD - Sinalização do C-mcast BGP

Use esta configuração para o perfil 13:

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

Perfil 14 MDT dividido - MLDP P2MP - BGP-AD - Sinalização do C-mastro BGP

Use esta configuração para o perfil 14:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
mdt strict-rpf interface
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Perfil 15 MDT dividido - MLDP MP2MP - BGP-AD - Sinalização do C-mastro BGP

O perfil 15 não é apoiado atualmente no Cisco IOS, e MLDP não apoia o MDT dividido com MP2MP.

Estática do padrão MDT do perfil 16 - P2MP TE - BGP-AD - Sinalização do C-mcast BGP

O perfil 16 não é apoiado atualmente no Cisco IOS.

Padrão MDT do perfil 17 - MLDP - P2MP - BGP-AD - Sinalização do C-mcast PIM

Use esta configuração para o perfil 17:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Estática do padrão MDT do perfil 18 - P2MP TE - BGP-AD - Sinalização do C-mcast PIM

O perfil 18 não é apoiado atualmente no Cisco IOS.

Padrão MDT do perfil 19 - IR - BGP-AD - Sinalização do C-mcast PIM

O perfil 19 e a replicação do ingresso (IR) não são apoiados atualmente no Cisco IOS.

Padrão MDT do perfil 20 - P2MP-TE - BGP-AD - PIM - sinalização do C-mcast

O perfil 20 e os Auto-túneis TE P2MP não são apoiados atualmente no Cisco IOS.

Padrão MDT do perfil 21 - IR - BGP-AD - BGP - sinalização do C-mcast

O perfil 21 e IR não é apoiado atualmente no Cisco IOS.       

Padrão MDT do perfil 22 - P2MP-TE - BGP-AD BGP - sinalização do C-mcast

O perfil 22 e os Auto-túneis TE P2MP não são apoiados atualmente no Cisco IOS.  

   

Perfil 23 MDT dividido - IR - BGP-AD - Sinalização do C-mcast PIM

O perfil 23 e IR não é apoiado atualmente no Cisco IOS.          

Perfil 24 MDT dividido - P2MP-TE - BGP-AD - Sinalização do C-mcast PIM

O perfil 24 e os Auto-túneis TE P2MP não são apoiados atualmente no Cisco IOS.

Perfil 25 MDT dividido - IR - BGP-AD - Sinalização do C-mcast BGP

O perfil 25 e IR não é apoiado atualmente no Cisco IOS.       

Perfil 26 MDT dividido - P2MP TE - BGP-AD - Sinalização do C-mcast BGP

O perfil 26 e os Auto-túneis TE P2MP não são apoiados atualmente no Cisco IOS.

MVPN Inter-autônomo

A informação nesta seção é fornecida sob a suposição que a configuração apropriada está executada no Roteadores a fim fazer o Inter-AS MPLS VPN operacional para o unicast.

A opção D não é apoiada para o mVPN.

Opção A

A configuração regular do mVPN é exigida para a opção A. Você pode ter todo o perfil nos sistemas autônomo, e os perfis não têm que combinar nos sistemas diferente autônomo.

PIM

Para as opções B e o C, se os endereços IP de Um ou Mais Servidores Cisco ICM NT da interface de loopback estão redistribuídos do Border Gateway Protocol (BGP) no Interior Gateway Protocol (IGP) dos outros sistemas autônomo (COMO), a seguir o vetor PIM não é exigido.

Opção B

Somente o mVPN do sistema inter-autônomo (inter-COMO) é apoiado com perfil 0 (com túneis NON-segmentados).

A configuração regular do mVPN é exigida para a opção B. Somente o IPv4 MDT AF pode ser usado; O IPv4 MVPN AF não é apoiado.

A origem do vetor PIM com distinguidor de rota (RD) é exigida nos roteadores de PE, com esta configuração adicional:

ip multicast vrf one rpf proxy rd vector

Os Autonomous System Border Router (ASBR) devem ter o PIM permitido no link ASBR-à-ASBR. Os ASBR devem igualmente ter o IPv4 MDT AF configurado para os vizinhos do internal border gateway protocol (iBGP) e o vizinho do Protocolo de Gateway Limite externo (eBGP) ASBR (eBGP).

Esta configuração adicional é exigida no ASBR:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
no bgp default route-target filter
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family vpnv4
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family

C da opção

Somente o mVPN do sistema inter-autônomo (inter-COMO) é apoiado com perfil 0 (com túneis NON-segmentados).

A configuração regular do mVPN é exigida para o C da opção. Os prefixos do laço de retorno PE dos outros AS são anunciados pelo BGP no IPv4 AF.

A origem do vetor PIM sem RD é exigida nos roteadores de PE igualmente, com esta configuração adicional:

ip multicast rpf proxy vector

Os ASBR devem ter o PIM permitido no link ASBR-à-ASBR. Os ASBR devem igualmente ter o IPv4 MDT AF configurado para os vizinhos iBGP e o vizinho de ebgp ASBR.

Esta configuração adicional é exigida no ASBR:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family ipv4
redistribute ospf 1 metric 100 route-map loopbacks-into-BGP
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.3.1.4 send-label
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
neighbor 10.100.1.6 send-label
exit-address-family
!     
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!        

Nota: O IPv4 MDT AF entre os sistemas autônomo pode igualmente ser configurado nos refletores de rota (RR) em uma sessão dos vários saltos e EBGP em vez nos ASBR.

MLDP

A opção B não é apoiada atualmente.

C da opção

Não há nenhum apoio para o Forwarding Equivalence Class recursivo (FEC) no Cisco IOS. Daqui, redistribução dos laços de retorno PE pelo iBGP no outro COMO não é suficiente, enquanto o Roteadores P (fornecedor) falta o conhecimento dos roteadores de PE no outro COMO.

Há um apoio se os laços de retorno PE são redistribuídos pelo IGP nos outro COMO. Neste caso, os perfis com MDT dividido e a malha cheia P2MP MLDP são apoiados. O IPv4 MDT AF não pode ser usado aqui; O IPv4 MVPN AF deve ser usado. A sessão do mVPN BGP pode ser executado entre os PE e os RR. Entre os RR, há já uma sessão dos vários saltos e EBGP que seja executado para o AF VPNv4/6.

O MLDP BGP-AD deve ser permitido. Inter-como a palavra-chave é exigido nos roteadores de PE a fim assegurar-se de que o tipo-1 rotas BGP-AD não tenha a comunidade sem exportação.

Perfis com malha cheia P2MP MLDP

Esta seção descreve as configurações para os perfis 12 e 17.

Configuração do perfil 17

Está aqui a configuração nos roteadores de PE para o perfil 17:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
route-target export 1:1
route-target import 1:1
exit-address-family

Está aqui a configuração nos ASBR para o perfil 17:

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding
end

Nota: A configuração dos mpls IP é exigida no link entre os ASBR a fim ter um neighborship MLDP entre eles.

Está aqui a configuração nos RR para o perfil 17:

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

Configuração do perfil 12

Esta configuração é a mesma que aquela usada para o perfil 17, mas há a sinalização adicional do C-Multicast pelo BGP.

Está aqui a configuração nos roteadores de PE para o perfil 12:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

Perfis com o MDT dividido MLDP

Esta seção descreve a configuração para o perfil 14.

Configuração do perfil 14

Está aqui a configuração nos roteadores de PE para o perfil 14:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

Está aqui a configuração nos ASBR para o perfil 14:

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding

Nota: Os mpls IP são exigidos no link entre os ASBR a fim ter um neighborship MLDP entre eles.

Está aqui a configuração nos RR para o perfil 14:

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

CsC

Esta informação é fornecida sob a suposição que a configuração apropriada está executada no Roteadores a fim ter o MPLS VPN do portador do portador (CsC) operacional para o unicast.

Somente o perfil 0 é apoiado para CsC. Isto significa que pode haver CsC hierárquico com VPN Multicast-permitidos. O VPN do CsC tem o perfil 0 do mVPN configurado. A rede do portador tem o perfil 0 do mVPN configurado também. Isto significa que há a configuração regular do mVPN, no Roteadores CSC-PE do CsC e nos roteadores de PE do portador, e então não há nenhuma configuração adicional necessária para o Multicast.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 118985