IP : Open Shortest Path First (OSPF)

OSPF com exemplo de configuração da adjacência da Multi-área

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve como configurar o protocolo de roteamento do estado do link do Open Shortest Path First (OSPF) para a adjacência da Multi-área.

Contribuído por Narendra Naukwal, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • OSPF

  • Adjacência da Multi-área

Cisco igualmente recomenda que estas exigências estejam cumpridas antes que você tente a configuração que está descrita neste documento:

  • O protocolo de roteamento do estado do link OSPF deve PRE-ser configurado na rede.

  • Somente dois oradores OSPF usam a relação entre que a funcionalidade da Multi-área OSPF trabalha. A Multi-área OSPF trabalha somente em tipos de rede Point-to-Point.

Componentes Utilizados

A informação neste documento é baseada na Multi-área OSPF.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Informações de Apoio

O protocolo de roteamento do estado do link OSPF usa o conceito de áreas, que são secundário-domínios dentro do domínio de OSPF. Um roteador dentro de uma área mantém a informação de topologia completa dessa área. À revelia, uma relação pode somente pertencer a uma área do OSPF. Isto não pode somente causar o roteamento subótimo na rede, mas pode igualmente conduzir a outras edições se a rede não é projetada corretamente.

Quando a adjacência da Multi-área é configurada em uma relação, os oradores OSPF formam mais de uma adjacência (ADJ) sobre esse link. A relação da Multi-área é uma lógica, a interface Point-to-Point sobre que o ADJ é formado. Este documento descreve uma encenação onde a Multi-área OSPF ADJ possa ser usada a fim trabalhar em torno de um problema e cumprir os requisitos de rede.

Configurar

Diagrama de Rede

Neste diagrama da rede, um domínio network/OSPF é usado. O sistema exige que o tráfego do roteador 5 (R5) ao r1 (10.1.1.1) passa sempre com o R3. Supõe que o R3 é um Firewall na rede através de que todo o tráfego deve ser distribuído, ou que o link entre o R3 e o R4 tem mais largura de banda do que o link entre o R2 e o R4. Em qualquer dos casos, o sistema exige que o tráfego deve correr através do R3 quando passa do R5 ao r1 (prefixo 10.1.1.1/32).

Configurações inicial

Esta seção descreve as configurações inicial para o r1 com o R5.

R1

!
interface Ethernet0/0
ip address 192.168.12.1 255.255.255.0
end

!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
end

!
ip route 0.0.0.0 0.0.0.0 192.168.12.2
!

R2

!
interface Ethernet0/0
ip address 192.168.12.2 255.255.255.0
end

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Ethernet0/2
ip address 192.168.24.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
end

!
ip route 10.1.1.1 255.255.255.255 192.168.12.1

!
router ospf 1
router-id 0.0.0.2
redistribute static metric-type 1 subnets
!

R3

!
interface Ethernet0/0
ip address 192.168.34.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Loopback0
ip address 10.3.3.3 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.3
!

R4

!
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.45.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.4
!

R5

!
interface Ethernet0/1
ip address 192.168.45.5 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.5.5.5 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.5
!

Comportamento padrão

Com as configurações precedente no lugar, esta seção descreve os comportamentos do roteador padrão.

Está aqui o traço do R5 a 10.1.1.1. Observe que o tráfego passa com o R2, não R3:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 6 msec 6 msec   <<< R4
2 192.168.24.2 6 msec 6 msec 8 msec   <<< R2
3 192.168.12.1 8 msec * 3 msec        <<< R1

Nesta rede, o roteador R4 deve fazer a decisão e deve distribuir o tráfego ao R3, não ao R2 diretamente, conforme o requisito do sistema.

Está aqui um exemplo da tabela de roteamento no R4:

R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:14:33 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:14:33 ago, via Ethernet0/2 <<< Towards R2
Route metric is 30, traffic share count is 1

Uma métrica de 30 é associada com esta rota para o prefixo 10.1.1.1/32. Isto é devido a uma métrica do padrão de 20 que seja usada pelo roteador de limite de sistema autônomo (ASBR) (R2) e por um custo do 10 na relação Eth0/2 no R4.

O trajeto do R4 ao prefixo 10.1.1.1/32 através do R3 é mais longo. Aqui, o custo para os Ethernet de interface 0/2 em R4 (o trajeto para o R2) é alterado a fim verificar se muda o comportamento:

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
end

Está aqui o traço do R5 e o comando show ip route output do R4:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 4 msec 9 msec 8 msec   <<< R4
2 192.168.24.2 8 msec 9 msec 10 msec  <<< R2
3 192.168.12.1 10 msec * 5 msec       <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 120, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:01:50 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:01:50 ago, via Ethernet0/2
  Route metric is 120, traffic share count is 1

Enquanto o traço mostra, o tráfego do R5 toma o mesmo trajeto, e o tráfego não flui através do R3. Também, segundo as indicações da saída do comando de 10.1.1.1 da rota da mostra IP no R4, o custo de 100 que foi adicionado em R4 (Ethernet de interface 0/2) toma o efeito e o custo da rota ao prefixo é 120 (oposto a 30). Contudo, o trajeto ainda não mudou e a exigência para que o tráfego flua através do R3 não é cumprida ainda.

A fim determinar a causa deste comportamento, é aqui o comando show ip ospf border-routers R4 output (o custo R4 nos Ethernet de interface 0/2 é ajustado ainda a 100):

R4#show ip ospf border-routers
            OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
 Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.2 [100] via 192.168.24.2, Ethernet0/2, ABR/ASBR, Area 99, SPF 3
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 3

No R4, você pode ver que há dois roteadores de borda de área (ABR) (0.0.0.2, que é R2, e 0.0.0.3, que é R3) e que o R2 é o ASBR. Esta saída igualmente mostra a informação do intra-area (i) para o ASBR.

Agora, o Ethernet de interface 0/2 é fechado no R4 a fim determinar se os fluxos de tráfego através do R3 e a fim ver como a saída do comando show ip ospf border-routers aparece:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
shutdown 
end

Está aqui o traço do R5 e o comando show ip route output do R4:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 7 msec 7 msec 8 msec   <<< R4
2 192.168.34.3 9 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 9 msec 9 msec 7 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1 <<< Metric 40
Last update from 192.168.34.3 on Ethernet0/0, 00:01:46 ago  <<< Traffic to R2
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:01:46 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

Como mostrado, quando o Ethernet de interface 0/2 é fechado no R4, o tráfego passa com o R3. Também, o custo que é associado com a rota para o R3 é somente 40, quando o custo para 10.1.1.1/32 através do R2 era 120. O protocolo de OSPF ainda prefere distribuir o tráfego através do R2 em vez do R3, mesmo que o custo para alcançar 10.1.1.1/32 seja mais baixo através do R3.

É aqui a saída de roteadores de borda OSPF da mostra IP mais uma vez no R4:

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
               Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

I 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ASBR, Area 99, SPF 4
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 4

A informação que é exigida a fim alcançar o ASBR é a informação do inter-area. Contudo, a informação do intra-area essa detalhes como alcançar o ASBR é preferida sobre a informação do inter-area independentemente dos custos de OSPF que são associados com os dois trajetos.

Por este motivo, o trajeto através do R3 não foi preferido, mesmo que o custo através do R3 fosse mais baixo.

Aqui, o Ethernet de interface 0/2 é trazido o apoio no R4:

interface Ethernet0/2
no shutdown
end
!

O traço do R5 indica que distribuindo ações retorne àquelas observadas previamente (o tráfego não flui através do R3):

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 7 msec 7 msec   <<< R4
2 192.168.24.2 7 msec 8 msec 7 msec   <<< R2
3 192.168.12.1 8 msec * 12 msec       <<< R1

Há umas várias maneiras que você pode resolver esta edição (esta lista não é exaustiva):

  • Mude a área entre o R2 e o R3 a 90, e altere então o custo.

  • Adicionar um outro link entre o R2 e o R3 e configurar-lo para estar na área 99.

  • Use a Multi-área ADJ.

Refira a próxima seção a fim ver a maneira em que a Multi-área OSPF ADJ trabalha e como pode resolver esta edição à mão.

Configuração da adjacência da Multi-área

Como mencionado previamente, a Multi-área ADJ pode ser usada a fim formar o ponto múltiplo para apontar adjacências lógicas sobre um link único. A exigência é que deve haver somente dois oradores OSPF no link, e em uma rede de transmissão, você deve manualmente mudar o tipo de rede OSPF a ponto a ponto no link.

Esta característica permite que um único enlace físico seja compartilhado por áreas múltiplas e cria um trajeto do intra-area em cada um das áreas que compartilham do link.

A fim cumprir esta exigência, você deve configurar a Multi-área ADJ OSPF entre o R2 e o R3 sobre o Ethernet 0/1 do link, que está atualmente somente na área 0.

Está aqui a configuração para o R2:

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

Está aqui a configuração para o R3:

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

O OSPF ADJ vem acima sobre o enlace virtual:

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.2 on OSPF_MA0 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.3 on OSPF_MA0 from LOADING to FULL, Loading Done

Está aqui o ADJ recentemente formado:

R2#show ip ospf neighbor 0.0.0.3
<Snip>
Neighbor 0.0.0.3, interface address 192.168.23.3
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:03:01
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec
R3#show ip ospf neighbor 0.0.0.2
<Snip>
Neighbor 0.0.0.2, interface address 192.168.23.2
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:01:41
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec

Verificar

A fim verificar se sua configuração trabalha corretamente, inscreva o comando show ip ospf border-routers no R4:

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 10
i 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ABR/ASBR, Area 99, SPF 10

Como mostrado, a informação do intra-area que é usada a fim distribuir o tráfego a R2 (0.0.0.2)/ASBR é através do R3. Isto deve resolver o problema previamente mencionado.

Está aqui o traço do R5:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 8 msec 9 msec 8 msec   <<< R4
2 192.168.34.3 8 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 7 msec 8 msec 8 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1

Como mostrado, o tráfego do R5 que é destinado a 10.1.1.1 flui corretamente através do R3, e o requisito do sistema são cumpridos.

Inscreva o comando show ip ospf neighbor no R2, no R3, e no R4 a fim verificar se os ADJ estão estabelecidos:

R2#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.3       0  FULL/ -  00:00:39   192.168.23.3   Ethernet0/1 
0.0.0.4       0  FULL/ -  00:00:37   192.168.24.4   Ethernet0/2
0.0.0.3       0  FULL/ -  00:00:33   192.168.23.3   OSPF_MA0 
R3#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:34   192.168.23.2   Ethernet0/1 
0.0.0.2       0  FULL/ -  00:00:35   192.168.23.2   OSPF_MA0 
0.0.0.4       0  FULL/ -  00:00:39   192.168.34.4   Ethernet0/0
R4#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:32   192.168.24.2   Ethernet0/2  
0.0.0.5       0  FULL/ -  00:00:32   192.168.45.5   Ethernet0/1
0.0.0.3       0  FULL/ -  00:00:35   192.168.34.3   Ethernet0/0

Nota: Nestas saídas, as entradas da relação Ethernet0/1 indicam o ADJ sobre a área 0, e as entradas da relação OSPF_MA0 indicam a Multi-área ADJ sobre a área 99.

R4 o Ethernet de interface 0/2 ainda tem um custo de 100, e o trajeto através do R3 é preferido no R4. Se este custo é removido, a seguir o R4 distribui o tráfego diretamente ao R2 como antes.

Estão aqui a configuração e a saída do comando show ip route no R4 com os custos de OSPF IP de 100 ainda configurados R4 nos Ethernet de interface 0/2:

!
interface Ethernet0/2
 ip address 192.168.24.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 99
 ip ospf cost 100
!
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1
Last update from 192.168.34.3 on Ethernet0/0, 00:28:45 ago
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:28:45 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

Está aqui a configuração e o comando show ip route output no R4 quando você remove o custo:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:00:13 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:00:13 ago, via Ethernet0/2 <<< Route changed back to R2
     Route metric is 30, traffic share count is 1

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 118879