Switches : Switches Cisco Catalyst 3850 Series

3750 MLS à conversão de 3850 MQC da configuração de QoS

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

O documento descreve a diferença básica entre 3750 Qualidade de Serviço (QoS) do switching multicamada (MLS) e Modular QoS CLI (MQC) QoS dos Cisco Catalyst 3850 Switch. Igualmente fornece a informação detalhada sobre a conversão com as configurações de amostra. Este documento aplica-se somente ao QoS prendido. Este documento é para os profissionais de comunicação de rede que são responsáveis para o projeto, o implemention, ou o administation de uma rede que inclua um Cisco Catalyst 3850 Switch autônomo ou uma pilha do Cisco Catalyst 3850 Switch, referido como o interruptor.

Contribuído por Jaroslaw Gawron e por Vivek Sharma, engenheiros de TAC da Cisco.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • Cisco IOS ® Software
  • Conceitos e terminologia de MLS e de MQC QoS

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Vista geral para a diferença entre 3750 MLS QoS e 3850 MQC QoS

A configuração de QoS na linha 3850 foi melhorado devido a sua aplicação da configuração MQC (modelo universal da configuração de QoS) em vez dos comandos velhos MLS QoS (configuração de QoS do dependente da plataforma) das 3750 e 3560 linhas de Switches.

Os principais diferença são destacados nesta tabela:

Tipo de Switch

3750

3850

Estrutura básica

MLS

MQC

Padrão de QoS

Desabilitado

Habilitado

Config global

Apoio MLS QoS

Apoie algum do MQC no ingresso

Não apoia MLS QoS

[class-map, policy-map] do apoio MQC

Configuração da relação

Apoie a configuração MLS QoS e a alguma de MQC CLI no ingresso

Anexe a política à relação

Padrão da confiabilidade da porta

Desabilitado

Habilitado

Ingresso da porta

Classificação/policiamento/marcação

Enfileiramento

Classificação/policiamento/marcação

[NO Iingress Queuing!]

Saída da porta

Enfileiramento

Classificação/policiamento/marcação/Enfileiramento

Comute o ingresso da interface virtual (SVI)

Classificação/policiamento/marcação

Classificação/Marcação

Saída SVI

Nenhum

Classificação/Marcação

É importante reconhecer a alteração fundamental principal na aproximação de QoS.

Nos 3750, o QoS é desabilitado à revelia visto que nos 3850, é permitido. A fim preservar igualmente a camada 2 (marcação L2)/Layer 3 (L3) QoS na plataforma 3750, uma configuração da confiança devem ser aplicados.

No caso dos 3850, todos os pacotes são confiados à revelia (a marcação L2/L3 QoS é preservado), a menos que você a mudar com um aplicativo de um mapa de política específico no ingresso ou na interface de saída.

Modelo de 3750 QoS

Modelo de 3850 QoS

Tabela de comparação do detalhe da característica

Ingresso

Recurso

3750

3850

Classificação

Differentiated Services Code Point do fósforo do mapa de classe (DSCP), precedência (Prec), Access Control List (ACL)

Apoia compatível com todos e compatível com qualquer

Classe de serviço (CoS) do mapa de classe, Prec, DSCP, ACL

E VLAN

Apoia compatível com qualquer somente

Marcação

[unconditional set]

Ajuste o DSCP e o Prec

Ajuste CoS, Prec, DSCP e QoS-grupo

Marcação

[conditional marking]

Mutação DSCP

Tabela-mapa do class-default

Vigilância

1r2c

1r2c e 2r3c

Policiando o markdown

Policiar excede Mark-para baixo

[Only supports DSCP]

Policiar excede e viola Mark-para baixo

[Supports CoS, DSCP, Prec]

Policiamento agregado

Apoios

Agg-policiando o [one type of  HQoS]

Enfileiramento do ingresso

Os apoios somente em 3750 mas não apoiam em 3750x

Não apoia

QoS hierárquico (HQoS)

O VLAN baseou HQoS somente

Agg-policiamento com base na porta e VLAN per. (picovolt)

Saída

Recurso

3750

3850

Apoio da classificação para nenhuns ação do Enfileiramento

Não apoia

CoS, Prec, DSCP, QoS-grupo, ACL

e VLAN

Apoio da classificação para a ação de enfileiramento

CoS e DSCP

CoS, Prec, DSCP e QoS-grupo

Marcação

Não apoia

Ajuste CoS, Prec, e DSCP

Vigilância

Não apoia

1r2c, 2r3c com excedem/violam a marca para baixo através do tabela-mapa

Número máximo de filas e de tipos de fila

[4 queues] 1P3Q3T

Expeça a fila de prioridade do queue->

[up to 8 queues] 2P6Q3T

Enfileiramento da saída

Compartilhe do modo, do modo da forma, do fila-limite, da prioridade e do buffer de fila

Largura de banda, permanecer da largura de banda, dar forma, fila-limite, prioridade e buffer de fila

HQoS

Não apoia

HQoS: Agg-policiamento, picovolt, Porta-shaper e de usuário do pai shaper com ação do NON-Enfileiramento da criança

Comandos show comuns de QoS

3750

Comandos show da entrada:

show run class-map  [name_of_class-map]
show run policy-map [name of policy-map]
show policy-map int [interface_name]

Comandos show gerais:

show mls qos maps
show mls qos maps <options>
show mls qos queue-set
show mls qos interface [interface_name] queuing
show platform port-asic stats drop [interface_name] statistics
show mls qos aggregate-policer

3850

show run class-map [name_of_class-map]
show run policy-map [name of policy-map]
show table-map [name_of_table-map]
show run policy-map [name_of_policy-map]
show policy-map int [interface_name]
show platform qos policies port sw [sw#]
show platform qos queue config interface_type [interface_name]
show platform qos queue stats interface_type [interface_name]

3750 à amostra da conversão de 3850 QoS

Configuração de QoS

3750

[Global]

           3750

        [Interface]

     3850 *

 

Link da amostra

Desabilitação de QoS

Nenhum MLS QoS

Duas filas

Fila de Control-> (2)

Dados - > fila (4)

Saída sem a política

Controle - > queue(1)

Dados - > queue(2)

Exemplo 1

Confiança ou grupo no ingresso e na saída

Ação de enfileiramento baseada no ingresso

Confiança ou grupo

MLS QOS

a)

Confiança CoS MLS QoS

A política de enfileiramento da saída classifica no [ingress need config trust CoS] de CoS

Exemplo 2

b)

Confiança DSCP MLS QoS

a política de enfileiramento da saída classifica no DSCP

Exemplo 3

c)

Política de entrada com a ação do grupo para marcar o valor DSCP

A política de enfileiramento da saída classifica no DSCP

Exemplo 4

d)

Nenhum [both CoS/DSCP will be set zero] da configuração da confiança MLS QoS

Política de entrada com class-default

Ajuste CoS/DSCP 0

Exemplo 5

Mapeamento de fila CoS/DSCP

O MLS QoS compartilhou do arredondamento robin (SRR) - [CoS-map/DSCP-map] das saídas de fila

A, b, c e d usarão o mapeamento novo correspondente

[CoS/DSCP] explícito da classificação da saída com ação do Enfileiramento

Exemplo 6

Mutação DSCP

Mutação MLS QoS DSCP

Configuração da necessidade da relação

Confiança DSCP MLS QoS

[name] da DSCP-mutação MLS QoS

Política da entrada de interface com tabela-mapa

Exemplo 7

Agg-policiamento

MLS QoS que aggregatepolicing

Configuração do relação-nível da necessidade

Agg-policiando o [one type of HQoS]

Exemplo 8

Polícia-markdown

Mapa policiar-DSCP [10] [11] MLS QoS a [63]

A política de vigilância que anexa para conectar, excede não a gota, o policiar-DSCP global tomará o efeito

[Input]

Um tabela-mapa para excede e uma ação do forviolate do tabela-mapa do policiamento

[Input and output]

Exemplo 9

Limite de fila

O fila-grupo MLS QoS output o ponto inicial [1] [100] [100] [50] [200] [1]

1-> fila-grupo 1

fila 1 <1->

Ponto inicial 1

Ponto inicial 2

Buffer reservado

Ponto inicial máximo

Fila-grupo [2] da configuração

[Fila-grupo 1] do padrão

Política de enfileiramento da saída com ação do Enfileiramento e configuração do fila-limite

Exemplo 10

Bufferes de fila

Bufferes da saída [1] do fila-grupo MLS QoS

[15] [25] [40] [20]

Fila-grupo da configuração da relação

Mapa de política com ação do Enfileiramento e relação [0-100] dos bufferes de fila

Exemplo 11

Parte/largura de banda

MLS QOS

Configuração do nível de interface

da “parte 1 da largura de banda SRR-fila 30 35 [Share mode] de 5"

Largura de banda no mapa de política

Exemplo 12

fila de prioridade

[Expedite queue]

MLS QOS

A configuração “prioridade-fila do nível de interface para fora”, isto fará fila dos fila-grupos correspondentes a?a como a fila de prioridade

Nível da prioridade 1 no mapa de política

Exemplo 13

Shaper

MLS QOS

[shape mode] da forma da largura de banda da SRR-fila

Média da forma no mapa de política

Exemplo 14

Porta-shaper

MLS QOS

limite da largura de banda da SRR-fila

Porta-shaper

Exemplo 15

HQoS

MLS QOS

O [attach policy to SVI] e a relação SVI precisam a configuração “MLS QoS VLAN_based”

Política picovolt

E política do anexo à porta no sentido da entrada

Exemplo 16

Exemplo 1: Desabilitação de QoS

3750 (config global)

3750 (relação)

3850

Nenhum MLS QoS

Fila dois [fila 2 do controle um, dados uma fila 4]

 

Saída sem a política

[Pacotes do controle na fila 1 e pacotes de dados na fila 2]

3750

3750#show mls qos
QoS is disabled <- disable
QoS ip packet dscp rewrite is enabled

3750#show mls qos interface gig1/0/1 statistics | b output queues enqueued
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 4 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

Policer: Inprofile: 0 OutofProfile: 0

3850

3850#show ru int gig1/0/1
interface GigabitEthernet1/0/1
end

3850#show platform qos queue config gigabitEthernet 1/0/1 sw 1
DATA Port:21 GPN:1 AFD:Disabled QoSMap:0 HW Queues: 168 - 175
DrainFast:Disabled PortSoftStart:1 - 600
----------------------------------------------------------
DTS Hardmax Softmax PortSMin GlblSMin PortStEnd
--- -------- -------- -------- --------- ---------
0 1 5 120 6 480 0 0 0 0 0 800 <- control
1 1 4 0 7 720 2 480 2 180 2 800 <- data
2 1 4 0 5 0 0 0 0 0 0 800
3 1 4 0 5 0 0 0 0 0 0 800
4 1 4 0 5 0 0 0 0 0 0 800
5 1 4 0 5 0 0 0 0 0 0 800
6 1 4 0 5 0 0 0 0 0 0 800
7 1 4 0 5 0 0 0 0 0 0 800
Priority Shaped/shared weight shaping_step
-------- ------------ ------ ------------
0 0 Shared 50 0
1 0 Shared 75 0
2 0 Shared 10000 179
3 0 Shared 10000 0
4 0 Shared 10000 0
5 0 Shared 10000 0
6 0 Shared 10000 192
7 0 Shared 10000 0

Weight0 Max_Th0 Min_Th0 Weigth1 Max_Th1 Min_Th1 Weight2 Max_Th2 Min_Th2
------- ------- ------ ------ ------ ------ ------ ------ ------
0 0 478 0 0 534 0 0 600 0
1 0 573 0 0 641 0 0 720 0
2 0 0 0 0 0 0 0 0 0
3 0 0 0 0 0 0 0 0 0
4 0 0 0 0 0 0 0 0 0
5 0 0 0 0 0 0 0 0 0
6 0 0 0 0 0 0 0 0 0
7 0 0 0 0 0 0 0 0 0

Exemplo 2: QoS permite a confiança COS

3750 (global)

3750 (relação)

3850

MLS QOS

Conecte “a confiança CoS MLS QoS” (baseado no CoS-mapeamento do padrão ao fila-grupo 1)

Política de enfileiramento da saída baseada em CoS (confiança CoS da configuração da necessidade do ingresso)

 

3750

Global config:
3750(config)#mls qos

Interface config:

interface GigabitEthernet1/0/1
mls qos trust cos

Related show cli:

3750#sh mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled

3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750 #show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 6 7
------------------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

Note: cos value 0 maps to 2-1 [queue-set1 : queue2 threshold 1]

3850

Ingress: apply policy-map trust-cos
Egress: create class based on cos and have queuing action for each class

Ingress policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy

Egress policy:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

Exemplo 3: QoS permite a confiança DSCP

3750 (global)

3750 (relação)

3850

MLS QOS

Conecte “a confiança DSCP MLS QoS” [baseada no mapeamento de DSCP do padrão ao fila-grupo 1]

Entre a confiança DSCP do padrão

Política de enfileiramento da saída baseada no DSCP

3750

config
3750(config)#mls qos <- Global
interface GigabitEthernet1/0/1 <- Interface
mls qos trust dscp


3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750#show mls qos maps dscp-output-q
Dscp-outputq-threshold map:
d1 :d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------------------------------
0 : 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
1 : 02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
2 : 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
3 : 03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
4 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
5 : 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
6 : 04-01 04-01 04-01 04-01

3850

Ingress: default trust dscp, no policy needed

Egress: use dscp as classification and add queuing action based on customer need

One Sample config:
Plolicy-map:
3850#show run policy-map dscp-shape
class dscp56
shape average percent 10
class dscp48
shape average percent 11
class dscp40
shape average percent 12
class dscp32
shape average percent 13
Class-map:
3850#show run class-map dscp56
class-map match-any dscp56
match dscp cs7

3850#show run class-map dscp48

class-map match-any dscp48
match dscp cs6

3850#show run class-map dscp40
class-map match-any dscp40
match dscp cs5

3850#show run class-map dscp32
class-map match-any dscp32
match dscp cs4

Exemplo 4: QoS permite com uma relação que tenha uma política do grupo

3750 (global)

3750 (relação)

3850

MLS QOS

Política da entrada de interface com a ação do grupo para marcar o valor CoS/DSCP

[Marked value will be used for egress mapping]

Política de saída explícita da necessidade para fazer o mapeamento do Enfileiramento

3750

3750#show run class-map dscp-1
class-map match-any dscp-1
match ip dscp 1

c3750#show run policy-map set-dscp-63
class dscp-1
set dscp 63

3750#show run int f7/0/2
interface FastEthernet7/0/2
mls qos trust dscp
service-policy input set-dscp-63

3750#show policy-map int f7/0/2
FastEthernet7/0/2

Service-policy input: set-dscp-63

Class-map: dscp-1 (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp 1

Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps

Note: Pkts come in interface fa7/0/2, dscp1 will be marked to dscp63 which mapping
based on the existing mapping table, other pkts will retain original dscp value
mapping accordingly

3850

Input will be same as 3750 config 

Egress: will add queuing action under class dscp-63


One sample config:

3850#show run policy-map dscp63-queuing
class dscp63
bandwidth percent 50

3850#show class-map dscp63
Class Map match-any dscp63

Match dscp 63

Exemplo 5: QoS permite sem a confiança MLS QoS na relação

3750 (global)

3750 (relação)

3850

MLS QOS

Confiança CoS/DSCP da configuração MLS QoS da relação não

[O CoS/DSCP será ajustado a 0]

Política da entrada de interface com class-default

Ajuste DSCP 0, política emissora com classe DSCP0 com ação do Enfileiramento

3750

Global:
c3750(config)#mls qos

Interface:
interface GigabitEthernet2/0/45
!

3850

Input policy:
c3850#show run policy-map example5-input
class class-default
set dscp default

Output policy:
c3850#show run policy-map example5-output
class dscp0
shape average percent 10 <- queuing action based on customer need

Attach to the ingress port:
c3850#show run int gig1/0/1
interface GigabitEthernet1/0/1
service-policy input example5-input

Attach to the egress port:
c3850#show ru int gig1/0/2
interface GigabitEthernet1/0/2
service-policy output example5-output

Exemplo 6: QoS permite com mapeamento de fila da mudança CoS/DSCP

3750 (global)

3750 (relação)

3850

Configuração do mapeamento da SRR-fila MLS QoS

(SRR-fila MLS QoS output [ponto inicial [3] [4 5] da fila [1] do mapa COS)

A, b, c e d usarão a tabela de mapeamento nova

[CoS 4 e 5 será mapa para enfileirar 1 ponto inicial 3]

Classificação explícita da saída com ação do Enfileiramento

3750

Before config:
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

User config mapping:
3750(config)#mls qos srr-queue output cos-map queue 3 threshold 3 0

New mapping table after config
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 3-3 2-1 3-1 3-1 4-1 1-1 4-1 4-1

3850

Input : need apply trust-cos policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy


Egress policy:

Before changing mapping:
Sample config:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
!
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

After mapping changing , corresponding sample config:

3850#show run policy-map example6
class cos5
bandwidth percent 15
class cos1
bandwidth percent 25
class cos0_2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show class-map cos5
Class Map match-any cos5 (id 25)
Match cos 5

3850#show run class-map cos1
class-map match-any cos1
match cos 1

3850#show run class-map cos0_2_3
class-map match-any cos0_2_3
match cos 0
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

Exemplo 7: O MLS permite com mutação DSCP

3750 (global)

3750 (relação)

3850

Mutação MLS QoS DSCP

Confiança DSCP da configuração MLS QoS da necessidade da relação

[name is defined in global] do nome da DSCP-mutação MLS QoS

Política da entrada de interface com o tabela-mapa que traça o DSCP diferente

3750

Global config :
3750(config)#mls qos map dscp-mutation dscp-mutation 0 1 to 63
3750(config)#mls qos map dscp-mutation dscp-mutation 2 3 to 62

Global show cli:
c3750#show mls qos maps dscp-mutation

Dscp-dscp mutation map:
dscp-mutation:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 63 63 62 62 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63
Dscp-dscp mutation map:
Default DSCP Mutation Map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Interface config:

interface FastEthernet7/0/3
description trust dscp
mls qos trust dscp
mls qos dscp-mutation dscp-mutation

c3750#show mls qos int f7/0/3
FastEthernet7/0/3
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: dscp-mutation
Trust device: none
qos mode: port-based

Interface using default dscp-table:

c3750#show mls qos int g3/0/1
GigabitEthernet3/0/1
trust state: not trusted
trust mode: not trusted
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3850

Ingress : apply policy with dscp table-map
Egress: classify on new dscp value with queuing action

Ingress:
3850#show table-map dscp-2-dscp
Table Map dscp-2-dscp
from 0 to 63
from 1 to 63
from 2 to 62
from 3 to 62
default copy
3850#show run policy-map example7-input
class class-default
set dscp dscp table dscp-2-dscp

Egress:
3850#show run policy-map example7-output

class dscp63
shape average percent 20 [ queuing action based on the user need]
class dscp62
shape average percent 30 [queuing action based on user need]

Exemplo 8: O MLS QoS permite com policiamento agregado

3750 (global)

3750 (relação)

3850

Policiamento agregado MLS QoS

[All classes using the agg-policing will share the policing rate]

Configuração do nível de interface da necessidade

Agg-policiar (HQoS)

Queda de ação em excesso 8000 8000 agg_traffic do vigilante agregado MLS QoS

Conecte ter a política que tem agg_traffic como o nome do vigilante do agg

3750

Global:
mls qos aggregate-policer agg_traffic 8000 8000 exceed-action drop

Access-list:
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 permit 10.0.0.0 0.0.0.255

Class-map:
class-map match-all agg1
match access-group 1
class-map match-all agg2
match access-group 2

Policy-map:
policy-map agg_policer
class agg1
set dscp 40
police aggregate agg_traffic
class agg2
set dscp 55
police aggregate agg_traffic

Note: class agg1 and agg2 will share the same policing rate

3850

policy-map agg_police
class class-default
police cir 8000
service-policy child

policy-map child
class agg1
set dscp 40
class agg2
set dscp 55

Exemplo 9: O MLS permite com policiamento de Mark para baixo

3750 (config global)

3750 (relação)

3850

Mapa policiar-DSCP x MLS QoS a y

Enquanto a relação tem a política de vigilância, exceda é transmitem, o CLI global tomará o [input only] do efeito

Um tabela-mapa para excede e um para o violate action do policiamento, da entrada, e da saída

3750

Default policed-dscp map:
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

User define policed-dscp map:
3750(config)#mls qos map policed-dscp 0 10 18 24 46 to 8
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 08 01 02 03 04 05 06 07 08 09
1 : 08 11 12 13 14 15 16 17 08 19
2 : 20 21 22 23 08 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 08 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Policy config:
class-map match-all policed-dscp
match access-group 2
class policed-dscp
police 8000 8000 exceed-action policed-dscp-transmit

Attach the above policy at ingress:

Note : Mark down table can be used by policing and interface policing
as long as exceed action is transmit

3850

3850(config)#table-map policed-dscp
3850(config-tablemap)#map from 0 to 8
3850(config-tablemap)#map from 10 to 8
3850(config-tablemap)#map from 18 to 8
3850(config-tablemap)#map from 24 to 8
3850(config-tablemap)#map from 46 to 8
3850#show table-map policed-dscp
Table Map policed-dscp
from 0 to 8
from 10 to 8
from 18 to 8
from 24 to 8
from 46 to 8
default copy

3850#show policy-map policed-dscp
Policy Map policed-dscp
Class class-default
police cir percent 10
conform-action transmit
exceed-action set-dscp-transmit dscp table policed-dscp

Exemplo 10: O MLS QoS permite com configuração do Fila-limite

3750 (global)

3750 (relação)

3850

O fila-grupo MLS QoS output 1 ponto inicial 1100 100 50 pés 200 (o fila-limite)

[1 - >queue-set 1,

fila 1->first,

100 - >threshold 1,

100 - >threshold 2,

50 pés - > reservaram o buffer,

200 - > ponto inicial máximo]

Fila-grupo da configuração da relação

[O padrão é o fila-grupo 1]

Política de enfileiramento da saída com ação do Enfileiramento e configuração do q-limite

3750

Global config:
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7


If no interface config, the queue-set 1 will be used:

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

For interface config queue-set 2 explicitly:

3750#show mls qos queue-set 2
Queueset: 2
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

3850

(multiple class with queue-limit turn on)
3850#show policy-map q-limit
Policy Map q-limit
Class users-class
Queuing action ( shaper, bandwidth and bandwidth remaining)
queue-limit cos 2 percent 50
queue-limit cos 3 percent 50
queue-limit cos 6 percent 70
queue-limit cos 7 percent 70
Note: using the above config, cos 2 and cos 3 will be dropped earlier then cos 6 and 7

Exemplo 11: O MLS QoS permite com configuração do buffer de fila

3750 (global)

3750 (relação)

3850

O fila-grupo MLS QoS output os bufferes [15 25 [1] 40 20]

Fila-grupo da configuração da relação [fila-grupo 1] do padrão

Mapa de política com ação do Enfileiramento e relação [0-100] dos bufferes de fila

3750

Default queue-buffer :
3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

User define queue-buffer:
mls qos queue-set output 1 buffers 15 25 40 20

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

3850

3850#show policy-map  queue-buffer
Policy Map queue-buffer
Class cos7
bandwidth percent 10
queue-buffers ratio 15
Class cos1
bandwidth percent 30
queue-buffers ratio 25

class-map:
========
3850#show class-map cos7
Class Map match-any cos7 (id 22)

Match cos 7

3850#show class-map cos1
Class Map match-any cos1 (id 28)

Match cos 1

Attach to the interface at egress direction:

Exemplo 12: O MLS QoS permite com configuração de largura de banda

3750 (global)

3750 (relação)

3850

MLS QoS (modo da parte)

Configuração do nível de interface

da “parte 1 da largura de banda SRR-fila 30 35 5"

Largura de banda no mapa de política

3750

Default share and shape mode:
3750-3stack#show mls qos interface gig 1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User config share mode under interface:
interface GigabitEthernet1/0/1
srr-queue bandwidth share 40 30 20 10
srr-queue bandwidth shape 0 0 0 0


3750#show mls qos interface gig1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 0 0 0 0
Shared queue weights : 40 30 20 10
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map  bandwidth
Policy Map bandwidth
Class cos1
bandwidth percent 40
Class cos2
bandwidth percent 30
Class cos3
bandwidth percent 20
Class class-default
bandwidth percent 10
3850#show class-map cos1
Class Map match-any cos1

Match cos 1

3850#show class-map cos2
Class Map match-any cos2

Match cos 2

3850#show class-map cos3
Class Map match-any cos3 (id 26)

Match cos 3

3850#show class-map cos4
Class Map match-any cos4 (id 25)

Match cos 4

Exemplo 13: O MLS QoS permite com prioridade

3750 (global)

3750 (relação)

3850

[expedite queue] MLS QoS

Nota: expeça a fila mesmos que a fila de prioridade

Do nível de interface da configuração da “prioridade-fila [make corresponding queue-set's 1st queue as strict priority queue] para fora”

Nível 1 de Prioriy no mapa de política

3750

interface GigabitEthernet1/0/2
priority-queue out
end

3750#show mls qos interface gig1/0/2 queueing
GigabitEthernet1/0/2
Egress Priority Queue : enabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show run policy-map  priority-queue
class cos7
priority level 1 ? strict priority
class cos1
shape average percent 10
Attach the above policy to interface at egress side:

Exemplo 14: O MLS QoS permite com configuração do shaper

3750

Default shape mode:
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User define shape mode:
interface GigabitEthernet1/0/3
srr-queue bandwidth shape 4 4 4 4


3750-3stack#show mls qos interface gigabitEthernet 1/0/3 queueing
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 4 4 4 4
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map shape
Policy Map shape
Class cos1
Average Rate Traffic Shaping
cir 25%
Class cos2
Average Rate Traffic Shaping
cir 25%
Class cos3
Average Rate Traffic Shaping
cir 25%
Class cos4
Average Rate Traffic Shaping
cir 25%

Exemplo 15: O MLS QoS permite com largura de banda

3750 (global)

3750 (relação)

3850

MLS QOS

limite da largura de banda da SRR-fila

Velocidade, largura de banda

3750

interface GigabitEthernet1/0/4
srr-queue bandwidth limit 50


3750-3stack#show mls qos interface g1/0/4 queueing
GigabitEthernet1/0/4
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 50 (Operational Bandwidth:50.0)
The port is mapped to qset : 1

3850

3850#show policy-map default-shape
Policy Map default-shape
Class class-default
Average Rate Traffic Shaping
cir 50%
service-policy child [ queuing based on customer need]

Exemplo 16: HQoS

3750 (configuração global)

3750 (relação)

3850

Mapa de classe,

Mapa de política

Anexe a política ao SVI

A relação precisa a configuração “MLS QoS vlan_based”

Política de ingresso picovolt

3750

Note:
SVI: Parent [class acl based class-map->policing]

Child [class interface range class-map->marking]


Child class-map:

3750(config)# class-map cm-interface-1
3750(config-cmap)# match input gigabitethernet3/0/1 - gigabitethernet3/0/2

Child policy-map:
3750(config)# policy-map port-plcmap-1
3750(config-pmap)# class cm-interface-1
3750(config-pmap-c)# police 900000 9000 drop


Parent class-map matching acl:
3750(config)# access-list 101 permit ip any any

Parent class-map:
3750(config)# class-map cm-1
3750(config-cmap)# match access 101

3750(config)# policy-map vlan-plcmap
3750(config-pmap)# class cm-1
3750(config-pmap-c)# set dscp 7
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# exit
3750(config-pmap)# class cm-2
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# set dscp 10

Attach the policy to the interface:
3750(config)# interface vlan 10
3750(config-if)# service-policy input vlan-plcmap

3850

Note: Due to target change, this can't be one to one mapping, need config based on
customer requirement.


Target is at port level
Parent classify on vlan
Child: none vlan classification [for example cos/dscp]


3850#sh run policy-map PV_parent_marking_child_policing
class vlan10
set dscp 63
service-policy child_class_dscp_policing
class vlan11
set cos 5
service-policy child_class_dscp_policing
class vlan12
set precedence 6
service-policy child_class_dscp_policing

3850#sh run policy-map child_class_dscp_policing
class dscp1
police cir percent 12
class dscp2
police cir percent 15
class dscp3
police cir percent 20
class class-default
police cir percent 22

3850#sh run class-map vlan10
class-map match-any vlan10
match vlan 10

3850#sh run class-map vlan11
class-map match-any vlan11
match vlan 11

3850#sh run class-map vlan12
class-map match-any vlan12
match vlan 12

3850#sh run class-map dscp1
class-map match-any dscp1
match dscp 1

3850#sh run class-map dscp2
class-map match-any dscp2
match dscp 2

3850#sh run class-map dscp3
class-map match-any dscp3
match dscp 3


Document ID: 118629