Switches : Switches Cisco Nexus 5000 Series

Configuração de FCoE entre o adaptador VIC no 5500 Switch do server e do nexo da cremalheira UCS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve como configurar o Fibre Channel sobre a Conectividade dos Ethernet (FCoE) entre os adaptadores do cartão de interface virtual (VIC) instalados em server da cremalheira do Cisco Unified Computing System (UCS) e o nexo de Cisco 5500 (nexo 5K) Series Switch. Dois exemplos de topologia incluem dispositivos do prolongamento da tela de Cisco (FEX), e um exemplo de topologia não faz.

Contribuído por Padmanabhan, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • 5500 Series Switch do nexo de Cisco
  • Server da cremalheira de Cisco UCS - Configuração do controlador do gerenciamento integrado de Cisco (CIMC)
  • Compreensão básica de FCoE

Esta configuração existe no ambiente:

  • A disposição da rede de área de armazenamento (SAN) é configurada a fim fornecer o acesso aos números de unidade lógica (LUN) para adaptadores virtuais do barramento do host (vHBAs) no cartão de Cisco VIC.
  • A versão 5.1(3)N1(1a) ou mais recente do nexo de Cisco é instalada nos 5K Switch do nexo de Cisco.
  • As licenças necessárias são instaladas nos 5K Switch do nexo.

Refira o manual de configuração de cada dispositivo de hardware específico para limitações e informação de compatibilidade.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Server de Cisco UCS C220 M3 com VIC 1225
  • CIMC 1.5.4 pacotes do firmware
  • Nexo 5548UP com versão 6.0(2)N2(1)
  • Modelo FEX - Nexo 2232PP

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Visão geral

Esta é uma vista geral do processo de configuração:

  1. Para uma instalação nova, execute a configuração básica em 5K Switch do nexo. Você pode saltar esta etapa se você está adicionando um server a uma rede existente.
  2. Configurar o adaptador VIC no server UCS.
  3. Configurar os 5K Switch do nexo baseados em sua topologia.

O server pode ser distribuído em uma destas três topologias:

  • Topologia 1 - Canal da porta virtual (vPC) configurado em 5K Switch do nexo, e em portas do adaptador de rede convergida (POSSA) conectadas diretamente a um 5K Switch do nexo
  • Topologia 2 - FEX conectado a um 5K Switch do nexo dentro reto-através do modo, e PODE conectado às portas FEX
  • Topologia 3 - FEX conectado a um 5K Switch do nexo no modo aumentado do vPC, e PODE conectado às portas FEX

O documento fornece configurações de amostra para a Conectividade de FCoE para cada topologia.

Notas:

Use a Command Lookup Tool ( somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

A ferramenta Output Interpreter (clientes registrados somente) apoia determinados comandos de exibição. Use a ferramenta Output Interpreter a fim ver uma análise do emissor de comando de execução.

Passo 1: Configurar a instalação nova

Mesmo que este documento se centre sobre a configuração de FCoE em adaptadores VIC e em 5K Switch do nexo, igualmente inclui a configuração básica exigida no vPC e das características de FCoE para a integralidade.

A topologia neste exemplo usa a rede de área do Virtual Storage (VSAN) 100 e VSAN 200 como duas telas SAN. Estes VSAN são criados no lado A e no lado B do 5K Switch do nexo e traçados a FCoE VLANS 100 e 200, respectivamente.

Para uma instalação nova, este procedimento descreve como executar a configuração básica nos 5K Switch do nexo:

  1. Permita os recursos requerido ([LLDP] do protocolo de descoberta da camada de enlace, [LACP] do protocolo link aggregation control, FCoE, FEX, vPC) nos 5K Switch do nexo. Veja a configuração dos recursos requerido para um exemplo desta etapa.
  2. Termine a configuração básica do vPC:
    1. Crie o domínio do vPC.
    2. Crie os links do keepalive do par do vPC.
    3. Configurar os links do par do vPC. Veja a configuração básica do vPC para um exemplo de como executar etapas 1-3 e de como permitir o vPC em ambos os 5K Switch do nexo.
    4. Crie o vPC, ou reutilize os Canais de porta.
    5. Verifique o vPC.
  3. Configurar os VSAN. Veja a configuração VSAN para um exemplo desta etapa.

Nota: Você pode saltar estas etapas se você está adicionando um server a uma rede existente; continue a etapa 2: Configurar o server UCS e o adaptador VIC.

Configuração dos recursos requerido

5548-switch# configure terminal
5548-switch(config)# feature lldp
5548-switch(config)# feature lacp
5548-switch(config)# feature fcoe
5548-switch(config)# feature fex
5548-switch(config)# feature vpc
5548-switch(config)# end

Configuração básica do vPC

5548-switch# configure terminal
5548-switch(config)# vpc domain 150
5548-switch (config-vpc-domain)# peer-keepalive destination <peer-switch-ip>
source <source-ip> vrf management
5548-switch(config-vpc-domain)# interface port-channel 150
5548-switch(config-if)# switchport mode trunk
5548-switch(config-if)# vpc peer-link
5548-switch(config-if)# no shut

Configuração VSAN

5548-switch-A # configure terminal
5548-switch-A(config)# vsan database
5548-switch-A(config-vsan-db)#vsan 100
5548-switch-A(config)#exit

5548-switch-A(config)#vlan 100
5548-switch-A(config-vlan)#fcoe vsan 100

5548-switch-B # configure terminal
5548-switch-B(config)#vsan database
5548-switch-B(config-vsan-db)#vsan 200
5548-switch-B(config)#exit

5548-switch-B(config)#vlan 200
5548-switch-B(config-vlan)#fcoe vsan 200

Passo 2: Configurar o server UCS e o adaptador VIC

Configurar o adaptador VIC no server UCS. Este procedimento descreve como aplicar esta configuração a todos os adaptadores de Cisco VIC (P81E ou VIC 1225 ou VIC 1225T):

  1. Use a utilidade da atualização do host a fim atualizar o firmware dos componentes de hardware do servidor à versão a mais atrasada. Seja certo atualizar o firmware VIC.
  2. À revelia, o adaptador VIC opera-se no modo clássico dos Ethernet (CE) e é configurado com os dois controladores da relação de rede virtual (vNICs) e os dois vHBAs. Cada um destes vNICs e os vHBAs são fixados a uma interface física do uplink DCE; isto é, fc0 é fixado à porta 0 do uplink DCE, e fc1 é fixado à porta 1 do uplink DCE do adaptador:

    117280-config-fcoe-01.png
  3. A potência no server, e nota que os detalhes do adaptador VIC estão povoados na seção do inventário.
  4. Clique a aba dos vHBAs, e selecione uma relação do vHBA (fc0 ou fc1).
  5. Clique propriedades, a seguir configurar as propriedades de FCoE no adaptador VIC. Seja certo definir o ID de VLAN de FCoE no campo de texto do VLAN padrão:

    117280-config-fcoe-02.png

    Se você planeia carreg do SAN, verifique a caixa de seleção da bota FC SAN, e adicionar o alvo WWPN à tabela da bota:

    117280-config-fcoe-03.png
  6. Recarregue o server para que as alterações de configuração tomem o efeito.

Passo 3: Configurar 5K Switch do nexo para topologias diferentes

O server pode ser distribuído em uma de três topologias. Esta seção descreve como configurar os 5K Switch do nexo baseados em sua topologia.

As diretrizes da configuração comum para todas as três topologias são:

  1. A relação virtual do Fibre Channel (VFC) é limitada a uma porta membro (interface Ethernet física) do Canal de porta.
  2. Os Switchports reagem do modo de tronco, e o FCoE VLAN é configurado como um VLAN NON-nativo.
  3. O tipo da medir-árvore de portas de switch é configurado assim que conectam ao server como um tronco da borda.

Este documento fornece configurações de amostra para a tela A; você deve executar uma configuração similar no outro interruptor para a tela B.

Topologia 1: PODEM as portas conectadas diretamente ao 5K Switch do nexo

Visão geral

Nesta encenação, os 5K Switch do nexo estão no vPC, e o server PODE portas é conectado diretamente a ambos os 5K Switch do nexo. Este procedimento descreve a configuração para esta topologia:

  1. Associe a interface Ethernet à interface de canal de porta nova.
  2. Configurar o Canal de porta como um tronco com o FCoE VLAN etiquetou, e associe o Canal de porta com o vPC ID.
  3. Crie a relação VFC, e ligue-a ao membro de canal de porta (interface Ethernet).
  4. Associe a relação VFC ao VSAN correspondente ID. Veja a configuração de exemplo em um lado do 5K Switch do nexo para um exemplo das etapas 1-4.
  5. Repita etapas 1-4 a fim configurar o lado B do 5K Switch do nexo.
  6. Verifique a configuração.

117280-config-fcoe-04.png

Configuração de exemplo em um lado do 5K Switch do nexo

N5548UP-A(config)# int eth 1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit
N5548UP-A# configure terminal
N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)# switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# vpc 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit
N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exitN5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Verificação

N5548UP-A# show run int port-channel 1 membership

interface port-channel 1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000
vpc 1
interface Ethernet1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
channel-group 1

N5548UP-A# show run int vfc 1
interface vfc1
bind interface Ethernet1/1
switchport trunk allowed vsan 100
no shutdown

Topologia 2: FEX conectou ao 5K Switch do nexo dentro Reto-através do modo e PODE conectado às portas FEX

Visão geral

Nesta encenação, o FEX é conectado ao 5K Switch do nexo dentro reto-através do modo, e a LATA é conectada às portas FEX. Este procedimento descreve a configuração para esta topologia:

Reto-através da configuração FEX:

  1. Atribua um FEX ID.
  2. Associe a interface Ethernet com a interface de canal de porta nova ID, e configurar o Canal de porta novo com os parâmetros da tela FEX. Veja a configuração de exemplo para um exemplo das etapas 1-2.

    Hospede a configuração do vPC:

  3. Associe as relações do host FEX (HIF) com a interface de canal de porta nova ID, e configurar os parâmetros do canal de porta.
  4. Associe o Canal de porta HIF à relação do vPC.
  5. Crie a relação VFC, e ligue-a à porta do membro (Ethernet) do canal da porta de host. Veja a configuração do vPC do host para um exemplo das etapas 3-5.
  6. Verifique a configuração.

Repita etapas 1-4 no lado B do 5K Switch do nexo, e use o mesmo número de interface do vPC sob o Canal de porta HIF.

117280-config-fcoe-05.png

Configuração de exemplo

N5548UP-A# configure terminal 
N5548UP-A(config)# fex 101
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/5 - 6
N5548UP-A(config-if-range)# channel-group 210
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit

N5548UP-A(config)# interface port-channel 210
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 101
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

Configuração do vPC do host

<---Create HIF port-channel-->

N5548UP-A(config-if)# interface ethernet 101/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Configure port-channel parameters-->

N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)#switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# vpc 10
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Create vfc interfvace and bind to port-channel (Ethernet interface)-->

N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 101/1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Associate vfc interface to corresponding VSAN ID-->

N5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Verificação

N5548UP-A# show run int port-channel 210 membership

interface port-channel210
switchport mode fex-fabric
fex associate 101

interface Ethernet1/5
switchport mode fex-fabric
fex associate 101
channel-group 210

interface Ethernet1/6
switchport mode fex-fabric
fex associate 101
channel-group 210

N5548UP-A# show int fex
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
101 Eth1/5 Active 1 N2K-C2232PP-10GE SSI142602QN
101 Eth1/6 Active 2 N2K-C2232PP-10GE SSI142602QN

N5548UP-A# show run int port-channel 1 membership

interface port-channel 1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000
vpc 10

interface Ethernet101/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
channel-group 1

N5548UP-A# show run int vfc 1
interface vfc1
bind interface Ethernet101/1/1
switchport trunk allowed vsan 100
no shutdown

Topologia 3: FEX conectou ao 5K Switch do nexo no modo aumentado do vPC e PODE conectado às portas FEX

Visão geral

Nesta encenação, o FEX é conectado ao 5K Switch do nexo no modo aumentado do vPC, e a LATA é conectada às portas FEX.

O tráfego da tela A SAN (VLAN 100 de FCoE) é associado com o lado FEX 101/A do 5K Switch do nexo. O tráfego da tela B SAN (FCoE VLAN 200) é associado com o FEX 102/lado B do 5K Switch do nexo.

Para um canal da porta de host de dois membros, você deve configurar portas HIF em ambos os dispositivos FEX em ambos os 5K Switch do nexo; isto é, um total de quatro configurações de porta HIF é exigido.

Este procedimento descreve a configuração para esta topologia:

Ativo - Configuração ativa FEX:

  1. Atribua o FEX ID.
  2. Adicionar a palavra-chave do “fcoe” sob um único FEX em cada 5K Switch do nexo a fim permitir o isolamento da tela SAN.
  3. Crie o Canal de porta da tela FEX.
  4. Repita etapas 1 e 3 para o outro FEX no mesmo 5K Switch do nexo.
  5. Repita etapas 1-4 no lado B do 5K Switch do nexo. Veja o Active - Configuração FEX e palavra-chave ativas de FCoE em FEX 102 no lado B do 5K Switch do nexo para um exemplo.

    Configuração do vPC do host:

  6. Crie a interface de canal de porta, e configurar os VLAN necessários.
  7. Configurar a porta HIF (a relação FEX conectada à LATA) em ambos FEXs, e permita o FCoE VLAN e vlan de Ethernet, a seguir associe a porta HIF com o canal de porta ID do host criado na etapa 6.
  8. Crie a relação VFC, e ligue-a à porta do membro (Ethernet) do canal da porta de host.
  9. Repita etapas 6-8 no lado B do 5K Switch do nexo, e use a mesma interface de canal de porta ID do host. Veja a configuração do vPC do host para um exemplo.

    Configuração da interface VFC:

  10. Crie a relação VC, e ligue-a à porta do membro de canal de porta (HIF).
  11. Atribua a relação VFC ao VSAN apropriado.
  12. Repita etapas 10-11 no lado B do 5K Switch do nexo. Veja a configuração VFC para um exemplo.
  13. Verifique a configuração.

117280-config-fcoe-06.png

Ativo - Configuração ativa FEX

N5548UP-A# configure terminal 
N5548UP-A(config)# fex 101
N5548UP-A(config-fex)# fcoe
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/3 - 4
N5548UP-A(config-if-range)# channel-group 201
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit
N5548UP-A(config)# interface port-channel 201
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 101
N5548UP-A(config-if)# vpc 201
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

N5548UP-A# configure terminal
N5548UP-A(config)# fex 102
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/5 - 6
N5548UP-A(config-if-range)# channel-group 202
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit

N5548UP-A(config)# interface port-channel 202
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 102
N5548UP-A(config-if)# vpc 202
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

Palavra-chave de FCoE em FEX 102 no lado B do 5K Switch do nexo

N5548UP-B# configure terminal 
N5548UP-B(config)# fex 102
N5548UP-B(config-fex)# fcoe
N5548UP-B(config-fex)# exit

Configuração do vPC do host

N5548UP-A(config-if)# interface ethernet 101/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

N5548UP-A(config)# interface ethernet 102/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)#switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

Configuração VFC

<---Create vfc interface and bind to port-channel member (ethernet interface)-->

N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 101/1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Associate vfc interface to corresponding VSAN ID-->

N5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Verificação

N5548UP-A# show fex
FEX FEX FEX FEX
Number Description State Model Serial
------------------------------------------------------------------------
101 FEX0101 Online N2K-C2232PP-10GE SSI142602QN
102 FEX0102 Online N2K-C2232PP-10GE SSI14260EVV

N5548UP-A# show interface fex
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
101 Eth1/3 Active 2 N2K-C2232PP-10GE SSI142602QN
102 Eth1/4 Active 1 N2K-C2232PP-10GE SSI14260EVV

N5548UP-A# show fex 101 detail
FEX: 101 Description: FEX0101 state: Online
FEX version: 6.0(2)N2(1) [Switch version: 6.0(2)N2(1)]
FEX Interim version: 6.0(2)N2(1)
Switch Interim version: 6.0(2)N2(1)
Extender Serial: SSI142602QN
FCoE Admin: true
FCoE Oper: true
FCoE FEX AA Configured: true

N5548UP-A# show run interface port-channel 1 membership

interface port-channel1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000

interface Ethernet102/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
channel-group 1

interface Ethernet101/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
channel-group 1

N5548UP-A# show int vfc 1
vfc1 is trunking
Bound interface is Ethernet101/1/1
Port WWN is 20:00:54:7f:ee:e1:6a:bf
Admin port mode is F, trunk mode is on
Port mode is TF
Port vsan is 100
Trunk vsans (admin allowed and active) (100)
Trunk vsans (up) (100)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()

N5548UP-A# show run int port-channel 201 membership

interface port-channel201
switchport mode fex-fabric
fex associate 101
vpc 201

interface Ethernet1/3
switchport mode fex-fabric
fex associate 101
channel-group 201

interface Ethernet1/4
switchport mode fex-fabric
fex associate 101
channel-group 201

N5548UP-A# show run int port-channel 202 membership

interface port-channel202
switchport mode fex-fabric
fex associate 102
vpc 202

interface Ethernet1/5
switchport mode fex-fabric
fex associate 102
channel-group 202

interface Ethernet1/6
switchport mode fex-fabric
fex associate 102
channel-group 202

Este screen shot da sequência de inicialização do server valida a configuração de switch enquanto o firmware VIC detecta com sucesso o LUN e atualiza a tabela da bota:

117280-config-fcoe-07.png

Verificar

Os procedimentos de verificação são incluídos dentro dos exemplos de configuração.

Troubleshooting

Esta seção fornece a informação que você pode se usar a fim pesquisar defeitos sua configuração.

Execute estas verificações a fim determinar se o VFC está vindo acima:

  1. Verifique que os cabos estão conectados corretamente entre as portas do adaptador traçadas ao vHBA e que as portas do 5K Switch do nexo têm os VSAN necessários.
  2. Certifique-se que as relações não estão fechadas administrativamente.
  3. Verifique que o FCoE VLAN está configurado na interface Ethernet limitada pelo VFC.

Use estes comandos a fim verificar a configuração:

  • mostre o fcoe da corrida
  • mostre vsan
  • mostre o fcoe vlan
  • mostre o vfc ID da relação
  • mostre o vpc
  • mostre o banco de dados do flogi

Informações Relacionadas


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 117280