Switches : Switches Cisco Nexus 1000V Series

Exemplos da configuração de canal de porta dos 1000V Series Switch do nexo

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve os melhores prática usar-se quando você distribui os Canais de porta no 1000V Series Switch do nexo de Cisco (N1KV). O N1KV exige os Canais de porta para os perfis da porta que contêm mais de uma relação pelo host.

Contribuído por Carlos López e por Matthew Wronkowski, engenheiros de TAC da Cisco.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • N1KV
  • Cisco Unified Computing System (UCS)
  • Nexo e Catalyst series switch de Cisco

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • N1KV
  • UCS

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Configurar

Esta seção contém estas configurações:

N1KV em server das B-séries UCS no modo do host final

Cisco UCS usa dois trajetos diversos entre a lâmina e a rede upstream. Atualmente, a tela Interconnects não faz Canal de porta do /virtual do protocolo de controle da agregação do link de suporte (LACP) (vPC) que ruma para o sul para as lâminas. Isto significa que um canal da porta estática da perspectiva N1KV deve ser usado. Fixar MAC é exigido, desde que o Switches ascendente não apoia o EtherChannel do multichassis.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV em server da série C UCS ou em server do montagem de contestação conectou ao nexo 5000/7000 de Switches com o vPC

Nesta topologia, cada server da cremalheira é conectado fisicamente a dois Switches diferentes do nexo - um cabo a cada interruptor. O LACP é o modo preferido, porque permite a melhor distribuição de tráfego e a adição sem interrupções/subtração dos links. Supõe-se que o Switches ascendente do nexo já tem um link do par do vPC configurado.

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
switchport mode trunk
vpc 1000
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable

no lacp suspend-individual <- Nexus 7k only!!!
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV em server da série C UCS ou em server do montagem de contestação conectou ao Switches sem o vPC

Nesta topologia, cada server da cremalheira é conectado fisicamente a dois Switches diferentes, mas o vPC não está disponível. A única configuração suportada é fixar MAC. Esta configuração é idêntica àquela usada em server das B-séries UCS. Um canal da porta estática (modo sobre) não é apoiado, desde que o Switches ascendente não apoia uma tecnologia EtherChannel do multichassis.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV nos server da série C UCS ou nos server do montagem de contestação conectados a 6500 VSS ou a interruptores do elevador da pilha

Nesta topologia, o Switches ascendente atua como um chassi único. Isto permite que o N1KV conecte com o LACP.

# VSM configuration
feature lacp
lacp offload
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# 6500 VSS configuration
interface Port-channel1000
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface GigabitEthernet1/1/1
description ESX-Host1 adapter 1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active
!
interface GigabitEthernet2/1/1
description ESX-Host1 adapter 2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV nos server da série C UCS ou nos server do montagem de contestação conectados a um único interruptor ascendente com um canal da porta estática

Nesta topologia, os server são conexão residenciada única a um interruptor ascendente. Esta topologia não fornece nenhuma Redundância do interruptor e não é um melhor prática.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream Nexus switch
interface port-channel 1000
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode on

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

show run interface po{X} membership
show port-channel summary

Troubleshooting

Esta seção fornece a informação que você pode se usar a fim pesquisar defeitos sua configuração.

show port-channel summary
show port-channel internal event-history [all|errors]debug lacp all

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 116739