Voz e comunicações unificadas : Cisco Unity Connection

Qualidade de áudio deficiente CUC com VMware

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve o processo para identificar se as edições de qualidade de áudio são uma questão de rede, ou uma edição com o aplicativo virtualizado.

Contribuído por engenheiros de TAC da Cisco.

Problema

Enquanto mais aplicativos da voz em tempo real são virtualizados, torna-se muito mais complexo para pesquisar defeitos edições de qualidade de áudio. Use a conexão de unidade como o assunto para este da “aplicativo voz em tempo real”.

Recolha a informação

  1. A primeira etapa é determinar se as alertas são distorcidas quando você deixa a conexão de unidade. A fim recolher um pacote, tamanho todo do arquivo capture1 do eth0 da captação da rede utils da captação dos “contagem 100000".

    Nota: Cisco unificou alertas de uma comunicação (CUC) é uma boa linha base para determinar a qualidade indesejável. Não use o usuário gravou cumprimentos como podem ser uma linha de base incerta.

          
  2. Analise a captura de pacote de informação: Mu-law de Wireshark, de G.711a-law dos apoios ou de G.711.
  3. Verifique a qualidade de córrego que parte do protocolo de tabela de roteamento (RTP) com o Wireshark:
    1. Descodifique com as configurações padrão.
    2. Descodifique com a opção do “data/hora de RTP uso” em Wireshark.

Possíveis causas

Se ambos os córregos descodificados experimentam questões de qualidade de voz, o problema pôde ser com a alerta (arquivo WAV) ou a conexão de unidade.

Se a gravação do padrão está distorcida, mas o uso das data/horas de RTP é muito bem, o problema pôde ser com recursos/VMware.

Se a qualidade é aceitável quando você escuta o córrego RTP usando o padrão que descodifica, o problema pôde ser com a conectividade de rede entre o CUC e o telefone.

Nota: Uma sugestão é toma uma captura de pacote de informação do interruptor onde o server de ESXi é conectado e verificação para a qualidade. Se é ruim, é provável que os direcionadores estão verificados no host próprio de ESXi.

Solução

Se o problema indica a edição é com conexão de unidade ou o arquivo WAV, verifica primeiramente a qualidade da gravação:

  1. Verifique o Network Time Protocol (NTP).
    1. Se o cliente tem NTP múltiplos configurados, assegure-se de que o CUC não comute entre os dois frequentemente.
    2. Verifique para ver se os servidores de NTP têm NTPv4 (captura de pacote de informação): dos “estado NTP utils”.
  2. Use a Web GUI para verificar a qualidade.
  3. Assegure-se de que não haja nenhum coredumps em CUC. Procure o Bug conhecido: os “utils retiram o núcleo da lista ativa”.
  4. Use o editor alternativo da cobra para verificar a qualidade.

Se o problema indica que a edição é com VMware verifique, siga estas etapas:

  1. Verifique que a reserva apropriada está feita nas máquinas virtuais da conexão de unidade: verifique reservas CPU e de RAM como nas plataformas suportadas.
  2. Assegure-se de que o grandes recebam Offload (LRO) estejam desligados para o host de ESXi (não uma edição com ESXi 5.1+). Veja o desabilitação LRO em desenvolvimentos de aplicativo UCS/UC para mais informação.
  3. Tome um instantâneo do CUC VM. Veja instantâneos de VMware para mais informação.

    Nota: Os instantâneos da conexão de unidade VM não são apoiados e puderam causar edições com Qualidade de voz.

  4. Assegure-se de que as ferramentas de VMware estejam instaladas. Veja ferramentas de VMware para mais informação.

    Nota: As ferramentas de VMware instalam os direcionadores do Network Interface Cards (NIC) no VM para melhorar o desempenho da rede.

  5. Assegure-se de que a sincronização VM com host não esteja verificada. O tempo desta máquina virtual da opção sincronizações com o host de ESXi. No cliente da esfera, navegue para selecionar a máquina virtual e para clicar com o botão direito a máquina virtual edite ajustes. Das opções catalogue, escolha ferramentas de VMware > avançou. Assegure-se de que o tempo do convidado do sincronizar com caixa de verificação do host esteja desmarcado.


Document ID: 116578