Sem fio/Mobilidade : LAN Wireless (WLAN)

Exemplo da configuração sem fio ISR

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve como dizer a diferença entre o legado Cisco e o Roteadores dos Serviços integrados da próxima geração (ISR) e fornece a informação sobre como configurar-los.

Contribuído por Surendra BG, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Informações de Apoio

Há uns tipos diferentes de Cisco ISR, e somente alguns deles são integrados com o ® do Cisco IOS para o Roteadores. Por exemplo, com legado 851W, 857W, 871W, e 877W ISR, você deve alcançar o roteador através do telnet/Shell Seguro (ssh), ou use o Security Device Manager (SDM) a fim alcançar as configurações sem fio. Em comparação, alguma próxima geração ISR, tais como 861W, 881W, 891W, 1941W, 819W, vem com pontos de acesso Wireless (AP) já integrou, e pode ser alcançada separadamente com a relação do Bridge Virtual Interface AP (BVI) (com o GUI ou o telnet/SSH).

Identifique o legado e a próxima geração ISR

A fim identificar o ISR, inscreva o comando show ip interface brief no roteador.

Se a atuação 0 da relação WLAN-AP 0 e da relação WLAN esta presente na lista de interface, a seguir significa que é um roteador da próxima geração e tem um Sem fio integrado AP dentro do roteador. Você pode alcançar este através do CLI com telnet/SSH ou do GUI.

Nota: Se você não vê a relação WLAN-AP 0 na lista de interface para um 861W, um 881W, um 891W, ou um 1941W, a seguir significa que o roteador não apoia o Sem fio.

Para o Roteadores do legado, este é o que aparece quando você inscreve o comando show ip int brief:

Como mostrado, para o Roteadores do legado, você vê somente a interface de rádio diretamente nos IO. 

Configurar

Há uns métodos diferentes usados a fim configurar ISR. A fim configurar o Roteadores do legado, onde os suportes de IOS Sem fio do roteador, você devem configurar o roteador através da interface de BVI para cada VLAN. Também, você deve construir uma ponte sobre o tráfego com a ponte da interface de rádio e da interface de VLAN através do BVI. Se você usa os identificadores do conjunto do serviço múltiplo (SSID), a seguir cada SSID deve ser traçado a cada VLAN, e cada VLAN deve ser traçado a um grupo de bridge original (BG) através de uma interface de BVI separada.

Por outro lado, quando você configura uma próxima geração ISR, a seguir a configuração é menos complexa. Você deve estabelecer uma conexão entre o roteador e o AP, e configura o AP apenas como todo o outro AP autônomo. Haverá uma única interface de BVI, com as subinterfaces múltiplas, que as ajudas comunicam entre SSID e VLAN múltiplos.

A próxima geração ISR pode ser sincronizado com a arquitetura do gerente do Cisco Unified Wireless (CUWM) também. O módulo AP dentro do roteador pode ser convertido ao protocolo de pouco peso do Access point (LWAPP) /Control e ao abastecimento do modo dos pontos de acesso Wireless (CAPWAP), que é registrado ao controlador do Wireless LAN (WLC). Esta seção descreve como converter o módulo AP de autônomo e do LWAPP.

Nota: 861W não apoia o modo LWAPP.

Exemplo de configuração do legado ISR

Este exemplo de configuração usa dois VLANS (VLAN1 e VLAN2) que cada um são traçados a um SSID diferente com acesso WiFi-protegido - pre Segurança da chave compartilhada (WPA-PSK):

en
conf t

vlan 2 mapped to GUESTRITS SSID..Use the vlan
  as per the network configuration


dot11 ssid GUESTRITS
vlan 2
mbssid
authentication open
authentication key-management wpa
wpa-psk ascii 0 cisco123


dot11 ssid INTERNAL
vlan 1                               >> vlan 1 mapped to INTERNAL SSID
authentication open
mbssid
authentication key-management wpa
wpa-psk ascii 0 cisco123
!

!
bridge irb                          <<< Enables IRB. Allows bridging of
                                        traffic

!

interface Dot11Radio0
no ip address
mbssid
!
encryption vlan 1 mode ciphers tkip  << Encryption            
!
encryption vlan 2 mode ciphers tkip
!
ssid GUESTRITS
!
ssid INTERNAL
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0
  basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1             <<< Corresponding Sub Interface
encapsulation dot1Q 1 native            configuration for Radio
bridge-group 1                      <<< Bridging between VLAN 1 and
bridge-group 1 subscriber-loop-control  Dot11 0.1
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!


interface Dot11Radio0.2               <<< Corresponding Sub Interface
encapsulation dot1Q 2                     configuration for Radio
bridge-group 2                        <<< Bridging between VLAN 2 and
bridge-group 2 subscriber-loop-control    Dot11 0/2  
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!


interface Vlan1
no ip address
bridge-group 1                        <<< Bridging between VLAN 1 and
                                          Dot11 0/1

 

interface Vlan2
no ip address
bridge-group 2                        <<< Bridging between VLAN 2 and
!                                         Dot11 0.2


interface BVI1                         << BVI 1 for VLAN 1
ip address 10.0.0.2 255.255.255.0               
!
interface BVI2                         << BVI 2 for VLAN 2
ip address 192.168.1.1 255.255.255.0
!

!
bridge 1 protocol ieee                <<< Mandatory Bridging commands
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!

Exemplo de configuração da próxima geração ISR

Termine estas etapas a fim configurar o Roteadores da próxima geração:

  1. Estabeleça a Conectividade entre o roteador e o AP com a interface de console reversa que está disponível no roteador (relação WLAN-AP 0). Use o endereço IP de Um ou Mais Servidores Cisco ICM NT para esta relação (você pode atribuir o endereço IP de Um ou Mais Servidores Cisco ICM NT, ou use o comando x unnumbered IP VLAN) a fim atribuir o IP.

    Está aqui um exemplo onde o comando vlan unnumbered IP seja usado:

    en
    conf t
    int wlan-ap 0
    ip unnumbered vlan 1
    no shut

    Isto aparece quando você incorpora o comando do Br da mostra IP int:



    Isto ajuda-o a entrar ao módulo AP.

  2. Inscreva o comando session WLAN-ap 0 do módulo de serviço a fim entrar ao AP.



    Siga o mesmo processo usado a fim configurar o AP autônomo. Para exemplos de configuração adicionais, veja a página de índice dos exemplos de configuração e dos TechNotes.

    Se seu desenvolvimento consiste em vlan múltiplos ou em SSID, você deve ajustar a relação WLAN-GIG 0 como uma porta de tronco que permita os VLAN exigidos no roteador.


Promova um ISR AP de pouco peso a autônomo

Quando o AP integrado executa a imagem LWAPP, tal como AP801-RCVK9W8-M, AP801-RCVK9 "W8" - M (indica o LWAPP), ou W7 (indica uma imagem autônoma), o comando config t não trabalham; o AP deve usar a imagem autônoma a fim executar os comandos. A fim resolver esta edição, você deve promover o ISR AP de pouco peso a autônomo.

Incorpore estes comandos:

Router>en
Router#config t
Router(config t)#service-module wlan-ap0 bootimage autonomous

Com estes comandos, você pode mudar o modo AP. Se você quer o AP carregar e executar uma imagem autônoma, uso autônomo no comando precedente. Se você quer o AP carregar e a bota com uma imagem LWAPP, a seguir o tipo unificou e recarrega o AP com este comando:

Router(config t)#service-module wlan-ap 0 reload

Isto ajusta o AP a autônomo. Os trabalhos para a maioria de caso. Contudo, se você encontra edições, você pode usar o processo manual:

  1. Transfira Tftpd32 em seu portátil e instale-o. Transfira a imagem IOS a mais atrasada para o AP801 Series:

    1. Navegue ao cisco.com.
    2. Clique a aba do apoio perto da parte superior da tela.
    3. Clique o software da transferência.
    4. Selecione o Sem fio, e selecione então roteadores integrados e Switches da lista de drop-down do produto.
    5. Selecione o modelo do roteador.
    6. Selecione a imagem IOS apropriada: 12.4(21a)JY (ou mais tarde, como desejado).
  2. Entre ao módulo AP do roteador, e incorpore estes comandos:

    • AP>en
    • O console CLI do capwap de AP#debug OU debuga o console CLI do lwapp
    • AP#config t (este comando configuration trabalha agora)
    • ATUAÇÃO 0 do #int AP (config t) ou FÁ 0 int
    • AP (configuração - int) # <mask> do <address> do endereço IP de Um ou Mais Servidores Cisco ICM NT (se assegure de que você tenha a Conectividade a seu endereço IP de Um ou Mais Servidores Cisco ICM NT do portátil, e que são ambos na mesma sub-rede)
    • #no AP (configuração - int) fechado
    • #end AP (configuração - int)
  3. Inscreva os comandos archive download a fim promover o AP a autônomo:

    • Endereço IP de Um ou Mais Servidores Cisco ICM NT de AP#archive transferência-SW /force-reload /overwrite tftp:// <TFTP (IP) >/<Autonomous image.tar dos portáteis >
    • AP#archive transferência-SW /overwrite /force-reload tftp://10.0.0.4/ap801-k9w7-tar.124-21a.JY.tar

    Isto termina o processo da configuração manual.

    Nota: Se o AP reage do modo autônomo e você quer o converter ao LWAPP, use os comandos das transferências do arquivo e selecione a imagem de recuperação LWAPP em vez da imagem do sistema operacional inter-redes de Autônomo-Cisco (AIO).

Verificar 

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting 

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração. 

Informações Relacionadas


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 116579