Roteadores : Roteadores de serviços de agregação Cisco ASR 9000 Series

Configuração do interruptor L2 ao processo de conversão da configuração XR L2VPN

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve como converter uma configuração do switching de Camada 2 do ® do Cisco IOS a uma configuração de Virtual Private Network da camada 2 do Cisco IOS XR (L2VPN).

Contribuído por Manuel Irizarry, por potências de David, e por Samuel Milstead, engenheiros de TAC da Cisco.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não é restringido ao software específico mas é restringido ao roteador agregado 9000 Series do serviço (ASR) - as versões de hardware relacionadas que usam o modelo dos circuitos virtuais dos Ethernet (EVC) a fim configurar o L2VPN. Os 9000 Series Router ASR usam o modelo EVC quando o Roteadores do sistema de roteamento do portador (CR) que executa o Cisco IOS XR não fizer.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Informações de Apoio

O 9000 Series Router ASR não segue o modelo da IEEE da configuração da camada 2 (L2), especialmente 802.1Q e 802.1AD. Em lugar de usa o modelo EVC. O modelo EVC permite que o Cisco IOS XR leverage as etiquetas atuais do 802.1Q VLAN em uma maneira nova. Tradicionalmente, a etiqueta VLAN define a classificação, o VLAN, a transmissão, e que tabela do Content Addressable Memory (CAM) a se usar a fim executar uma consulta do MAC address. Com o modelo EVC, este conceito é decuplado a fim reservar mais flexibilidade e escala mais alta. O modelo EVC elimina a limitação do Cisco IOS de 4,096 VLAN máximos.

EVC usa estes montagens de bloco:

  • Os Ethernet fluem o ponto (o EFP) - O EFP é uma subinterface lógica L2 que seja usada a fim classificar o tráfego sob um exame ou um bundle interface.

  • EVC - EVC é uma representação fim-a-fim de uma instância única do L2. Um EFP é definido como um valor-limite de um EVC dentro de um nó. Porque EVCs múltiplo pode passar através de uma interface física, o propósito principal de uma configuração EFP é reconhecer o tráfego que pertence a um EVC específico nessa relação e aplicar o comportamento de encaminhamento e as características específicos àquela EVC.

  • Domínio de Bridge (BD) - Um BD é um domínio de transmissão dos Ethernet interno ao dispositivo. O BD permite-o de decuplar o VLAN do domínio de transmissão. O BD tem mapeamentos de um para muitos com EFPs: todos os EFPs em um nó para um EVC específico são agrupados com uso do BD. Se os EFPs pertencem ao mesmo BD e têm o mesmo número BD, a seguir os EFPs recebem o tráfego mesmo se têm números de VLAN diferentes.

Problema

O Cisco IOS XR em 9000 Series Router ASR usa o modelo dos circuitos virtuais dos Ethernet (EVC). O modelo EVC não tem o conceito dos troncos, das interfaces de VLAN, ou de uma interface virtual do interruptor (SVI). Os troncos, as interfaces de VLAN, e os SVI do Cisco IOS devem ser convertidos às configurações do Cisco IOS XR através das subinterfaces, do L2VPN BD, e das interfaces virtuais da ponte (BVI). O modelo EVC pôde ser novo a alguns usuários do Cisco IOS quando migram primeiramente ao Cisco IOS XR.

Solução

A configuração no Cisco IOS XR consiste em três etapas:

  1. Crie o EFP através da configuração de uma relação ou de uma secundário-relação com a opção l2transport, que representa um VLAN.

  2. Crie um BD a fim agrupar os EFPs.

  3. Quando a camada 3 (L3) SVI é precisada, configurar através da relação BVI no Cisco IOS XR, em vez da relação vlan no Cisco IOS, a fim fornecer as funções L3 básicas para as relações L2 que pertencem ao BD.

Nota: As interfaces de BVI não apoiam etiquetas VLAN; assim para que o BVI segure o tráfego de ingresso no EFP, a etiqueta VLAN deve ser estalada no ingresso e ser adicionada na saída. Isto é terminado com o comando da reescrita.

Converta uma configuração

Este exemplo ilustra como converter uma configuração do Cisco IOS ao Cisco IOS XR.

Configuração do IOS

interface GigabitEthernet3/13
switchport
switchport access vlan 4
speed 1000
duplex full
!
interface GigabitEthernet3/14
switchport
switchport access vlan 130
speed 1000
duplex full
!
interface GigabitEthernet3/15
switchport
switchport access vlan 133
speed 1000
duplex full
!
interface TenGigabitEthernet13/3
description IOS Trunk
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1*,4,130,133
switchport mode trunk
no ip address
!
interface Vlan 4
ip address 10.10.4.1 255.255.255.0

interface Vlan 130
ip address 10.10.130.1 255.255.255.0
!

*Vlan 1 is the native vlan

Crie uma relação EFP. O Cisco IOS XR executa um CLI estruturado para a configuração EFP e EVC. A fim configurar um EFP, use estes comandos interface configuration:

  • comando l2transport - Este comando identifica uma subinterface, uma porta física, ou uma relação do pai da pacote-porta como um EFP.

  • comando encapsulation - Este comando é usado a fim especificar critérios deharmonização.

  • comando da reescrita - Este comando é usado a fim especificar os critérios da reescrita da etiqueta VLAN.

Configuração ASR 9000 para Interfate TenGigabitEhternet 13/3 (porta de tronco)

interface GigabitEthernet 0/0/0/1
!
interface GigabitEthernet 0/0/0/1.1 l2transport
encapsulation dot1q untagged **
!

interface GigabitEthernet 0/0/0/1.4 l2transport
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric

interface GigabitEthernet 0/0/0/2
!
interface GigabitEthernet 0/0/0/2.130 l2transport
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet 0/0/0/3
!
interface GigabitEthernet 0/0/0/3.133 l2transport
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0
!
interface tengig0/0/0/0.4 l2transport
no ip address
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.130 l2transport
no ip address
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.133 l2transport
no ip address
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!

A fim adicionar o VLAN nativo 1, o tráfego do untag, e criar uma secundário-relação l2transport com o encapsulamento do sem etiqueta do dot1q. Use o comando do sem etiqueta do dot1q do encapsulamento sob uma relação l2transport ou uma secundário-relação se a porta é conectada a uma porta configura para o acesso de porta de switch no dispositivo de IOS.

Aqui está um exemplo:

IOS:

interface Gigabitethernet 1/1
switchport
switchport access vlan 3

IOSXR:

interfage GigabitEthernet 0/1/1/1.1 l2transport
encapsulation dot1q untagged

Depois que o EFP é criado, uma interface de BVI pode ser criada e adicionado ao BD. A interface de BVI é usada a fim acomodar a relação VLAN no Cisco IOS.

interface BVI4
ipv4 address 10.10.4.1 255.255.0.0
!
interface BVI130
ipv4 address 10.130.1.1 255.255.0.0
!

O número da interface de BVI não precisa necessariamente de combinar o identificador de VLAN. O mesmo é verdadeiro para o número da subinterface das interfaces de transporte L2. Contudo, para maior clareza neste exemplo, o número de BVI combina a etiqueta do dot1q assim como o número da subinterface EFP.

Neste exemplo, um l2-VPN BD é criado a fim construir uma ponte sobre junto os EFPs e os BVI:

l2vpn
bridge group VLAN4
bridge-domain VLAN4
interface ten0/0/0/0.4
!
interface GigabitEthernet 0/0/0/1.4
!
routed interface bvi4
!
!
bridge-domain VLAN130
interface ten0/0/0/0.130
!
interface GigabitEthernet 0/0/0/2.130
!
routed interface bvi130
!
!
bridge-domain VLAN133
interface ten0/0/0/0.133
!
interface GigabitEthernet 0/0/0/3.133
!
!
!
!

O grupo de bridge (BG) é uma hierarquia NON-funcional da configuração que amarre diversos BD junto parte de no mesmo grupo funcional. Funciona apenas como a criação de grupos individuais múltiplos com seus domínios faz, ao contrário de um grupo com domínios múltiplos.

Comandos equivalentes

Esta tabela alista outros comandos disponíveis no Cisco IOS, e os comandos equivalentes no Cisco IOS XR configurado sob o BD:

IOSIO XR
unicast do bloco do switchport}inundando o desabilitação do unicast desconhecido
máximo da Segurança de portas do switchportmáximo do limite do Mac (escala 5-512000)
violação de Segurança de portas do switchportnotificação do limite do Mac da ação do limite do Mac (inundação, nenhum-inundação, parada programada) (ambos, nenhum, armadilha)
MAC-movimento da notificação da tabela de endereços MACNecessidade de configurar o seguinte: ação segura do Mac nenhuns registro seguro do Mac
endereço MAC da Segurança de portas do switchportendereço MAC estático máximo H.H.H do limite y do Mac da relação x

Informações Relacionadas



Document ID: 116500