IP : Layer Two Tunnel Protocol (L2TP)

L2 que constrói uma ponte sobre através de um exemplo da configuração de rede L3

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve como construir uma ponte sobre uma rede da camada 2 (L2) através de uma rede da camada 3 (L3).

Contribuído por Atri Basu, gaio Taylor novo, e por Mani Ganesan, engenheiros de TAC da Cisco.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • Versão 3 do protocolo Layer 2 Tunneling Protocol (L2TPv3)
  • Generic Routing Encapsulation (GRE)

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Informações de Apoio

Em muitas situações, você exige uma solução a fim agregar o tráfego de WiFi dos pontos quentes a um local central. Nesses casos, a solução precisa de permitir que os dispositivos do equipamento da premissa do cliente (CPE) construam uma ponte sobre o tráfego Ethernet do host final, e encapsula os pacotes através do tráfego Ethernet a um valor-limite.

Se você usa o Roteadores dos serviços da agregação (ASR), a maneira fácil fazer isto é usar Ethernet sobre o GRE macio. Contudo, para o Roteadores do serviço integrado (ISR) e os todos dispositivos CPE restantes, esta não é uma opção. Em umas versões mais velhas do ® do Cisco IOS, era possível escavar um túnel o L2 sobre o GRE construindo uma ponte sobre a interface física com uma interface do túnel GRE. Embora o Bridging regular descasque o cabeçalho de VLAN dos pacotes recebidos, o uso do Integrated Routing and Bridging (IRB) no roteador pode distribuir e construir uma ponte sobre o mesmo protocolo de camada de rede na mesma relação e ainda permitir que o roteador mantenha o cabeçalho de VLAN de uma relação a outra.

Nota: Quando você configura o ponte-grupo na interface de túnel em umas versões do Cisco IOS mais velhas, os IO relatam que o comando é não-editado e unsupported, mas ainda aceita o comando. Em mais versões recentes, este comando é completamente Obsoleto, e os indicadores de Mensagem de Erro.

A solução anterior não é apoiada por Cisco. A solução apoiada para construir uma ponte sobre uma rede L2 é usar o L2TPv3 como descrito neste documento. O L2TPv3 fornece o apoio para o transporte dos vários protocolos L2 como Ethernet, 802.1q (VLAN), Frame Relay, High-Level Data Link Control (HDLC), e Point-to-Point Protocol (PPP). O foco deste documento é extensão dos Ethernet.

Configurar

Esta instalação é muito básica. Saque r101 e r201 do Roteadores como anfitriões na mesma rede, quando r100 e r202 tiverem uma relação L3 e uma relação L2. O objetivo é estabelecer a conexão do L2TPv3 tais que r101 e r201 podem se sibilar sem a exigência de todas as rotas.

Diagrama de Rede

Configuração de túnel

A configuração de túnel L2TP envolve três etapas:

  1. Configurar um L2TP-class (opcional)

    Esta classe é usada a fim definir alguma autenticação e os parâmetros de controle para o L2TP escavam um túnel. Se é usado, as duas extremidades devem espelhar-se.
    l2tp-class test
    hostname stanford
    password 7 082E5C4B071F091805

  2. Configurar a Pseudowire-classe

    Enquanto o nome sugere, esta seção está usada a fim configurar o túnel ou o “pseudowire real” entre os dois valores-limite. Defina um molde que contenha o encapsulamento do pseudowire, um valor-limite, e o protocolo do canal de controle.
    pseudowire-class test
    encapsulation l2tpv3
    ip local interface Loopback0
    ip pmtu

  3. Use Xconnect a fim fornecer o destino de túnel

    Ligue o pseudowire L2TP ao circuito do acessório (relação para o lado L2 local) e defina seu destino. 

Pontos a notar:

  • O circuito próprio do acessório não tem nenhum endereço IP de Um ou Mais Servidores Cisco ICM NT configurado.
  • O origem de túnel configurado com a interface local IP está na seção da pseudowire-classe.
  • O destino de túnel é definido com o comando do xconnect.

Considerações

  • Como com a solução do tunelamento GRE, o uso de um roteador em que terminar o túnel L2 ainda não permite que as mensagens da unidade de dados de protocolo (PDU) L2 sejam encaminhadas através do túnel. Sem o Tunelamento apropriado do protocolo L2, que não é apoiado neste dispositivo, estas mensagens são consumidas pela relação L2.

  • O apoio para o Tunelamento do protocolo L2 (protocolo cisco discovery, Spanning Tree Protocol, protocolo VLAN trunking, e protocolo de descoberta da camada de enlace) exige que o dispositivo é um interruptor. Este interruptor precisa de ser L3 ciente a fim poder ao tráfego de túnel e limitar as escolhas possíveis.

  • O encapsulamento do Tunelamento L3 depende do dispositivo que faz o Tunelamento:
    1. Encapsulamento do L2TPv3 dos apoios do Cisco 7301.
    2. Cisco 65xx não apoia a extensão L2 com o túnel do L2TPv3. Contudo, o L2 pode ser prolongado através de um núcleo MLPS com todo o transporte sobre a opção MPLS (átomo).
    3. O túnel L2TP não é apoiado nos Cisco 4500 Switch.

  • Somente uma única interface de túnel do xconnect pode ser configurada em uma interface física ou em uma secundário-relação. Uma interface separada é precisada para cada valor-limite do pseudowire. Você não pode configurar interfaces múltiplas com o xconnect com a mesma picowatt-classe e o mesmo L2TP ID.

  • O tamanho máximo da unidade de transmissão máxima do payload para um túnel L2TP é geralmente 1460 bytes para o tráfego que viaja sobre os Ethernet padrão. No caso do L2TP sobre o User Datagram Protocol (UDP), as despesas gerais são o resultado do cabeçalho IP (20 bytes), do cabeçalho de UDP (8 bytes), e do encabeçamento L2TP (12 bytes).

Configuração de exemplo

Configuração do roteador r101

interface Ethernet0/0
ip address 172.16.1.100 255.255.255.0

Configuração do roteador r100

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 198.51.100.100 255.255.255.0
!
interface FastEthernet0/1
description LAN
no ip address
speed 100
full-duplex
xconnect 203.0.113.102 1 encapsulation l2tpv3 manual pw-class test
l2tp id 1 2
!
ip route 0.0.0.0 0.0.0.0 198.51.100.1

Configuração do roteador r202

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 203.0.113.102 255.255.255.255

interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 198.51.100.100 1 encapsulation l2tpv3 manual pw-class test
l2tp id 2 1

Configuração do roteador r201

interface Ethernet0/0
ip address 172.16.1.201 255.255.255.0

Nota: Use a Command Lookup Tool ( somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Verificar

A fim indicar a informação detalhada sobre os canais de controle L2TP que se estabelecem a outros dispositivos L2TP-enabled para todas as sessões de L2TP no roteador, use o comando show l2tun tunnel all.

A fim verificar que o encapsulamento do L2TPv3 trabalha corretamente, sibile um host no local remoto que é suposto para estar no mesmo VLAN. Se o sibilo é bem sucedido, você pode usar este comando a fim confirmar que sua configuração trabalha corretamente. A ferramenta Output Interpreter (clientes registrados somente) apoia determinados comandos de exibição. Use a ferramenta Output Interpreter a fim ver uma análise do emissor de comando de execução.

  • O comando show arp indica o esconderijo do Address Resolution Protocol (ARP).

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.



Document ID: 116266