Unified Computing : Cisco UCS Manager

Exemplo de configuração do uplink UCS FCoE

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve como configurar o Fibre Channel sobre uplinks dos Ethernet (FCoE). Em versões da versão 2.1 e mais recente do Cisco Unified Computing System (UCS), o Fibre Channel multihop sobre o apoio dos Ethernet (FCoE) foi introduzido. Este apoio permite a consolidação do uplink de dois links separados a um único uplink que leve o Fibre Channel (FC) e os Ethernet.

Nota: Os uplinks unificados são diferentes das portas unificadas. Toda a interconexão da tela (FI), que inclui a geração 1, pode ter unificado uplinks. Contudo, somente a geração 2 FIs unificou portas.

Contribuído por Christopher Brown, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada na versão 2.1 do gerente UCS (UCSM). Você deve executar pelo menos a versão 2.1(1a) a fim usar este documento.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Configurar

Configurações suportadas

Em todas estas configurações, você pode substituir todo o link com um canal de porta do mesmo tipo. Por exemplo, se a configuração mostra um link, pode ser configurado com um canal de porta pelo contrário. Contudo, você não pode ter um Ethernet e uma porta unificada no mesmo canal de porta.

Uplink de FCoE com canal da porta virtual (vPC)

Esta configuração não contém nenhum link unificado, mas é a maneira a mais fácil de integrar uplinks de FCoE em seu ambiente atual. Esta configuração elimina a necessidade de cruzar as telas FC.

Conexão cruzada com fixar

Nesta configuração, os 5000 Series Switch do nexo (N5ks) e FIs são conexão cruzada, mas porta-não canalizado junto. Isto permite que você tenha alguns uplinks unificados, mas você ainda mantém um projeto de rede conhecido.

Todos os uplinks unificados

Esta configuração fornece a maioria de consolidação. Recorde que estes links podem igualmente ser canais de porta, mas todos os links deve ser uplinks unificados. Este é provável ser a maioria de Implementação comum.

Configuração no UCS

Há três etapas para configurar o UCS:

  1. Configurar a rede de área do Virtual Storage (VSAN).
  2. Configurar uplinks unificados.
  3. Configurar os canais de porta (opcionais).

Configurar o VSAN

Nesta configuração, o VSAN 500 é fora da tela A, e o VSAN 600 é fora da tela B. Esta é a mesma configuração que você se usaria a fim criar um VSAN para um FC normal.

Configurar uplinks unificados

O uplink unificado está hidden no GUI. A fim fazer uma porta unificada, você deve primeiramente configurar-la como um uplink ou um uplink de FCoE. Então, você pode configurar-lo como uma porta unificada. Esta configuração não remove o primeiro papel. Em lugar de, cria uma relação que tenha ambos.

Certifique-se ajustar neste momento seu VSAN.

Neste momento, seu UCS é configurado para o tráfego unificado. Este exemplo não usa os canais de porta. Contudo, você pode configurar os canais de porta normalmente neste momento. Certifique-se ajustar o VSAN sob a aba VSAN para o canal de porta.

Configuração no N5k

A configuração no N5k consiste em 3 etapas:

  1. Permita FCoE e opte por ajustes do Qualidade de Serviço (QoS). Crie o FCoE VLAN e ligue-lhe o VSAN.
  2. Configurar a interface Ethernet (ou o canal de porta).
  3. Crie um Fibre Channel virtual (vFC) e ligue-o à interface Ethernet.

Nota: O UCS é um interruptor da virtualização da porta N (NPV) à revelia assim que o interruptor ascendente precisa de reagir do modo de Identifer Virtulization da porta N (NPIV) (incorpore o comando do npiv da característica a fim permitir).  Veja configurar a virtualização da porta N para obter mais informações sobre desta característica.

Permita FCoE e opte por ajustes de QoS

Você pode saltar esta etapa se o N5k é configurado já para FCoE. Se o N5k não é configurado para FCoE, refira o apêndice A na extremidade deste documento para a instrução.

Configurar as interfaces Ethernet (ou os canais de porta)

Esta é a configuração para a relação que conecta normalmente ao UCS.  Certifique-se permitir o FCoE VLAN.

f340-31-15-5596-1(config)# interface ethernet 1/32
f340-31-15-5596-1(config-if)# switchport mode trunk
f340-31-15-5596-1(config-if)# switchport trunk allowed vlan all

Este é um exemplo de uma configuração de entroncamento muito básica. Observe que não há nenhuma configuração de FCoE nesta relação.

Configurar o vFC

Esta é a configuração para o vFC, que segura todo o tráfego de FCoE do UCS:

f340-31-15-5596-1(config-if)# int vfc 25
f340-31-15-5596-1(config-if)# switchport trunk allowed vsan 500
f340-31-15-5596-1(config-if)# no shut
f340-31-15-5596-1(config-if)# bind interface ethernet 1/32
f340-31-15-5596-1(config-if)#

Há alguns pontos a observar neste exemplo:

  • O número do vFC não importa. Pode ser qualquer coisa, enquanto não está já no uso.
  • Esta é uma porta da tela do entroncamento (TF), assim que certifique-se permitir seu VSAN.
  • Ligue isto à relação que enfrenta o UCS. Esta é a interface física em que o tráfego de FCoE é enviado/recebido. É enviada no VLAN associado com o VSAN.

Neste momento, você tem tudo configurado inteiramente. Incorpore o comando do vfc xx da relação da mostra a fim assegurar-se de que o VSAN venha acima.

f340-31-15-5596-1(config-if)# show interface vfc 25
vfc25 is trunking
Bound interface is Ethernet1/32
Hardware is Ethernet
Port WWN is 20:18:54:7f:ee:d3:f8:bf
Admin port mode is F, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 500
Trunk vsans (admin allowed and active) (500)
Trunk vsans (up) (500)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
1 minute input rate 4448 bits/sec, 556 bytes/sec, 1 frames/sec
1 minute output rate 610448 bits/sec, 76306 bytes/sec, 27 frames/sec
27347 frames input, 45743308 bytes
0 discards, 0 errors
114710 frames output, 218235936 bytes
0 discards, 0 errors
last clearing of "show interface" counters Thu May 9 13:37:42 2013

Interface last changed at Thu May 9 14:03:44 2013

Se o VSAN não está acima, verifique sua configuração e suas conexões. Se é ainda trague, bata a porta Ethernet no N5k.

Neste momento, você aplica sua configuração normal FC (política da bota, dividindo).

f340-31-15-5596-1(config-if)# show flogi database
--------------------------------------------------------------------------------
INTERFACE VSAN FCID PORT NAME NODE NAME
--------------------------------------------------------------------------------
fc2/3 500 0xd80000 20:42:00:0d:ec:b1:34:c0 21:f4:00:0d:ec:b1:34:c1
fc2/3 500 0xd80001 20:00:00:25:b5:12:dc:5f 20:00:00:25:b5:13:dc:2f
[svinfra-esxi-1]
fc2/3 500 0xd80003 20:00:00:25:b5:12:dc:3f 20:00:00:25:b5:13:dc:0f
[svinfra-esxi-2]
vfc7 500 0xd80060 25:f6:00:0d:ec:cc:d3:ff 21:f4:00:0d:ec:cc:d3:c1
vfc7 500 0xd80061 20:00:00:25:b5:19:70:28 20:00:00:25:b5:19:70:18
vfc25 500 0xd80042 20:00:00:25:b5:ab:1a:01 20:00:00:25:b5:00:00:8f
vfc25 500 0xd80043 20:00:00:25:b5:ab:1a:02 20:00:00:25:b5:00:00:9f
vfc25 500 0xd80044 20:00:00:25:b5:00:3a:08 20:00:00:25:b5:00:00:5f
vfc25 500 0xd80045 20:00:00:25:b5:00:3a:09 20:00:00:25:b5:00:00:4f
vfc25 500 0xd80048 2d:9a:00:05:73:c2:c6:3f 21:f4:00:05:73:c2:c6:01

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Apêndice A - Configuração básica N5k FCoE

A fim configurar o N5k para FCoE, entre:

feature fcoe
system qos
service-policy type network-qos fcoe-default-nq-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
service-policy type qos input fcoe-default-in-policy

Estes comandos permitem primeiramente FCoE, e permitem então as políticas de QoS do padrão que são precisadas para FCoE. Se você tem ajustes feitos sob encomenda de QoS, use aqueles como uma base. Estão aqui as configurações padrão:

  policy-map type qos fcoe-default-in-policy
class type qos class-fcoe
set qos-group 1
class type qos class-default
set qos-group 0

policy-map type queuing fcoe-default-in-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50
policy-map type queuing fcoe-default-out-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50

policy-map type network-qos fcoe-default-nq-policy
class type network-qos class-fcoe

pause no-drop
mtu 2158
class type network-qos class-default

mtu 1500
multicast-optimize

Como você pode ver, estas políticas criam a classe de tráfego de FCoE, marcam-na para a nenhum-gota, e dão-lhe a largura de banda dedicada. Você pode alterar estes enquanto você precisa (por exemplo, a fim adicionar o Jumbo Frames).

Em seguida, você precisa de ligar o VSAN ao VLAN:

f340-31-15-5596-1(config)# vlan 500
f340-31-15-5596-1(config-vlan)# name VNX_500
f340-31-15-5596-1(config-vlan)# fcoe vsan 500
f340-31-15-5596-1(config-vlan)#

Isto diz ao N5k que o VLAN 500 é um FCoE VLAN e que todo o tráfego que entrar deve ser comutado a VSAN 500.

Neste momento, seu N5k é configurado para FCoE e apronta-se para a conexão UCS.



Document ID: 116188