Unified Computing : Cisco UCS Manager

Exemplo da configuração de canal da porta upstream UCS

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback

Introdução

Este documento descreve como configurar um canal da porta upstream em server de Cisco UCS.

Contribuído por Joe LeBlanc e por Andrew Kelly, engenheiros de TAC da Cisco.

Pré-requisitos

Requisitos

Cisco recomenda que você tem o conhecimento dos Canais de porta antes que você tente esta configuração.

Componentes Utilizados

A informação neste documento é baseada nos Cisco Unified Computing System (UCS).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Configurar

A configuração de canal de porta UCS é ajustada estaticamente ao active do modo do protocolo link aggregation control (LACP). Esta configuração não pode ser alterada; consequentemente, todas as configurações de canal de porta ascendentes devem aderir ao active do modo LACP também. Alternativamente, você pode configurar os switchports ascendentes para a voz passiva do modo LACP.

Configuração de CLI

Está aqui uma amostra da configuração da interface UCS que não pode ser alterada:

UCS1-B(nxos)# show run interface eth1/19

!Command: show running-config interface Ethernet1/19
!Time: Fri Oct 12 20:25:59 2012

version 5.0(3)N2(2.11)

interface Ethernet1/19
description U: Uplink
pinning border
switchport mode trunk
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
channel-group 100 mode active
no shutdown

Está aqui a configuração da interface de canal de porta:

UCS1-B(nxos)# show run interface po100

!Command: show running-config interface port-channel100
!Time: Fri Oct 12 20:21:19 2012

version 5.0(3)N2(2.11)

interface port-channel100
description U: Uplink
switchport mode trunk
pinning border
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
speed 10000

Você pode executar o comando show interface no Canal de porta a fim mostrar os membros de canal de porta:

UCS1-B(nxos)# show interface po100
port-channel100 is up
Hardware: Port-Channel, address: 000d.eccd.665a (bia 000d.eccd.665a)
Description: U: Uplink
MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth1/19, Eth1/20

O canal da porta upstream deve ser LACP para combinar a configuração UCS. Outras configurações enlatam estam presente, mas (em um mínimo) você deve ver esta configuração:

5k# show run int eth1/3

!Command: show running-config interface Ethernet1/3
!Time: Sat Oct 13 00:30:51 2012

version 5.1(3)N2(1)

interface Ethernet1/3
switchport mode trunk
spanning-tree port type edge trunk
channel-group 100 mode active

Observe o tipo tronco da porta de Spanning Tree da borda em dispositivos NXOS. Esta configuração assegura-se de que, se um link bate, a porta venha imediatamente apoio. Em uma situação de falha, é importante que as portas de switch ascendentes não se movem através dos estados STP, que prolongam o tempo ocioso da máquina. Para obter mais informações sobre deste comando, refira o tipo borda da porta de Spanning Tree.

O equivalente do Cisco IOS deste comando é tronco do portfast de Spanning Tree.

Consulte estes documentos para obter outras informações:

Nota: Use a Command Lookup Tool ( somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Configuração de GUI

  1. Crie a relação de Canal de porta.

    116095-configure-ucs-upstream-port-channel-01.jpg

  2. Selecione as portas e clique a seta dobro para adicionar-las ao Canal de porta.

  3. Depois que você clica o revestimento, o Canal de porta aparece como para baixo quando o LACP negociar com o interruptor ascendente.

    116095-configure-ucs-upstream-port-channel-02.jpg

Se o interruptor ascendente é configurado corretamente, o status geral move-se para um estado ascendente.

Troubleshooting

  • Um Canal de porta não virá acima se a velocidade é diferente em ambos os lados. Esta é uma falta de configuração comum.
  • Você pôde precisar de trazer acima individualmente todos os links primeiramente e de verificar portas confinante. Use o vizinho cdp da mostra para verificar portas confinante.


Document ID: 116095