Cisco Interfaces and Modules : Cisco Unified SIP Proxy

Como configurar o Failover para Cisco unificou o proxy do SORVO

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (21 Abril 2016) | Feedback

Introdução

Este documento discute duas opções para usar-se a fim configurar a Redundância (Failover) para Cisco unificou o proxy do SORVO.

Contribuído por Randy Yuan Wu, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • Hot Standby Router Protocol (HSRP)
  • DNS
  • Cisco unificou o proxy do SORVO (o LIMITE)

Componentes

A informação neste documento é baseada no LIMITE.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento começado com uma configuração cancelada do padrão). Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Crie um gateway padrão Falha-resistente

A capacidade para criar um gateway padrão falha-resistente é uns recursos chaves que Cisco unificado SORVA o proxy (LIMITE) forneça. Há duas opções que você pode se usar para conseguir a Redundância para o LIMITE. Um é usar o server DNS SRV do Domain Name System; a outro é criar um servidor virtual. O Hot Standby Router Protocol (HSRP) é o mecanismo por que um servidor virtual pode ser criado. O primeiro parte de este documento descreve momentaneamente como executar DNS SRV. O resto e a maioria deste documento descrevem como HSRP? as características s podem ser executadas a fim detectar problemas no chassi do roteador dos Serviços integrados (ISR) ou no módulo de serviço próprio do LIMITE.

Opção um — DNS SRV

Nesta opção, configurar o elemento ascendente (qualquer elemento chama para a frente ao LIMITE) para usar o DNS. Se a tentativa de alcançar cusp1 falha, as perguntas ascendentes do elemento para a entrada seguinte em DNS SRV e tentativas usar cusp2. O DNS deve ser configurado corretamente para que este trabalhe.

  1. Primeiramente, dois registros DNS SRV (serviço) devem ser criados, um para cada limite. O registro que aponta a cusp1 tem uma prioridade mais alta.

  2. Em segundo lugar, dois registros DNS A (hostname) devem ser criados de modo que os destinos nos registros DNS SRV possam ser resolved. Este exemplo mostra o que o servidor DNS deve conter em seus registros.

116015-configure-failover-cusp-01.png

Opção dois — HSRP

Este diagrama fornece uma arquitetura básica de como configurar o LIMITE para o HSRP. O lado esquerdo é um elemento ascendente do SORVO, e o lado direito é o elemento a jusante do SORVO. Entre estes elementos é um roteador virtual com um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.20.7. Ambos os elementos do fluxo acima e fluxo abaixo conduzem o tráfego do SORVO para o endereço IP de Um ou Mais Servidores Cisco ICM NT do roteador virtual. Dentro do roteador virtual são dois roteadores reais: um preliminar e um secundário. Este dois Roteadores compartilham deste mesmo endereço IP de Um ou Mais Servidores Cisco ICM NT virtual, e suas configurações são idênticas com duas exceções. Consequentemente, as configurações dadas neste documento são as mesmas para ambo o Roteadores.

Nota: A configuração de HSRP para dois limites em um roteador único não foi testada. Pôde ser possível tomar esta solução e expandi-la para limites múltiplos, mas não é apoiada neste tempo.

116015-configure-failover-cusp-02.png

Conectividade básica da instalação

Primeiramente, Conectividade setup entre o roteador e a lâmina. Embora isto seja coberto em outros documentos, é discutido redundantemente neste documento também. Neste exemplo, o roteador principal tem um endereço de 192.168.20.80 e seu LIMITE tem um endereço de 192.168.20.81.

interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

O roteador secundário tem um endereço de 192.168.20.90 e seu LIMITE tem um endereço de 192.168.20.81.

interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Failover do Roteador-nível da instalação

Em seguida, o Failover nivelado do roteador deve ser configurado. Isto envolve uma designação de um do Roteadores como o preliminar e da outro como o secundário. Há uma pequena diferença na configuração dos dois Roteadores.

Está aqui a configuração para o roteador principal:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 100

Está aqui a configuração para o roteador secundário:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 90

Ambo o Roteadores tem seus endereços IP em standby ajustados ao roteador virtual; contudo, o roteador principal tem uma prioridade mais alta do que secundária. Isso significa, quando todas coisas restantes forem idênticas, o roteador principal é considerado active, e todo o tráfego do SORVO vai através do roteador principal e então ao LIMITE nesse roteador. O roteador secundário está no apoio e toma somente sobre se o roteador principal vai para baixo por qualquer razão, como uma interrupção de energia.

Siga as relações

O HSRP igualmente deve ser setup para detectar uma falha do nível do LIMITE. Que acontece se o LIMITE no roteador principal morre para alguém razão, mas o roteador próprio é não afetado? O tráfego do SORVO continua a ser enviado ao LIMITE no roteador principal. A prioridade do roteador deve ser mudada baseou no estado do LIMITE situado em cada roteador.

A maneira de fazer isto é setup um eco ICMP ao LIMITE de cada roteador. Neste caso, o eco é enviado cada dois (2) segundos, com um (1) um segundo intervalo. Mais baixos estes valores são, a seguir mais rapidamente o roteador pode detectar que o LIMITE está para baixo. Contudo, se o eco ICMP é ajustado demasiado baixo, isto poderia conduzir aos falsos positivos. A última linha de configuração neste exemplo começa o eco e ajusta-o para ocorrer para sempre.

Nota: Os ecos ICMP não podem seguir o estado da porta do SORVO. O failover de HSRP não pode ser iniciado se o problema está a nível da porta. Para reiterar; se o roteador falha, o outro roteador toma sobre; se os sibilos para os acordos do nível de serviço IP (SLA) falham, o outro roteador toma sobre; se a porta do SORVO falha, esta não está detectada.

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now

Um objeto deve ser setup para seguir o estado desse eco. O número do objeto é 100 neste caso. A relação deve ser ajustada para decrescer a prioridade do roteador por 20, se o estado deste objeto está para baixo. Isto significa se o LIMITE no roteador principal vai inativo por qualquer motivo, sua prioridade deixará cair de 100 a 80. Sua prioridade é então menos do que aquela do secundário, que tem uma prioridade de 90. Se o apoio 0 cancela é ajustado, força o roteador secundário à aquisição maioritária para o preliminar, e então o tráfego do SORVO vai ao LIMITE secundário.

track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
standby 0 track 100 decrement 20
standby 0 preempt

Configuração de HSRP do roteador principal

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 100
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Configuração de HSRP do roteador secundário

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 90
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Informações Relacionadas



Document ID: 116015