Switches de LAN : 802.1Q

Perda de pacotes sobre um túnel Dot1Q/L2P

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento discute sobre a pesquisa de defeitos da perda de pacotes sobre um túnel Dot1Q/L2P devido ao projeto de rede deficiente no½ do¿Â do Cisco IOSï com uns Casos Práticos.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • Conhecimento básico na escavação de um túnel do dot1q

  • Conhecimento básico do OSPF

Componentes Utilizados

Este documento não é restrito a versões de software ou hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Diagrama de Rede

Nesta instalação de rede, a relação Gi1/44 e o soldado 1/43 do roteador 7600-Core têm o roteador em um cabo setup com Fa0/13 e Fa0/12 do roteador 3400-Metro-1 respectivamente. No 7600-Dot1Q Switch a relação Gi9/44 e o soldado 9/45 são permitidos com modo de túnel do dot1q. As relações vlan SVI são criadas na borda 3400-Metro e Fa0/13 e Fa0/12 são configurados como portas de tronco. O Roteadores usa o OSPF para comunicar-se um com o otro.

http://www.cisco.com/c/dam/en/us/support/docs/lan-switching/8021q/113632-packet-loss-dot1q-l2p-01.gif

Configurações

Núcleo 7609
!
version 15.0
hostname 7609-CORE
interface GigabitEthernet1/43
 mtu 9216
 no ip address
 no ip redirects
 no ip proxy-arp
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
!
interface GigabitEthernet1/43.3503
 encapsulation dot1Q 3503
 ip address 172.16.41.17 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!
!
interface GigabitEthernet1/44
 mtu 9216
 no ip address
 no ip redirects
 no ip proxy-arp
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
!
interface GigabitEthernet1/44.3803
 encapsulation dot1Q 3803
 ip address 172.16.73.137 255.255.255.248 secondary
 ip address 172.16.41.21 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf cost 5
 ip ospf hello-interval 3
 ip ospf dead-interval 10

!--- Output omitted.

!
end

7609 DOT1QS
!
version 12.2
!
interface GigabitEthernet9/44
  switchport
 switchport access vlan 24
 switchport mode dot1q-tunnel
 mtu 9216
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
 spanning-tree portfast disable
 spanning-tree bpdufilter enable
!
!
interface GigabitEthernet9/45
 switchport
 switchport access vlan 24
 switchport mode dot1q-tunnel
 mtu 9216
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
 spanning-tree portfast disable
 spanning-tree bpdufilter enable
!

!--- Output omitted.

!
end

3400-Metro-1
!
version 12.2
!
interface FastEthernet0/3
  port-type nni
 switchport trunk allowed vlan 1052,3503
 switchport mode trunk
 load-interval 60
!
interface FastEthernet0/4
 port-type nni
 switchport trunk allowed vlan 1052,3803
 switchport mode trunk
 load-interval 60
!
!
interface FastEthernet0/12
 port-type nni
 switchport trunk allowed vlan 2-4094
 switchport mode trunk

!
interface FastEthernet0/13
 port-type nni
 switchport trunk allowed vlan 2-4094
 switchport mode trunk
!
end

borda 3400-Metro
!
version 12.2
!
interface FastEthernet0/12
 port-type nni
 switchport mode trunk
 load-interval 60
 storm-control broadcast level 1.00
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
!
interface FastEthernet0/13
 port-type nni
 switchport mode trunk
 load-interval 60
 storm-control broadcast level 1.00
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
!
!
interface Vlan3503
 ip address 172.16.41.18 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!
interface Vlan3803
 ip address 172.16.73.139 255.255.255.248 secondary
 ip address 172.16.41.22 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf cost 5
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!

!--- Output omitted.

!
end

Observação

As gotas aleatórias do sibilo ocorrem quando o pacote atravessa através do túnel do dot1q. Mas, não há nenhuma gota do entrada/saída nas relações e igualmente não há nenhum sintoma das questões de camada física. Emita o comando show interface <interface> a fim verificar as gotas do entrada/saída na relação:

7609-Dot1Q#show interface gi9/44 

!--- Output omitted.

 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    0 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored
    0 output errors, 0 collisions, 1 interface resets
    0 lost carrier, 0 no carrier, 0 PAUSE output

!--- Output omitted.

Quando um tráfego ICMP de aproximadamente 100 sibilos for mandado da Metro-borda, simplesmente 95 ecos estão recebidos no núcleo, que sugere que os pacotes ICMP estejam obtendo deixou cair no trajeto.

Metro-Edge#ping 172.16.41.21 re 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.41.21, timeout is 2 seconds:
.....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 95 percent (95/100), round-trip min/avg/max = �/9 ms

Nota: O comando show ip traffic nos 7609 mostra que somente 95 ecos estão recebidos visto que na Metro-borda e nela mostra que 100 ecos estão mandados.

mostre o tráfego IP
Na Metro-borda
ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 0 unreachable
        0 echo, 95 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 0 redirects, 0 unreachable, 100 echo, 0 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

!--- The above output shows that 100 echos are sent
!--- but received 95 replies from 7609-Core.

Em 7609-Core
ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 0 unreachable
        95 echo, 0 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 0 redirects, 0 unreachable, 0 echo, 95 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

Troubleshooting

Verifique se os endereços MAC estão aprendidos corretamente a fim pesquisar defeitos a gota em uns pacotes.

Use o comando da tabela de endereços MAC da mostra a fim verificar as entradas de endereço MAC.

Para o ping bem-sucedido

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 all
Legend: * - primary entry
age - seconds since last seen
n/a - not available
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
* 24 e05f.b972.1f00 dynamic Yes 0 Gi9/44

!--- This output displays the MAC address learnt
!--- and its associated port, in this case the associated 
!--- port for successful ping is Gi9/44.

Para o sibilo da falha

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 all
Legend: * - primary entry
age - seconds since last seen
n/a - not available
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
* 24 e05f.b972.1f00 dynamic Yes 5 Gi9/45

!--- This output displays the MAC address learnt
!--- and its associated port, in this case, 
!--- the port number is Gi9/45.

A fim ver o deslocamento predeterminado detalhado MAC programar, use o comando show mac-address-table.

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 det

MAC Table shown in details
========================================

PI_E RM RMA Type Alw-Lrn Trap Modified Notify Capture Flood Mac Address Age Pvlan SWbits Index XTag
----+---+---+----+-------+----+--------+------+-------+------+--------------+----+------+------+----

Active Supervisor:

Yes No No DY No No Yes No No No e05f.b972.1f00 0xE0 24 0 0x22C 0

Emita os comandos do number> do <Index do deslocamento predeterminado LTL-informação do mcast do interruptor e do teste do login remoto a fim saber que número de porta que o valor de HEX precedente denotou.

7609-DOT1q-sp#test mcast ltl-info index 22B
index 0x22B contain ports 9/44
7609-DOT1q-sp#test mcast ltl-info index 22C
index 0x22C contain ports 9/45

!--- The output shows that hex number 22B 
!--- points to 9/44 port and hex 22C points to 9/45.

Para a falha de ping a fonte e o deslocamento predeterminado do destino são a mesma porta e daqui a gota. Quando o MAC-movimento permitido com o comando do MAC-movimento da notificação do mac-address-table nos 7600 ele mostra aletas MAC entre duas portas diferentes e este é o Mensagem de Erro:

Nota: Desde que 6500/7600 usam um MAC address comum para o interruptor., o mesmo MAC address atribuiu entre portas diferentes. O comando do chassi-MAC-endereço do catalizador 6000 da mostra mostra o MAC address reservado do interruptor.

* Jul 2 10:29:44.011: %MAC_MOVE-SP-4-NOTIF: Host e05f.b972.1f00 in 
vlan 24 is flapping between port Gi9/45 and port Gi9/44

!--- The previous error message indicates 
!--- that the same MAC address is assigned between 
!--- two different ports: Gi9/45 and port Gi9/44.

Solução

A rede precedente é uma instalação de rede da malha cheia que tenha pontos finais de túnel do DOT1Q no mesmo interruptor. Neste tipo da instalação de rede as MAC-aletas são esperadas. A fim evitar o MAC-flapping, uma destas soluções pode ser executado.

  • Mova o ponto final de túnel para um interruptor diferente, por exemplo, o encapsulamento e o decapsulation devem acontecer no interruptor diferente.

  • A poda de vlan pode ser feita para regular o VLANS em algumas das portas de tronco.


Informações Relacionadas


Document ID: 113632