IP : IP Versão 6 (IPv6)

Redistribua a rota padrão do IPv6 BGP no exemplo de configuração EIGRPv6

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo de como redistribuir uma rota padrão do protocolo Protocolo de la puerta de enlace marginal (BGP) (IPv6 BGP) dentro ao protocolo enhanced interior gateway routing (EIGRPv6) que usa a redistribuição mútua entre EIGRPv6 e IPv6 BGP.

Pré-requisitos

Certifique-se de que você cumpre estas exigências antes que você tente esta configuração:

  • Tenha um conhecimento básico de EIGRPv6

  • Tenha um conhecimento básico do IPv6 BGP

  • Tenha um conhecimento básico do endereçamento do IPv6

Versões de hardware e software

As configurações neste documento são baseadas no Cisco 7200 Series Router com Software Release 15.0(1) do½ do¿Â do Cisco IOSïÂ.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Neste exemplo, o Roteadores R2 e o r1 comunicam-se um com o otro usando o eBGP do IPv6. O r1 do Roteadores e o R3 usam EIGRPv6. A rota padrão é criada no roteador R2 emitindo o comando neighbor default-originate. A fim redistribuir mutuamente dentro as rotas do eBGP do IPv6 a EIGRPv6, use o comando bgp da redistribuição com métrico EIGRP. Similarmente, a fim redistribuir dentro as rotas EIGRPv6 a IPv6BGP, use o eigrp da redistribuição COMO o comando number sob o modo de configuração da endereço-família.

Nota: Use a ferramenta de consulta de comandos (clientes registrados somente) a fim encontrar mais informação nos comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113598-redis-ipv6-default-route-01.gif

Configurações

Este documento utiliza as seguintes configurações:

R1 do roteador
R1#show run
Building configuration...
!
version 15.0
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address BB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address BB20::20/128
!
interface Loopback30
 no ip address
 ipv6 address BB30::30/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 ipv6 address 4040:1:1:1::10/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
router bgp 505
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 500
 no auto-summary
 !
 address-family ipv6
  redistribute eigrp 1

!--- EIGRP is redistributed in to BGP.

  no synchronization
  network BB10::10/128
  network BB20::20/128
  neighbor 3030:1:1:1::10 activate
 exit-address-family
!
!
ipv6 router eigrp 1
 eigrp router-id 1.1.1.1
 redistribute bgp 505 metric 100 1 255 1 1500

!--- EIGRP for IPv6 has a shutdown feature.
!--- Make sure that the routing process is in "no shut" mode 
!--- in order to start running the protocol.


!--- BGP is redistributed with EIGRP default metrics.

!
end

Roteador R2
R2#show run
Building configuration...
!
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address AB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address AB20::20/128
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 serial restart-delay 0
!
router bgp 500
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 505
 neighbor 3030:1:1:1::11 default-originate
 no auto-summary
!
 address-family ipv6
  no synchronization
  network AB10::10/128
  network AB20::20/128
  neighbor 3030:1:1:1::11 activate
  neighbor 3030:1:1:1::11 default-originate
 exit-address-family
!
end

!--- Originates default route to the 
!--- neighbor 3030:1:1:1::11.

Roteador R3
R3#show run
!
version 15.0
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback10
 no ip address
 ipv6 address CC10::10/128
 ipv6 eigrp 1
!
interface Loopback20
 no ip address
 ipv6 address CC20::20/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 4040:1:1:1::11/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
ipv6 router eigrp 1
 eigrp router-id 3.3.3.3
!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use o OIT a fim ver uma análise do emissor de comando de execução.

comandos show

A fim verificar que o roteador R3 está recebendo a rota padrão redistribuída do IPv6 BGP, use o comando eigrp do show ipv6 route no roteador R3.

eigrp do show ipv6 route
No roteador R3
R3#show ipv6 route eigrp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
EX  ::/0 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB10::10/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB20::20/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
D   BB30::30/128 [90/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the default route
!--- is redistributed in EIGRP. EX indicates EIGRP external routes.

A fim verificar as rotas EIGRPv6 são redistribuídos no roteador R2 corretamente, usam o comando bgp do show ipv6 route no roteador R2.

BGP do show ipv6 route
No roteador R2
R2#show ipv6 route bgp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   BB10::10/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   BB20::20/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC10::10/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC20::20/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the eigrp routes
!--- are redistributed in to BGP.

Verifique a alcançabilidade entre o Roteadores R2 e R3 usando o comando ping.

ping
Do roteador R2:
 
R2#ping  CC10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/40/96 ms

R2#ping CC20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/44/100 ms
Do roteador R3:
 
R3#ping AA10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

R3#ping AA20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

!--- The above ping responses shows that R1 and R3 are able
!--- to communicate with each other.


Informações Relacionadas


Document ID: 113598