IP : Border Gateway Protocol (BGP)

Redistribuição mútua entre o EIGRP e o exemplo da configuração de BGP

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar a redistribuição mútua entre o Enhanced Interior Gateway Routing Protocol (EIGRP) e o Border Gateway Protocol (BGP).

Pré-requisitos

  • Conhecimento básico do EIGRP

  • Conhecimento básico do BGP

Versões de hardware e software

As configurações neste documento são baseadas no Cisco 7200 Series Router com Software Release 15.0(1) do½ do¿Â do Cisco IOSïÂ.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Neste exemplo, o r1 do Roteadores e o R2 comunicam-se um com o otro usando o EIGRP. O Roteadores R2 e R3 usa o eBGP. A fim redistribuir mutuamente dentro as rotas do eBGP ao EIGRP, use o comando bgp da redistribuição com métrico EIGRP. Similarmente, a fim redistribuir dentro rotas de EIGRP ao BGP, use o eigrp da redistribuição COMO o comando number.

Nota: Use a ferramenta de consulta de comandos (clientes registrados somente) a fim encontrar mais informação nos comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113506-failover-eigrp-bgp-01.gif

Configurações

Este documento utiliza as seguintes configurações:

R1 do roteador
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.101 255.255.255.0
 duplex auto
 speed auto

!
router eigrp 100
 network 30.0.0.0
 network 192.168.1.0
 no auto-summary
!
end

Roteador R2
!
hostname R2
!
ip cef
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.100.50 255.255.255.0
 serial restart-delay 0
 clock rate 2000000

!
router eigrp 100
 redistribute static
 redistribute bgp 1000 metric 100 1 255 1 1500
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary
!
router bgp 1000
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.20 mask 255.255.255.255
 redistribute connected
 redistribute static
 redistribute eigrp 100
 neighbor 172.16.100.51 remote-as 2000
 neighbor 172.16.100.51 next-hop-self

 
 no auto-summary
!
end

Roteador R3
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 22.22.22.22 255.255.255.255

!
interface Serial0/0
 ip address 172.16.100.51 255.255.255.0
 serial restart-delay 0
 clock rate 2000000
!
router bgp 2000
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 network 172.16.100.0 mask 255.255.255.0
 neighbor 172.16.100.50 remote-as 1000
 neighbor 172.16.100.50 default-originate
 default-information originate

!--- Default route is configured!


 no auto-summary

!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use o OIT a fim ver uma análise do emissor de comando de execução.

comandos show

A fim verificar que o EIGRP está recebendo as rotas redistribuída, use o comando show ip route eigrp.

mostre o eigrp da rota IP
No r1 do roteador
R1#show ip route eigrp
20.0.0.0/32 is subnetted, 1 subnets
D EX    20.20.20.20
           [170/25625856] via 192.168.1.100, 01:00:33, FastEthernet0/0
     22.0.0.0/32 is subnetted, 1 subnets
D EX    22.22.22.22
           [170/25625856] via 192.168.1.100, 00:59:49, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
D       10.10.10.10 [90/409600] via 192.168.1.100, 00:55:17, FastEthernet0/0
D*EX 0.0.0.0/0 [170/25625856] via 192.168.1.100, 00:46:24, FastEthernet0/0


!--- Shows the default route from router R3.



!--- EX indicates that the routes are EIGRP external routes.



A fim verificar que as rotas de EIGRP estão redistribuídas no BGP corretamente, use o comando show ip route bgp no roteador R3.

mostre o BGP da rota IP
No roteador R3
R3#show ip route bgp
show ip route bgp
     20.0.0.0/32 is subnetted, 1 subnets
B       20.20.20.20 [20/0] via 172.16.100.50, 01:03:02
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.100.50, 01:03:02
B    192.168.1.0/24 [20/0] via 172.16.100.50, 01:03:02
     30.0.0.0/32 is subnetted, 1 subnets
B       30.30.30.30 [20/409600] via 172.16.100.50, 00:59:06

!--- The output indicates that the EIGRP routes are
!--- redistributed in BGP.



Informações Relacionadas


Document ID: 113506