IP : Enhanced Interior Gateway Routing Protocol (EIGRP)

Failover com EIGRP usando o exemplo da configuração de VRF

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar o Failover com Enhanced Interior Gateway Routing Protocol (EIGRP) usando o roteamento virtual e a transmissão (VRF). O VRF é uma extensão de Roteamento IP que forneça exemplos do roteamento múltiplo. Os provedores de serviço da Internet (ISP) aproveitam-se deste VRF a fim criar o Virtual Private Networks (VPNs) separado para os clientes enquanto permite que as múltiplas instâncias da tabela de roteamento existam em um roteador.

Pré-requisitos

  • Conhecimento básico do EIGRP

  • Conhecimento básico do VRF

Versões de hardware e software

As configurações neste documento são baseadas no Cisco 3700 Series Router no Software Release 12.4 (15)T 13 do � do Cisco IOS.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Neste exemplo, o r1 do roteador é considerado um roteador de PE. O Roteadores R2 e R3 é considerado CE Router. O Roteadores usa o EIGRP para comunicar-se um com o otro. Se o R2 perde a Conectividade com r1 (isto é, em caso do Failover), as rotas podem alcançar o r1 com o R3. O Roteadores R2 e R3 tem uma conexão MPLS entre elas.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/113446-failover-eigrp-vrf-01.gif

Configurações

Este documento utiliza as seguintes configurações:

R1 do roteador
!
version 12.4
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 57.35.169.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 220
 network 2.2.2.2 0.0.0.0
 network 57.35.169.2 0.0.0.0
 network 192.168.1.0
 no auto-summary

!--- Configured EIGRP and advertised the networks.

!
end

Roteador R2
!
version 12.4
!
hostname R2
!
ip cef
!
ip vrf A

!--- Configures VRF routing table!

 rd 1.1.1.1:111

!---Configuring a route distinguisher RD creates routing and forwarding
table for a VRF.

The RD can be used in either of these formats:

    - 16-bit AS number: Your 32-bit number (for example, 1:100)

    - 32-bit IP address: Your 16-bit number (In our case, 1.1.1.1:111)


 route-target export 1.1.1.1:111
 route-target import 1.1.1.1:111

!--- Creates a list of import and/or export
 route target communities for the specified VRF.

!
ip vrf B
 rd 2.2.2.2:222
import ipv4 unicast map vrfA-to-vrfB

!--- Associates the specified route map with the VRF.

 route-target export 2.2.2.2:222
 route-target import 2.2.2.2:222
!
mpls label protocol ldp
!
interface Loopback1
 ip vrf forwarding B

!--- Associates a VRF instance with an interface.

 ip address 172.16.2.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding A
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip vrf forwarding A
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet1/0
 ip vrf forwarding B
 ip address 203.197.194.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 no auto-summary
 !
 address-family ipv4 vrf B

!--- Enter address family configuration mode
  for configuring EIGRP routing sessions.


  network 172.16.2.0 0.0.0.255
  network 203.197.194.0
  no auto-summary
  autonomous-system 330

!--- Defines the autonomous system number for this 
specific instance of EIGRP.

 exit-address-family
 !
 address-family ipv4 vrf A
  network 10.0.0.1 0.0.0.0
   network 192.168.1.0
  no auto-summary
  autonomous-system 220
 exit-address-family
!
access-list 99 permit 172.16.1.0 0.0.0.255
access-list 99 permit 192.168.1.0 0.0.0.255
access-list 101 permit udp host 192.168.1.1 eq bootps host 1.1.1.1 eq bootps

!--- Create access list in order to permit the host addresses.

!
route-map vrfA-to-vrfB permit 10
 match ip address 99

!--- Created a route map and distributed the routes
permitted by access list 99. 

!
end

Roteador R3
!
version 12.4
!
hostname R3
!
ip cef
!
!
!
!
ip vrf A
 rd 1.1.1.1:111
!
mpls label protocol ldp
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding A
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip vrf forwarding A
 ip address 57.35.169.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 203.197.194.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 330
 network 1.1.1.1 0.0.0.0
 network 10.0.0.2 0.0.0.0
 network 57.35.169.1 0.0.0.0
 network 203.197.194.0
 no auto-summary
 !
 address-family ipv4 vrf A
  network 10.0.0.2 0.0.0.0
  network 57.35.169.1 0.0.0.0
  no auto-summary
 autonomous-system 220
 exit-address-family
!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

comandos show

A fim verificar que o EIGRP está configurado corretamente, use o comando show ip route vrf.

show ip route vrf
No roteador R2
R2#show ip route vrf A

Routing Table: A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 192.168.1.2, 00:15:47, FastEthernet0/0
     57.0.0.0/24 is subnetted, 1 subnets
D       57.35.169.0 [90/307200] via 192.168.1.2, 00:15:47, FastEthernet0/0
                    [90/307200] via 10.0.0.2, 00:15:47, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0
No roteador R3
R3#show ip route vrf A

Routing Table: A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 57.35.169.2, 00:16:59, FastEthernet0/1
     57.0.0.0/24 is subnetted, 1 subnets
C       57.35.169.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
D    192.168.1.0/24 [90/307200] via 57.35.169.2, 00:17:02, FastEthernet0/1
                    [90/307200] via 10.0.0.1, 00:17:02, FastEthernet0/0

!--- Displays the routing table associated with
VRF instance A.

Se o R2 perde a Conectividade ao r1, as rotas do R2 alcançarão o r1 do roteador com o R3.

Em caso do Failover
Quando o R2 perde sua Conectividade ao r1, tente a emissão fechada em R2' Fa0/0. No roteador R2
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int fa0/0
R2(config-if)#shut down
R2(config-if)#
*Mar  1 00:01:01.539: %TDP-5-INFO: VRF A: TDP ID removed
*Mar  1 00:01:01.675: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 57.35.169.1:0 (1) is
  DOWN (LDP Router ID changed)
*Mar  1 00:01:01.679: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 220: Neighbor 192.168.1.2
  (FastEthernet0/0) is down: interface down
R2(config-if)#
*Mar  1 00:01:03.519: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state
  to administratively down
*Mar  1 00:01:04.519: %LINEPROTO-5-UPDOWN: Line protocol on Interface 
  FastEthernet0/0, changed state to down
Na mesma instância no roteador R3, o link failover obtém ativado.
R3#
*Mar  1 00:00:52.527: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 192.168.1.1:0 (1) is 
  DOWN (TCP connection closed by peer)
R3#
*Mar  1 00:00:59.591: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 10.0.0.1:0 (1) is UP

A fim verificar que o roteador R2 pode ainda alcançar o r1, emita o comando vrf do sibilo a fim sibilar o r1 do roteador R2.

Ping
No roteador R2
R2#ping vrf A 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/51/96 ms

!--- R2 can still reach R1 through R3.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 113446