IP : Border Gateway Protocol (BGP)

Exemplo de configuração MP-EBGP

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece a informação como configurar o protocolo Protocolo de la puerta de enlace marginal (BGP) prolongado multiprotocol (MP-EBGP) no Roteadores do Cisco IOS. O MP-BGP é um BGP prolongado que permita que o BGP leve a informação de roteamento para o IPv6, o VPNv4, e o outro dos protocolos de camada da rede múltipla. O MP-BGP permite que você tenha uma topologia do roteamento do unicast diferente de uma topologia do roteamento de transmissão múltipla, que ajude a controlar a rede e os recursos.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As configurações neste documento são baseadas no Cisco 3700 Series Router que executa o Software Release 12.4 (15)T 13 do ½ do ¿  de Cisco IOSïÂ.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Neste exemplo, o r1 e o Roteadores R3 são configurados para estar dentro COMO 5500 iBGP de formação. O roteador R2 é configurado para ser dentro COMO 6500. O r1 e o Roteadores R2 comunicam-se um com o otro usando MP-EBGP. Todo o Roteadores é configurado com endereços de loopback.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113555-mp-ebgp-config-01.gif

Configurações

Este documento utiliza as seguintes configurações:

Configuração no r1 do roteador
R1#show run
Building configuration...
!
version 12.4
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.100.10 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.10.1 255.255.255.0
 mpls ip
 clock rate 2000000
!
router bgp 5500
 no synchronization
 bgp router-id 10.10.10.10
 bgp log-neighbor-changes
 network 192.168.100.0
 redistribute connected
 neighbor 172.16.10.2 remote-as 6500
 neighbor 172.16.10.2 soft-reconfiguration inbound
 neighbor 192.168.100.11 remote-as 5500
 no auto-summary
 !
 address-family vpnv4
  neighbor 172.16.10.2 activate
  neighbor 172.16.10.2 send-community both

!--- Sends the community attribute to a BGP neighbor.

 exit-address-family
!
!
end

Configuração no roteador R2
R2#show run
Building configuration...
!
version 12.4
!
hostname R2
!
ip cef
!
ip vrf WAN
 rd 2020:1
 route-target export 2020:1
 route-target import 2020:1
!
!
interface Loopback0
 ip vrf forwarding WAN

!--- Associates a VRF instance with an interface or subinterface.

 ip address 20.20.20.20 255.255.255.255
!
interface Serial0/0
 ip vrf forwarding WAN
 ip address 172.16.10.2 255.255.255.0
 mpls ip
 clock rate 2000000
!
router bgp 6500
 no synchronization
 bgp router-id 20.20.20.20
 bgp log-neighbor-changes
 neighbor 172.16.10.1 remote-as 5500
 no auto-summary
 !
 !
 address-family vpnv4
  neighbor 172.16.10.1 activate
  neighbor 172.16.10.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf WAN
  redistribute connected
  redistribute static
  neighbor 172.16.10.1 remote-as 5500
  neighbor 172.16.10.1 activate
  no synchronization
 exit-address-family
!
!
!
end

Configuração no roteador R3
R3#show run
Building configuration...
!
version 12.4
!
hostname R3
!
ip cef
!
!
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.100.11 255.255.255.0
 duplex auto
 speed auto
!
router bgp 5500
 no synchronization
 bgp router-id 11.11.11.11
 bgp log-neighbor-changes
 neighbor 192.168.100.10 remote-as 5500
 no auto-summary
!
end

Verificar

A fim indicar entradas na tabela de roteamento (BGP), use o comando show ip bgp.

mostre o BGP IP
No r1 do roteador
R1#show ip bgp 172.16.10.2
BGP routing table entry for 172.16.10.2/32, version 14
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
        1    2
  Local
    0.0.0.0 from 0.0.0.0 (10.10.10.10)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best

!--- Displays the routing table entries for the host 172.16.10.2

R1#sh ip bgp 192.168.100.11
BGP routing table entry for 192.168.100.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
        1    2
  Local
    0.0.0.0 from 0.0.0.0 (10.10.10.10)
      Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced, local, best

!--- Displays the entries for the host 192.168.100.11

No roteador R3
R3#sh ip bgp 192.168.100.10
BGP routing table entry for 192.168.100.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17))
  Not advertised to any peer
  Local
    192.168.100.10 from 192.168.100.10 (10.10.10.10)
      Origin IGP, metric 0, localpref 100, valid, internal, best

!--- Displays the entries for the host 192.168.100.10

No roteador R2, use o comando show ip bgp vpnv4 indicar a informação de endereço (do VPNv4) da tabela (BGP).

mostre o VPNv4 BGP IP
No roteador R2
R2#sh ip bgp vpnv4 vrf WAN
BGP table version is 24, local router ID is 20.20.20.20
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 2020:1 (default for vrf WAN)
*> 10.10.10.0/24    172.16.10.1              0             0 5500 ?
*> 20.20.20.20/32   0.0.0.0                  0         32768 ?
*  172.16.10.0/24   172.16.10.1              0             0 5500 ?
*>                  0.0.0.0                  0         32768 ?
r> 172.16.10.2/32   172.16.10.1              0             0 5500 ?
*> 192.168.100.0    172.16.10.1              0             0 5500 I

!--- Displays prefixes associated with the (VRF) instance WAN. 

R2#show ip bgp vpnv4 vrf WAN 172.16.10.1
BGP routing table entry for 2020:1:172.16.10.0/24, version 7
Paths: (2 available, best #2, table WAN)
  Advertised to update-groups:
        1
  5500
    172.16.10.1 from 172.16.10.1 (10.10.10.10)
      Origin incomplete, metric 0, localpref 100, valid, external
      Extended Community: RT:2020:1
      mpls labels in/out 18/nolabel
  Local
    0.0.0.0 from 0.0.0.0 (20.20.20.20)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:2020:1
      mpls labels in/out 18/aggregate(WAN)

!--- Displays prefixes associated with neighbor 172.16.10.1

MP-EBGP é estabelecido entre o r1 e o Roteadores R2. Use o comando ping verificar e vice-versa a alcançabilidade do r1 ao R2.

ping
No r1 do roteador
R1#ping 172.16.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/64/208 ms

R1#ping 192.168.100.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/41/96 ms

!--- Router R1 can successfully ping the routers R2 and R3.

No roteador R2
R2#ping vrf WAN 172.16.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/32/96 ms

R2#ping vrf WAN 192.168.100.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/73/204 ms


!--- Router R2 can successfully reach router R1 and R3.


Informações Relacionadas


Document ID: 113555