Switches : Switches Cisco Nexus 7000 Series

Exemplo de configuração do 7000 Series Switch ERSPAN do nexo

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar uma sessão do analisador de porta comutada remota encapsulada (ERSPAN) em um switch da série Nexus 7000 que monitore o tráfego entre portas Ethernet em dois switches da série 7000.

Pré-requisitos

Requisitos

Certifique-se de que você cumpre estas exigências antes que você tente esta configuração:

  • Tenha o conhecimento básico da configuração em 7000 Series Switch do nexo

  • Tenha o conhecimento básico de ERSPAN

Componentes Utilizados

A informação neste documento é baseada no 7018 Series Switch do nexo na liberação do Software Cisco NX-OS 5.1(3).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Sobre ERSPAN

  • ERSPAN permite a monitorização remota dos switch múltiplos através de sua rede.

  • ERSPAN transporta o tráfego espelhado das portas de origem do Switches diferente à porta do destino, onde o analisador de rede conectou.

  • O tráfego é encapsulado no switch de origem e transferido ao switch de destino, onde o pacote é descapsulado e enviado então à porta do destino.

  • ERSPAN consiste em uma sessão da fonte ERSPAN, no Generic Routing Encapsulation (GRE) do roteável ERSPAN - tráfego encapsulado, e em uma sessão do destino ERSPAN.

  • Você pode configurar sessões da fonte ERSPAN e sessões do destino no Switches diferente separadamente.

  • ERSPAN não faz monitora nenhuns pacotes que são gerados pelo supervisor, apesar de sua fonte.

Fontes ERSPAN

  • As relações de que o tráfego pode ser monitorado são chamadas fontes ERSPAN.

  • Você pode monitorar todos os pacotes para a porta de origem que é recebida (ingresso), transmitido (saída), ou bidirecional (ambos).

  • As fontes ERSPAN incluem portas de origem, fonte VLAN, ou fonte VSAN. Quando um VLAN é especificado como uma fonte ERSPAN, todas as interfaces suportadas no VLAN são fontes ERSPAN.

Destinos ERSPAN

  • As portas do destino recebem o tráfego copiado das fontes ERSPAN.

  • A porta do destino é uma porta que seja conectada ao dispositivo tal como o dispositivo switchprobe ou a outra ponta de prova ou dispositivo de segurança do Remote Monitoring (RMON) que podem receber e analisam os pacotes copiados porta da única ou do origem múltipla.

  • As portas do destino não participam em nenhuma instância de Spanning Tree ou em nenhuns protocolos da camada 3.

Configurar

Este exemplo de configuração usa uma porta de origem no 7000 Series Switch 1 do nexo e uma porta do destino em um outro 7000 Switch do nexo, onde o analisador de rede conecte. Há umas ligações de Ethernet entre ambo o Switches, segundo as indicações do diagrama.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113480-erspan-nexus-7k-01.gif

Configurações

Este documento utiliza as seguintes configurações:

7000 Switch 1 do nexo
switch_1#configure terminal


!--- Configures an ERSPAN source session.

switch_1(config)#monitor session 48 type erspan-source

!--- Configure the sources and traffic direction.

switch_1(config-erspan-src)#source interface Ethernet2/10 both

!--- Configure the destination IP address in the ERSPAN session.

switch_1(config-erspan-src)#destination ip 10.11.11.3

!--- Configure the ERSPAN ID.

switch_1(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_1(config-erspan-src)#vrf default

!--- Enable the ERSPAN source session (by default the session is 
!--- in shutdown state).

switch_1(config-erspan-src)#no shut
switch_1(config-erspan-src)#exit


!--- Configure the ERSPAN global origin IP address.

switch_1(config)#monitor erspan origin ip-address 10.254.254.21 global



!--- Configure the IP address for loopback interface, which is used
!--- as source of the ERSPAN traffic.

switch_1(config)#interface loopback1
switch_1(config-if)#ip address 10.254.254.21/32
switch_1(config-if)#exit

switch_1(config)#interface Ethernet1/1
switch_1(config-if)#switchport
switch_1(config-if)#switchport mode trunk
switch_1(config-if)#no shutdown
switch_1(config-if)#exit

switch_1(config)#feature interface-vlan
switch_1(config)#interface Vlan 11
switch_1(config-if)#ip address 10.11.11.2/29
switch_1(config-if)#no ip redirects
switch_1(config-if)#no shutdown
switch_1(config-if)#exit


!--- Save the configurations in the device.

switch_1(config)#copy running-config startup-config
Switch_1(config)#exit

7000 Switch 2 do nexo
switch_2#configure terminal


!--- Configures an ERSPAN destination session.

switch_2(config)#monitor session 47 type erspan-destination

!--- Configures the source IP address.

switch_2(config-erspan-src)#source ip 10.11.11.3

!--- Configures a destination for copied source packets.

switch_2(config-erspan-src)#destination interface Ethernet2/34

!--- Configure the ERSPAN ID.

switch_2(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_2(config-erspan-src)#vrf default

!--- Enable the ERSPAN destination session (by default the session is 
!--- in shutdown state).

switch_2(config-erspan-src)#no shut
switch_2(config-erspan-src)#exit

switch_2(config)#interface Ethernet2/34
switch_2(config-if)#switchport monitor
switch_2(config-if)#exit

switch_2(config)#feature interface-vlan
switch_2(config)#interface Vlan 11
switch_2(config-if)#ip address 10.11.11.3/29
switch_2(config-if)#no ip redirects
switch_2(config-if)#no shutdown
switch_2(config-if)#exit

switch_2(config)#interface Ethernet1/2
switch_2(config-if)#switchport
switch_2(config-if)#switchport mode trunk
switch_2(config-if)#no shutdown
switch_2(config-if)#exit


!--- Save the configurations in the device.

switch_2(config)#copy running-config startup-config
Switch_2(config)#exit

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Estes são alguns dos comandos de verificação ERSPAN:

  • Use o comando show monitor a fim indicar o estado das sessões ERSPAN:

    switch_1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    4        up           The session is up
  • Use o comando do [session session_number] da sessão de monitor da mostra a fim indicar a configuração de sessão ERSPAN:

    switch_1# show monitor session 48
       session 48
    ---------------
    type              : erspan-source
    state             : up
    erspan-id         : 902
    vrf-name          : default
    acl-name          : acl-name not specified
    ip-ttl            : 255
    ip-dscp           : 0
    destination-ip    : 10.11.11.3
    origin-ip         : 10.254.254.21 (global)
    source intf       :
        rx            : Eth2/10
        tx            : Eth2/10
        both          : Eth2/10
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
  • Use o comando all da sessão de monitor da mostra a fim indicar toda a configuração das sessões ERSPAN no dispositivo.

  • Use o comando monitor da executar-configuração da mostra a fim indicar a configuração do corredor ERSPAN:

    switch_1# show running-config monitor
    
    !Command: show running-config monitor
    !Time: Thu Apr 19 10:15:33 2012
    
    version 5.1(3)
    monitor session 48 type erspan-source
      erspan-id 902
      vrf default
      destination ip 10.11.11.3
      source interface Ethernet2/10 both
      no shut
    
    monitor erspan origin ip-address 10.254.254.21 global
  • Use o comando monitor da partida-configuração da mostra a fim indicar a configuração de inicialização ERSPAN.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 113480