IP : Border Gateway Protocol (BGP)

Exemplo de configuração do refletor da rota de BGP do IPv6

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo usando o IPv6 que o ajuda a compreender a característica do refletor de rota (RR) no Border Gateway Protocol (BGP). Como padrão, as rotas recebidas de um par iBGP não estão enviadas a outro par iBGP a menos que uma configuração de malha integral seja formada entre todos os roteadores BGP dentro de um AS. Isto resulta em problemas de escalabilidade. O uso de refletores de rota BGP leva a níveis muito mais altos de escalabilidade.

Configurar o refletor de rota permite que um roteador anuncie ou reflita as rotas ensinadas pelo iBGP a outros alto-falantes iBGP. O roteador seriam um refletor de rota quando configurado com o comando neighbor route-refletora-client e os vizinhos em que o comando aponta são os clientes desse RR.

Pré-requisitos

Requisitos

Certifique-se de que você cumpre estas exigências antes que você tente esta configuração:

  • Tenha uma compreensão do protocolo de roteamento BGP e da sua operação

  • Tenha uma compreensão do método de endereçamento do IPv6

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As configurações neste documento são baseadas no Cisco 3700 Series Router com Software Release 12.4 (15)T1 do½ do¿Â do Cisco IOSïÂ.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Neste exemplo, o roteador A é configurado porque o RR e o Roteadores RRClient1 e RRClient2 são os clientes do roteador A. Todo o Roteadores é configurado para estar no AS100, embora o Roteadores não tenha a configuração da malha cheia. Em lugar de, usa a característica BGP RR a fim comunicar-se um com o otro.

Nota: Use a ferramenta de consulta de comandos (clientes registrados somente) a fim encontrar mais informação nos comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113419-ipv6-bgp-rr-01.gif

Configurações de exemplo

Este documento utiliza as seguintes configurações:

Roteador A
hostname Router-A
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2011:11:11:11::11/128
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2011:12:12:12::1/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2011:13:13:13::1/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:22:22:22::22 remote-as 100
 neighbor 2011:22:22:22::22 update-source Loopback0
 neighbor 2011:33:33:33::33 remote-as 100
 neighbor 2011:33:33:33::33 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:22:22:22::22 activate
  neighbor 2011:22:22:22::22 route-reflector-client

!--- Configures the router RRClient1
as route reflector client!


  neighbor 2011:33:33:33::33 activate
  neighbor 2011:33:33:33::33 route-reflector-client

!--- Configures the router RRClient2
as route reflector client!

 exit-address-family
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 1.1.1.1

!--- Router ID of the route reflector router A!

 log-adjacency-changes
!
end

RRClient1
hostname RR-Client1
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2011:22:22:22::22/128
 ipv6 ospf 10 area 0
!
interface Loopback10
 no ip address
 ipv6 address 1010:10:10:10::10/128
!
interface Serial0/0
 no ip address
 ipv6 address 2011:12:12:12::2/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 2.2.2.2

!--- Router ID of the RRClient1

 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::11 remote-as 100
 neighbor 2011:11:11:11::11 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:11:11:11::11 activate
  network 1010:10:10:10::10/128
 exit-address-family
!
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
!
end

RRClient2
hostname RR-Client2
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
!
!
interface Loopback0
 no ip address
 ipv6 address 2011:33:33:33::33/128
 ipv6 ospf 10 area 0
!
interface Loopback20
 no ip address
 ipv6 address 2020:20:20:20::20/128
!
interface Serial0/0
 no ip address
 ipv6 address 2011:13:13:13::2/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 3.3.3.3

!--- Router ID of the RRClient2

 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::11 remote-as 100
 neighbor 2011:11:11:11::11 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:11:11:11::11 activate
  network 2020:20:20:20::20/128
 exit-address-family
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Estes comandos show são usados verificar a configuração:

Em clientes RR:

BGP do show ipv6 route
Em RRClient1
 
RRClient1#sh ipv6 route bgp
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2020:20:20:20::20/128 [200/0]
     via 2011:33:33:33::33

!--- The iBGP route from RRClient2 is reflected


RRClient1#ping 2011:33:33:33::33
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2011:33:33:33::33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/32 ms

!--- Ping to the RRClient2 from RRClient1 is successful

Em RRClient2
 
RRCLlient2#sh ipv6 route bgp
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1010:10:10:10::10/128 [200/0]
     via 2011:22:22:22::22

!--- The iBGP route from RRClient1 is reflected

RRCLlient2#ping 1010:10:10:10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1010:10:10:10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/50/76 ms

!--- Ping to the RRClient1 from RRClient2 is successful

No roteador A:

prefixo do IPv6 do unicast do show bgp ipv6
RouterA#sh bgp ipv6 unicast 1010:10:10:10::10/128
BGP routing table entry for 1010:10:10:10::10/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Advertised to update-groups:
        1
  Local, (Received from a RR-client)

!--- Indicates that the route was received from a route-reflector
 client router RRClient1

    2011:22:22:22::22 (metric 64) from 2011:22:22:22::22 (2.2.2.2)
      Origin IGP, metric 0, localpref 100, valid, internal, best
RouterA#show bgp ipv6 unicast 2020:20:20:20::20/128
BGP routing table entry for 2020:20:20:20::20/128, version 2
Paths: (1 available, best #1, table Global-IPv6-Table)
  Advertised to update-groups:
        1
  Local, (Received from a RR-client)

!--- Indicates that the route was received from a route-reflector
client router RRClient2

    2011:33:33:33::33 (metric 64) from 2011:33:33:33::33 (3.3.3.3)
      Origin IGP, metric 0, localpref 100, valid, internal, best

Em clientes RR:

Sempre que uma rota iBGP é refletida (isto é, propagado a um outro iBGP o par), o roteador que executa o refletor de rota (em nosso caso, o roteador A) adiciona 2 atributos NON-transitivos:

  • Identificador de originador:

    Este é uns atributos de BGP opcionais NON-transitivos. A rota iBGP refletida terá o Router ID do par do iBGP de que a rota foi recebida como seu identificador de originador. Em nosso exemplo, a rota 2020:20:20:20::20/128 que é do RRClient 2 é refletida pelo roteador A (RR), a RRClient1. Em consequência, esta rota terá o Router ID do RRClient2 (Router ID: 3.3.3.3) como seu identificador de originador.

  • Conjunto-ID:

    Este é uns atributos de BGP opcionais NON-transitivos. A rota iBGP refletida terá o Router ID do RR como seu Conjunto-ID, se o valor conjunto-identificação não é configurado. Em nosso exemplo, a rota 2020:20:20:20::20/128 não tem a conjunto-identificação configurada e consequentemente o Router ID (Router ID: 1.1.1.1) do roteador A (RR) será o Conjunto-ID.

unicast ipv6-prefix do show bgp ipv6
Em RRClient1
 
show bgp ipv6 unicast 2020:20:20:20::20/128
BGP routing table entry for 2020:20:20:20::20/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Not advertised to any peer
  Local
    2011:33:33:33::33 (metric 128) from 2011:11:11:11::11 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 3.3.3.3, Cluster list: 1.1.1.1

!--- Originator ID 3.3.3.3 is the router id of the RRClient2 from
which the route is received!


!--- Similarly, Cluster ID 1.1.1.1 is the router ID of the
router reflector Router A!

Em RRClient2
 
show bgp ipv6 unicast 1010:10:10:10::10/128
BGP routing table entry for 1010:10:10:10::10/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Not advertised to any peer
  Local
    2011:22:22:22::22 (metric 128) from 2011:11:11:11::11 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 2.2.2.2, Cluster list: 1.1.1.1

!--- Originator ID 2.2.2.2 is the router ID of the RRClient1 from 
which the route is received!


!--- Similarly, Cluster ID 1.1.1.1 is the router ID of the
router reflector Router A!


Informações Relacionadas


Document ID: 113419