IP : IP Versão 6 (IPv6)

Rotas estáticas do implementar para o exemplo de configuração do IPv6

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar rotas estáticas para o IPv6. As rotas estáticas são rotas manualmente configuradas que define um caminho explícito entre dois dispositivos. No caso da alteração de topologia em uma rede, as rotas estáticas não são atualizadas automaticamente como aquela do protocolos dinâmicos e devem manualmente ser reconfiguradas. As rotas estáticas são úteis para redes menores que tem somente um trajeto às redes externas.

A desvantagem principal do uso das rotas estáticas é a falta da configuração automática em caso das alterações de topologia. As rotas estáticas são executadas igualmente para fornecer a Segurança para determinados tipos de tráfegos a outras redes que precisam mais controle. As limitações que são consideradas no uso das rotas estáticas são a falta da Redundância e em redes que maiores a nova configuração manual das rotas pode se transformar uma grande carga adicional administrativa.

Use o comando route do IPv6 a fim configurar o roteamento estático. Note que antes que você configure o roteador com uma rota estática do IPv6, você deve permitir a transmissão de pacotes do IPv6 com o comando do roteamento do unicast do IPv6 no modo de configuração global.

Pré-requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento do roteamento estático do IPv4

  • Conhecimento do método de endereçamento do IPv6

Componentes Utilizados

A informação neste documento é baseada no Cisco 3700 Series Router no Software Release 12.4 (15)T 13 do � do Cisco IOS.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113361-ipv6-static-routes-01.gif

Configurações

Este documento utiliza as seguintes configurações:

Está aqui um link a um vídeo, disponível na comunidade do apoio de Ciscoleavingcisco.com , que demonstra como configurar rotas estáticas para a rede do IPv6 no Roteadores do Cisco IOS:

Configuração das rotas estáticas para o IPv6 no Cisco IOS leavingcisco.com

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113361-ipv6-static-routes-02.gif

R1 do roteador
version 12.4
!
hostname R1
!
ip cef
!
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

!
interface Loopback1
 no ip address
 ipv6 address 1010::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000::1/126
!
ip forward-protocol nd
!
ipv6 route 2001::/126 2000::2
ipv6 route 2020::1/128 2000::2
ipv6 route 3030::1/128 2000::2

!--- Static routes are configured in router R1, 
!--- to reach the networks in router R2 and R3.
!--- This is done when you specify 
!--- the next-hop address, which in this case is
!--- 2000::2 from which the output interface 
!--- is automatically derived.


!
end

Roteador R2
version 12.4
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback2
 no ip address
 ipv6 address 2020::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000::2/126
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001::1/126
!
ip forward-protocol nd
!
ipv6 route 1010::1/128 2000::1
ipv6 route 3030::1/128 2001::2

!--- Static routes are configured to reach
!--- routers R1 and R3 loopback address when you 
!--- specify the corresponding interface address.

!
end

Roteador R3
version 12.4
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback3
 no ip address
 ipv6 address 3030::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001::2/126
!
ip forward-protocol nd
!
ipv6 route 1010::1/128 2001::1
ipv6 route 2000::/126 2001::1
ipv6 route 2020::1/128 2001::1

!--- For router 3, to reach R1 and R2, 
!--- static routes are configured when you 
!--- mention 2001::1 as the next-hop address.

!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Use o comando static do show ipv6 route a fim indicar os índices da tabela de roteamento do IPv6, e a saída é mostra abaixo:

estática do show ipv6 route
No r1 do roteador
R1#show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
S   2001::/126 [1/0]
     via 2000::2
S   2020::1/128 [1/0]
     via 2000::2
S   3030::1/128 [1/0]
     via 2000::2

!--- Displays the static routes learnt by router R1 through 2000::2.

No roteador R3
R3#show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
S   1010::1/128 [1/0]
     via 2001::1
S   2000::/126 [1/0]
     via 2001::1
S   2020::1/128 [1/0]
     via 2001::1

!--- Displays the static routes learnt by router R3 through 2001::1.

O r1 do roteador tem as rotas ao roteador R2 e R3, consequentemente, o r1 do roteador deve poder sibilar o endereço de loopback do roteador R2' e o roteador R3. Use o comando ping a fim verificar o mesmos.

No r1 do roteador
Endereço de loopback sibilando do roteador R2'
R1#ping 2020::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2020::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/36/104 ms

!--- Router R1 is successfully able to ping 
!--- router R2's loopback address.

Roteador R3 sibilar
R1#ping 2001::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/40/116 ms

R1#ping 3030::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3030::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/84 ms

!--- Similarly R1 is also able to reach R3,
!--- for example, ping to R3's interface address
!--- and loopback address from router R1 is successful.

Nota: Similarmente o roteador R3 pode igualmente alcançar o endereço 2000::1 do Roteadores R1 Fa0/0 e seu endereço de loopback 1010::1.

Use o comando static do IPv6 da mostra a fim indicar os índices atuais da tabela de roteamento e usar a sintaxe do detalhe a fim indicar mais informação util, que é discutida neste exemplo:

mostre a estática do IPv6
No r1 do roteador
R1#show ipv6 static
IPv6 Static routes
Code: * - installed in RIB
* 2001::/126 via nexthop 2000::2, distance 1
* 2020::1/128 via nexthop 2000::2, distance 1
* 3030::1/128 via nexthop 2000::2, distance 1

!--- Displays the routes that are installed in 
!--- the IPv6 Routing Information Base(RIB) marked with *!

Quando a palavra-chave do detalhe é especificada, a informação adicional está indicada. Esta é uma amostra da saída:

mostre o detalhe da estática do IPv6
No roteador R2
R2#show ipv6 static detail
IPv6 Static routes
Code: * - installed in RIB
* 1010::1/128 via nexthop 2000::1, distance 1
     Resolves to 1 paths (max depth 1)

!--- Displays the output path set, and maximum 
!--- resolution depth, which in this case is 1.

     via FastEthernet0/0
* 3030::1/128 via nexthop 2001::2, distance 1
     Resolves to 1 paths (max depth 1)
     via FastEthernet0/1

!--- Displays that the route is received through 
!--- the next-hop 2000::1 through interface fa0/0.

Nota: Em caso das rotas inválidas, esta informação é indicada:

  • Para rotas recursiva inválidas, a razão pela qual a rota é inválida.

  • Para inválido dirija ou inteiramente rotas especificadas, a razão pela qual a rota é inválida.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 113361