IP : Open Shortest Path First (OSPF)

Redistribua redes conectadas no OSPF com palavras-chave de sub-rede

16 Agosto 2014 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (12 Agosto 2014) | Feedback


Índice


Introdução

Este documento descreve o comportamento da redistribução das rotas conectadas no Open Shortest Path First (OSPF). Há dois comportamentos que dependem sobre se as palavras-chave de sub-rede estão dadas ou não quando você redistribui as redes conectadas. No general, quando o comando redistribute é usado para redistribuir rotas em um domínio de OSPF, o roteador torna-se automaticamente em um roteador de limite de sistema autônomo (ASBR). À revelia quando as rotas dos protocolos são redistribuídas dentro ao OSPF com a palavra-chave conectada, estas rotas transformam-se tão externos redistribuído ao COMO e somente as rotas que não são sub-rede são redistribuídas. Em você inclua as palavras-chave de sub-redes, o OSPF redistribui as rotas, que são sub-rede. O processo usa 20 como a métrica do padrão. Isto acontece quando nenhuma métrica é especificada pelo uso da palavra-chave do tipo métrico.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento da distribuição do IP geral

  • Conhecimento de conceitos e de termos do protocolo de roteamento OSPF

Componentes Utilizados

As configurações neste documento são baseadas no Cisco 3700 Series Router no software 12.4 do software release de Cisco IOS® (15)T 13.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

O r1 do Roteadores, o R2 e o R3 são conectados através da interface serial entre si e configurados com o endereço IP de Um ou Mais Servidores Cisco ICM NT. Há alguns endereços de loopback criados no r1 e no R3 para gerar redes. O EIGRP é executado no r1 do Roteadores e no R2 quando o R3 se comunicar ao r1 usando o OSPF. O roteador R2, que executa o EIGRP e o OSPF, usa o comando redistribute a fim redistribuir dentro rotas de EIGRP ao OSPF.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/113339/ospf_connected_net-01.gif

Configurações

Este documento utiliza as seguintes configurações:

R1 do roteador
version 12.4
!
hostname R1
!
ip cef
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.240
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.240
!
interface Loopback2
 ip address 30.30.30.30 255.255.255.240
!
interface Serial0/0
 ip address 172.16.10.1 255.255.248.0
 clock rate 2000000
!
router eigrp 100
 network 10.10.10.0 0.0.0.15
 network 20.20.20.16 0.0.0.15
 network 30.30.30.16 0.0.0.15
 network 172.16.8.0 0.0.7.255
 no auto-summary

!--- Auto-summary is disabled so that 
!--- the networks are summarized with subnets.

!
end

Roteador R2
version 12.4
!
hostname R2
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback2
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 172.16.10.2 255.255.248.0
 clock rate 2000000
!
interface Serial0/1
 ip address 172.16.64.1 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 network 1.0.0.0
 network 3.0.0.0
 network 172.16.8.0 0.0.7.255
 auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 100 
 redistribute connected
 network 2.2.2.2 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

Roteador R3
version 12.4
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 11.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 12.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 13.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 172.16.64.2 255.255.255.0
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 11.1.1.1 0.0.0.0 area 0
 network 12.1.1.1 0.0.0.0 area 0
 network 13.1.1.1 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

Verificar

Verifique a redistribução das redes conectadas no OSPF

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Use o comando show ip route ospf a fim verificar que o roteador R3 receoved as rotas redistribuída.

mostre o OSPF da rota IP
Quando as rotas conectadas forem redistribuídas com a redistribuição conectada no roteador R2: No roteador R3
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0

!--- Only the classful routes are shown without actual subnets.

Quando redistribuído com a especificação das palavras-chave de sub-redes nas sub-redes conectadas da redistribuição no roteador R2: No roteador R3
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0
R3#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O E2    1.1.1.1 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- When routes are redistributed in to OSPF, 
!--- OSPF uses 20 as the default metric if 
!--- the metric-type keyword is not mentioned
!--- and the routes are redistributed as External Type 2(E2) routes.

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:36:58, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/20] via 172.16.64.1, 00:00:02, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.8.0/21 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- On specifying the keyword subnets, 
!--- the routes are reflected along with the subnets.



!--- Only the classful routes are shown without actual subnets.

Verifique a redistribução das rotas de EIGRP no OSPF

Quando as rotas de EIGRP são redistribuídas dentro ao OSPF com o <process do eigrp da redistribuição identificação > comando, as rotas estão redistribuídas como as rotas E2 com a métrica do padrão de 20 quando nenhuma palavra-chave do tipo métrico é especificada.

mostre o OSPF da rota IP
Quando o EIGRP for redistribuído com o comando 100 do eigrp da redistribuição no roteador R2: No roteador R3
R3#show ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:03:16, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:00:09, Serial0/0

!--- Only classful networks are redistributed by default.

Quando você especificar as palavras-chave de sub-rede no comando subnets do eigrp 100 da redistribuição no roteador R2: No roteador R3
R3#sh ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:09:26, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     20.0.0.0/28 is subnetted, 1 subnets
O E2    20.20.20.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     10.0.0.0/28 is subnetted, 1 subnets
O E2    10.10.10.0 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     30.0.0.0/28 is subnetted, 1 subnets
O E2    30.30.30.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0

!--- On specifying the keyword subnets, 
!--- the subnetted routes are reflected along
!--- with their subnet mask.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 113339