IP : Conversão de endereços de rede (NAT)

NAT-PT estático para o exemplo de configuração do IPv6

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A tradução de endereço de rede - A tradução de porta (NAT-PT) é um IPv6 ao mecanismo da tradução do IPv4, que permite que os dispositivos IPv6-only se comuniquem com os dispositivos IPv4-only e vice-versa. O NAT-PT é projetado ser distribuído para permitir transparentemente uma comunicação direta entre as redes IPv6-only e as redes IPv4-only que usam um único endereço V4.

Este documento explica como executar o NAT-PT estático que usa um exemplo de configuração onde os nós de rede do IPv6 se comuniquem com os nós de rede do IPv4 que usam um traço do IPv6 do endereço do IPv4 configurado no roteador do NAT-PT.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento básico de conceitos e de operações NAT.

  • Conhecimento básico do método de endereçamento do IPv6

  • Conhecimento básico do roteamento estático do IPv6

Nota: O NAT-PT foi julgado suplicado pelo IETF devido a seu acoplamento apertado com Domain Name System (DNS) e a suas limitações gerais na tradução, e provou como a tecnologia ser demasiado complexa manter serviços translational escaláveis. Com o deprecation do NAT-PT e a transição crescente do IPv6 entre usuários conduziu à introdução de NAT64. Refira estes documentos para obter mais informações sobre de NAT64:

Componentes Utilizados

As configurações neste documento são baseadas no Cisco 3700 Series Router no Software Release 12.4 (15)T 13 do � do Cisco IOS.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Neste exemplo, três r1 do Roteadores, R2 e R3 são conectados através de uma interface serial onde o r1 atue como o roteador do NAT-PT, que conecta ao roteador R2 usando o endereço do IPv4 e ao R3 usando o endereço do IPv6.

Nota: O NAT-PT não é apoiado no Cisco Express Forwarding (CEF) e tem que ser desabilitado.

Nota: Use a ferramenta de consulta de comandos (clientes registrados somente) a fim encontrar mais informação nos comandos usados neste documento.

Diagrama de Rede

Este exemplo usa esta instalação de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/network-address-translation-nat/113275-nat-ptv6-01.gif

Configurações

Este exemplo usa este a configuração:

Configuração do r1
hostname R1
ipv6 unicast-routing
!
interface Serial0/0
 ip address 192.168.30.10 255.255.255.0
 duplex auto
 speed auto
 ipv6 nat
!
interface Serial0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::9/64
 ipv6 enable
!
ipv6 route ::/0 2001:DB8:3002::10
ipv6 nat v4v6 source 192.168.30.9 2000::960B:202

!--- Translates the ipv4 add of R2 fa0/0 to ipv6 address.
          
ipv6 nat v6v4 source 3001:11:0:1::1 150.11.3.1

!--- Translates the ipv6 add of loop0 of R3 to ipv4 address.
              
ipv6 nat prefix 2000::/96

!--- The destination prefixes that matches 2000::/96 
!--- are translated by NAT-PT.
                            
!
end

Configuração R2
hostname R2
!
interface Serial0/0
 ip address 192.168.30.9 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.30.10
!

!
end

Configuração R3
hostname R3
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3001:11:0:1::1/64
!
interface Serial0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::10/64
!
ipv6 route ::/0 2001:DB8:3002::9
!

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

No roteador R3

Agora todo o pacote do endereço do IPv6 de Loopback0 do R3 deve poder alcançar o endereço do IPv4 fa0/0 do R2 usando o endereço 2000::960B:202 do IPv6 como mostrado aqui:

Ping
R3#ping 2000::960b:202 sou lo 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000::960B:202, timeout is 2 seconds:
Packet sent with a source address of 3001:11:0:1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/60/124 ms

!--- This shows that the router R3 is able to reach 
!--- the router R2 through lo address 3001:11:0:1::1.

No roteador R2

Ping
R2#ping 150.11.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.11.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/68/120 ms

!--- The successful ping response shows that the router R2
!--- is able to reach the IPv6 network.

No r1 do roteador

mostre a IPv6 traduções nat

mostre a IPv6 traduções nat
R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

!--- This command displays the active NAT-PT translations in the router.

debugar detalhado nat do IPv6

debugar detalhado nat do IPv6
R1#debug ipv6 nat detailed
R1#
*Mar  1 09:12:41.877: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (0.0.0.0 -> ::)
                 ref_count = 1, usecount = 0, flags = 513,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (0.0.0.0 -> ::)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 257,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: IPv6->IPv4:
                 src (3001:11:0:1::1 -> 150.11.3.1)
                 dst (2000::960B:202 -> 192.168.30.9)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: icmp src (3001:11:0:1::1) -> (150.11.3.1), 
                 dst (2000::960B:202) -> (192.168.30.9)
*Mar  1 09:12:41.965: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.965: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0,


!--- This command displays detailed information about NAT-PT events.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 113275