IP : Roteamento IP

Exemplo de configuração do IPv6 EIGRP

29 Julho 2013 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (26 Setembro 2011) | Feedback


Índice


Introdução

Este documento descreve como configurar o Enhanced Interior Gateway Routing Protocol (EIGRP) para IPv6. O EIGRP é uma versão aprimorada do IGRP desenvolvido por Cisco. É um protocolo de vetor de distância avançado que confie no Diffused Update Algorithm (DUPLO) para calcular o caminho mais curto a um destino dentro de uma rede. O EIGRP para o IPv6 trabalha da mesma forma como o IPv4 EIGRP onde podem ser configurados e controlado separada.

Pré-requisitos

  • Conhecimento básico de EIGRPv4

  • Conhecimento básico do endereçamento do IPv6

Restrições

Configurar o EIGRP para o IPv6 tem algumas limitações; estão listados abaixo:

  • As relações podem diretamente ser configuradas com o EIGRP para o IPv6, sem o uso de um endereço global do IPv6. Não há nenhuma instrução de rede no EIGRP para o IPv6.

  • O Router ID precisa de ser configurado para um exemplo do protocolo EIGRPv6 antes que possa ser executado.

  • O EIGRP para o IPv6 tem uma característica da parada programada. Assegure-se de que o processo de roteamento reaja de “nenhum” modo fechado para começar executar o protocolo.

Componentes Utilizados

As configurações neste documento são baseadas no Cisco 3700 Series Router no Cisco IOS Software Release 12.4 (15)T 13.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Neste exemplo, dois Roteadores (r1 e R2) são configurados com endereço do IPv6. Os endereços de loopback são atribuídos em ambo o Roteadores, e são configurados para estar em EIGRP1. O EIGRPv6 é permitido pelo nível de interface usando este comando: como-número do eigrp do IPv6

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este exemplo usa esta instalação de rede:

/image/gif/paws/113267/eigrp-ipv6-01.gif

Configurações

Este exemplo usa este a configuração:

Configuração do r1
hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1010:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2020:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3030:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::1 link-local
 ipv6 address 2010:AB8::1/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 2.2.2.2
 no shutdown
!
end

Configuração R2
hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::2 link-local
 ipv6 address 2010:AB8::2/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 1.1.1.1
 no shutdown
!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Comandos show

Os vizinhos EIGRP do IPv6 da mostra comandam indicadores que os vizinhos descobriram pelo EIGRPv6.

Mostre vizinhos EIGRP do IPv6
R1 do roteador
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             13 15:17:58   44   264  0  12
    FE80::2

!--- Shows the link local address of router R2. 

Roteador R2
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             14 16:32:05   30   300  0  12
    FE80::1

!--- Shows the link local address of router R1. 

O comando eigrp do show ipv6 route mostra o índice da tabela de roteamento do IPv6 que inclui as rotas específicas ao EIGRP.

eigrp do show ipv6 route
R1 do roteador
R1#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   2000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   3000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0

!--- This command shows IPv6-specific EIGRP routes.

Roteador R2
R2#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1010:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   2020:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   3030:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0

O eigrp do IPv6 da mostra conecta o comando indica a informação sobre as relações que são configuradas para o EIGRP.

mostre relações do eigrp do IPv6
R1 do roteador
R1#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        44       0/15         199           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

!--- This command determines which interface EIGRP is active.

Roteador R2
R2#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        30       0/15         135           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 113267