Switches : Switches Cisco Catalyst 2960 Series

Switches do 2960/2950 Series do catalizador usando o exemplo da configuração de VLAN da Voz

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (20 Outubro 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para VLAN de voz nos Cisco Catalyst 2960/2950 Series Switches. Especificamente, este documento mostra como configurar a característica de VLAN de voz em um Cisco Catalyst 2950 Switch.

Pré-requisitos

Requisitos

Certifique-se de que você cumpre estas exigências antes que você tente esta configuração:

  • Tenha um conhecimento básico da configuração no Switches do 2960/2950 Series do Cisco catalyst.

  • Tenha uma compreensão básica da Voz VLAN.

Componentes Utilizados

A informação neste documento é baseada no Cisco Catalyst 2950 Switch.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Exprima a vista geral VLAN

A característica da Voz VLAN permite as portas de switch levar o tráfego de voz com a Precedência IP da camada 3 e mergulhar 2 valores do Classe de serviço (CoS) de um telefone IP. Baseado no IEEE 802.1P CoS, o interruptor apoia o Qualidade de Serviço (QoS) que usa a classificação e a programação para enviar o tráfego de rede do interruptor. Você pode configurar o Cisco IP Phone para enviar o tráfego com uma prioridade do IEEE 802.1P, e configura o interruptor para confiar ou cancelar a prioridade de tráfego atribuída por um telefone IP.

Você pode configurar a porta de switch, que é conectada com um telefone IP, para usar um VLAN para o tráfego de voz e um outro VLAN para o tráfego de dados de um dispositivo anexado à porta de acesso do telefone IP. Você pode configurar portas de acesso no interruptor para enviar pacotes do Cisco Discovery Protocol (CDP) a fim instruir um telefone IP anexado para enviar o tráfego de voz ao interruptor por qualquens um métodos:

  • Na Voz o VLAN etiquetou com um valor de prioridade de CoS da camada 2

  • No acesso o VLAN etiquetou com um valor de prioridade de CoS da camada 2

  • No acesso VLAN, sem etiqueta (nenhum valor de prioridade de CoS da camada 2)

O interruptor pode processar o tráfego de dados que vem do dispositivo anexado à porta de acesso no telefone IP. Você pode configurar as portas de switch que enviam os pacotes de CDP que instruem o telefone IP anexado configurar o modo (confiado ou não confiável) do modo para a porta de acesso no telefone.

No modo confiado, a porta de acesso no telefone IP passa o tráfego do PC sem nenhuma mudança. No modo não confiável, a porta de acesso no telefone IP recebe todo o tráfego nos quadros do IEEE 802.1Q que contêm um valor configurado de CoS da camada 2. O valor de CoS da camada 2 do padrão é 0. modos não confiáveis é o padrão.

Configurar

Nesta seção, você é presentado com a informação para configurar as características da Voz VLAN descritas neste documento.

No interruptor, a característica da Voz VLAN é desabilitada à revelia. Quando você permite a Voz VLAN na porta, todo o tráfego sem etiqueta está enviado de acordo com a prioridade de CoS do padrão. Antes que você permita a Voz VLAN, permita o QoS no interruptor emitindo o comando global configuration dos qos dos mls e configurar o estado de confiança da porta para confiar emitindo o comando interface configuration de cos da confiança dos qos dos mls.

À revelia, uma porta de switch deixa cair todos os quadros etiquetados no hardware. A fim aceitar etiquetou quadros em uma porta de switch, um destes comandos deve ser configurada na porta:

  • dot1p vlan da Voz do switchport

  • Voz V_VLAN_ID vlan do switchport

  • tronco de modo de porta de comutação

Use o comando vlan do dot1p da Voz do switchport a fim instruir a porta de switch para usar a rotulação de prioridade do IEEE 802.1P para enviar todo o tráfego de voz com uma prioridade mais alta com (acesso) o VLAN nativo.

Use o comando vlan da Voz V_VLAN_ID do switchport a fim configurar uma Voz especificada VLAN, assim que o telefone IP pode enviar o tráfego de voz em quadros do IEEE 802.1Q com um valor de CoS da camada 2. O Cisco IP Phone pode igualmente enviar o tráfego de voz do sem etiqueta ou pode usar sua própria configuração para enviar o tráfego de voz ao acesso VLAN do interruptor.

Use o comando switchport priority extend trust a fim estender o estado de confiança ao dispositivo (PC) conectado ao telefone IP. Emitindo este comando, o interruptor instruirá o telefone em como processar os pacotes de dados do dispositivo anexado à porta de acesso no Cisco IP Phone. Os pacotes gerados pelo PC usam um valor atribuído de CoS no encabeçamento 802.1q. O telefone não deve mudar (confiança) a prioridade dos quadros que chegam na porta de telefone do PC.

Você deve permitir o CDP na porta de switch a que o telefone IP é conectado. À revelia, o CDP é permitido globalmente nas interfaces de switch. O CDP é o mecanismo usado entre o interruptor e o Cisco IP Phone a fim configurar o Cisco IP Phone para uma comunicação com a porta de switch. O CDP é proprietário ao Cisco Systems e os telefones de outros fabricantes não podem poder usar este método para configurar o telefone IP para combinar a configuração de porta do interruptor.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-2950-series-switches/113260-voice-vlan-01.gif

Este diagrama é um exemplo de uma configuração de VLAN da Voz em um Cisco Catalyst 2950 Switch. Os FastEthernet 0/6 e 0/8 das portas de switch são conectados com um Cisco IP Phone, e a porta de acesso em ambos os Telefones IP é conectada ao PC.

Configurações

Este documento utiliza as seguintes configurações:

Baseado no valor confiado de CoS

No 2950 Switch, o FastEthernet 0/6 de porta tem o VLAN configurado 10 para a Voz VLAN com o dot1p para usar a rotulação de prioridade do IEEE 802.1P para o tráfego de voz, e o modo configurado da confiança para o tráfego de dados do PC que é conectado à porta de acesso do Cisco IP Phone. Aqui, o Cisco IP Phone está confiando que um portátil ou um PC através de CoS e de tráfego de dados usam o VLAN nativo. Esta configuração é usada tipicamente para estações de trabalho de gerenciamento, usuários prioritários, ou um aplicativo alto do valor de CoS.

Quando um Cisco phone faz o CDP com o interruptor, o limite confiável está estendido sempre ao telefone IP. Isto é, os pacotes do telefone IP são mudados nunca de CoS 5 ao padrão de CoS. O comando switchport priority extend trust é usado é por isso para o portátil ou o PC. É enviado através do CDP para dizer o telefone IP para não reescrever pacotes de alta prioridade.

O FastEthernet 0/8 de porta é configurado com os VLAN separados para a voz e tráfego de dados. Neste exemplo, o VLAN10 é usado para o tráfego de voz e o VLAN20 é usado para o tráfego de dados. Esta configuração é usada para Telefones IP típicos de Cisco sem confiar o portátil ou o PC. O tráfego usa o tipo de frame do IEEE 802.1Q.

Com o comando mls qos trust cos, os olhares da porta do interruptor do catalizador no valor de CoS no cabeçalho de Ethernet para classificar o tráfego de ingresso e confiam o valor do CoS do pacote rotulado que origina do Cisco IP Phone. À revelia, a porta Ethernet torna-se não confiável, assim que o tráfego que vem da Voz VLAN e do VLAN de dados não será confiado.

Use o comando priority-queue out a fim dar privilégios do início da linha dos pacotes de voz ao tentar retirar a porta que impede o tremor. O comando spanning-tree portfast remove a relação do Spanning Tree Protocol, e o comando do bpduguard protege a rede se alguém tentar lhe conectar um interruptor novo após ter desconectado o telefone IP. Se um interruptor devia ser obstruída dentro, a porta iria ao desativado por erro. Estes são adicionados tipicamente às portas de telefone.

Cisco Catalyst 2950 Switch
Switch#configure terminal
Switch(config)#mls qos
Switch(config)#interface fastethernet 0/6


!--- Set the interface to classify incoming traffic packets by
 using the packet CoS value.

Switch(config-if)#mls qos trust cos


!--- Configure the phone to use IEEE 802.1p priority tagging for
 voice traffic.

Switch(config-if)#switchport voice vlan dot1p
Switch(config-if)#switchport voice vlan 10


!--- Trust the CoS value the PC sends in on the data VLAN.

Switch(config-if)#switchport priority extend trust
Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit


Switch(config)#interface gigabitethernet0/8
Switch(config-if)#mls qos trust cos


!--- Configure specified VLANs for voice and data traffic.

Switch(config-if)#switchport voice vlan 10
Switch(config-if)#switchport access vlan 20

Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit

Ao usar um telefone IP não-Cisco

Se você está usando um telefone IP não-Cisco que não reconheça Cisco CDP proprietário e automaticamente se ajuste - acima da porta de tronco, você terá que configurar manualmente o tronco. Neste exemplo de configuração, nós restringimos os VLAN ao 10 e a 20, e obstruímos o VLAN nativo 1 do padrão ou o VLAN0. VLAN10 é usado para o tráfego de voz e o VLAN20 é usado para o tráfego de dados. O telefone IP não-Cisco aprende o VLAN correto para seus pacotes rotulados com a configuração manual ou através do arquivo TFTP transfere durante a bota acima. Este exemplo usa esta configuração:

Cisco Catalyst 2950 Switch
Switch#configure terminal
Switch(config)#interface fastethernet 0/6


!---Trusts tagged packets CoS value; all untagged packets reset DSCP 
value in IP header to 0.

Switch(config-if)#mls qos trust cos


!--- Turn off DTP (dynamic trunking protocol).

Switch(config-if)#switchport nonegotiate


!--- Forces the port into trunking mode.

Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 20


!--- Restricts the VLANs.

Switch(config-if)#switchport trunk allowed vlans 10,20
Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast trunk
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit

Baseado no valor confiado DSCP no cabeçalho IP

Aqui, nós usamos um valor confiado dos pontos de código de DiffService (DSCP) em vez de um valor de CoS, porque CoS oferece uma maneira de compreender a importância do pacote apenas olhando seu encabeçamento L2. O DSCP é um campo 6-bit dentro do pacote IP. Use o comando mls qos trust dscp a fim confiar o valor DSCP no cabeçalho IP. Neste caso, os grupos de telefone IP seu DSCP corretamente em seus pacotes e o portátil ajustariam seu DSCP corretamente. Este exemplo usa esta configuração:

Cisco Catalyst 2950 Switch
Switch#configure terminal
Switch(config)#interface fastethernet 0/6


!---Trust the DSCP value in the IP header.

Switch(config-if)#mls qos trust DSCP


!--- IP phone VLAN

Switch(config-if)#switchport voice vlan 10
Switch(config-if)#switchport access vlan 20


!--- Trust the DSCP value the PC sends in on the data VLAN.

Switch(config-if)#switchport priority extend trust
Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • Use o comando show interfaces interface-id switchport a fim verificar sua configuração de VLAN da Voz.

    Por exemplo:

    Switch#show interfaces FastEthernet 0/6 switchport
    Name: Fa0/6
    Switchport: Enabled
    Administrative Mode: dynamic desirable
    Operational Mode: static access
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: native
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Voice VLAN: dot1p
    Administrative private-vlan host-association: none 
    Administrative private-vlan mapping: none 
    Administrative private-vlan trunk native VLAN: none
    Administrative private-vlan trunk encapsulation: dot1q
    Administrative private-vlan trunk normal VLANs: none
    Administrative private-vlan trunk private VLANs: none
    Operational private-vlan: none
    Trunking VLANs Enabled: ALL
    Pruning VLANs Enabled: 2-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL
    Protected: false
    Unknown unicast blocked: disabled
    Unknown multicast blocked: disabled
    Appliance trust: trusted
    
  • Use o comando do ID de interface do show running-config interface a fim verificar suas entradas da Voz VLAN para uma interface particular.

    Por exemplo:

    Switch#show running-config interface fastEthernet 0/6
    Building configuration...
    
    Current configuration : 139 bytes
    !
    interface FastEthernet0/6
     switchport voice vlan dot1p
     switchport voice vlan 10
     switchport priority extend trust
     mls qos trust cos
     priority-queue out
     spanning-tree portfast
     spanning-tree bpduguard enable
    end
    
    Switch#show running-config interface fastEthernet 0/8
    Building configuration...
    
    Current configuration : 137 bytes
    !
    interface FastEthernet0/8
     switchport voice vlan 10
     switchport access vlan 20
     mls qos trust cos
     priority-queue out
     spanning-tree portfast
     spanning-tree bpduguard enable
    end

Informações Relacionadas


Document ID: 113260