IP : Hot Standby Router Protocol (HSRP)

Exemplo da configuração de HSRP do IPv6

18 Outubro 2014 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Setembro 2014) | Feedback


Índice


Introdução

Este documento descreve como configurar o protocolo de roteamento do standby recente (HSRP) para o IPv6. O HSRP é usado dentro de um grupo de Roteadores a fim selecionar um roteador ativo e um roteador em standby. Em um grupo de interfaces do roteador, o roteador ativo é o roteador da escolha para pacotes de roteamento; o roteador em standby é o roteador que toma sobre quando o roteador ativo falha ou quando as condições do pré-ajuste estão estadas conformes. O HSRP é projetado fornecer somente um primeiro salto virtual para anfitriões do IPv6.

Um grupo do IPv6 HSRP tem um endereço MAC virtual que seja derivado do número do grupo HSRP e de um endereço local de link virtual do IPv6 isto é, à revelia, derivado do endereço MAC virtual hsrp. Os anúncios de roteador periódicos (RA) estão enviados para o endereço local de link virtual do IPv6 HSRP quando o grupo HSRP é ativo. Estes RA param depois que um RA final é enviado quando o grupo deixa o estado ativo.

O HSRP usa um mecanismo de prioridade a fim determinar que roteador configurado HSRP é ser o roteador ativo do padrão. A fim configurar um roteador como o roteador ativo, você deve atribuir-lhe uma prioridade que seja mais alta do que a prioridade de todo Roteadores HSRP-configurado restante. A prioridade padrão é 100; consequentemente, se você configura apenas um roteador para ter uma prioridade mais alta, esse roteador será o roteador ativo do padrão. A versão 2 HSRP usa o endereço IP Multicast novo 224.0.0.102 para enviar pacotes Hello em vez do endereço de multicast de 224.0.0.2, que é usado pela versão 1.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento de configurar o HSRP; refira configurar o HSRP para mais informação.

  • Conhecimento básico de executar o endereçamento e a conectividade básica do IPv6; refira a aplicação do endereçamento e da conectividade básica do IPv6 para mais informação.

  • A versão 2 HSRP deve ser permitida em uma relação antes que o IPv6 HSRP possa ser configurado.

  • O roteamento do unicast do IPv6 deve ser permitido no dispositivo para que o IPv6 HSRP seja configurado

Componentes Utilizados

As configurações neste documento são baseadas no Cisco 3700 Series Router no software 12.4 do Cisco IOS Software Release (15)T 13.

Nota: Verifique a informação de licença para os comandos do IPv6.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter informações sobre convenções de documentos.

Configurar

O r1 do Roteadores e o R2 são conectados ao R3 através de uma interface serial. As interfaces rápidas de Ethernet do r1 e do R2 são configuradas com o IPv6 HSRP de tal maneira que o r1 atua como o roteador ativo e o R2 atua como o roteador em standby. Caso que a interface serial S0/0 do r1 vai para baixo, o roteador R2 muda seu estado de à espera ao Active.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/113216/ipv6-hsrp-01.gif

Configurações

Este documento utiliza as seguintes configurações:

Está aqui um link a um vídeo (disponível na comunidade do apoio de Ciscoleavingcisco.com ) que demonstre como configurar o HSRP para o IPv6 no Roteadores do Cisco IOS:

Configurando o HSRP para o IPv6 leavingcisco.com

ipv6-hsrp-02.gif

Configuração do r1 do roteador
R1#show run
Building configuration...
!
hostname R1
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1010/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig

!--- Assigns a standby group and standby IP address.


 standby 1 priority 120


!--- R1 is configured as the active router.
!--- This is done by assigning a priority value 
!--- (in this case 120) to the router's Fa0/0 interface.
!--- The default priority value is 100.


 standby 1 preempt delay minimum 30


!--- The preempt command allows the router to become the 
!--- active router when it has the priority higher than 
!--- all the other HSRP-configured routers. 
!---- Without this command, even if a router has higher 
!--- priority value, it will not become an active router.
!--- The delay minimum value causes the local router to postpone
!--- taking over the active role for a minimum of 30 seconds.


 standby 1 track Serial0/0 90


!--- Indicates that HSRP tracks serial0/0.
!--- The interface priority is configured (in this case 90) which 
!--- indicates that if the tracked interface goes down the router 
!--- priority value is to be decremented by 90. 
!--- Default decrement value is 10.

!
interface Serial0/0
 no ip address
 ipv6 enable
 ipv6 address 2010:AB8:2001::1010/64
 clock rate 2000000
!
end

Configuração do roteador R2
R2#show run
Building configuration...
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0

!--- R2 is configured as a standby router
!--- with a default priority value of 100.

 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1011/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig
 standby 1 preempt delay minimum 30
 standby 1 track Serial0/0
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2010::1020/64
 ipv6 enable
 clock rate 2000000
!
end

Configuração do roteador R3
R3#show run
Building configuration...
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2001::1011/64
 ipv6 enable
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2010:AB8:2010::1021/64
 clock rate 2000000
!
end

Verificar

Use o comando show standby no r1 e o Roteadores R2 a fim verificar a configuração.

R1 do roteador
R1#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active 
!--- R1 router is in Active state.

    4 state changes, last state change 02:51:30
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.480 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C010:21FF:FE78:0, priority 100 (expires in 7.036 sec)
  Priority 120 (configured 120)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Roteador R2
R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Standby
!--- R2 router is in Standby state.

    4 state changes, last state change 02:51:43
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.900 secs
  Preemption enabled, delay min 30 secs
  Active router is FE80::C00F:21FF:FE78:0, priority 120 (expires in 9.928 sec)
    MAC address is c20f.2178.0000
  Standby router is local
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Caso que o roteador ativo (r1 neste exemplo) vai para baixo, o roteador em standby muda seu estado imediatamente ao Active segundo as indicações desta tabela:

Quando o roteador ativo (o r1) for abaixo de…
R1 do roteador
R1(config)#interface s0/0
R1(config-if)#shut
R1(config-if)#exit
*Mar  1 00:01:34.879: %LINK-5-CHANGED: Interface Serial0/0, changed state to 
      administratively down
*Mar  1 00:01:35.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, 
      changed state to down
R1#
*Mar  1 00:04:06.691: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar  1 00:04:36.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Speak
R1#
*Mar  1 00:04:46.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

!--- When the interface goes down, the active router changes its state to Standby.

Roteador R2
*Mar  1 00:04:35.631: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby ->Active


!--- The standby router is now the active router.
 

R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active
    2 state changes, last state change 00:10:39
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.532 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C00F:21FF:FE78:0, priority 30 (expires in 7.524 sec)
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 113216