IP : Open Shortest Path First (OSPF)

Exemplo de configuração do enlace virtual OSPFv3

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece um exemplo em configurar os enlaces virtuais na primeira versão 3 do caminho mais curto aberto (OSPFv3). OSPFv3 expande na versão 2 OSPF para fornecer o apoio para o IPv6 que distribui prefixos e o tamanho maior de endereços do IPv6.

Para cada enlace virtual, um datablock mestre da informação de segurança é criado para o enlace virtual. Porque um soquete seguro deve ser aberto em cada relação, haverá um datablock correspondente da informação de segurança para cada relação na área de trânsito. O estado seguro do soquete é mantido no datablock da informação de segurança da relação. O campo de estado no datablock mestre da informação de segurança reflete o estado do todo o fixa os soquetes abertos para o enlace virtual. Se todo o fixe os soquetes estão ACIMA, a seguir o estado da Segurança para o enlace virtual será ajustado a ACIMA.

Os pacotes enviaram sobre um enlace virtual com o IPsec devem usar endereços de rementente e destinatário predeterminados. O primeiro endereço da área local encontrado no intra-área-prefixo LSA do roteador para a área é usado como o endereço de origem. Este endereço de origem salvar na estrutura de dados da área e usado quando fixe os soquetes são abertos e pacotes enviado sobre o enlace virtual. O enlace virtual não transição ao estado ponto a ponto até que um endereço de origem esteja selecionado. Também, quando o endereço de origem ou de destino muda, o precedentes fixam os soquetes devem ser fechados e novo fixe os soquetes abertos.

Este exemplo de configuração usa o comando area virtual-link definir um enlace virtual de OSPF no modo de configuração do roteador.

Nota: Cada vizinho de link virtual deve incluir a área de trânsito ID e o Router ID correspondente do vizinho de link virtual para que um enlace virtual seja configurado corretamente. Use o comando exec OSPF da mostra IP ver o Router ID.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Termine a estratégia e o planeamento da rede de OSPF para sua rede do IPv6.

  • Permita o roteamento do unicast do IPv6.

  • Permita o IPv6 na relação.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As configurações neste documento são baseadas no Cisco 3700 Series Router no software 12.4 do software release do ½ do ¿  de Cisco IOSï (15)T 13.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/113204-ospfv3-vlink-config-01.gif

Configurações

Este documento utiliza as seguintes configurações:

  • R1 do roteador

  • Roteador R2

  • Roteador R3

  • Roteador R4

R1 do roteador
hostname R1
! 
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes

Roteador R2
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 clock rate 64000
 !
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 area 23 virtual-link 3.3.3.3
!

Roteador R3
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 !

interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 !
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 area 23 virtual-link 2.2.2.2
!

Roteador R4
hostname R4
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:4::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
ipv6 router ospf 10
 router-id 4.4.4.4
 log-adjacency-changes
!

Verificar

Use estes comandos verificar a configuração:

No r1 do roteador

A saída mostra claramente que o r1 do roteador pode sibilar com sucesso o endereço de loopback do roteador R4.

IPv6 do sibilo
R1#ping ipv6
Target IPv6 address: fe01:4::4

Ping Loopback 0 interface of R4
   	
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/72/96 ms

No roteador R2

O comando neighbor OSPF do IPv6 da mostra fornece a informação vizinha na pela base da relação.

mostre o vizinho OSPF do IPv6
R2# show ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
3.3.3.3                 0   FULL/  -                -                22        OSPFv3_VL0   

Virtual Link Between R2 & R3
       
1.1.1.1                 1   FULL/DR         00:00:35         4                 Ethernet1/0
3.3.3.3                 0   FULL/  -           00:00:31      12                Serial2/0

No roteador R4

A saída mostra claramente que o roteador R4 pode sibilar com sucesso a relação do laço de retorno do r1 do roteador.

IPv6 do sibilo
R4#ping ipv6
Target IPv6 address: fe01:1::1				

Ping Loopback 0 interface of R1

Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/100/224 ms

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 113204