Voz : Media Gateway Control Protocol (MGCP)

Apoio MGCP em um exemplo de configuração do roteador ativado VRF

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar o protocolo de controle do gateway da mensagem (MGCP) em um roteador ativado do roteamento de voz e da transmissão (VRF).

Há dois elementos que principais você deve compreender a consideração do MGCP:

  • Valores-limite

  • Agentes do atendimento

Os valores-limite são algumas das portas de voz no gateway designado. Estas portas de voz fornecem a Conectividade aos portos analógicos, tais como a estação de intercâmbio do escritório de câmbio internacional (FXO) /Foreign (FXS), e os troncos digitais, tais como um T1 ou E1, ao PSTN. Os gateways podem ter múltiplos pontos finais dependentes no número de portas que contém.

Os agentes do atendimento são dispositivos de controle externos em um sistema de voz. O CallManager da Cisco é o agente do atendimento provido neste documento. No MGCP, o agente do atendimento é o dispositivo que tem o controle completo do gateway. Este é muito um sistema eficiente porque toda a administração é executada pelo agente do atendimento. Há uma instalação muito pequena exigida na extremidade do gateway, porque todas as rotas padrão e dial plan são configurados no CallManager da Cisco.

É importante recordar que este protocolo está usado para propósitos de controle somente. Nenhum dados de voz é transmitido com o protocolo de MGCP próprio. Toda a transferência de dados de voz ocorre diretamente entre o telefone e o gateway. Este gráfico descreve os relacionamentos das comunicações de MGCP:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-01.gif

Os Telefones IP de Cisco neste uso do exemplo o Skinny Call Control Protocol (SCCP) comunicar-se com o CallManager da Cisco. Os dados de voz reais são transferidos com o Real-Time Transport Protocol (RTP) diretamente entre os dois dispositivos. O MGCP é usado pelo CallManager da Cisco para controlar somente o gateway.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Versão 12.4(24)T 4 do Cisco IOS Software

  • Cisco 2800 Series Router

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

MGCP e VRF Lite

A inteligência de roteamento VRF não existe no protocolo de MGCP.

Desde que o MGCP não é um protocolo “VRF-ciente”, você não pode configurar um Gateway de Voz IOS para pôr o tráfego MGCP na Voz VRF. O tráfego MGCP usará somente a tabela de roteamento padrão do roteador apesar das configurações de VRF.

Há duas soluções para apoiar o MGCP em um desenvolvimento típico VRF. Refira este cenário de rede típico VRF:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-02.gif

Usando dois Roteadores você pode estabelecer um, isto é, com o gateway MGCP atuando como um roteador básico (nenhuns VRF) que fornece o tráfego Ethernet a um segundo roteador que faça o roteamento MPLS VRF. Você pode então distribuir o tráfego MGCP sobre um roteador VRF porque é apenas uma técnica de distribuição e o MGCP é inconsciente.

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-03.gif

Uma outra solução similar é usar um único roteador VRF e utilizar uma segunda relação disponível para dirigir para fora o tráfego MGCP à rede de voz.

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-04.gif

Conectar a relação à Voz VLAN na rede de comutação permite que os protocolos de MGCP sejam distribuídos de novo no roteador através da relação VRF e finalmente do CallManager.

A rota global do roteador VRF precisa somente de ser dada um IP e uma rota estática que apontam ao IP da relação VRF ou de um endereço de DHCP fora da Voz VLAN. Veja estes detalhes de configuração:

hostname VRF_MGCP_rtr
!
ip DATA
rd 65232:1
route-target export 65232:1
route-target import 65232:1
!
ip VOICE
rd 65232:3
route-target export 65232:3
route-target import 65232:3
!
interface GigabitEthernet0/0
 description MGCP interface
 ip address dhcp 
!-- USE DHCP or Static IP address from VOICE VLAN

!
interface GigabitEthernet0/1
 no ip address
 duplex full
 speed auto
 no keepalive
!
interface GigabitEthernet0/1.100
description DATA VLAN
encapsulation dot1Q 1 native
ip forwarding DATA
ip address 10.1.232.1 255.255.255.0
ntp broadcast
!
Interface GigabitEthernet0/1.300
Description VOICE VLAN
encapsulation dot1Q 2
ip forwarding VOICE
ip address 10.2.20.129 255.255.255.128
!
Interface Serial0/0/0
no ip address
no encapsulation ppp
encapsulation frame-relay IETF
!
interface Serial0/0/0.100 point-to-point
description DATA PVC
ip forwarding DATA
ip address 10.1.52.198 255.255.255.252
frame-relay interface-dlci 100 IETF
!
interface Serial0/0/0.300 point-to-point
description VOICE PVC
ip forwarding VOICE
ip address 10.2.54.198 255.255.255.252
frame-relay interface-dlci 300 IETF
!
mgcp
mgcp call-agent 10.1.255.241 2427 service-type mgcp version 0.1
mgcp bind control source-interface GigabitEthernet0/0 
!-- Bind to MGCP Interface

mgcp bind media source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.


Informações Relacionadas


Document ID: 113180